No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un switch de Capa 3 a trabajar con un router para acceso a Internet

Ejemplo para configurar un switch de Capa 3 a trabajar con un router para acceso a Internet

Switch de Capa 3

Los switches de Capa 3 proporcionan la función de enrutamiento, que indica una función de capa de red en el modelo OSI.

Los switches de Capa 3 pueden funcionar en la Capa 2 y en la Capa 3 y desplegarse en la capa de acceso o en la capa de agregación como gateways de usuario.

Notas de configuración

  • Este ejemplo usa configuraciones de router de AR3600 V200R007C00SPCc00. Para otras configuraciones de router, vea la documentación correspondiente.
  • Las configuraciones del servidor de switch DHCP utilizadas en este ejemplo se aplican a los siguientes switches y versiones.
    Tabla 2-7  Modelos de productos y versiones aplicables

    Serie

    Modelo del producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S2350EI

    V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S3300

    S3300SI, S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300LI

    V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300SI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320SI

    V200R011C10, V200R012C00

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306, S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E, S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

Requisitos de redes

En Figura 2-20, una compañía tiene múltiples departamentos que pertenecen a diferentes segmentos de red, y cada departamento necesita acceder a Internet. Se requiere que los usuarios accedan a Internet a través del switch y router de Capa 3 y que el switch de Capa 3 funcione como el gateway de los usuarios.

Figura 2-20  Configuración de un switch de Capa 3 a trabajar con un router para acceso de Internet

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure el switch como el gateway de los usuarios para admitir que los usuarios se comuniquen por segmentos de red a través de las interfaces VLANIF.

  2. Configure el switch como el servidor DHCP para asignar direcciones IP a los usuarios.

  3. Configure la función NAT en el router para admitir que los usuarios de la intranet tengan acceso a Internet.

Procedimiento

  1. Configure el Switch.

    # Configure las interfaces conectadas a los usuarios y las interfaces VLANIF correspondientes.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 2 3
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access   //Establezca el tipo de enlace de la interfaz a access.
    [Switch-GigabitEthernet0/0/2] port default vlan 2   //Agregue la interfaz a VLAN 2.
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] port default vlan 3   
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] interface vlanif 2
    [Switch-Vlanif2] ip address 192.168.1.1 24
    [Switch-Vlanif2] quit
    [Switch] interface vlanif 3
    [Switch-Vlanif3] ip address 192.168.2.1 24
    [Switch-Vlanif3] quit
    

    # Configure la interfaz conectada al router y la interfaz VLANIF correspondiente.

    [Switch] vlan batch 100
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 100   
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 192.168.100.2 24
    [Switch-Vlanif100] quit
    

    # Configure la ruta predeterminada.

    [Switch] ip route-static 0.0.0.0 0.0.0.0 192.168.100.1   //El siguiente salto de la ruta predeterminada es la dirección IP 192.168.100.1 de la interfaz del router.
    

    # Configure el Servidor DHCP.

    [Switch] dhcp enable   
    [Switch] interface vlanif 2
    [Switch-Vlanif2] dhcp select interface   //DHCP usa un grupo de direcciones de interfaz para asignar direcciones IP a usuarios de la intranet.
    [Switch-Vlanif2] dhcp server dns-list 114.114.114.114 223.5.5.5   //La lista DNS configurada 114.114.114.114 es una dirección pública del servidor DNS, que es la misma para los operadores. En la práctica, la dirección de la lista DNS debe configurarse según el DNS asignado a un operador.
    [Switch-Vlanif2] quit
    [Switch] interface vlanif 3
    [Switch-Vlanif3] dhcp select interface
    [Switch-Vlanif3] dhcp server dns-list 114.114.114.114 223.5.5.5
    [Switch-Vlanif3] quit
    

  2. Configure el Router.

    # Configure una dirección IP para la interfaz conectada al switch.

    <Huawei> system-view
    [Huawei] sysname Router
    [Router] interface gigabitethernet 0/0/1
    [Router-GigabitEthernet0/0/1] ip address 192.168.100.1 255.255.255.0   //Configure la dirección IP 192.168.100.1 como la dirección IP del siguiente salto de la ruta predeterminada del switch.
    [Router-GigabitEthernet0/0/1] quit
    

    # Configure una dirección IP para la interfaz conectada a Internet.

    [Router] interface gigabitethernet 0/0/2
    [Router-GigabitEthernet0/0/2] ip address 200.0.0.2 255.255.255.0   //La dirección IP de la interfaz conectada a Internet está en el mismo segmento de red que la dirección IP pública.
    [Router-GigabitEthernet0/0/2] quit
    

    # Configure una ruta predeterminada y una ruta de retorno.

    [Router] ip route-static 0.0.0.0 0.0.0.0 200.0.0.1   //Configure una ruta predeterminada estática con el siguiente salto apuntando a la dirección IP pública 200.0.0.1.
    [Router] ip route-static 192.168.0.0 255.255.0.0 192.168.100.2   //Configure un enrutamiento de retorno con el siguiente salto apuntando a la dirección IP 192.168.100.2 de la interfaz de enlace ascendente del switch.
    

    # Configure la función NAT para admitir que los usuarios de la intranet tengan acceso a Internet.

    [Router] acl number 2001
    [Router-acl-basic-2001] rule 5 permit source 192.168.0.0 0.0.255.255   //NAT sólo tiene efecto para las direcciones IP de origen en el segmento de red 192.168.0.0/16 y traduce sólo direcciones IP de origen de paquetes salientes en GE0/0/2.
    [Router-acl-basic-2001] quit
    [Router] interface gigabitethernet 0/0/2
    [Router-GigabitEthernet0/0/2] nat outbound 2001
    [Router-GigabitEthernet0/0/2] quit
    

  3. Verifique la configuración

    Configure una dirección IP como 192.168.1.2/24 y una dirección de gateway como 192.168.1.1 para PC1, y configure una dirección IP como 192.168.2.2/24 y una dirección de gateway como 192.168.2.1 para PC2.

    Configure una dirección IP como 200.0.0.1/24 y una dirección de gateway como 200.0.0.2 para la red externa.

    Una vez completadas las configuraciones, PC1 y PC2 pueden hacer ping a la dirección IP 200.0.0.1/24 de la red externa y acceder a Internet.

Archivos de configuración

  • Archivo de configuración de Switch
    #
    sysname Switch
    #
    vlan batch 2 to 3 100
    #
    dhcp enable
    #
    interface Vlanif2
     ip address 192.168.1.1 255.255.255.0
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5
    #
    interface Vlanif3
     ip address 192.168.2.1 255.255.255.0
     dhcp select interface
     dhcp server dns-list 114.114.114.114 223.5.5.5
    #
    interface Vlanif100
     ip address 192.168.100.2 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type access
     port default vlan 100
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 2
    #
    interface GigabitEthernet0/0/3
     port link-type access
     port default vlan 3
    #
    ip route-static 0.0.0.0 0.0.0.0 192.168.100.1
    #
    return
    
  • Archivo de configuración del Router
    #
    sysname Router
    #
    acl number 2001
     rule 5 permit source 192.168.0.0 0.0.255.255
    #
    interface GigabitEthernet0/0/1
     ip address 192.168.100.1 255.255.255.0
    #
    interface GigabitEthernet0/0/2
     ip address 200.0.0.2 255.255.255.0
     nat outbound 2001
    #
    ip route-static 0.0.0.0 0.0.0.0 200.0.0.1
    ip route-static 192.168.0.0 255.255.0.0 192.168.100.2
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15453

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente