No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Configuración típica para la interconexión entre switches y servidores NLB

Configuración típica para la interconexión entre switches y servidores NLB

Ejemplo para conectar un dispositivo a un Clúster NLB (utilizando ARP de interfaz múltiple)

Descripción general

NLB está desarrollado por Microsoft para un clúster configurado por múltiples servidores de Windows. Cuando un switch está conectado a un clúster NLB, el switch debe enviar los paquetes destinados a la dirección IP del clúster a cada servidor NLB del clúster. Un servidor NLB puede funcionar en modo de unidifusión, multidifusión o IGMP multidifusión.

Actualmente, se puede conectar un switch al servidor NLB que funciona en modo de unidifusión o multidifusión. Después de configurar el ARP de múltiples interfaces en el switch, el switch se puede conectar a los servidores NLB.

En un modelo de dispositivo o en una versión que no admite ARP de múltiples interfaces, los siguientes métodos están disponibles para implementar la conexión:
  • Agregue un switch de Capa 2 entre el switch y los servidores NLB. (Cuando los servidores NLB funcionan en modo de multidifusión, habilite el aprendizaje dinámico de entradas ARP con direcciones MAC de multidifusión o configure entradas ARP estáticas en el switch.) Este método se puede usar cuando hay suficientes recursos de dispositivo.
  • Use bucle de retorno de enlace físico. Este método resulta una configuración compleja.
Notas de configuración
  • La VLAN a la que se agrega una interfaz no puede ser una MAC VLAN, una súper VLAN, una línea arrendada VLAN, MUX VLAN en las tarjetas LE1D2S04SEC0, LE1D2X32SEC0 y LE1D2H02QEC0 y las tarjetas de la serie X y VLAN de control de Protección de Ethernet inteligente (SEP) y Protocolo de protección de anillo rápido (RRPP).

  • Las tarjetas de la serie SA (excepto la placa LE0DX12XSA00) no admiten ARP múltiples interfaces.

  • En el S5320SI, S5330SI y S6320SI, cuando las interfaces de salida son interfaces Eth-Trunk, debe ejecutar el comando load-balance para configurar el balanceo de carga en función de las direcciones IP. De lo contrario, la configuración no se ponen en vigor.

  • En los switches excepto el S5320SI, S5330SI y S6320SI, cuando las interfaces de salida son interfaces Eth-Trunk, debe ejecutar el comando unknown-unicast load-balance enhanced para configurar el modo del balanceo de carga a tráfico de unidifusión desconocido en las interfaces. De lo contrario, la configuración no se ponen en vigor.

  • Tabla 2-8 enumera productos y versiones aplicables.

    Tabla 2-8  Modelos y versiones de los productos aplicables

    Producto

    Modelo del Producto

    Versión del software

    S5300

    S5300HI

    V200R003C00, V200R005 (C00 y C01)

    S5310EI

    V200R003C00, V200R005 (C00 y C01)

    S5320SI

    V200R011C10, V200R012C00

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R003C00, V200R005 (C00 y C01)

    S6320SI

    V200R011C10, V200R012C00

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008 (C00 y C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008 (C00 y C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:

    Para obtener más información sobre los mapeos de software, consulte Version Mapping Search for Huawei Campus Switches.

  • En un escenario de VPN, los switches que admiten VPN y ejecutan V200R010C00 y las versiones posteriores se pueden conectar a un clúster NLB. Un cliente y el servidor al que accede el cliente deben estar en la misma VPN.
Requisitos de red

Como se muestra en Figura 2-21, el Switch se conecta a tres servidores NLB respectivamente a través de GE1/0/1, GE1/0/2 y GE1/0/3 en VLAN 10. El clúster NLB funciona en modo de multidifusión. Cada servidor en el clúster NLB tiene una dirección IP y una dirección MAC. Todos los servidores del clúster comparten la dirección IP del clúster (10.128.246.252/24) y la dirección MAC del clúster (03bf-0a80-f6fc). Hay enrutamientos accesibles entre el Switch y el Cliente.

El cliente requiere que el Switch pueda enviar el paquete del Cliente destinado a la dirección IP del clúster a cada servidor en el clúster NLB.

Figura 2-21  Diagrama de red para configurar ARP de múltiples interfaces

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure las direcciones IP para las interfaces y agregue las interfaces a las VLAN.
  2. Configure una entrada de dirección MAC mapeando múltiples interfaces de salida y configure una entrada ARP estática para que el Switch pueda enviar los paquetes destinados a la dirección IP del clúster a los tres servidores en el clúster NLB.

Procedimiento

  1. Cree VLAN y agregue interfaces a las VLAN.

    # Cree una VLAN en el Switch y agregue las interfaces a la VLAN.
    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type access
    [Switch-GigabitEthernet1/0/3] quit
    [Switch] vlan 10
    [Switch-vlan10] port gigabitethernet 1/0/1 to 1/0/3
    [Switch-vlan10] quit
    

  2. # Cree una interfaz VLANIF en el Switch y asigne una dirección IP a la interfaz VLANIF.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.128.246.251 24
    [Switch-Vlanif10] quit
    

  3. Configure una entrada de dirección MAC mapeando múltiples interfaces de salida en el Switch.

    [Switch] mac-address multiport 03bf-0a80-f6fc interface gigabitethernet 1/0/1 to gigabitethernet 1/0/3 vlan 10  //Configure una entrada de dirección MAC mapeando múltiples interfaces de salida
    

  4. Configure entradas ARP estáticas en el Switch.

    [Switch] arp static 10.128.246.252 03bf-0a80-f6fc //Las entradas ARP estáticas cortas se deben configurar aquí.
    [Switch] quit

  5. Verifique la configuración

    # Ejecute el comando display mac-address multiport vlan 10 en el Switch para comprobar la entrada de la dirección MAC configurada mapeando múltiples interfaces de salida.

    <Switch> display mac-address multiport vlan 10
    --------------------------------------------------------------------------------
    MAC Address       VLANID    Out-Interface               Status  
    --------------------------------------------------------------------------------
    03bf-0a80-f6fc    10        GigabitEthernet1/0/1        Active                                
                                GigabitEthernet1/0/2        Active                                
                                GigabitEthernet1/0/3        Active                                
                                                3 port(s)                           
    --------------------------------------------------------------------------------
     Total Group(s) : 1 
    

    # Ejecute el comando display arp static en el Switch para comprobar entradas ARP estáticas.

    <Switch> display arp static
    IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE  
                                              VLAN/CEVLAN                           
    ------------------------------------------------------------------------------
    10.128.246.252  03bf-0a80-f6fc            S--         Multi-port:3            
    ------------------------------------------------------------------------------  
    Total:1        Dynamic:0      Static:1     Interface:0 
    

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 10 
#
interface Vlanif10
 ip address 10.128.246.251 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10 
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 10
 mac-address multiport 03bf-0a80-f6fc vlan 10
#
arp static 10.128.246.252 03bf-0a80-f6fc
#
return

Ejemplo de conexión de un dispositivo único a un clúster NLB (usando bucle de retorno de enlace físico)

Descripción general

NLB está desarrollado por Microsoft para un clúster configurado por múltiples servidores de Windows. Cuando un switch está conectado a un clúster NLB, el switch debe enviar los paquetes destinados a la dirección IP del clúster a cada servidor NLB del clúster. Un servidor NLB puede funcionar en modo de unidifusión, multidifusión o IGMP multidifusión.

Actualmente, se puede conectar un switch al servidor NLB que funciona en modo de unidifusión o multidifusión. Si el switch admite ARP de múltiples interfaces, se recomienda esta función para implementar la conexión entre el switch y el clúster NLB. Cuando el switch o la versión no admite ARP de múltiples interfaces y no hay recursos suficientes en el dispositivo, puede usar el bucle de retorno del enlace físico para conectar el switch al clúster NLB.

Notas de configuración
  • Cuando el clúster NLB funciona en modo de unidifusión, las entradas ARP estáticas no necesitan configurarse en el switch; cuando el clúster funciona en modo de multidifusión, las entradas ARP estáticas deben configurarse en el switch.

  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

    NOTA:

    Para obtener más información sobre los mapeos de software, consulte Version Mapping Search for Huawei Campus Switches.

Requisitos de red

Como se muestra en Figura 2-22, el Switch se conecta a tres servidores NLB a través de GE0/0/1, GE0/0/2, y GE0/0/3. El clúster NLB funciona en modo de unidifusión, la dirección IP del clúster es 10.128.246.252/24 y la dirección MAC del clúster es 02bf-0a80-f6fc. Hay enrutamientos accesibles entre el Switch y el Cliente.

El cliente requiere que el Switch pueda enviar los paquetes del Cliente destinados a la dirección IP del clúster NLB a todos los servidores NLB.

Figura 2-22  Conexión de un dispositivo único a un clúster NLB en modo de unidifusión

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Agregue GE0/0/1 a través de GE0/0/3 que están conectados directamente a los servidores NLB a la VLAN 100.
  2. Inhabilite STP, RSTP, VBST o MSTP en GE0/0/4 y GE0/0/5, y agregue las interfaces a la VLAN 100 y la VLAN 200 respectivamente en el modo de acceso.
  3. Configure una dirección IP para VLANIF 200 que funcione como el gateway del clúster NLB.
  4. Conecte GE0/0/4 y GE0/0/5.

Procedimiento

  1. Agregue GE0/0/1 a través de GE0/0/3 que están conectados directamente a los servidores NLB a la VLAN 100.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 200
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] quit
    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] quit
    [Switch] interface gigabitethernet 0/0/3
    [Switch-GigabitEthernet0/0/3] port link-type access
    [Switch-GigabitEthernet0/0/3] quit
    [Switch] vlan 100
    [Switch-vlan100] port gigabitethernet 0/0/1 to 0/0/3
    [Switch-vlan100] quit
    

  2. Configure GE0/0/4 y GE0/0/5.

    # Inhabilitar STP, RSTP, VBST o MSTP en GE0/0/4 y GE0/0/5.

    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] undo stp enable  //Deshablite STP, RSTP, VBST, o MSTP
    [Switch-GigabitEthernet0/0/4] quit
    [Switch] interface gigabitethernet 0/0/5
    [Switch-GigabitEthernet0/0/5] undo stp enable  //Deshablite STP, RSTP, VBST, o MSTP
    [Switch-GigabitEthernet0/0/5] quit

    # Agregue GE0/0/4 y GE0/0/5 a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

    [Switch] interface gigabitethernet 0/0/4
    [Switch-GigabitEthernet0/0/4] port link-type access
    [Switch-GigabitEthernet0/0/4] port default vlan 100
    [Switch-GigabitEthernet0/0/4] quit
    [Switch] interface gigabitethernet 0/0/5
    [Switch-GigabitEthernet0/0/5] port link-type access
    [Switch-GigabitEthernet0/0/5] port default vlan 200
    [Switch-GigabitEthernet0/0/5] quit

  3. Configure una dirección IP para el gateway del clúster NLB.

    [Switch] interface vlanif 200
    [Switch-Vlanif200] ip address 10.128.246.250 24
    [Switch-Vlanif200] quit
    

  4. Conecte GE0/0/4 y GE0/0/5.

    Después de las configuraciones anteriores, conecte los enlaces físicos.

  5. Verifique la configuración

    Verifique que Server_1 a través de Server_3 pueda recibir los paquetes destinados al clúster NLB.

Archivos de configuración

Archivo de configuración de Switch

#
sysname Switch
#
vlan batch 100 200
#                                                                               
interface Vlanif200                                                             
 ip address 10.128.246.250 255.255.255.0                                        
#                                                                               
interface GigabitEthernet0/0/1              
 port link-type access                                                          
 port default vlan 100                                                
# 
interface GigabitEthernet0/0/2              
 port link-type access                                                          
 port default vlan 100                                                  
#                                                                               
interface GigabitEthernet0/0/3              
 port link-type access                                                          
 port default vlan 100                                                  
#                                                                               
interface GigabitEthernet0/0/4              
 port link-type access                                                          
 port default vlan 100                                                          
 stp disable                                                                    
# 
interface GigabitEthernet0/0/5              
 port link-type access                                                          
 port default vlan 200                                                          
 stp disable                                                                    
# 
return

Ejemplo para conectar un grupo VRRP a un clúster NLB (usando bucle de retorno de enlace físico)

Descripción general

NLB está desarrollado por Microsoft para un clúster configurado por múltiples servidores de Windows. Cuando un switch está conectado a un clúster NLB, el switch debe enviar los paquetes destinados a la dirección IP del clúster a cada servidor NLB del clúster. Un servidor NLB puede funcionar en modo de unidifusión, multidifusión o IGMP multidifusión.

Actualmente, se puede conectar un switch al servidor NLB que funciona en modo de unidifusión o multidifusión. Si el switch admite ARP de múltiples interfaces, se recomienda esta función para implementar la conexión entre el switch y el clúster NLB. Cuando el switch o la versión no admite ARP de múltiples interfaces y no hay recursos suficientes en el dispositivo, puede usar el bucle de retorno del enlace físico para conectar el switch al clúster NLB.

Notas de configuración
  • Cuando el clúster NLB funciona en modo de unidifusión, las entradas ARP estáticas no necesitan configurarse en el switch; cuando el clúster funciona en modo de multidifusión, las entradas ARP estáticas deben configurarse en el switch.

  • Tabla 2-9 enumera productos y versiones aplicables.

    Tabla 2-9  Modelos y versiones de los productos aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320SI

    V200R011C10, V200R012C00

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:

    Para obtener más información sobre los mapeos de software, consulte Version Mapping Search for Huawei Campus Switches.

Requisitos de red

Como se muestra en Figura 2-23, Switch_1 y Switch_2 se conectan entre sí usando GE0/0/2 y forman un grupo VRRP a través el enlace de latido. Switch_1 es el principal y Switch_2 es ​​la copia de seguridad. Las interfaces GE0/0/1 en Switch_1 y Switch_2 están conectadas directamente a dos servidores NLB, respectivamente. El clúster NLB funciona en modo de unidifusión, la dirección IP del clúster es 10.128.246.252/24 y la dirección MAC del clúster es 03bf-0a80-f6fc. Hay enrutamientos accesibles entre el Switch y el Cliente.

El cliente requiere que el grupo VRRP pueda enviar los paquetes del Cliente destinados a la dirección IP del clúster NLB a todos los servidores NLB.

Figura 2-23  Conexión de un grupo VRRP a un clúster NLB en modo de multidifusión

Plan de datos

Antes de la configuración, necesita los siguientes datos.

ítem Datos Descripción
Dirección IP
  • La VLANIF 200 de Switch_1: 10.128.246.10/24
  • La VLANIF 200 de Switch_2: 10.128.246.11/24
  • Dirección IP virtual: 10.128.246.250
-
Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Agregue GE0/0/1 a la VLAN 100.
  2. Agregue GE0/0/2 a la VLAN 100.
  3. Inhabilite STP, RSTP, VBST o MSTP en GE0/0/4 y GE0/0/5, y agregue las interfaces a la VLAN 100 y la VLAN 200 respectivamente en el modo de acceso.
  4. Configure una dirección IP virtual VRRP para VLANIF 200 que funcione como el gateway del clúster NLB.
  5. Configure una entrada ARP estática. En la entrada ARP estática, la dirección IP es la dirección IP del clúster, la dirección MAC es la dirección MAC de multidifusión del clúster y la interfaz de salida es la interfaz donde está configurada la VLAN a la que pertenece el gateway del clúster NLB.
  6. Conecte GE0/0/4 y GE0/0/5.

Procedimiento

  1. # Configure GE0/0/1.

    # Agregue GE0/0/1 en Switch_1 a VLAN 100.

    <Quidway> system-view
    [Quidway] sysname Switch_1
    [Switch_1] vlan batch 100 200
    [Switch_1] interface gigabitethernet 0/0/1
    [Switch_1-GigabitEthernet0/0/1] port link-type access
    [Switch_1-GigabitEthernet0/0/1] port default vlan 100
    [Switch_1-GigabitEthernet0/0/1] quit
    

    # Agregue GE0/0/1 en Switch_2 a VLAN 100.

    <Quidway> system-view
    [Quidway] sysname Switch_2
    [Switch_2] vlan batch 100 200
    [Switch_2] interface gigabitethernet 0/0/1
    [Switch_2-GigabitEthernet0/0/1] port link-type access
    [Switch_2-GigabitEthernet0/0/1] port default vlan 100
    [Switch_2-GigabitEthernet0/0/1] quit
    

  2. Agregue GE0/0/2 a la VLAN 100.

    # Agregue GE0/0/2 en Switch_1 a VLAN 100.

    [Switch_1] interface gigabitethernet 0/0/2
    [Switch_1-GigabitEthernet0/0/2] port link-type trunk 
    [Switch_1-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_1-GigabitEthernet0/0/2] quit
    

    # Agregue GE0/0/2 en Switch_2 a VLAN 100.

    [Switch_2] interface gigabitethernet 0/0/2
    [Switch_2-GigabitEthernet0/0/2] port link-type trunk 
    [Switch_2-GigabitEthernet0/0/2] port trunk allow-pass vlan 100
    [Switch_2-GigabitEthernet0/0/2] quit
    
    NOTA:

    Las interfaces de latido y el gateway no pueden pertenecer a la misma VLAN para evitar un bucle de tráfico dentro del grupo VRRP. Por ejemplo, GE 0/0/2 en este ejemplo no se puede agregar a la VLAN 200.

  3. Configure GE0/0/4 y GE0/0/5.

    # Inhabilitar STP, RSTP, VBST o MSTP de GE0/0/4 y GE0/0/5 en Switch_1.

    [Switch_1] interface gigabitethernet 0/0/4
    [Switch_1-GigabitEthernet0/0/4] undo stp enable  //Deshablite STP, RSTP, VBST, o MSTP
    [Switch_1-GigabitEthernet0/0/4] quit
    [Switch_1] interface gigabitethernet 0/0/5
    [Switch_1-GigabitEthernet0/0/5] undo stp enable  //Deshablite STP, RSTP, VBST, o MSTP
    [Switch_1-GigabitEthernet0/0/5] quit

    # Agregue GE0/0/4 y GE0/0/5 en Switch_1 a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

    [Switch_1] interface gigabitethernet 0/0/4
    [Switch_1-GigabitEthernet0/0/4] port link-type access
    [Switch_1-GigabitEthernet0/0/4] port default vlan 100
    [Switch_1-GigabitEthernet0/0/4] quit
    [Switch_1] interface gigabitethernet 0/0/5
    [Switch_1-GigabitEthernet0/0/5] port link-type access
    [Switch_1-GigabitEthernet0/0/5] port default vlan 200
    [Switch_1-GigabitEthernet0/0/5] quit

    # Inhabilitar STP, RSTP, VBST o MSTP de GE0/0/4 y GE0/0/5 en Switch_2.

    [Switch_2] interface gigabitethernet 0/0/4
    [Switch_2-GigabitEthernet0/0/4] undo stp enable  //Deshablite STP, RSTP, VBST, o MSTP
    [Switch_2-GigabitEthernet0/0/4] quit
    [Switch_2] interface gigabitethernet 0/0/5
    [Switch_2-GigabitEthernet0/0/5] undo stp enable  //Deshablite STP, RSTP, VBST, o MSTP
    [Switch_2-GigabitEthernet0/0/5] quit

    # Agregue GE0/0/4 y GE0/0/5 en Switch_2 a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

    [Switch_2] interface gigabitethernet 0/0/4
    [Switch_2-GigabitEthernet0/0/4] port link-type access
    [Switch_2-GigabitEthernet0/0/4] port default vlan 100
    [Switch_2-GigabitEthernet0/0/4] quit
    [Switch_2] interface gigabitethernet 0/0/5
    [Switch_2-GigabitEthernet0/0/5] port link-type access
    [Switch_2-GigabitEthernet0/0/5] port default vlan 200
    [Switch_2-GigabitEthernet0/0/5] quit

  4. Configure una dirección IP para el gateway del clúster NLB.

    # Cree el grupo 1 de VRRP en Switch_1 y establezca la prioridad de VRRP en 120.

    [Switch_1] interface vlanif 200
    [Switch_1-Vlanif200] ip address 10.128.246.10 24
    [Switch_1-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //Cree grupo 1 de VRRP
    [Switch_1-Vlanif200] vrrp vrid 1 priority 120   //Establezca la prioridad de VRRP a 120
    [Switch_1-Vlanif200] quit

    # Cree el grupo 1 de VRRP en Switch_2 y use la prioridad 100 predeterminada de VRRP.

    [Switch_2] interface vlanif 200
    [Switch_2-Vlanif200] ip address 10.128.246.11 24
    [Switch_2-Vlanif200] vrrp vrid 1 virtual-ip 10.128.246.250  //Cree grupo 1 de VRRP
    [Switch_2-Vlanif200] quit
    NOTA:
    • Configure una dirección IP virtual de VRRP 10.128.246.250 para VLANIF 200 que funcione como el gateway del clúster NLB.
    • Para reducir la carga de trabajo de red, se recomienda separar el gateway del clúster NLB de otros gateways.

      En esta red, el tráfico de un switch al clúster NLB pasa a lo largo del enlace de latido al switch del otro extremo y luego pasa a lo largo de la línea de autobucle en el switch del otro extremo. En este caso, si otros servidores usan el mismo gateway que los servidores NLB, otros servidores recibirán tráfico destinado al clúster NLB, lo que provocará un aumento de la carga de trabajo de la red. Por ejemplo, los paquetes destinados al clúster NLB desde Switch_1 pasan a lo largo del enlace de latido a Switch_2. En Switch_2, los paquetes se envían desde GE0/0/4 a 0/0/5. Si VLANIF 200 en Switch_2 también es el gateway de servidores que no son NLB, los paquetes se envían a servidores que no son NLB a través de GE0/0/5.

  5. Configure las entradas ARP estáticas.

    # En Switch_1, configure una entrada ARP estática. En la entrada ARP, la dirección IP es 10.128.246.252, la dirección MAC es 03bf-0a80-f6fc, la interfaz de salida es GE 0/0/5 donde se encuentra la VLAN 200.

    [Switch_1] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

    # En Switch_2, configure una entrada ARP estática. En la entrada ARP, la dirección IP es 10.128.246.252, la dirección MAC es 03bf-0a80-f6fc, la interfaz de salida es GE 0/0/5 donde se encuentra la VLAN 200.

    [Switch_2] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface gigabitethernet 0/0/5

  6. Conecte GE0/0/4 y GE0/0/5.

    Después de las configuraciones anteriores, conecte los enlaces físicos en Switch_1 y Switch_2 respectivamente.

  7. Verifique la configuración

    Verifique que Server_1 y Server_2 puedan recibir los paquetes destinados al clúster NLB.

Archivos de configuración
  • Archivo de configuración de Switch_1

    #
    sysname Switch_1
    #
    vlan batch 100 200
    #                                                                               
    interface Vlanif200
     ip address 10.128.246.10 255.255.255.0 
     vrrp vrid 1 virtual-ip 10.128.246.250
     vrrp vrid 1 priority 120
    #                                                                               
    interface GigabitEthernet0/0/1                                                 
     port link-type access                                                          
     port default vlan 100                                                 
    # 
    interface GigabitEthernet0/0/2                                                 
     port link-type trunk                                                           
     port trunk allow-pass vlan 100                                                 
    #                                                                               
    interface GigabitEthernet0/0/4                                                
     port link-type access                                                          
     port default vlan 100                                                          
     stp disable                                                                    
    # 
    interface GigabitEthernet0/0/5                                                
     port link-type access                                                          
     port default vlan 200                                                          
     stp disable                                                                    
    # 
    arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5
    #  
    return
    
  • Archivo de configuración de Switch_2

    #
    sysname Switch_2
    #
    vlan batch 100 200
    #                                                                               
    interface Vlanif200
     ip address 10.128.246.11 255.255.255.0 
     vrrp vrid 1 virtual-ip 10.128.246.250
    #                                                                               
    interface GigabitEthernet0/0/1                                                 
     port link-type access                                                          
     port default vlan 100                                                
    # 
    interface GigabitEthernet0/0/2                                                 
     port link-type trunk                                                           
     port trunk allow-pass vlan 100                                                 
    #                                                                               
    interface GigabitEthernet0/0/4                                                
     port link-type access                                                          
     port default vlan 100                                                          
     stp disable                                                                    
    # 
    interface GigabitEthernet0/0/5                                                
     port link-type access                                                          
     port default vlan 200                                                          
     stp disable                                                                    
    # 
    arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface GigabitEthernet0/0/5
    #  
    return
    

Ejemplo para conectar una pila a un clúster NLB (usando bucle de retorno de enlace físico)

Descripción general

NLB está desarrollado por Microsoft para un clúster configurado por múltiples servidores de Windows. Cuando un switch está conectado a un clúster NLB, el switch debe enviar los paquetes destinados a la dirección IP del clúster a cada servidor NLB del clúster. Un servidor NLB puede funcionar en modo de unidifusión, multidifusión o IGMP multidifusión.

Actualmente, se puede conectar un switch al servidor NLB que funciona en modo de unidifusión o multidifusión. Si el switch admite ARP de múltiples interfaces, se recomienda esta función para implementar la conexión entre el switch y el clúster NLB. Cuando el switch o la versión no admite ARP múltiples interfaces y no hay suficientes recursos del dispositivo, puede usar el bucle de entorno de enlace físico para conectar el switch al clúster NLB.

Notas de configuración
  • Cuando el clúster NLB funciona en modo de unidifusión, las entradas ARP estáticas no necesitan configurarse en el switch; cuando el clúster funciona en modo de multidifusión, las entradas ARP estáticas deben configurarse en el switch.

  • Un gateway virtual de VRRP no se puede configurar en un switch en una pila para los Clientes.

  • Tabla 2-10 enumera los productos y las versiones aplicables.

    Tabla 2-10  Modelos y versiones de los productos aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2300EI

    V100R006C05

    S2320EI

    V200R011C10, V200R012C00

    S2350EI

    V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S3300

    S3300SI

    V100R006C05

    S3300EI

    V100R006C05

    S5300

    S5300LI

    V200R001C00, V200R002C00, V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300SI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320SI

    V200R011C10, V200R012C00

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    NOTA:

    Para obtener más información acerca de las asignaciones de software, consulte Version Mapping Search for Huawei Campus Switches.

Requisitos de red

Como se muestra en Figura 2-24, Switch_1 y Switch_2 forman una pila y se conectan directamente a dos servidores NLB respectivamente a través de GE0/0/1 y GE1/0/1. El clúster NLB funciona en modo de multidifusión, la dirección IP del clúster es 10.128.246.252/24 y la dirección MAC del clúster es 03bf-0a80-f6fc. Hay enrutamientos accesibles entre el Switch y el Cliente.

El cliente requiere que la pila pueda enviar los paquetes del Cliente destinados a la dirección IP del clúster NLB a todos los servidores NLB.

Figura 2-24  Conectar una pila a un clúster NLB en modo de multidifusión

Plan de datos

Antes de la configuración, necesita los siguientes datos.

Ítem Datos Descripción
Dirección IP VLANIF200: 10.128.246.250/24 -
Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Agregue GE0/0/1 y GE1/0/1 que están conectados directamente con los servidores NLB a la VLAN 100.
  2. Agregue GE0/0/4 y GE1/0/4 a Eth-Trunk 4, GE0/0/5 y GE1/0/5 a Eth-Trunk 5.
  3. Deshabilite STP, RSTP, VBST o MSTP en Eth-Trunk 4 y Eth-Trunk 5, y agregue Eth-Trunk 4 y Eth-Trunk 5 a VLAN 100 y VLAN 200 respectivamente en modo de acceso.
  4. Configure una dirección IP para VLANIF 200 que funcione como el gateway del clúster NLB.
  5. Configure una entrada ARP estática. En la entrada ARP estática, la dirección IP es la dirección IP del clúster, la dirección MAC es la dirección MAC de multidifusión del clúster y la interfaz de salida es la interfaz donde está configurada la VLAN a la que pertenece el gateway del clúster NLB.
  6. Conecte GE0/0/4 y GE0/0/5 así como GE1/0/4 y GE1/0/5.

Procedimiento

  1. Agregue las interfaces conectadas directamente a los servidores NLB a la VLAN 100.

    # Agregue GE0/0/1 a la VLAN 100.

    <Quidway> system-view
    [Quidway] sysname Stack
    [Stack] vlan batch 100 200
    [Stack] interface gigabitethernet 0/0/1
    [Stack-GigabitEthernet0/0/1] port link-type access 
    [Stack-GigabitEthernet0/0/1] port default vlan 100
    [Stack-GigabitEthernet0/0/1] quit
    

    # Agregue GE1/0/1 a la VLAN 100.

    [Stack] interface gigabitethernet 1/0/1
    [Stack-GigabitEthernet1/0/1] port link-type access 
    [Stack-GigabitEthernet1/0/1] port default vlan 100
    [Stack-GigabitEthernet1/0/1] quit
    

  2. Agregue las interfaces a Eth-Trunks.

    # Agregue GE0/0/4 y GE1/0/4 a Eth-Trunk 4.

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] quit
    [Stack] interface gigabitethernet 0/0/4
    [Stack-GigabitEthernet0/0/4] eth-trunk 4
    [Stack-GigabitEthernet0/0/4] quit
    [Stack] interface gigabitethernet 1/0/4
    [Stack-GigabitEthernet1/0/4] eth-trunk 4
    [Stack-GigabitEthernet1/0/4] quit

    # Agregue GE0/0/5 y GE1/0/5 a Eth-Trunk 5.

    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] quit
    [Stack] interface gigabitethernet 0/0/5
    [Stack-GigabitEthernet0/0/5] eth-trunk 5
    [Stack-GigabitEthernet0/0/5] quit
    [Stack] interface gigabitethernet 1/0/5
    [Stack-GigabitEthernet1/0/5] eth-trunk 5
    [Stack-GigabitEthernet1/0/5] quit

  3. Configure Eth-Trunk 4 y Eth-Trunk 5.

    # Deshabilite STP, RSTP, VBST o MSTP en Eth-Trunk 4 y Eth-Trunk 5.

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] undo stp enable  //Deshabilite STP, RSTP, VBST o MSTP
    [Stack-Eth-Trunk4] quit
    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] undo stp enable  //Deshabilite STP, RSTP, VBST o MSTP
    [Stack-Eth-Trunk5] quit
    

    # Agregue Eth-Trunk 4 y Eth-Trunk 5 a VLAN 100 y VLAN 200 respectivamente en modo de acceso.

    [Stack] interface eth-trunk 4
    [Stack-Eth-Trunk4] port link-type access
    [Stack-Eth-Trunk4] port default vlan 100
    [Stack-Eth-Trunk4] quit
    [Stack] interface eth-trunk 5
    [Stack-Eth-Trunk5] port link-type access
    [Stack-Eth-Trunk5] port default vlan 200
    [Stack-Eth-Trunk5] quit

  4. Configure una dirección IP para el gateway del clúster NLB.

    [Stack] interface vlanif 200
    [Stack-Vlanif200] ip address 10.128.246.250 24
    [Stack-Vlanif200] quit
    

  5. Configure una entrada ARP estática. En la entrada ARP estática, la dirección IP es la dirección IP del clúster 10.128.246.252, la dirección MAC es la dirección MAC de multidifusión del clúster 03bf-0a80-f6fc, y la interfaz de salida es Eth-Trunk 5 en la VLAN 200.

    [Stack] arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface eth-trunk 5   //Configure una entrada ARP estática

  6. Conecte GE0/0/4 y GE0/0/5 en Switch_1, y GE1/0/4 y GE1/0/5 en Switch_2.

    Después de las configuraciones anteriores, conecte los enlaces físicos.

  7. Verifique la configuración

    Verifique que Server_1 y Server_2 puedan recibir los paquetes destinados a la dirección IP del clúster NLB.

Archivos de configuración

Archivo de configuración de pila

#
sysname Stack
#
vlan batch 100 200
#                                                                               
interface Vlanif200                                                             
 ip address 10.128.246.250 255.255.255.0                                        
#
interface Eth-Trunk4                                                            
 port link-type access                                                          
 port default vlan 100                                                          
 stp disable                                                                    
#                                                                                
interface Eth-Trunk5                                                            
 port link-type access                                                          
 port default vlan 200                                                          
 stp disable                                                                    
#                                                                                
interface GigabitEthernet0/0/1                                                 
 port link-type access                                                          
 port default vlan 100                                               
# 
interface GigabitEthernet0/0/4
 eth-trunk 4
# 
interface GigabitEthernet0/0/5
 eth-trunk 5
# 
interface GigabitEthernet1/0/1                                                 
 port link-type access                                                          
 port default vlan 100                                                
#                                                                               
interface GigabitEthernet1/0/4                                                 
 eth-trunk 4                                                                    
#                                                                               
interface GigabitEthernet1/0/5                                                 
 eth-trunk 5                                                                    
#
arp static 10.128.246.252 03bf-0a80-f6fc vid 200 interface Eth-Trunk5 
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15623

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente