No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el inicio de sesión de conmutación a través del sistema web

Ejemplo para configurar el inicio de sesión de conmutación a través del sistema web

Configuración de fábrica de archivos de la página web para los switches de la serie S

En V200R006 y las versiones posteriores, el archivo de la página web se ha integrado en el software del sistema y se ha cargado. Para las configuraciones de fábrica de archivos de páginas web en las versiones anteriores a V200R006, consulte las siguientes tablas.

Tabla 3-2  Configuración de fábrica de archivos de páginas web para los switches fijos

Modelo del Producto

V100R006C05

V200R001

V200R002

V200R003

V200R005

S2300SI/S2300EI

El medio de almacenamiento no contiene un archivo de página web.

-

-

-

-

S2350EI

-

-

-

El medio de almacenamiento no contiene un archivo de página web.

El software del sistema contiene un archivo de página web que está cargado para el sistema web de Classics.

S3300SI/S3300EI

El medio de almacenamiento no contiene un archivo de página web.

-

-

-

-

S3300HI

-

El medio de almacenamiento no contiene un archivo de página web.

-

-

-

S5300LI

-

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El software del sistema contiene un archivo de página web que está cargado.

S5300SI/S5300EI

-

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

S5310EI

-

-

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

S5300HI

-

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

S5306LI

-

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El software del sistema contiene un archivo de página web que está cargado.

S6300EI

-

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

Tabla 3-3  Configuración de fábrica de archivos de páginas web para los switches modulares

Modelo del Producto

V200R001

V200R002

V200R003

V200R005

S9300

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El medio de almacenamiento no contiene un archivo de página web.

El software del sistema contiene un archivo de página web que está cargado.

S9300E

El S9300E no es compatible con el inicio de sesión del sistema web.
NOTA:

Un guión (-) indica que la versión no está disponible para el modelo.

Ejemplo para configurar el inicio de sesión de conmutación a través del sistema web (V200R001)

Descripción general

El sistema web utiliza el servidor web incorporado en un switch para proporcionar una GUI a través de la cual los usuarios pueden realizar la gestión y el mantenimiento de los switches. Los usuarios pueden iniciar sesión en el sistema web desde los terminales mediante HTTPS.

Notas de configuración

Este ejemplo se aplica a V200R001 de todos los switches de la serie S.

NOTA:

A continuación, se utilizan las líneas de comando y las salidas del S5300EI que ejecuta V200R001C00 como ejemplo.

Requisitos de red

Como se muestra en Figura 3-8, un switch funciona como el servidor HTTPS. El usuario desea iniciar sesión en el sistema web mediante HTTPS para administrar y mantener el switch. El usuario ha obtenido el certificado digital del servidor 1_servercert_pem_dsa.pem y el archivo de clave privada 1_serverkey_pem_dsa.pem del CA.

Figura 3-8  Diagrama de redes para configurar el inicio de sesión del switch a través del sistema web

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure una dirección IP de gestión para transferir archivos de forma remota e iniciar sesión en el switch a través del sistema web.

  2. Suba los archivos necesarios al servidor HTTPS a través de FTP, incluido el archivo de la página web, el certificado digital del servidor y el archivo de clave privada.

  3. Cargue el archivo de la página web y el certificado digital.

  4. Vincule una política SSL y habilite el servicio de HTTPS.

  5. Configure un usuario web y entre en la página de inicio de sesión del sistema web.
AVISO:

FTP es un protocolo inseguro. Se recomienda el uso de SFTP V2, SCP o FTPS.

Procedimiento

  1. Obtenga el archivo de la página web.

    Los siguientes métodos están disponibles:
    • Obtenga el archivo de la página web de un agente de Huawei.
    • Descargue el archivo de la página web del Sitio web de asistencia técnica de Huawei (http://support.huawei.com/carrier). En V200R001, el archivo de la página web se nombra en el formato de product name-software version.web page file version.web.zip.

    NOTA:

    Verifique si el tamaño del archivo de la página web obtenido es igual que el tamaño del archivo que se muestra en el sitio web. Si no, puede ocurrir una excepción durante la descarga del archivo. Descargue el archivo de nuevo.

  2. Configure una dirección IP de gestión.

    <Quidway> system-view
    [Quidway] sysname HTTPS_Server
    [HTTPS_Server] vlan 10
    [HTTPS_Server-vlan10] interface vlanif 10   //Configure VLANIF 10 como la interfaz de administración.
    [HTTPS_Server-Vlanif10] ip address 192.168.0.1 24   //Configure la dirección IP y despliegue la ruta según el plan de la red para garantizar la accesibilidad entre el PC y el switch.
    [HTTPS_Server-Vlanif10] quit
    [HTTPS_Server] interface gigabitethernet 0/0/10   //En este ejemplo, GE0/0/10 es la interfaz física utilizada para iniciar sesión en el switch a través del sistema web en un PC. Seleccione una interfaz basada en los requisitos reales de red.
    [HTTPS_Server-GigabitEthernet0/0/10] port link-type access   //Establezca el tipo de interfaz para acceder.
    [HTTPS_Server-GigabitEthernet0/0/10] port default vlan 10   //Agregue la interfaz a VLAN 10.
    [HTTPS_Server-GigabitEthernet0/0/10] quit

  3. Suba el archivo de la página web y el certificado digital al servidor HTTPS a través de FTP.

    # Configure las interfaces de usuario VTY en el servidor HTTPS.

    [HTTPS_Server] user-interface vty 0 14   //Introduzca las interfaces de usuario VTY 0 a 14.
    [HTTPS_Server-ui-vty0-14] authentication-mode aaa   //Establezca el modo de autenticación de los usuarios en las interfaces de usuario VTY de 0 a 14 a AAA.
    [HTTPS_Server-ui-vty0-14] quit

    # Configure la función de FTP para el switch y la información sobre un usuario de FTP, incluida la contraseña, el nivel de usuario, el tipo de servicio y el directorio autorizado.

    [HTTPS_Server] ftp server enable   //Habilite la función del servidor FTP.
    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user client001 password cipher Helloworld@6789   //Establezca la contraseña del inicio de sesión para Helloworld@6789.
    [HTTPS_Server-aaa] local-user client001 privilege level 15   //Establezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user client001 service-type ftp   //Establezca el tipo de servicio del usuario a FTP.
    [HTTPS_Server-aaa] local-user client001 ftp-directory flash:/   //Establezca el directorio FTP autorizado para flash:/.
    [HTTPS_Server-aaa] quit
    [HTTPS_Server] quit

    # Inicie sesión en el servidor HTTPS desde el ordenador a través de FTP y cargue el archivo de la página web y el certificado digital en el servidor HTTPS.

    Conecte el ordenador al switch mediante FTP. Introduzca el nombre de usuario client001 y la contraseña Helloworld@6789 y configure el modo de transferencia de archivos como binary.

    El siguiente ejemplo asume que el ordenador ejecuta el sistema operativo Windows XP.

    C:\Documents and Settings\Administrator> ftp 192.168.0.1
    Connected to 192.168.0.1.
    220 FTP service ready.
    User (192.168.0.1:(none)): client001
    331 Password required for client001.
    Password:
    230 User logged in.
    ftp> binary   //Establezca el modo de transferencia de archivos al binario. Por defecto, los archivos se transfieren en modo ASCII.
    200 Type set to I.
    ftp>

    Suba el archivo de la página web y el certificado digital al servidor HTTPS desde el ordenador.

    ftp> put web.zip    //Cargue el archivo de la página web. El archivo web.zip es usado como un ejemplo aquí.
    200 Port command okay.
    150 Opening BINARY mode data connection for web.zip
    226 Transfer complete.
    ftp: 1308478 bytes sent in 11 Seconds 4.6Kbytes/sec.
    ftp> put 1_servercert_pem_dsa.pem
    200 Port command okay.
    150 Opening BINARY mode data connection for 1_servercert_pem_dsa.pem
    226 Transfer complete.
    ftp: 1302 bytes sent in 2 Seconds 4.6Kbytes/sec.
    ftp> put 1_serverkey_pem_dsa.pem
    200 Port command okay.
    150 Opening BINARY mode data connection for 1_serverkey_pem_dsa.pem
    226 Transfer complete.
    ftp: 951 bytes sent in 1 Second 4.6Kbytes/sec.
    # Ejecute el comando dir en el Switch para verificar si el archivo de la página web y el certificado digital existen en el directorio de almacenamiento actual.
    NOTA:

    Si los tamaños del archivo de la página web y el certificado digital en el directorio de almacenamiento actual en el switch son diferentes a los del ordenador, puede ocurrir una excepción durante la transferencia de archivos. Sube los archivos de nuevo.

    # Cree el subdirectorio security en el servidor HTTPS y copie el certificado digital y el archivo de clave privada en el subdirectorio.

    <HTTPS_Server> mkdir security
    <HTTPS_Server> copy 1_servercert_pem_dsa.pem security
    Copy flash:/1_servercert_pem_dsa.pem to flash:/security/1_servercert_pem_dsa.pem?[Y/N]:y
    100%  complete
    Info: Copied file flash:/1_servercert_pem_dsa.pem to flash:/security/1_servercert_pem_dsa.pem...Done. 
    <HTTPS_Server> copy 1_serverkey_pem_dsa.pem security
    Copy flash:/1_serverkey_pem_dsa.pem to flash:/security/1_serverkey_pem_dsa.pem?[Y/N]:y
    100%  complete
    Info: Copied file flash:/1_serverkey_pem_dsa.pem to flash:/security/1_serverkey_pem_dsa.pem...Done.

    # Ejecute el comando dir en el subdirectorio de security para verificar el certificado digital.

    <HTTPS_Server> cd security
    <HTTPS_Server> dir
    Directory of flash:/security/
    
      Idx  Attr     Size(Byte)  Date        Time       FileName
        0  -rw-          1,200  Sep 26 2013 22:35:37   1_servercert_pem_dsa.pem
        1  -rw-            736  Sep 26 2013 22:36:11   1_serverkey_pem_dsa.pem
    
    30,008 KB total (348 KB free)

  4. Cargue el archivo de la página web y el certificado digital.

    # Cargue el archivo de la página web.

    <HTTPS_Server> system-view
    [HTTPS_Server] http server load web.zip

    # Cree una política SSL y cargue el certificado digital PEM.

    [HTTPS_Server] ssl policy http_server
    [HTTPS_Server-ssl-policy-http_server] certificate load pem-cert 1_servercert_pem_dsa.pem key-pair dsa key-file 1_serverkey_pem_dsa.pem auth-code 123456
    [HTTPS_Server-ssl-policy-http_server] quit

    # Una vez completadas las configuraciones anteriores, ejecute el comando display ssl policy en el servidor HTTPS para verificar la información detallada sobre el certificado digital cargado.

    [HTTPS_Server] display ssl policy
    
           SSL Policy Name: http_server
         Policy Applicants: 
             Key-pair Type: DSA
     Certificate File Type: PEM
          Certificate Type: certificate
      Certificate Filename: 1_servercert_pem_dsa.pem
         Key-file Filename: 1_serverkey_pem_dsa.pem
                 Auth-code: 123456
                       MAC:
                  CRL File:
           Trusted-CA File: 

  5. Vincule una política SSL y habilite el servicio de HTTPS.

    NOTA:

    Deshabilite el servicio HTTP antes de habilitar el servicio HTTPS.

    [HTTPS_Server] undo http server enable   //Deshabilite el servicio HTTP.
    [HTTPS_Server] http secure-server ssl-policy http_server   //Enlace una política SSL llamada http_server al servidor HTTP.
    [HTTPS_Server] http secure-server enable   //Habilite el servicio HTTP.

  6. Configure un usuario web y entre en la página de inicio de sesión del sistema web.

    # Configure un usuario web.

    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user admin password cipher Helloworld@6789   //Crea un usuario local llamado admin a establezca su contraseña a Helloworld@6789.
    [HTTPS_Server-aaa] local-user admin privilege level 15   //Establezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user admin service-type http   //Establezca el tipo de acceso a http, es decir, usuario de web.
    [HTTPS_Server-aaa] quit

    # Entre en la página de inicio de sesión del sistema web.

    Abra el navegador web en el ordenador, escriba https://192.168.0.1 en el cuadro de dirección y presione Enter. Se muestra la página de inicio de sesión del sistema web, como se muestra en Figura 3-9.

    Puede iniciar sesión en el sistema web mediante los navegadores Internet Explorer (6.0 o 8.0) o Firefox (3.5). Si la versión del navegador o la versión del parche del navegador no se encuentra dentro de los rangos anteriores, la página web puede mostrarse incorrectamente. Además, el navegador web utilizado para iniciar sesión en el sistema web debe ser compatible con JavaScript.

    Introduzca el nombre de usuario, la contraseña y el código de verificación. Haga clic en Login. Se muestra la página de inicio del sistema web.

    Figura 3-9  Página de inicio de sesión del sistema web

  7. Verifique la configuración

    Inicie sesión en el switch a través del sistema web. El inicio de sesión es exitoso.

    Ejecute el comando de display http server para ver el nombre de la política SSL y el estado del servidor HTTPS.

    [HTTPS_Server] display http server
       HTTP Server Status              : disabled
       HTTP Server Port                : 80(80)
       HTTP Timeout Interval           : 20
       Current Online Users            : 0
       Maximum Users Allowed           : 5
       HTTP Secure-server Status       : enabled
       HTTP Secure-server Port         : 443(443)
       HTTP SSL Policy                 : http_server

Archivos de configuración

Archivo de configuración de HTTPS_Server

#
sysname HTTPS_Server
#
FTP server enable
#
vlan batch 10
#
undo http server enable
http server load web.zip
http secure-server ssl-policy http_server
http secure-server enable
#
aaa
 local-user admin password cipher %$%$_h,hW_!nJ!2gXkH9v$X)+,#w%$%$ 
 local-user admin privilege level 15
 local-user admin service-type http
 local-user client001 password cipher %$%$jD,QKAhe{Yd9kD9Fqi#I+QH~%$%$
 local-user client001 privilege level 15
 local-user client001 ftp-directory flash:/
 local-user client001 service-type ftp
#
interface Vlanif10
 ip address 192.168.0.1 255.255.255.0
#
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 10
# 
user-interface vty 0 14
 authentication-mode aaa
#
ssl policy http_server
 certificate load pem-cert 1_servercert_pem_dsa.pem key-pair dsa key-file 1_serverkey_pem_dsa.pem auth-code 123456
#
return

Ejemplo para configurar el inicio de sesión de conmutación a través del sistema web (V100R006C05, V200R002 y V200R003)

Descripción general

El sistema web utiliza el servidor web incorporado en un switch para proporcionar una GUI a través de la cual los usuarios pueden realizar la gestión y el mantenimiento de los switches. Los usuarios pueden iniciar sesión en el sistema web desde los terminales mediante HTTPS.

Notas de configuración

Este ejemplo se aplica a V100R006C05, V200R002 y V200R003 de todos los switches de la serie S.

NOTA:

A continuación, se utilizan las líneas de comando y las salidas del S5300EI que ejecuta V200R002C00 como ejemplo.

Requisitos de red

Como se muestra en Figura 3-10, un switch funciona como el servidor HTTPS. El usuario desea iniciar sesión en el sistema web mediante HTTPS para administrar y mantener el switch.

Figura 3-10  Diagrama de redes para configurar el inicio de sesión del switch a través del sistema web

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

NOTA:

Un switch proporciona una política SSL predeterminada y tiene un certificado digital autofirmado generado aleatoriamente en el archivo de la página web. Si la política SSL predeterminada y el certificado digital autofirmado pueden cumplir con los requisitos de seguridad, no es necesario cargar un certificado digital ni configurar manualmente una política SSL, lo que simplifica la configuración. La siguiente configuración usa la política SSL predeterminada proporcionada por el switch como ejemplo.

  1. Configure una dirección IP de gestión para transferir los archivos de forma remota e iniciar sesión en el switch a través del sistema web.

  2. Suba el archivo de la página web al servidor HTTPS a través de FTP.

  3. Cargue el archivo de la página web.

  4. Configure un usuario web y entre en la página de inicio de sesión del sistema web.

AVISO:

FTP es un protocolo inseguro. Se recomienda el uso de SFTP V2, SCP o FTPS.

Procedimiento

  1. Obtenga el archivo de la página web.

    Los siguientes métodos están disponibles:
    • Obtenga el archivo de la página web de un agente de Huawei.
    • Obtenga el archivo de la página web de http://support.huawei.com/carrier.
      • Para un switch fijo, descargue el software del sistema que contiene el archivo de la página web.

      • Para un switch modular, descargue el archivo de la página web.

      • En V100R006C05, el archivo de la página web se nombra en el formato de product name-software version.web page file version.web.zip. En V200R002 y V200R003, el archivo de la página web se nombra en el formato de product name-software version.web page file version.web.7z.
    NOTA:

    Verifique si el tamaño del archivo de la página web obtenido es igual que el tamaño del archivo que se muestra en el sitio web. Si no, puede ocurrir una excepción durante la descarga del archivo. Descargue el archivo de nuevo.

  2. Configure una dirección IP de gestión.

    <Quidway> system-view
    [Quidway] sysname HTTPS_Server
    [HTTPS_Server] vlan 10
    [HTTPS_Server-vlan10] interface vlanif 10   //Configure VLANIF 10 como la interfaz de administración.
    [HTTPS_Server-Vlanif10] ip address 192.168.0.1 24   //Configure la dirección IP y despliegue la ruta según el plan de la red para garantizar la accesibilidad entre el PC y el switch.
    [HTTPS_Server-Vlanif10] quit
    [HTTPS_Server] interface gigabitethernet 0/0/10   //En este ejemplo, GE0/0/10 es la interfaz física utilizada para iniciar sesión en el switch a través del sistema web en un PC. Seleccione una interfaz basada en los requisitos reales de red.
    [HTTPS_Server-GigabitEthernet0/0/10] port link-type access   //Establezca el tipo de interfaz para acceder.
    [HTTPS_Server-GigabitEthernet0/0/10] port default vlan 10   //Agregue la interfaz a VLAN 10.
    [HTTPS_Server-GigabitEthernet0/0/10] quit

  3. Suba el archivo de la página web al servidor HTTPS a través de FTP.

    # Configure las interfaces de usuario VTY en el servidor HTTPS.

    [HTTPS_Server] user-interface vty 0 14   //Introduzca las interfaces de usuario VTY 0 a 14.
    [HTTPS_Server-ui-vty0-14] authentication-mode aaa   //Establezca el modo de autenticación de los usuarios en las interfaces de usuario VTY de 0 a 14 a AAA.
    [HTTPS_Server-ui-vty0-14] quit

    # Configure la función de FTP para el switch y la información sobre un usuario de FTP, incluida la contraseña, el nivel de usuario, el tipo de servicio y el directorio autorizado.

    [HTTPS_Server] ftp server enable   //Habilite la función del servidor FTP.
    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user client001 password cipher Helloworld@6789   //Establezca la contraseña del inicio de sesión para Helloworld@6789.
    [HTTPS_Server-aaa] local-user client001 privilege level 15   //Establezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user client001 service-type ftp   //Establezca el tipo de servicio del usuario a FTP.
    [HTTPS_Server-aaa] local-user client001 ftp-directory flash:/   //Establezca el directorio FTP autorizado para flash:/.
    [HTTPS_Server-aaa] quit
    [HTTPS_Server] quit

    # Inicie sesión en el servidor HTTPS desde el ordenador a través de FTP y suba el archivo de la página web al servidor HTTPS.

    Conecte el ordenador al switch mediante FTP. Introduzca el nombre de usuario client001 y la contraseña Helloworld@6789 y configure el modo de transferencia de archivos como binary.

    El siguiente ejemplo asume que el ordenador ejecuta el sistema operativo Windows XP.

    C:\Documents and Settings\Administrator> ftp 192.168.0.1
    Connected to 192.168.0.1.
    220 FTP service ready.
    User (192.168.0.1:(none)): client001
    331 Password required for client001.
    Password:
    230 User logged in.
    ftp> binary   //Establezca el modo de transferencia de archivos al binario. Por defecto, los archivos se transfieren en modo ASCII.
    200 Type set to I.
    ftp>

    Suba el archivo de la página web al servidor HTTPS desde el ordenador.

    ftp> put web.7z    //Cargue el archivo de la página web. El archivo web.7z es usado como un ejemplo aquí.
    200 Port command okay.
    150 Opening BINARY mode data connection for web.7z
    226 Transfer complete.
    ftp: 1308478 bytes sent in 11 Seconds 4.6Kbytes/sec.
    NOTA:

    Si el tamaño del archivo de la página web en el directorio actual del switch es diferente al del ordenador, puede ocurrir una excepción durante la transferencia de archivos. Suba el archivo de la página web de nuevo.

  4. Cargue el archivo de la página web.

    <HTTPS_Server> system-view
    [HTTPS_Server] http server load web.7z   //Cargue el archivo de la página web.

  5. Habilite el servicio de HTTPS.

    [HTTPS_Server] http secure-server enable   //El servicio HTTPS está habilitado por defecto y no requiere configuración manual. Si el servicio HTTPS se deshabilita manualmente, ejecute este comando para habilitarlo.

  6. Configure un usuario web y entre en la página de inicio de sesión del sistema web.

    # Configure un usuario web.

    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user admin password cipher Helloworld@6789   //Crea un usuario local llamado admin y establezca su contraseña a Helloworld@6789.
    [HTTPS_Server-aaa] local-user admin privilege level 15   //Esteblezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user admin service-type http   //Esteblezca el tipo de acceso a http, es decir, usuario web.
    [HTTPS_Server-aaa] quit

    # Entre en la página de inicio de sesión del sistema web.

    Abra el navegador web en el ordenador, escriba https://192.168.0.1 en el cuadro de dirección y presione Enter. Se muestra la página de inicio de sesión del sistema web, como se muestra en Figura 3-11.

    Puede utilizar los navegadores Internet Explorer (6.0 – 9.0), Firefox (3.5 – 17.0) para iniciar sesión en el sistema web para V100R006C05, usar los navegadores Internet Explorer (8.0), Firefox (3.6) para iniciar sesión en el sistema web para V200R001C00, use los navegadores Internet Explorer (6.0 – 9.0), Firefox (3.5 – 17.0) para iniciar sesión en el sistema web para V2100R003C00. Si la versión del navegador o la versión del parche del navegador no se encuentra dentro de los rangos anteriores, la página web puede mostrarse incorrectamente. Además, el navegador web utilizado para iniciar sesión en el sistema web debe ser compatible con JavaScript.

    Introduzca el nombre de usuario, la contraseña y el código de verificación. Haga clic en Login. Se muestra la página de inicio del sistema web.

    Figura 3-11  Página de inicio de sesión del sistema web

  7. Verifique la configuración

    Inicie sesión en el switch a través del sistema web. El inicio de sesión es exitoso.

    Ejecute el comando de display http server para ver el estado del servidor HTTPS.

    [HTTPS_Server] display http server
       HTTP Server Status              : enabled
       HTTP Server Port                : 80(80)
       HTTP Timeout Interval           : 20
       Current Online Users            : 0
       Maximum Users Allowed           : 5
       HTTP Secure-server Status       : enabled
       HTTP Secure-server Port         : 443(443)
       HTTP SSL Policy                 : Default

Archivos de configuración

Archivo de configuración del servidor HTTPS

#
sysname HTTPS_Server
#
FTP server enable
#
vlan batch 10
#
http server load web.7z
#
aaa
 local-user admin password cipher %$%$llCb"D|46>hV2w2=%&nOT/_K%$%$
 local-user admin privilege level 15
 local-user admin service-type http
 local-user client001 password cipher %$%$aL$_U%#$W^1T-\}Fqpe$E<#HN%$%$
 local-user client001 privilege level 15
 local-user client001 ftp-directory flash:/
 local-user client001 service-type ftp
#
interface Vlanif10
 ip address 192.168.0.1 255.255.255.0
#
interface GigabitEthernet1/0/10
 port link-type access
 port default vlan 10
#
user-interface vty 0 14
 authentication-mode aaa
#
return

Ejemplo para configurar el inicio de sesión de conmutación a través del sistema web (V200R005)

Descripción general

El sistema web utiliza el servidor web incorporado en un switch para proporcionar una GUI a través de la cual los usuarios pueden realizar la gestión y el mantenimiento de los switches. Los usuarios pueden iniciar sesión en el sistema web desde los terminales mediante HTTPS.

El sistema web está disponible en las versiones de EasyOperation y Classics.
  • La versión EasyOperation proporciona muchos gráficos y una UI más fácil de usar en la que los usuarios pueden realizar tareas de monitoreo, configuración, mantenimiento y otras operaciones de red.
  • La versión de Classics hereda el estilo de la página web de los switches de Huawei y proporciona las funciones integrales de configuración y gestión.
Notas de configuración

Este ejemplo se aplica a V200R005 de todos los switches de la serie S.

NOTA:

A continuación, se utilizan las líneas de comando y las salidas del S5300HI que ejecuta V200R005 como ejemplo.

Requisitos de red

Como se muestra en Figura 3-12, un switch funciona como el servidor HTTPS. El usuario desea iniciar sesión en el sistema web mediante HTTPS para administrar y mantener el switch.

Figura 3-12  Diagrama de redes para configurar el inicio de sesión del switch a través del sistema web

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

NOTA:

Un switch proporciona una política SSL predeterminada y tiene un certificado digital autofirmado generado aleatoriamente en el archivo de la página web. Si la política SSL predeterminada y el certificado digital autofirmado pueden cumplir con los requisitos de seguridad, no es necesario cargar un certificado digital ni configurar manualmente una política SSL, lo que simplifica la configuración. La siguiente configuración usa la política SSL predeterminada proporcionada por el switch como ejemplo.

  1. Configure una dirección IP de gestión para transferir los archivos de forma remota e iniciar sesión en el switch a través del sistema web.

  2. Suba el archivo de la página web al servidor HTTPS a través de FTP.

  3. Cargue el archivo de la página web.

  4. Configure un usuario web e introduzca a la página de inicio de sesión del sistema web.
NOTA:

FTP es un protocolo inseguro. Se recomienda el uso de SFTP V2, SCP o FTPS.

En los siguientes modelos de switches, el software del sistema ha integrado y cargado el archivo de la página web. Solo necesita configurar un usuario web y entrar en la página de inicio de sesión del sistema web.

  • Switch modular: todos los modelos
  • Switch fijo: S2350, S5300LI, S5306LI

Procedimiento

  1. Obtenga el archivo de la página web.

    Los siguientes métodos están disponibles:
    • Obtenga el archivo de la página web de un agente de Huawei.
    • Descargue el archivo de la página web del Sitio web de asistencia técnica de Huawei (http://support.huawei.com/carrier).
      • Para un switch fijo, descargue el software del sistema que contiene el archivo de la página web.

      • Para un switch modular, descargue el archivo de la página web.

      • En V200R005, el archivo de la página web se nombra en el formato de product name-software version.web page file version.web.7z.
    NOTA:

    Verifique si el tamaño del archivo de la página web obtenido es igual que el tamaño del archivo que se muestra en el sitio web. Si no, puede ocurrir una excepción durante la descarga del archivo. Descargue el archivo de nuevo.

  2. Configure una dirección IP de gestión.

    <Quidway> system-view
    [Quidway] sysname HTTPS_Server
    [HTTPS_Server] vlan 10
    [HTTPS_Server-vlan10] interface vlanif 10   //Configure VLANIF 10 como la interfaz de administración.
    [HTTPS_Server-Vlanif10] ip address 192.168.0.1 24   //Configure la dirección IP y despliegue la ruta según el plan de la red para garantizar la accesibilidad entre el PC y el switch.
    [HTTPS_Server-Vlanif10] quit
    [HTTPS_Server] interface gigabitethernet 0/0/10   //En este ejemplo, GE0/0/10 es la interfaz física utilizada para iniciar sesión en el switch a través del sistema web en un PC. Seleccione una interfaz basada en los requisitos reales de red.
    [HTTPS_Server-GigabitEthernet0/0/10] port link-type access   //Establezca el tipo de interfaz para acceder.
    [HTTPS_Server-GigabitEthernet0/0/10] port default vlan 10   //Agregue la interfaz a VLAN 10.
    [HTTPS_Server-GigabitEthernet0/0/10] quit

  3. Suba el archivo de la página web al servidor HTTPS a través de FTP.

    # Configure las interfaces de usuario VTY en el servidor HTTPS.

    [HTTPS_Server] user-interface vty 0 14   //Introduzca las interfaces de usuario VTY 0 a 14.
    [HTTPS_Server-ui-vty0-14] authentication-mode aaa   //Establezca el modo de autenticación de los usuarios en las interfaces de usuario VTY de 0 a 14 a AAA.
    [HTTPS_Server-ui-vty0-14] quit

    # Configure la función de FTP para el switch y la información sobre un usuario de FTP, incluida la contraseña, el nivel de usuario, el tipo de servicio y el directorio autorizado.

    [HTTPS_Server] ftp server enable   //Habilite la función del servidor FTP.
    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user client001 password irreversible-cipher Helloworld@6789   //Establezca la contraseña del inicio de sesión para Helloworld@6789.
    [HTTPS_Server-aaa] local-user client001 privilege level 15   //Establezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user client001 service-type ftp   //Establezca el tipo de servicio del usuario a FTP.
    [HTTPS_Server-aaa] local-user client001 ftp-directory flash:/   //Establezca el directorio FTP autorizado para flash:/.
    [HTTPS_Server-aaa] quit

    # Inicie sesión en el servidor HTTPS desde el ordenador a través de FTP y suba el archivo de la página web al servidor HTTPS.

    Conecte el ordenador al switch mediante FTP. Introduzca el nombre de usuario client001 y la contraseña Helloworld@6789 y configure el modo de transferencia de archivos como binary.

    El siguiente ejemplo asume que el ordenador ejecuta el sistema operativo Windows XP.

    C:\Documents and Settings\Administrator> ftp 192.168.0.1
    Connected to 192.168.0.1.
    220 FTP service ready.
    User (192.168.0.1:(none)): client001
    331 Password required for client001.
    Password:
    230 User logged in.
    ftp> binary   //Establezca el modo de transferencia de archivos al binario. Por defecto, los archivos se transfieren en modo ASCII.
    200 Type set to I.
    ftp>

    Suba el archivo de la página web al servidor HTTPS desde el ordenador.

    ftp> put web.7z    //Descargue el archivo de la página web. El archivo web.7z es usado como un ejemplo aquí.
    200 Port command okay.
    150 Opening BINARY mode data connection for web.zip
    226 Transfer complete.
    ftp: 1308478 bytes sent in 11 Seconds 4.6Kbytes/sec.
    NOTA:

    Si el tamaño del archivo de la página web en el directorio actual del switch es diferente al del ordenador, puede ocurrir una excepción durante la transferencia de archivos. Suba el archivo de la página web de nuevo.

  4. Cargue el archivo de la página web.

    # Cargue el archivo de la página web.

    [HTTPS_Server] http server load web.7z    //Cargue el archivo de la página web.

  5. Habilite el servicio de HTTPS.

    [HTTPS_Server] http secure-server enable    //El servicio HTTPS está habilitado por defecto y no requiere configuración manual. Si el servicio HTTPS se deshabilita manualmente, ejecute este comando para habilitarlo.

  6. Configure un usuario web y entre en la página de inicio de sesión del sistema web.

    # Configure un usuario web.

    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user admin password irreversible-cipher Helloworld@6789    //Establezca la contraseña del inicio de sesión para Helloworld@6789.
    [HTTPS_Server-aaa] local-user admin privilege level 15    //Establezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user admin service-type http    //Establezca el tipo de servicio del usuario a HTTP.
    [HTTPS_Server-aaa] quit

    # Entre en la página de inicio de sesión del sistema web.

    Abra el navegador web en el ordenador, escriba https://192.168.0.1 en el cuadro de dirección y presione Enter. Se muestra la página de inicio de sesión del sistema web, como se muestra en Figura 3-13.

    Enter the web user name admin and password Helloworld@6789, and click GO or press Enter. Se muestra la página de inicio del sistema web. El sistema web EasyOperation está conectado de manera predeterminada.

    Figura 3-13  Página de inicio de sesión del sistema web

  7. Verifique la configuración

    Inicie sesión en el switch a través del sistema web. El inicio de sesión es exitoso.

    Ejecute el comando de display http server para ver el estado del servidor HTTPS.

    [HTTPS_Server] display http server
       HTTP Server Status              : enabled
       HTTP Server Port                : 80(80)
       HTTP Timeout Interval           : 20
       Current Online Users            : 0
       Maximum Users Allowed           : 5
       HTTP Secure-server Status       : enabled
       HTTP Secure-server Port         : 443(443)
       HTTP SSL Policy                 : Default
       HTTP IPv6 Server Status         : disabled
       HTTP IPv6 Server Port           : 80(80)
       HTTP IPv6 Secure-server Status  : disabled
       HTTP IPv6 Secure-server Port    : 443(443) 

Archivos de configuración

Archivo de configuración de HTTPS_Server

#
sysname HTTPS_Server
#
FTP server enable
#
vlan batch 10
#
http server load web.7z
#
aaa
 local-user admin password irreversible-cipher %@%@wU:(2j8~r8Htyu3.]',NwU`Td[-A9~9"%4Kvhm'0RV[/U`Ww%@%@
 local-user admin privilege level 15
 local-user admin service-type http
 local-user client001 password irreversible-cipher %@%@5d~9:M^ipCfL\iB)EQd>,,ajwsi[\ad,saejin[qndi83Uwe%@%@
 local-user client001 privilege level 15
 local-user client001 ftp-directory flash:/
 local-user client001 service-type ftp
#
interface Vlanif10
 ip address 192.168.0.1 255.255.255.0
#
interface GigabitEthernet1/0/10
 port link-type access
 port default vlan 10
#
user-interface vty 0 14
 authentication-mode aaa
#
return

Ejemplo para configurar el inicio de sesión del switch a través del sistema web (V200R006 y las versiones posteriores)

Descripción general

El sistema web utiliza el servidor web incorporado en un switch para proporcionar una GUI a través de la cual los usuarios pueden realizar la gestión y el mantenimiento de los switches. Los usuarios pueden iniciar sesión en el sistema web desde los terminales mediante HTTPS.

El sistema web está disponible en las versiones de EasyOperation y Classics.
  • La versión EasyOperation proporciona muchos gráficos y una UI más fácil de usar en la que los usuarios pueden realizar las tareas de monitoreo, configuración, mantenimiento y otras operaciones de red.
  • La versión de Classics hereda el estilo de la página web de los switches de Huawei y proporciona las funciones integrales de configuración y gestión.
NOTA:

En V200R011C10 y las versiones posteriores, la versión de Classics no es compatible.

Notas de configuración

Este ejemplo se aplica a V200R006 y las versiones posteriores de todos los switches de la serie S.

NOTA:

A continuación, se utilizan las líneas de comando y las salidas del S5300LI que ejecuta V200R006C00 como ejemplo.

Requisitos de red

Como se muestra en Figura 3-14, un switch funciona como el servidor HTTPS. El usuario desea iniciar sesión en el sistema web mediante HTTPS para administrar y mantener el switch.

Figura 3-14  Diagrama de redes para configurar el inicio de sesión del switch a través del sistema web

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  • El software del sistema del switch ha integrado y cargado el archivo de la página web. No se requiere configuración manual.

  • Un switch proporciona una política SSL predeterminada y tiene un certificado digital autofirmado generado aleatoriamente en el archivo de la página web. Si la política SSL predeterminada y el certificado digital autofirmado pueden cumplir con los requisitos de seguridad, no es necesario cargar un certificado digital ni configurar manualmente una política SSL, lo que simplifica la configuración. La siguiente configuración usa la política SSL predeterminada proporcionada por el switch como ejemplo.

  • Configure una dirección IP de gestión para iniciar sesión en el switch a través del sistema web.

  • Configure un usuario web y entre en la página de inicio de sesión del sistema web.

Procedimiento

  1. Configure una dirección IP de gestión.

    <HUAWEI> system-view
    [HUAWEI] sysname HTTPS_Server
    [HTTPS_Server] vlan 10
    [HTTPS_Server-vlan10] interface vlanif 10    //Configure VLANIF 10 como la interfaz de administración.
    [HTTPS_Server-Vlanif10] ip address 192.168.0.1 24    //Configure la dirección IP y despliegue la ruta según el plan de la red para garantizar la accesibilidad entre el PC y el switch.
    [HTTPS_Server-Vlanif10] quit
    [HTTPS_Server] interface gigabitethernet 1/0/10    //En este ejemplo, GE1/0/10 es la interfaz física utilizada para iniciar sesión en el switch a través del sistema web en un PC. Seleccione una interfaz basada en los requisitos reales de red.
    [HTTPS_Server-GigabitEthernet1/0/10] port link-type access    //Esteblezca el tipo de interfaz para acceder.
    [HTTPS_Server-GigabitEthernet1/0/10] port default vlan 10    //Agregue la interfaz a VLAN 10.
    [HTTPS_Server-GigabitEthernet1/0/10] quit

  2. Habilite el servicio de HTTPS.

    [HTTPS_Server] http secure-server enable    //El servicio HTTPS está habilitado por defecto y no requiere configuración manual. Si el servicio HTTPS se deshabilita manualmente, ejecute este comando para habilitarlo.

  3. Configure un usuario web y entre en la página de inicio de sesión del sistema web.

    # Configure un usuario web.

    [HTTPS_Server] aaa
    [HTTPS_Server-aaa] local-user admin password irreversible-cipher Helloworld@6789    //Establezca la contraseña del inicio de sesión para Helloworld@6789.
    [HTTPS_Server-aaa] local-user admin privilege level 15    //Establezca el nivel de usuario a 15.
    [HTTPS_Server-aaa] local-user admin service-type http    //Establezca el tipo de servicio del usuario a HTTP.
    [HTTPS_Server-aaa] quit

    # Entre en la página de inicio de sesión del sistema web.

    Abra el navegador web en el ordenador, escriba https://192.168.0.1 en el cuadro de dirección y presione Enter. Se muestra la página de inicio de sesión del sistema web, como se muestra en Figura 3-15.

    Tabla 3-4 enumera las versiones de navegador requeridas para iniciar sesión en un switch a través del sistema web. Si la versión del navegador o la versión del parche del navegador no se encuentra dentro de los rangos anteriores, es posible que la página web no se muestre correctamente. Actualice el navegador y el parche del navegador. Además, el navegador debe ser compatible con JavaScript.

    Introduzca el nombre de usuario de la web admin y la contraseña Helloworld@6789, y haga clic en GO o presione Enter. Se muestra la página de inicio del sistema web. El sistema web EasyOperation está conectado de manera predeterminada.

    Tabla 3-4  Mapeo entre la versión del producto y la versión del navegador
    Versión del producto Versión del navegador para el sistema web EasyOperation Versión del navegador para el sistema web Classic
    V200R006 Internet Explorer 8.0 a 11.0, Firefox 12.0 a 28.0 o Google Chrome 23.0 a 34.0 Internet Explorer 8.0 a 11.0, o Firefox 12.0 a 28.0
    V200R007 Internet Explorer 8.0 a 11.0, Firefox 12.0 a 32.0 o Google Chrome 23.0 a 37.0 Internet Explorer 8.0 a 11.0, o Firefox 12.0 a 32.0
    V200R008 Internet Explorer 10.0, Internet Explorer 11.0, Firefox 31.0 a 35.0 o Google Chrome 30.0 a 39.0 Internet Explorer 10.0, Internet Explorer 11.0 o Firefox 31.0 a 35.0
    V200R009 Internet Explorer 10.0, Internet Explorer 11.0, Firefox 35.0 a 45.0 o Google Chrome 34.0 a 49.0 Internet Explorer 10.0, Internet Explorer 11.0 o Firefox 35.0 a 45.0
    V200R010 Microsoft Edge, Internet Explorer 10.0, Internet Explorer 11.0, Firefox 39.0 a 49.0 o Google Chrome 39.0 a 54.0 Internet Explorer 10.0, Internet Explorer 11.0, o Firefox 39.0 a 49.0
    V200R011C10 Microsoft Edge, Internet Explorer 10.0, Internet Explorer 11.0, Firefox 50.0 a 54.0, o Google Chrome 50.0 a 59.0
    Figura 3-15  Página de inicio de sesión del sistema web

  4. Verifique la configuración

    Inicie sesión en el switch a través del sistema web. El inicio de sesión es exitoso.

    Ejecute el comando de display http server para ver el estado del servidor HTTPS.

    [HTTPS_Server] display http server
       HTTP Server Status              : enabled
       HTTP Server Port                : 80(80)
       HTTP Timeout Interval           : 20
       Current Online Users            : 0
       Maximum Users Allowed           : 5
       HTTP Secure-server Status       : enabled
       HTTP Secure-server Port         : 443(443)
       HTTP SSL Policy                 : Default
       HTTP IPv6 Server Status         : disabled
       HTTP IPv6 Server Port           : 80(80)
       HTTP IPv6 Secure-server Status  : disabled
       HTTP IPv6 Secure-server Port    : 443(443)
       HTTP server source address      : 0.0.0.0

Archivos de configuración

Archivo de configuración de HTTPS_Server

#
sysname HTTPS_Server
#
vlan batch 10
#
aaa
 local-user admin password irreversible-cipher %#%#wU:(2j8~r8Htyu3.]',NwU`Td[-A9~9"%4Kvhm'0RV[/U`Ww%#%#
 local-user admin privilege level 15
 local-user admin service-type http
#
interface Vlanif10
 ip address 192.168.0.1 255.255.255.0
#
interface GigabitEthernet 1/0/10
 port link-type access
 port default vlan 10
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15745

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente