No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la limitación de la dirección MAC en una VLAN

Ejemplo para configurar la limitación de la dirección MAC en una VLAN

Descripción general

El switch limita el número de las entradas de direcciones MAC basadas en VLAN o interfaces. En las oficinas donde los clientes rara vez cambian, puede configurar la limitación de la dirección MAC para controlar el acceso de los usuarios. Esto puede proteger contra ciertos ataques. Por ejemplo, si un atacante falsifica una gran cantidad de paquetes con diferentes direcciones MAC de origen y envía los paquetes al dispositivo, se pueden agotar las entradas de direcciones MAC finitas en la tabla de direcciones MAC del dispositivo. Cuando la tabla de direcciones MAC está llena, el dispositivo no puede aprender las direcciones MAC de origen de los paquetes válidos. Como resultado, el dispositivo difunde los paquetes válidos, desperdiciando recursos de ancho de banda.

La limitación de direcciones MAC en una VLAN puede limitar el número de las entradas de direcciones MAC en múltiples interfaces en una VLAN.

Notas de configuración

  • Después de que el comando port-security enable esté configurado en una interfaz, la limitación de la dirección MAC no puede tener efecto en la interfaz. No configure la seguridad del puerto y la limitación de la dirección MAC en la misma interfaz simultáneamente.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.
  • Una vez que el número de las entradas de direcciones MAC aprendidas alcanza el límite, las tarjetas SA de la serie S y F de los dispositivos de chasis y dispositivos de caja (excluyendo S5320EI) no pueden descartar paquetes con direcciones MAC de origen inexistentes.

Requisitos de redes

En Figura 6-3, la red 1 de usuario está conectada a GE1/0/1 del switch a través de LSW1, la red 2 de usuario está conectada a GE1/0/2 del switch a través de LSW2, y GE1/0/1 y GE1/0/2 pertenecen a la VLAN 2. Para controlar el número de los usuarios de acceso, configure la limitación de la dirección MAC en la VLAN 2.

Figura 6-3  Redes de la limitación de la dirección MAC en una VLAN

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree una VLAN y agregue interfaces a la VLAN para implementar el reenvío de Capa 2.

  2. Configure la limitación de direcciones MAC en una VLAN para evitar ataques de direcciones MAC y controlar el número de los usuarios de acceso.

Procedimiento

  1. Cree VLAN 2 y agregue GE1/0/1 y GE1/0/2 para VLAN 2.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 2
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk   //Configure el tipo de enlace de la interfaz como troncal.
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 2   //Agregue GE1/0/1 a VLAN 2.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2   //La configuración de GE1/0/2 es similar a la configuración de of GE1/0/1.
    [Switch-GigabitEthernet1/0/2] port link-type trunk 
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [Switch-GigabitEthernet1/0/2] quit
    

  2. Configure la siguiente regla de la limitación de la dirección MAC en la VLAN 2: Se puede aprender un máximo de 100 direcciones MAC. Cuando el número de las entradas de direcciones MAC aprendidas alcanza el límite, el dispositivo reenvía los paquetes con nuevas entradas de dirección MAC de origen y genera una alarma.

    [Switch] vlan 2
    [Switch-vlan2] mac-limit maximum 100 action forward   //La acción predeterminada tomada para los paquetes en diferentes versiones es diferente. Se recomienda configurar manualmente la acción. La función de alarma está habilitada de manera predeterminada, por lo que no debe configurar la función de alarma manualmente.
    [Switch-vlan2] quit

  3. Verifique la configuración

    # Ejecute el comando display mac-limit en cualquier vista para verificar si la regla de la limitación de la dirección MAC está configurada correctamente.

    [Switch] display mac-limit
    MAC limit is enabled
    Total MAC limit rule count : 1
    
    PORT                 VLAN/VSI      SLOT Maximum Rate(ms) Action  Alarm
    ----------------------------------------------------------------------------
    -                    2                -    100     -     forward enable  
    

Archivos de configuración

Archivo de configuración de switch

#
sysname Switch
#
vlan batch 2
#
vlan 2
 mac-limit maximum 100 action forward
#
interface GigabitEthernet1/0/1
 port link-type trunk                                                           
 port trunk allow-pass vlan 2  
#
interface GigabitEthernet1/0/2
 port link-type trunk                                                           
 port trunk allow-pass vlan 2  
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15535

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente