No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar agregación de enlace en modo LACP cuando los switches están conectados directamente

Ejemplo para configurar agregación de enlace en modo LACP cuando los switches están conectados directamente

Descripción general

La agregación de enlaces de Ethernet aumenta el ancho de banda del enlace agrupando varios enlaces físicos para formar un enlace lógico. La agregación de enlaces puede funcionar en modo manual o en modo de Protocolo de control de agregación de enlaces (LACP).

Si se requiere un alto ancho de banda de enlace entre dos dispositivos conectados directamente y los dispositivos son compatibles con LACP, se recomienda el modo LACP. El modo LACP aumenta el ancho de banda, mejora la confiabilidad, implementa el equilibrio de carga, mejora la tolerancia a fallas de Eth-Trunk y proporciona la copia de seguridad.

En el modo LACP, algunos enlaces son enlaces activos y otros enlaces son enlaces de reserva. Todos los enlaces activos participan en el reenvío de datos. Si un enlace activo se vuelve defectuoso, se selecciona un enlace de reserva para reemplazar el enlace defectuoso. Es decir, la cantidad de enlaces que participan en el reenvío de datos permanece sin cambios.

Notas de configuración

  • Las interfaces de miembro de un Eth-Trunk deben usar el mismo tipo y velocidad de Ethernet.
  • Ambos dispositivos de Eth-Trunk deben usar la misma cantidad de interfaces físicas, velocidad de interfaz, modo dúplex y modo de control de flujo.
  • Si se agrega una interfaz del dispositivo local a un Eth-Trunk, una interfaz del dispositivo remoto conectado directamente a la interfaz del dispositivo local también se debe agregar a un Eth-Trunk. De lo contrario, los dos extremos no pueden comunicarse.
  • Ambos dispositivos de un Eth-Trunk deben usar el mismo modo de agregación de enlaces.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-6, SwitchA y SwitchB se conectan a dispositivos en VLAN 10 y VLAN 20 a través de enlaces de Ethernet, y el tráfico pesado se transmite entre SwitchA y SwitchB. El enlace entre SwitchA y SwitchB es necesario para proporcionar un gran ancho de banda para implementar la comunicación entre VLAN. La agregación de enlaces en modo LACP está configurada en SwitchA y SwitchB para mejorar el ancho de banda y la confiabilidad. Se deben cumplir los siguientes requisitos:

  • Dos enlaces activos implementan el equilibrio de carga.

  • Un enlace funciona como enlace de reserva. Cuando ocurre una falla en un enlace activo, el enlace de reserva reemplaza el enlace defectuoso para mantener una transmisión de datos confiable.

  • Los dispositivos en la misma VLAN se pueden comunicar.

Figura 6-6  Diagrama de redes para configurar la agregación de enlaces en modo LACP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree un Eth-Trunk y configure el Eth-Trunk para que funcione en modo LACP para implementar la agregación de enlaces.

  2. Agregue interfaces de miembro al Eth-Trunk.

  3. Ajuste la prioridad del sistema LACP y determine el Actor para que el Partner seleccione las interfaces activas según la prioridad de la interfaz Actor.

  4. Ajuste el umbral superior para la cantidad de interfaces activas para mejorar la confiabilidad.

  5. Ajuste las prioridades de la interfaz LACP y determine las interfaces activas para que las interfaces con prioridades más altas se seleccionen como interfaces activas.

  6. Cree las VLAN y agregue interfaces a las VLAN.

Procedimiento

  1. Cree Eth-Trunk 1 en SwitchA y configure Eth-Trunk 1 para que funcione en modo LACP. La configuración de SwitchB es similar a la de SwitchA, y no se menciona aquí.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] interface eth-trunk 1   //Cree Eth-Trunk 1.
    [SwitchA-Eth-Trunk1] mode lacp   //Configure la agregación de enlaces en modo LACP.
    [SwitchA-Eth-Trunk1] quit

  2. # Agregue interfaces de miembro en SwitchA a Eth-Trunk 1. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] eth-trunk 1   //Agregue GE1/0/1 to Eth-Trunk 1.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] eth-trunk 1   //Agregue GE1/0/2 to Eth-Trunk 1.
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] eth-trunk 1   //Agregue GE1/0/3 to Eth-Trunk 1.
    [SwitchA-GigabitEthernet1/0/3] quit
    

  3. Ajuste la prioridad LACP del sistema de SwitchA a 100 para que SwitchA se vuelva en Actor.

    [SwitchA] lacp priority 100   //La prioridad LACP del sistema por defecto es de 32768. Cambie la prioridad LACP de SwitchA para que sea más alta que la de SwitchB para que SwitchA funcione como Actor.
    

  4. En SwitchA, ajuste el umbral superior para la cantidad de interfaces activas a 2.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] max active-linknumber 2   //El umbral superior por defecto para el número de las interfaces activas en el LAG es de 8. Cambie el umbral superior para el número de las interfaces activas a 2.
    [SwitchA-Eth-Trunk1] quit

  5. Ajuste la prioridad LACP de la interfaz y determine los enlaces activos en SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] lacp priority 100   //La prioridad LACP del sistema por defecto es de 32768. Cambie la prioridad LACP de GE1/0/1 a 100 para que GE1/0/1 sirva como la interfaz activa.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] lacp priority 100   //La prioridad LACP del sistema por defecto es de 32768. Cambie la prioridad LACP de GE1/0/2 to 100 so that GE1/0/2 sirva como la interfaz activa.
    [SwitchA-GigabitEthernet1/0/2] quit
    

  6. Cree las VLAN y agregue interfaces a las VLAN.

    # Cree VLAN 10 y VLAN 20 y agrégueles interfaces. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type trunk   //Configure la interfaz como una interfaz Trunk. El tipo de enlace por defecto de una interfaz no es Trunk.
    [SwitchA-GigabitEthernet1/0/4] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/4] quit
    [SwitchA] interface gigabitethernet 1/0/5
    [SwitchA-GigabitEthernet1/0/5] port link-type trunk   //Configure la interfaz como una interfaz Trunk. El tipo de enlace por defecto de una interfaz no es Trunk.
    [SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/5] quit
    

    # Configure Eth-Trunk 1 para permitir que los paquetes de VLAN 10 y VLAN 20 pasen. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] port link-type trunk   //Configure la interfaz como una interfaz Trunk. El tipo de enlace por defecto de una interfaz no es Trunk.
    [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 10 20
    [SwitchA-Eth-Trunk1] quit

  7. Verifique la configuración

    # Verifique la información sobre Eth-Trunk en cada Switch y verifique si la negociación del enlace es exitosa.

    [SwitchA] display eth-trunk 1
    Eth-Trunk1's state information is:
    Local:                                                                          
    LAG ID: 1                       WorkingMode: LACP                             
    Preempt Delay: Disabled         Hash arithmetic: According to SIP-XOR-DIP       
    System Priority: 100            System ID: 00e0-fca8-0417
    Least Active-linknumber: 1      Max Active-linknumber: 2                        
    Operate status: up              Number Of Up Port In Trunk: 2
    --------------------------------------------------------------------------------
    ActorPortName                    Status     PortType PortPri   PortNo PortKey   PortState  Weight
    GigabitEthernet1/0/1             Selected  1GE       100      6145    2865      11111100     1
    GigabitEthernet1/0/2             Selected  1GE       100      6146    2865      11111100     1
    GigabitEthernet1/0/3             Unselect  1GE       32768    6147    2865      11100000     1
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName                     SysPri    SystemID    PortPri PortNo PortKey   PortState
    GigabitEthernet1/0/1              32768  00e0-fca6-7f85  32768     6145   2609      11111100
    GigabitEthernet1/0/2              32768  00e0-fca6-7f85  32768     6146   2609      11111100
    GigabitEthernet1/0/3              32768  00e0-fca6-7f85  32768     6147   2609      11110000
    
    [SwitchB] display eth-trunk 1
    Eth-Trunk1's state information is:
    Local:
    LAG ID: 1                      WorkingMode: LACP
    Preempt Delay: Disabled        Hash arithmetic: According to SIP-XOR-DIP
    System Priority: 32768         System ID: 00e0-fca6-7f85
    Least Active-linknumber: 1     Max Active-linknumber: 8
    Operate status: up             Number Of Up Port In Trunk: 2
    --------------------------------------------------------------------------------
    ActorPortName                   Status     PortType    PortPri   PortNo  PortKey   PortState  Weight
    GigabitEthernet1/0/1            Selected  1GE        32768      6145    2609      11111100     1
    GigabitEthernet1/0/2            Selected  1GE        32768      6146    2609      11111100     1
    GigabitEthernet1/0/3            Unselect  1GE        32768      6147    2609      11110000     1
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName                     SysPri    SystemID     PortPri  PortNo  PortKey   PortState
    GigabitEthernet1/0/1              100    00e0-fca8-0417  100      6145     2865      11111100
    GigabitEthernet1/0/2              100    00e0-fca8-0417  100      6146     2865      11111100
    GigabitEthernet1/0/3              100    00e0-fca8-0417  32768    6147     2865      11100000
    

    La información anterior muestra que la prioridad del sistema LACP de SwitchA es de 100 y es más alta que la prioridad LACP del sistema de SwitchB. GigabitEthernet1/0/1 y GigabitEthernet1/0/2 son interfaces activas y se queda bajo el estado Selected. GigabitEthernet1/0/3 se queda bajo el estado Unselect. Además, se implementan el equilibrio de carga y la redundancia.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    lacp priority 100
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     mode lacp
     max active-linknumber 2
    #
    interface GigabitEthernet1/0/1
     eth-trunk 1
     lacp priority 100
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
     lacp priority 100
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/5
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 10 20
     mode lacp
    #
    interface GigabitEthernet1/0/1
     eth-trunk 1
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4
     port link-type trunk 
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/5
     port link-type trunk 
     port trunk allow-pass vlan 20
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15503

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente