No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para conectar un E-Trunk a una red de VPLS

Ejemplo para conectar un E-Trunk a una red de VPLS

Descripción general

Enhanced Trunk (E-Trunk) es una extensión de LACP (un protocolo de agregación de enlaces para un solo dispositivo) e implementa la agregación de enlaces entre múltiples dispositivos. E-Trunk logra la confiabilidad del enlace a nivel del dispositivo pero no la confiabilidad del enlace a nivel de la tarjeta.

Cuando un CE esté dual-homed a una red VPLS, VLL o PWE3, se puede configurar un E-Trunk para proteger los enlaces entre el CE y los PE e implementar la copia de seguridad entre los PE. Si no se configura ningún E-Trunk, se puede conectar un CE a solo un PE usando un Eth-Trunk. Si el Eth-Trunk o el PE falla, el CE no puede comunicarse con el PE. Después de que se utilice el E-Trunk, el CE puede estar dual-homed a dos PE para implementar la copia de seguridad.

Notas de configuración

  • Los dispositivos deben usar la agregación de enlaces en modo LACP.
  • En Figura 6-7, la configuración del E-Trunk en PE1 y en PE2 debe ser la misma. Los Eth-Trunks entre PE1 y CE1 y entre PE2 y CE1 deben usar la misma velocidad y el mismo modo dúplex (los valores clave deben ser los mismos) y unirse al mismo E-Trunk. Después de que los Eth-Trunks se agreguen al E-Trunk, asegúrese de que las prioridades de LACP y los IDs del sistema de PE1 y PE2 sean los mismos. En CE1, las interfaces conectadas directamente a PE1 y PE2 se deben agregar al mismo Eth-Trunk. Eth-Trunk puede tener un ID de Eth-Trunk distinto al de los PE. Por ejemplo, el CE está configurado con Eth-Trunk 20, mientras que ambos PE están configurados con Eth-Trunk 10.

  • Debe especificar una dirección IP (se recomienda una dirección de loopback) para cada PE para garantizar la conectividad de Capa 3. Asegúrese de que la dirección IP del otro extremo de un PE sea la dirección IP local del otro PE.

  • El E-Trunk debe estar vinculado a una sesión BFD.

  • Debe ajustar la misma contraseña del paquete de protocolo para PE1 y PE2.

  • Tabla 6-1  Modelos de productos y versiones aplicables

    Producto

    Modelo del producto

    Versión del software

    S5300

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9300E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Si no se configura ningún E-Trunk, se puede conectar un CE a solo un PE usando un Eth-Trunk. Si el Eth-Trunk o el PE falla, el CE no puede comunicarse con el PE. Después de que se configure un E-Trunk, el CE puede estar dual-homed para PE. E-Trunk logra la confiabilidad del enlace a nivel del dispositivo pero no la confiabilidad del enlace a nivel de la tarjeta.

En Figura 6-7, CE1 es conectado a PE1 y PE2 usando dos Eth-Trunks en modo LACP y está dual-homed a una red VPLS.

Inicialmente, CE1 se comunica con CE2 en la red VPLS a través de PE1. Si PE1 o Eth-Trunk entre CE1 y PE1 falla, CE1 no se puede comunicar con CE2. Para evitar la interrupción del servicio, configure un E-Trunk en PE1 y PE2. Cuando falla la comunicación entre CE1 y PE1, el tráfico cambia a PE2 para que CE1 pueda comunicarse con CE2 a través de PE2. Cuando se recupere PE1 o Eth-Trunk entre CE1 y PE1, el tráfico vuelve a ser cambiado a PE1.

El E-Trunk implementa una copia de seguridad de los grupos de agregación de enlaces (LAG) entre PE1 y PE2 y, por lo tanto, mejora la confiabilidad de la red.

Figura 6-7  Conexión de un E-Trunk a una red VPLS

Switch

Interfaz

Interfaz de capa 3

Dirección IP

PE1

GigabitEthernet1/0/1

-

-

-

GigabitEthernet1/0/2

-

-

-

GigabitEthernet1/0/3

VLANIF 100

10.1.1.1/24

-

Loopback1

-

1.1.1.9/32

PE2

GigabitEthernet1/0/1

-

-

-

GigabitEthernet1/0/2

-

-

-

GigabitEthernet1/0/3

VLANIF 200

10.1.2.1/24

-

Loopback1

-

2.2.2.9/32

PE3

GigabitEthernet1/0/1

VLANIF 100

10.1.1.2/24

-

GigabitEthernet1/0/2

VLANIF 200

10.1.2.2/24

-

GigabitEthernet1/0/3

GigabitEthernet1/0/3.1

-

-

Loopback1

-

3.3.3.9/32

CE1

GigabitEthernet1/0/1

-

-

-

GigabitEthernet1/0/2

-

-

-

GigabitEthernet1/0/3

-

-

-

GigabitEthernet1/0/4

-

-

CE2

GigabitEthernet1/0/3

-

-

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure un E-Trunk.

    • Cree Eth-Trunks en modo LACP entre CE1 y PE1 y entre CE1 y PE2. Agregue interfaces de miembro a Eth-Trunks.

    • Cree un E-Trunk en PE1 y PE2 y agregue los dos Eth-Trunks en modo LACP al E-Trunk.

    • Ajuste los parámetros de E-Trunk:

      • Prioridad de E-Trunk

      • ID del sistema LACP y prioridad de LACP del E-Trunk

      • Intervalo al que se envían los paquetes de Hello

      • Multiplicador de tiempo para detectar paquetes de Hello

      • Direcciones IP del extremo local y remoto

    • Enlace el E-Trunk a una sesión BFD.
  2. Configure CE1 para conectarse a la red VPLS de la siguiente manera:
    • Configure un protocolo de enrutamiento en la red de backbone para implementar el interfuncionamiento entre dispositivos.

    • Configure las funciones básicas de MPLS y el LDP.

    • Habilite MPLS L2VPN en PE.

    • Configure un VSI y especifique LDP como el protocolo de señalización.

    • Cree subinterfaces de Eth-Trunk y vincule el VSI a las subinterfaces.

Procedimiento

  1. Configure VLAN y direcciones IP de las interfaces del lado de PW según Figura 6-7. Configure un protocolo de enrutamiento en la red de backbone para implementar el interfuncionamiento entre dispositivos. OSPF se usa en este ejemplo.

    # Configure el switch de agregación PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] vlan batch 100
    [PE1] interface gigabitethernet 1/0/3
    [PE1-GigabitEthernet1/0/3] port link-type trunk
    [PE1-GigabitEthernet1/0/3] port trunk allow-pass vlan 100
    [PE1-GigabitEthernet1/0/3] quit
    [PE1] interface vlanif 100
    [PE1-Vlanif100] ip address 10.1.1.1 24
    [PE1-Vlanif100] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure el switch de agregación PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] vlan batch 200
    [PE2] interface gigabitethernet 1/0/3
    [PE2-GigabitEthernet1/0/3] port link-type trunk
    [PE2-GigabitEthernet1/0/3] port trunk allow-pass vlan 200
    [PE2-GigabitEthernet1/0/3] quit
    [PE2] interface vlanif 200
    [PE2-Vlanif200] ip address 10.1.2.1 24
    [PE2-Vlanif200] quit
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 2.2.2.9 32
    [PE2-LoopBack1] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    # Configure el switch de agregación PE3.

    <Quidway> system-view
    [Quidway] sysname PE3
    [PE3] vlan batch 100 200
    [PE3] interface gigabitethernet 1/0/1
    [PE3-GigabitEthernet1/0/1] port link-type trunk
    [PE3-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
    [PE3-GigabitEthernet1/0/1] quit
    [PE3] interface gigabitethernet 1/0/2
    [PE3-GigabitEthernet1/0/2] port link-type trunk
    [PE3-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
    [PE3-GigabitEthernet1/0/2] quit
    [PE3] interface vlanif 100
    [PE3-Vlanif100] ip address 10.1.1.2 24
    [PE3-Vlanif100] quit
    [PE3] interface vlanif 200
    [PE3-Vlanif200] ip address 10.1.2.2 24
    [PE3-Vlanif200] quit
    [PE3] interface loopback 1
    [PE3-LoopBack1] ip address 3.3.3.9 32
    [PE3-LoopBack1] quit
    [PE3] ospf 1
    [PE3-ospf-1] area 0
    [PE3-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [PE3-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] quit
    [PE3-ospf-1] quit

    Una vez completada la configuración, PE1, PE2 y PE3 usan OSPF para descubrir rutas de IP a la interfaz Loopback1 de cada uno y pueden hacer ping entre sí. Ejecute el comando display ip routing-table en PE1, PE2 y PE3 para determinar si los PE se han aprendido las rutas entre sí.

    NOTA:
    • La interfaz del lado AC y la interfaz del lado PW de un PE no se pueden agregar a la misma VLAN; de lo contrario, puede ocurrir un bucle.
    • Al configurar OSPF, configure PE1, PE2 y PE3 para anunciar direcciones de loopback de 32 bits.

  2. Configure Eth-Trunks en modo LACP en el switch CE1, PE1 y PE2 del lado del usuario, y agregue interfaces de miembro a Eth-Trunks. Configure el reenvío de Capa 2 en CE1.

    # Configure CE1.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface eth-trunk 20 //Cree Eth-Trunk 20 e introduzca la vista de Eth-Trunk 20.
    [CE1-Eth-Trunk20] port link-type trunk //Establezca el tipo de enlace de la interfaz al Trunk.
    [CE1-Eth-Trunk20] port trunk allow-pass vlan 10 //Agregue Eth-Trunk 20 a VLAN 10.
    [CE1-Eth-Trunk20] mode lacp //Configure Eth-Trunk 20 a funcionar en modo LACP.
    [CE1-Eth-Trunk20] trunkport GigabitEthernet 1/0/1 to 1/0/4 //Agregue GE1/0/1 a GE1/0/4 a Eth-Trunk20.
    [CE1-Eth-Trunk20] quit

    # Configure PE1.

    [PE1] interface eth-trunk 10 //Cree Eth-Trunk 10 e introduzca la vista de Eth-Trunk 10.
    [PE1-Eth-Trunk10] port link-type trunk //Establezca el tipo de enlace de la interfaz al Trunk.
    [PE1-Eth-Trunk10] mode lacp //Configure Eth-Trunk 10 a funcionar en modo LACP.
    [PE1-Eth-Trunk10] trunkport GigabitEthernet 1/0/1 to 1/0/2 //Agregue GE1/0/1 a GE1/0/2 a Eth-Trunk10.
    [PE1-Eth-Trunk10] quit

    # Configure PE2.

    [PE2] interface eth-trunk 10 //Cree Eth-Trunk 10 e introduzca la vista de Eth-Trunk 10.
    [PE2-Eth-Trunk10] port link-type trunk //Establezca el tipo de enlace de la interfaz al Trunk.
    [PE2-Eth-Trunk10] mode lacp //Configure Eth-Trunk 10 a funcionar en modo LACP.
    [PE2-Eth-Trunk10] trunkport GigabitEthernet 1/0/1 to 1/0/2 //Agregue GE1/0/1 a GE1/0/2 a Eth-Trunk10.
    [PE2-Eth-Trunk10] quit

  3. Cree un E-Trunk y ajuste la prioridad de LACP, el ID del sistema LACP, la prioridad de E-Trunk, el multiplicador de tiempo para detectar paquetes de saludo, el intervalo al que se envían los paquetes de saludo y las direcciones IP locales y remotas.

    # Configure PE1.

    [PE1] e-trunk 1 //Cree E-Trunk 1 e introduzca la vista de E-Trunk 1.
    [PE1-e-trunk-1] quit
    [PE1] lacp e-trunk priority 1 //Establezca la prioridad LACP de E-Trunk 1 a 1.
    [PE1] lacp e-trunk system-id 00E0-FC00-0000 //Establezca el ID del sistema LACP de E-Trunk 1 a 00E0-FC00-0000.
    [PE1] e-trunk 1 //Introduzca la vista de E-Trunk 1.
    [PE1-e-trunk-1] priority 10 //Establezca la prioridad de E-Trunk 1 a 10.
    [PE1-e-trunk-1] timer hold-on-failure multiplier 3 //Establezca el multiplicador de tiempo para detectar paquetes de saludo a 3.
    [PE1-e-trunk-1] timer hello 9 //Establezca  el intervalo al que se envían los paquetes de saludo a 9 ms.
    [PE1-e-trunk-1] peer-address 2.2.2.9 source-address 1.1.1.9 //Establezca  la dirección IP remota a 2.2.2.9 y la dirección IP local a 1.1.1.9.
    [PE1-e-trunk-1] quit

    # Configure PE2.

    [PE2] e-trunk 1 //Cree Eth-Trunk 1 e ingresa en la vista de E-Trunk 1.
    [PE2-e-trunk-1] quit
    [PE2] lacp e-trunk priority 1 //Establezca la prioridad LACP de E-Trunk 1 a 1.
    [PE2] lacp e-trunk system-id 00E0-FC00-0000 //Establezca el ID del sistema LACP de E-Trunk 1 a 00E0-FC00-0000.
    [PE2] e-trunk 1 //Introduzca la vista de E-Trunk 1.
    [PE2-e-trunk-1] priority 20 //Establezca la prioridad de E-Trunk 1 a 20.
    [PE2-e-trunk-1] timer hold-on-failure multiplier 3 //Establezca el multiplicador de tiempo para detectar paquetes de saludo a 3.
    [PE2-e-trunk-1] timer hello 9 //Establezca  el intervalo al que se envían los paquetes de saludo a 9 ms.
    [PE2-e-trunk-1] peer-address 1.1.1.9 source-address 2.2.2.9 //Establezca  la dirección IP remota a 1.1.1.9 y la dirección IP local a 2.2.2.9.
    [PE2-e-trunk-1] quit

  4. Agregue los Eth-Trunks en modo LACP al E-Trunk.

    # Configure PE1.

    [PE1] interface eth-trunk 10 //Introduzca la vista de E-Trunk 10.
    [PE1-Eth-Trunk10] e-trunk 1 //Agregue Eth-Trunk 10 a E-Trunk 1.
    [PE1-Eth-Trunk10] quit

    # Configure PE2.

    [PE2] interface eth-trunk 10 //Introduzca la vista de E-Trunk 10.
    [PE2-Eth-Trunk10] e-trunk 1 //Agregue Eth-Trunk 10 a E-Trunk 1.
    [PE2-Eth-Trunk10] quit

  5. Enlace el E-Trunk a una sesión BFD.

    • Cree una sesión BFD.

      # Configure PE1.

      [PE1] bfd //Habilite BFD.
      [PE1-bfd] quit
      [PE1] bfd hello1 bind peer-ip 2.2.2.9 source-ip 1.1.1.9 //Cree una sesión BFD llamada hello1 y enlace la sesión BFD a la dirección IP remota 2.2.2.9 y la dirección IP local 1.1.1.9.
      [PE1-bfd-session-hello1] discriminator local 1 //Establezca el discriminador local a 1.
      [PE1-bfd-session-hello1] discriminator remote 2 //Establezca el discriminador remoto a 2.
      [PE1-bfd-session-hello1] commit //Confirme la configuración de la sesión BFD.
      [PE1-bfd-session-hello1] quit

      Las direcciones IP del extremo local y remoto de una sesión BFD deben ser las mismas que las del E-Trunk.

      # Configure PE2.

      [PE2] bfd
      [PE2-bfd] quit
      [PE2] bfd hello2 bind peer-ip 1.1.1.9 source-ip 2.2.2.9 //Cree una sesión BFD llamada hello2 y enlace la sesión BFD a la dirección IP remota 1.1.1.9 y la dirección IP local 2.2.2.9.
      [PE2-bfd-session-hello2] discriminator local 2 //Establezca el discriminador local a 2.
      [PE2-bfd-session-hello2] discriminator remote 1 //Establezca el discriminador remoto a 1.
      [PE2-bfd-session-hello2] commit //Confirme la configuración de la sesión BFD.
      [PE2-bfd-session-hello2] quit
    • Enlace el E-Trunk 1 a la sesión BFD.

      # Configure PE1.

      [PE1] e-trunk 1 //Introduzca la vista de E-Trunk 1.
      [PE1-e-trunk-1] e-trunk track bfd-session session-name hello1 //Enlace E-Trunk 1 a la sesión BFD hello1.
      [PE1-e-trunk-1] quit

      # Configure PE2.

      [PE2] e-trunk 1 //Introduzca la vista de E-Trunk 1.
      [PE2-e-trunk-1] e-trunk track bfd-session session-name hello2 //Enlace E-Trunk 1 a la sesión BFD hello2.
      [PE2-e-trunk-1] quit

  6. Configure los PE para que CE1 pueda acceder a la red VPLS.

    1. Configure las funciones básicas de MPLS y el LDP en PE1, PE2 y PE3.

      # Configure PE1.

      [PE1] mpls lsr-id 1.1.1.9 //Establezca el ID de LSR a 3.3.3.9.
      [PE1] mpls //Habilite MPLS global.
      [PE1-mpls] quit
      [PE1] mpls ldp //Habilite LDP global.
      [PE1-mpls-ldp] quit
      [PE1] interface vlanif 100
      [PE1-Vlanif100] mpls //Habilite MPLS en una interfaz.
      [PE1-Vlanif100] mpls ldp //Habilite LDP en una interfaz.
      [PE1-Vlanif100] quit

      # Configure PE2.

      [PE2] mpls lsr-id 2.2.2.9 //Establezca el ID de LSR a 2.2.2.9.
      [PE2] mpls //Habilite MPLS global.
      [PE2-mpls] quit
      [PE2] mpls ldp //Habilite LDP global.
      [PE2-mpls-ldp] quit
      [PE2] interface vlanif 200
      [PE2-Vlanif200] mpls //Habilite MPLS en una interfaz.
      [PE2-Vlanif200] mpls ldp //Habilite LDP en una interfaz.
      [PE2-Vlanif200] quit

      # Configure PE3.

      [PE3] mpls lsr-id 3.3.3.9 ////Establezca el ID de LSR a 3.3.3.9.
      [PE3] mpls //Habilite MPLS global.
      [PE3-mpls] quit
      [PE3] mpls ldp //Habilite LDP global.
      [PE3-mpls-ldp] quit
      [PE3] interface vlanif 100
      [PE3-Vlanif100] mpls //Habilite MPLS en una interfaz.
      [PE3-Vlanif100] mpls ldp //Habilite LDP en una interfaz.
      [PE3-Vlanif100] quit
      [PE3] interface vlanif 200
      [PE3-Vlanif200] mpls //Habilite MPLS en una interfaz.
      [PE3-Vlanif200] mpls ldp //Habilite LDP en una interfaz.
      [PE3-Vlanif200] quit

      Una vez completada la configuración, ejecute el comando display mpls ldp session en PE para determinar si el estado de la relación del otro extremo de LDP remota es Operational. Esto indica que las sesiones remotas de LDP están creadas.

    2. Habilite MPLS L2VPN en PE1, PE2 y PE3.

      # Configure PE1.

      [PE1] mpls l2vpn //Habilite MPLS L2VPN global.
      [PE1-l2vpn] quit

      # Configure PE2.

      [PE2] mpls l2vpn //Habilite MPLS L2VPN global.
      [PE2-l2vpn] quit

      # Configure PE3.

      [PE3] mpls l2vpn //Habilite MPLS L2VPN global.
      [PE3-l2vpn] quit
    3. Cree un VSI ldp1 en PE1, PE2 y PE3 y especifique LDP como el protocolo de señalización en el VSI.

      # Configure PE1.

      [PE1] vsi ldp1 static //Cree una VSI llamada ldp1 y configure descubrimiento de miembro estático.
      [PE1-vsi-ldp1] pwsignal ldp //Establezca el modo de señalización a LDP.
      [PE1-vsi-ldp1-ldp] vsi-id 2 //Establezca el ID de la VSI a 2.
      [PE1-vsi-ldp1-ldp] peer 3.3.3.9 //Establezca  la dirección del otro extremo de la VSI a 3.3.3.9.
      [PE1-vsi-ldp1-ldp] quit
      [PE1-vsi-ldp1] quit

      # Configure PE2.

      [PE2] vsi ldp1 static //Cree una VSI llamada ldp1 y configure descubrimiento de miembro estático.
      [PE2-vsi-ldp1] pwsignal ldp //Establezca el modo de señalización a LDP.
      [PE2-vsi-ldp1-ldp] vsi-id 2 //Set the ID of the VSI to 2.
      [PE2-vsi-ldp1-ldp] peer 3.3.3.9 //Establezca  la dirección del otro extremo de la VSI a 3.3.3.9.
      [PE2-vsi-ldp1-ldp] quit
      [PE2-vsi-ldp1] quit

      # Configure PE3.

      [PE3] vsi ldp1 static //Cree una VSI llamada ldp1 y configure descubrimiento de miembro estático.
      [PE3-vsi-ldp1] pwsignal ldp //Establezca el modo de señalización a LDP.
      [PE3-vsi-ldp1-ldp] vsi-id 2 //Establezca el ID de la VSI a 2.
      [PE3-vsi-ldp1-ldp] peer 1.1.1.9 //Establezca  la dirección del otro extremo de la VSI a 1.1.1.9.
      [PE3-vsi-ldp1-ldp] peer 2.2.2.9 //Establezca  la dirección del otro extremo de la VSI a 2.2.2.9.
      [PE3-vsi-ldp1-ldp] quit
      [PE3-vsi-ldp1] quit
    4. Configure las subinterfaces de Eth-Trunk en PE1 y PE2, y vincule el VSI a las subinterfaces de Eth-Trunk.

      # Configure PE1.

      [PE1] interface Eth-Trunk 10.1 //Cree Eth-Trunk 10.1 e introduzca la vista de Eth-Trunk 10.1.
      [PE1-Eth-Trunk10.1] dot1q termination vid 10 //Establezca el ID de VLAN único para la encapsulación dot1q en Eth-Trunk 10.1 a VLAN 10.
      [PE1-Eth-Trunk10.1] l2 binding vsi ldp1 //Enlace Eth-Trunk 10.1 a la VSI ldp1.
      [PE1-Eth-Trunk10.1] quit

      # Configure PE2.

      [PE2] interface Eth-Trunk 10.1 //Cree Eth-Trunk 10.1 e introduzca la vista de Eth-Trunk 10.1.
      [PE2-Eth-Trunk10.1] dot1q termination vid 10 //Establezca el ID de VLAN único para la encapsulación dot1q en Eth-Trunk 10.1 a VLAN 10.
      [PE2-Eth-Trunk10.1] l2 binding vsi ldp1 //Enlace Eth-Trunk 10.1 a la VSI ldp1.
      [PE2-Eth-Trunk10.1] quit
    5. Configure una subinterfaz en PE3 y vincule el VSI a la subinterfaz.

      # Configure PE3.

      [PE3] interface gigabitethernet 1/0/3.1 //Cree GE1/0/3.1 e introduzca la vista de GE1/0/3.1.
      [PE3-GigabitEthernet1/0/3.1] dot1q termination vid 10 //Establezca el ID de VLAN único para la encapsulación dot1q en GE1/0/3.1 a VLAN 10.
      [PE3-GigabitEthernet1/0/3.1] l2 binding vsi ldp1 //Enlace GE1/0/3.1 a la VSI ldp1.
      [PE3-GigabitEthernet1/0/3.1] quit

  7. Verifique la configuración

    • Ejecute el comando display eth-trunk en CE1 para verificar la configuración de Eth-Trunk.

    • Ejecute el comando display e-trunk para verificar la información sobre el E-Trunk.

      # Verifique la información sobre E-Trunk 1 en PE1.

      [PE1] display e-trunk 1
                                  The E-Trunk information   
      E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120 
      Priority : 10                           System-ID : 00e0-0f74-eb00
      Peer-IP : 2.2.2.9                       Source-IP : 1.1.1.9
      State : Master                          Causation : PRI
      Send-Period (100ms) : 9                 Fail-Time (100ms) : 27
      Receive : 41                            Send : 42
      RecDrop : 0                             SndDrop : 0
      Peer-Priority : 20                      Peer-System-ID : 00e0-3b6c-6100
      Peer-Fail-Time (100ms) : 27             BFD-Session : hello1
      Description : -  
      Sequence : Enable
      --------------------------------------------------------------------------------   
                                  The Member information                               
      Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID    
      Eth-Trunk 10  Up             auto          Master  ETRUNK_MASTER    10   

      # Verifique la información sobre E-Trunk 1 en PE2.

      [PE2] display e-trunk 1
                                  The E-Trunk information   
      E-TRUNK-ID : 1                          Revert-Delay-Time (s) : 120 
      Priority : 20                           System-ID : 00e0-3b6c-6100
      Peer-IP : 1.1.1.9                       Source-IP : 2.2.2.9
      State : Backup                          Causation : PRI
      Send-Period (100ms) : 9                 Fail-Time (100ms) : 27
      Receive : 43                            Send : 42
      RecDrop : 3                             SndDrop : 0
      Peer-Priority : 10                      Peer-System-ID : 00e0-0f74-eb00
      Peer-Fail-Time (100ms) : 27             BFD-Session : hello2
      Description : -  
      Sequence : Enable
      --------------------------------------------------------------------------------   
                                  The Member information                               
      Type      ID  LocalPhyState  Work-Mode     State   Causation        Remote-ID    
      Eth-Trunk 10  Down           auto          Backup  ETRUNK_BACKUP    10   

      La información anterior muestra que la prioridad de E-Trunk en PE1 es de 10, y el estado de E-Trunk es Master; la prioridad de E-Trunk en PE2 es de 20 y el estado de E-Trunk es Backup. La copia de seguridad del dispositivo está implementada.

Archivos de configuración

  • Archivo de configuración del CE1

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk allow-pass vlan 10
     mode lacp
    #
    interface GigabitEthernet1/0/1
     eth-trunk 20
    #
    interface GigabitEthernet1/0/2
     eth-trunk 20
    #
    interface GigabitEthernet1/0/3
     eth-trunk 20
    #
    interface GigabitEthernet1/0/4
     eth-trunk 20
    #
    return       
  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 100
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    bfd
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls l2vpn
    #
    vsi ldp1 static
     pwsignal ldp
      vsi-id 2
      peer 3.3.3.9 
    #
    mpls ldp
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    e-trunk 1
     priority 10
     peer-address 2.2.2.9 source-address 1.1.1.9
     timer hello 9
     timer hold-on-failure multiplier 3
     e-trunk track bfd-session session-name hello1
    #
    interface Eth-Trunk10
     port link-type trunk
     mode lacp
     e-trunk 1
    #
    interface Eth-Trunk10.1
     dot1q termination vid 10
     l2 binding vsi ldp1
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bfd hello1 bind peer-ip 2.2.2.9 source-ip 1.1.1.9
     discriminator local 1
     discriminator remote 2
     commit
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
    vlan batch 200
    #
    lacp e-trunk system-id 00e0-fc00-0000
    lacp e-trunk priority 1
    #
    bfd
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls l2vpn
    #
    vsi ldp1 static
     pwsignal ldp
      vsi-id 2
      peer 3.3.3.9
    #
    mpls ldp
    #
    interface Vlanif200
     ip address 10.1.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    e-trunk 1
     priority 20
     peer-address 1.1.1.9 source-address 2.2.2.9
     timer hello 9
     timer hold-on-failure multiplier 3
     e-trunk track bfd-session session-name hello2
    #
    interface Eth-Trunk10
     port link-type trunk
     mode lacp
     e-trunk 1
    #
    interface Eth-Trunk10.1
     dot1q termination vid 10
     l2 binding vsi ldp1
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    bfd hello2 bind peer-ip 1.1.1.9 source-ip 2.2.2.9
     discriminator local 2
     discriminator remote 1
     commit
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    return
  • Archivo de configuración del PE3

    #
    sysname PE3
    #
    vlan batch 100 200
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls l2vpn
    #
    vsi ldp1 static
     pwsignal ldp
      vsi-id 2
      peer 1.1.1.9
      peer 2.2.2.9
    #
    mpls ldp
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif200
     ip address 10.1.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/3.1
     dot1q termination vid 10
     l2 binding vsi ldp1
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15746

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente