No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un Eth-Trunk para preferencialmente reenviar tráfico local en un CSS o una pila

Ejemplo para configurar un Eth-Trunk para preferencialmente reenviar tráfico local en un CSS o una pila

Descripción general

En un CSS o una pila, un Eth-Trunk se configura como la interfaz saliente del tráfico para garantizar una transmisión confiable. Las interfaces de miembro del Eth-Trunk están ubicadas en diferentes chasis. Cuando los dispositivos en el CSS o la pila reenvíen el tráfico, el Eth-Trunk puede seleccionar una interfaz de miembro entre chasis basada en un algoritmo de hash. El ancho de banda del cable entre dispositivos en el CSS o la pila es limitado, por lo que el reenvío del tráfico entre chasis ocupa recursos del ancho de banda entre dispositivos, reduciendo la eficiencia del reenvío del tráfico. Para solucionar este problema, puede habilitar un Eth-Trunk para reenviar preferentemente el tráfico local.

Notas de configuración

  • Si las interfaces activas de un Eth-Trunk en el dispositivo local tienen suficiente ancho de banda para reenviar el tráfico, puede configurar el Eth-Trunk para reenviar preferentemente el tráfico local. Esto mejora la eficiencia del reenvío del tráfico y aumenta la capacidad del ancho de banda entre los dispositivos en el CSS.
  • Si las interfaces activas de un Eth-Trunk en el dispositivo local no tienen suficiente ancho de banda para reenviar el tráfico, puede configurar el Eth-Trunk para que no reenvíe preferentemente el tráfico local. En este caso, una parte del tráfico en el dispositivo local se reenvía a través de las interfaces de miembro de un Eth-Trunk en otro dispositivo, evitando la pérdida de paquetes.
  • Tabla 6-2  Modelos de productos y versiones aplicables

    Producto

    Modelo del producto

    Versión del software

    S2300

    S2350EI

    V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S2320EI

    V200R011C10, V200R012C00

    S5300

    S5300LI

    V200R003(C00&C02), V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10

    S5300SI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300EI

    V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En la red que se muestra en Figura 6-8, la tecnología del CSS se usa para aumentar la capacidad total de los switches. Switch3 y Switch4 están conectados a través de los cables de pila para formar un switch lógico. Para implementar la copia de seguridad entre switches y mejorar la confiabilidad, las interfaces físicas en los dos switches se agregan a un Eth-Trunk. En situaciones normales, el tráfico desde VLAN 2 y VLAN 3 se reenvía a través de GE1/0/1 y GE1/0/2 respectivamente. Esto aumenta la capacidad del ancho de banda entre switches y reduce la eficiencia del reenvío del tráfico.

Para garantizar que el tráfico de VLAN 2 se reenvíe a través de GE1/0/1 y que el tráfico de VLAN 3 se reenvíe a través de GE1/0/2, puede configurar el Eth-Trunk para reenviar preferentemente el tráfico local.

Figura 6-8  Preferencial reenvío del tráfico local

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Crea un Eth-Trunk.

  2. Agregue interfaces de miembro al Eth-Trunk.

  3. Habilite que Eth-Trunk reenvíe preferentemente el tráfico local.

  4. Agregue interfaces a VLAN para implementar la conectividad de Capa 2.

Procedimiento

  1. Cree un Eth-Trunk y configure el ID de una VLAN desde la cual los paquetes pueden pasar a través del Eth-Trunk.

    # Configure el CSS.

    <Quidway> system-view
    [Quidway] sysname CSS
    [CSS] interface eth-trunk 10 //Cree Eth-Trunk 10 e introduzca la vista de Eth-Trunk 10.
    [CSS-Eth-Trunk10] port link-type trunk  //Establezca el tipo de enlace de la interfaz a Trunk.
    [CSS-Eth-Trunk10] port trunk allow-pass vlan all //Configure la interfaz para permitir todas las VLAN.
    [CSS-Eth-Trunk10] quit

    # Configure el switch de agregación PE.

    <Quidway> system-view
    [Quidway] sysname PE
    [PE] interface eth-trunk 10 //Cree Eth-Trunk 10 e introduzca la vista de Eth-Trunk 10.
    [PE-Eth-Trunk10] port link-type trunk //Establezca el tipo de enlace de la interfaz a Trunk.
    [PE-Eth-Trunk10] port trunk allow-pass vlan all //Configure la interfaz para permitir todas las VLAN.
    [PE-Eth-Trunk10] quit

  2. Agregue interfaces de miembro al Eth-Trunk.

    # Configure el CSS.

    [CSS] interface gigabitethernet 1/1/0/4
    [CSS-GigabitEthernet1/1/0/4] eth-trunk 10 //Agregue GE1/1/0/4 a Eth-Trunk 10.
    [CSS-GigabitEthernet1/1/0/4] quit
    [CSS] interface gigabitethernet 2/1/0/4
    [CSS-GigabitEthernet2/1/0/4] eth-trunk 10 //Agregue GE2/1/0/4 a Eth-Trunk 10.
    [CSS-GigabitEthernet2/1/0/4] quit

    # Configure el PE.

    [PE] interface gigabitethernet 1/0/1
    [PE-GigabitEthernet1/0/1] eth-trunk 10 //Agregue GE1/0/1 a Eth-Trunk 10.
    [PE-GigabitEthernet1/0/1] quit
    [PE] interface gigabitethernet 1/0/2 
    [PE-GigabitEthernet1/0/2] eth-trunk 10 //Agregue GE1/0/2 a Eth-Trunk 10.
    [PE-GigabitEthernet1/0/2] quit

  3. Configure el Eth-Trunk en los dispositivos en el CSS para reenviar preferentemente el tráfico local.

    [CSS] interface eth-trunk 10
    [CSS-Eth-Trunk10] local-preference enable //Habilite Eth-Trunk 10 para reenviar preferentemente el tráfico local.
    [CSS-Eth-Trunk10] quit
    NOTA:
    Por defecto, un Eth-Trunk está habilitado para reenviar preferentemente el tráfico local. Si ejecuta el comando local-preference enable, el sistema muestra el mensaje "Error: The local preferential forwarding mode has been configured."

  4. Configure el reenvío de Capa 2.

    # Configure el CSS.

    [CSS] vlan batch 2 3
    [CSS] interface gigabitethernet 1/1/0/3
    [CSS-GigabitEthernet1/1/0/3] port link-type trunk
    [CSS-GigabitEthernet1/1/0/3] port trunk allow-pass vlan 2
    [CSS-GigabitEthernet1/1/0/3] quit
    [CSS] interface gigabitethernet 2/1/0/3
    [CSS-GigabitEthernet2/1/0/3] port link-type trunk
    [CSS-GigabitEthernet2/1/0/3] port trunk allow-pass vlan 3
    [CSS-GigabitEthernet2/1/0/3] quit

    # Configure el switch de acceso Switch1.

    <Quidway> system-view
    [Quidway] sysname Switch1
    [Switch1] vlan 2
    [Switch1-vlan2] quit
    [Switch1] interface gigabitethernet 1/0/1
    [Switch1-GigabitEthernet1/0/1] port link-type trunk
    [Switch1-GigabitEthernet1/0/1] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet1/0/1] quit
    [Switch1] interface gigabitethernet 1/0/2
    [Switch1-GigabitEthernet1/0/2] port link-type trunk
    [Switch1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2
    [Switch1-GigabitEthernet1/0/2] quit

    # Configure el switch de acceso Switch2.

    <Quidway> system-view
    [Quidway] sysname Switch2
    [Switch2] vlan 3
    [Switch2-vlan3] quit
    [Switch2] interface gigabitethernet 1/0/1
    [Switch2-GigabitEthernet1/0/1] port link-type trunk
    [Switch2-GigabitEthernet1/0/1] port trunk allow-pass vlan 3
    [Switch2-GigabitEthernet1/0/1] quit
    [Switch2] interface gigabitethernet 1/0/2
    [Switch2-GigabitEthernet1/0/2] port link-type trunk
    [Switch2-GigabitEthernet1/0/2] port trunk allow-pass vlan 3
    [Switch2-GigabitEthernet1/0/2] quit

  5. Verifique la configuración

    Una vez completada la configuración, ejecute el comando display trunkmembership eth-trunk en cualquier vista para verificar la información sobre las interfaces de miembro del Eth-Trunk.

    La visualización en el CSS se usa como un ejemplo.

    <CSS> display trunkmembership eth-trunk 10
    Trunk ID: 10
    Used status: VALID
    TYPE: ethernet
    Working Mode : Normal
    Number Of Ports in Trunk = 2
    Number Of Up Ports in Trunk = 2
    Operate status: up
    
    Interface GigabitEthernet1/1/0/4, valid, operate up, weight=1
    Interface GigabitEthernet2/1/0/4, valid, operate up, weight=1

Archivos de configuración

  • Archivo de configuración del CSS

    #
    sysname CSS
    #
    vlan batch 2 3
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet1/1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface GigabitEthernet2/1/0/3
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface GigabitEthernet1/1/0/4
     eth-trunk 10
    #
    interface GigabitEthernet2/1/0/4
     eth-trunk 10
    #
    return         
  • Archivo de configuración del PE

    #
    sysname PE
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk allow-pass vlan 2 to 4094
    #
    interface GigabitEthernet1/0/1
     eth-trunk 10
    #
    interface GigabitEthernet1/0/2
     eth-trunk 10
    #
    return
  • Archivo de configuración del Switch1

    #
    sysname Switch1
    #
    vlan batch 2
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2
    #
    return
  • Archivo de configuración del Switch2

    #
    sysname Switch2
    #
    vlan batch 3
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 3
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15432

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente