No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un Eth-Trunk y una asociación entre VRRP y el estado de interfaz

Ejemplo para configurar un Eth-Trunk y una asociación entre VRRP y el estado de interfaz

Asociación entre VRRP y el estado de interfaz

Se requieren tecnologías adicionales para mejorar la función activa/standby de VRRP. Por ejemplo, cuando se desconecta el enlace del dispositivo Master a una red, VRRP no puede detectar la falla y no se puede realizar una conmutación activa/standby. Como resultado, los hosts no pueden acceder remotamente a la red a través del dispositivo Master. Para solucionar este problema, puede configurar la asociación entre VRRP y el estado de interfaz.

Cuando el dispositivo Master detecta que la interfaz de enlace ascendente falla, el Master reduce su prioridad a ser menor que la prioridad del dispositivo Backup y envía inmediatamente paquetes VRRP. Después de que el dispositivo Backup recibe los paquetes VRRP, detecta que la prioridad en los paquetes VRRP es menor que su prioridad y cambia al Master. Esto asegura el reenvío de tráfico correcto.

Notas de configuración

  • En V200R003 y versiones anteriores, VRRP se puede configurar solo en la interfaz VLANIF.

    En V200R005 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF y en la interfaz Ethernet de capa 3.

    Para un switch modular en V200R006 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3, subinterfaz de terminación Dot1q y subinterfaz de terminación QinQ.

    Para un switch fijo en V200R009 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3 y subinterfaz.

  • Asegúrese de que cada dispositivo del mismo grupo VRRP esté configurado con el mismo VRID.
  • Los grupos VRRP deben usar diferentes direcciones IP virtuales. La dirección IP virtual de un grupo VRRP debe estar en el mismo segmento de red que la dirección IP de la interfaz donde está configurado el grupo VRRP.

  • Un grupo VRRP se puede asociar con un máximo de ocho interfaces. La asociación entre un grupo VRRP y el estado de interfaz no se puede configurar en el dispositivo como el propietario de la dirección IP.

  • A lo siguiente se describen los Modelos de productos y versiones aplicables.
    Tabla 6-3  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 6-9, los hosts de usuario tienen doble pertenencia a SwitchA y SwitchB a través del switch. Los requisitos son los siguientes:
  • Los hosts usan SwitchA como gateway predeterminado para conectarse a Internet. Cuando SwitchA o el enlace descendente/enlace ascendente fallan, SwitchB funciona como el gateway para implementar gateway de reserva.

  • El ancho de banda del enlace entre SwitchA y SwitchB se incrementa para implementar enlace de reserva y mejorar la confiabilidad del enlace.

  • Después de que SwitchA se recupera, se convierte en el gateway dentro de los 20 segundos.

Figura 6-9  Interconexión de una red de asociación entre VRRP y el estado de interfaz

Hoja de ruta de configuración

Un grupo VRRP en modo activo/standby se usa para implementar el gateway de reserva. La hoja de ruta de la configuración es la siguiente:

  1. Asigne una dirección IP a cada interfaz y configure un protocolo de enrutamiento para garantizar la conectividad de la red.

  2. Configure la agregación de VLAN en SwitchA y SwitchB para implementar el aislamiento de Capa 2 y la conectividad de Capa 3 de las VLAN 101 a 180 y guarde las direcciones IP.

  3. Cree un Eth-Trunk en SwitchA y SwitchB y agregue interfaces de miembros al Eth-Trunk para aumentar el ancho de banda del enlace e implementar el enlace de reserva.

  4. Configure un grupo VRRP entre SwitchA y SwitchB. Establezca una prioridad más alta para SwitchA para que SwitchA funcione como Master a reenviar el tráfico, y establezca el retardo de preferencia en 20 segundos en SwitchA. Establezca una prioridad más baja para SwitchB para que SwitchB funcione como Backup.

  5. Asocie VRRP con GE1/0/1 y GE1/0/2 en SwitchA para que el grupo VRRP pueda detectar la falla de Master y realizar una conmutación activa/standby inmediatamente.

NOTA:

SwitchA y SwitchB son switches principales, y el switch es un conmutador de agregación.

Procedimiento

  1. Configure los dispositivos para garantizar la conectividad de la red.

    # Asigne una dirección IP a cada interfaz en los dispositivos principales. SwitchA se usa como un ejemplo. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 11 to 15 101 to 180 301 to 305 400
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 400
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 101 to 180
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 11
    [SwitchA-Vlanif11] ip address 10.1.1.2 24
    [SwitchA-Vlanif11] quit
    [SwitchA] interface vlanif 12
    [SwitchA-Vlanif12] ip address 10.1.2.2 24
    [SwitchA-Vlanif12] quit
    [SwitchA] interface vlanif 13
    [SwitchA-Vlanif13] ip address 10.1.3.2 24
    [SwitchA-Vlanif13] quit
    [SwitchA] interface vlanif 14
    [SwitchA-Vlanif14] ip address 10.1.4.2 24
    [SwitchA-Vlanif14] quit
    [SwitchA] interface vlanif 15
    [SwitchA-Vlanif15] ip address 10.1.5.2 24
    [SwitchA-Vlanif15] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 192.168.1.1 24
    [SwitchA-Vlanif400] quit

    # Configure la transmisión transparente de Capa 2 en el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 11 to 15 101 to 180
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 11 to 15 101 to 180
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk
    [Switch-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 11 to 15 101 to 180
    [Switch-GigabitEthernet1/0/2] quit

    # Configure OSPF en SwitchA, SwitchB y switch. SwitchA se usa como un ejemplo. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  2. Configure una super-VLAN en SwitchA y SwitchB.

    # Configure una super-VLAN en SwitchA. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] vlan 11
    [SwitchA-vlan11] aggregate-vlan
    [SwitchA-vlan11] access-vlan 101 to 116 301
    [SwitchA-vlan11] quit
    [SwitchA] vlan 12
    [SwitchA-vlan12] aggregate-vlan
    [SwitchA-vlan12] access-vlan 117 to 132 302
    [SwitchA-vlan12] quit
    [SwitchA] vlan 13
    [SwitchA-vlan13] aggregate-vlan
    [SwitchA-vlan13] access-vlan 133 to 148 303
    [SwitchA-vlan13] quit
    [SwitchA] vlan 14
    [SwitchA-vlan14] aggregate-vlan
    [SwitchA-vlan14] access-vlan 149 to 164 304
    [SwitchA-vlan14] quit
    [SwitchA] vlan 15
    [SwitchA-vlan15] aggregate-vlan
    [SwitchA-vlan15] access-vlan 165 to 180 305
    [SwitchA-vlan15] quit

  3. Configure la agregación de enlaces en SwitchA y SwitchB.

    # Cree Eth-Trunk 1 en modo LACP en SwitchA. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] interface eth-trunk 1
    [SwitchA-Eth-Trunk1] mode lacp
    [SwitchA-Eth-Trunk1] port link-type trunk
    [SwitchA-Eth-Trunk1] undo port trunk allow-pass vlan 1
    [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 301 to 305
    [SwitchA-Eth-Trunk1] quit

    # Agregue interfaces de miembros en SwitchA a Eth-Trunk 1. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] eth-trunk 1
    [SwitchA-GigabitEthernet1/0/4] quit
    

  4. Configure los grupos VRRP en SwitchA y SwitchB.

    # Configure un grupo VRRP en SwitchA y establezca la prioridad de SwitchA en 120 y el retardo de preferencia en 20 segundos.

    [SwitchA] interface vlanif 11
    [SwitchA-Vlanif11] vrrp vrid 1 virtual-ip 10.1.1.1
    [SwitchA-Vlanif11] vrrp vrid 1 priority 120                                          //La prioridad predeterminada del dispositivo en un grupo VRRP es 100. Cambie la prioridad de Master para que sea más alta que Backup.
    [SwitchA-Vlanif11] vrrp vrid 1 preempt-mode timer delay 20                           //El dispositivo en un grupo VRRP usa el modo de preferencia inmediata de forma predeterminada. Cambie la demora de preferencia de Master para evitar interrupciones de tráfico cuando Master y Backup se adelantan con frecuencia al ancho de banda en una red inestable.
    [SwitchA-Vlanif11] vrrp vrid 1 track interface gigabitethernet 1/0/1 reduced 100     //Asocie el grupo VRRP con la interfaz de enlace ascendente. Establezca la prioridad reducida para garantizar que la prioridad del reserva sea mayor que la prioridad de Master. Entonces se puede activar una conmutación activa/standby.
    [SwitchA-Vlanif11] vrrp vrid 1 track interface gigabitethernet 1/0/2 reduced 100     //Asocie el grupo VRRP con la interfaz de enlace descendente. Establezca la prioridad reducida para garantizar que la prioridad del reserva sea mayor que la prioridad de Master. Entonces se puede activar una conmutación activa/standby.
    [SwitchA-Vlanif11] vrrp advertise send-mode 301                                      //Especifique la VLAN 301 donde se transmiten los paquetes VRRP para guardar el ancho de banda de la red.
    [SwitchA-Vlanif11] quit
    [SwitchA] interface vlanif 12
    [SwitchA-Vlanif12] vrrp vrid 2 virtual-ip 10.1.2.1
    [SwitchA-Vlanif12] vrrp vrid 2 priority 120
    [SwitchA-Vlanif12] vrrp vrid 2 preempt-mode timer delay 20
    [SwitchA-Vlanif12] vrrp vrid 2 track interface gigabitethernet 1/0/1 reduced 100
    [SwitchA-Vlanif12] vrrp vrid 2 track interface gigabitethernet 1/0/2 reduced 100
    [SwitchA-Vlanif12] vrrp advertise send-mode 302
    [SwitchA-Vlanif12] quit
    [SwitchA] interface vlanif 13
    [SwitchA-Vlanif13] vrrp vrid 3 virtual-ip 10.1.3.1
    [SwitchA-Vlanif13] vrrp vrid 3 priority 120
    [SwitchA-Vlanif13] vrrp vrid 3 preempt-mode timer delay 20
    [SwitchA-Vlanif13] vrrp vrid 3 track interface gigabitethernet 1/0/1 reduced 100
    [SwitchA-Vlanif13] vrrp vrid 3 track interface gigabitethernet 1/0/2 reduced 100
    [SwitchA-Vlanif13] vrrp advertise send-mode 303
    [SwitchA-Vlanif13] quit
    [SwitchA] interface vlanif 14
    [SwitchA-Vlanif14] vrrp vrid 4 virtual-ip 10.1.4.1
    [SwitchA-Vlanif14] vrrp vrid 4 priority 120
    [SwitchA-Vlanif14] vrrp vrid 4 preempt-mode timer delay 20
    [SwitchA-Vlanif14] vrrp vrid 4 track interface gigabitethernet 1/0/1 reduced 100
    [SwitchA-Vlanif14] vrrp vrid 4 track interface gigabitethernet 1/0/2 reduced 100
    [SwitchA-Vlanif14] vrrp advertise send-mode 304
    [SwitchA-Vlanif14] quit
    [SwitchA] interface vlanif 15
    [SwitchA-Vlanif15] vrrp vrid 5 virtual-ip 10.1.5.1
    [SwitchA-Vlanif15] vrrp vrid 5 priority 120
    [SwitchA-Vlanif15] vrrp vrid 5 preempt-mode timer delay 20
    [SwitchA-Vlanif15] vrrp vrid 5 track interface gigabitethernet 1/0/1 reduced 100
    [SwitchA-Vlanif15] vrrp vrid 5 track interface gigabitethernet 1/0/2 reduced 100
    [SwitchA-Vlanif15] vrrp advertise send-mode 305
    [SwitchA-Vlanif15] quit

    # Configure un grupo VRRP en SwitchB. SwitchB usa la prioridad predeterminada de 100.

    [SwitchB] interface vlanif 11
    [SwitchB-Vlanif11] vrrp vrid 1 virtual-ip 10.1.1.1
    [SwitchB-Vlanif11] vrrp advertise send-mode 301
    [SwitchB-Vlanif11] quit
    [SwitchB] interface vlanif 12
    [SwitchB-Vlanif12] vrrp vrid 2 virtual-ip 10.1.2.1
    [SwitchB-Vlanif12] vrrp advertise send-mode 302
    [SwitchB-Vlanif12] quit
    [SwitchB] interface vlanif 13
    [SwitchB-Vlanif13] vrrp vrid 3 virtual-ip 10.1.3.1
    [SwitchB-Vlanif13] vrrp advertise send-mode 303
    [SwitchB-Vlanif13] quit
    [SwitchB] interface vlanif 14
    [SwitchB-Vlanif14] vrrp vrid 4 virtual-ip 10.1.4.1
    [SwitchB-Vlanif14] vrrp advertise send-mode 304
    [SwitchB-Vlanif14] quit
    [SwitchB] interface vlanif 15
    [SwitchB-Vlanif15] vrrp vrid 5 virtual-ip 10.1.5.1
    [SwitchB-Vlanif15] vrrp advertise send-mode 305
    [SwitchB-Vlanif15] quit

  5. Verifique la configuración

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchA. Pueden ver que SwitchA es el dispositivo Master en el grupo 1 de VRRP. El grupo 1 de VRRP se usa como un ejemplo. La información de otros grupos VRRP es similar a la información del grupo 1 de VRRP.

    [SwitchA] display vrrp 1
      Vlanif11  | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.1
        Master IP : 10.1.1.2
        Send VRRP packet to subvlan : 301
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track IF       : GigabitEthernet1/0/1   Priority reduced : 100
        IF state       : UP
        Track IF       : GigabitEthernet1/0/2   Priority reduced : 100
        IF state       : UP
        Create time : 2012-05-11 11:39:18
        Last change time : 2012-05-26 11:38:58

    # Ejecute el comando display vrrp en SwitchB. Puede ver que SwitchB es el dispositivo Backup. El grupo 1 de VRRP se usa como un ejemplo.

    [SwitchB] display vrrp 1
      Vlanif11  | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.1
        Master IP : 10.1.1.2
        Send VRRP packet to subvlan : 301
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2012-05-11 11:39:18
        Last change time : 2012-05-26 11:38:58

    # Ejecute el comando shutdown en GE1/0/1 de SwitchA para simular un error de enlace. Luego ejecute el comando display vrrp en SwitchA y SwitchB. Pueden ver que SwitchA está en estado de Backup, SwitchB cambia al estado Master y la interfaz asociada se convierte en Down.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] shutdown
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] display vrrp 1
      Vlanif11  | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.1
        Master IP : 10.1.1.3
        Send VRRP packet to subvlan : 301
        PriorityRun : 20
        PriorityConfig : 120
        MasterPriority : 100
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track IF       : GigabitEthernet1/0/1   Priority reduced : 100
        IF state       : DOWN
        Track IF       : GigabitEthernet1/0/2   Priority reduced : 100
        IF state       : UP
        Create time : 2012-05-11 11:39:18
        Last change time : 2012-05-26 14:12:38
    [SwitchB] display vrrp 1
      Vlanif11  | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.1
        Master IP : 10.1.1.3
        Send VRRP packet to subvlan : 301
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 100
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2012-05-11 11:39:18
        Last change time : 2012-05-26 14:12:38

    # Ejecute el comando undo shutdown en GE1/0/1 de SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] undo shutdown
    [SwitchA-GigabitEthernet1/0/1] quit

    # Después de 20 segundos, ejecute el comando display vrrp en SwitchA y SwitchB. Pueden ver que SwitchA se restaura como Master y SwitchB se restaura como Backup, y la interfaz asociada se encuentra en el estado Up.

    [SwitchA] display vrrp 1
      Vlanif11  | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.1
        Master IP : 10.1.1.2
        Send VRRP packet to subvlan : 301
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Track IF       : GigabitEthernet1/0/1   Priority reduced : 100
        IF state       : UP
        Track IF       : GigabitEthernet1/0/2   Priority reduced : 100
        IF state       : UP
        Create time : 2012-05-11 11:39:18
        Last change time : 2012-05-26 14:17:36
    [SwitchB] display vrrp 1
      Vlanif11  | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.1
        Master IP : 10.1.1.2
        Send VRRP packet to subvlan : 301
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2012-05-11 11:39:18
        Last change time : 2012-05-26 14:17:36

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 11 to 15 101 to 180 301 to 305 400
    #
    vlan 11
     aggregate-vlan
     access-vlan 101 to 116 301
    vlan 12
     aggregate-vlan
     access-vlan 117 to 132 302
    vlan 13
     aggregate-vlan
     access-vlan 133 to 148 303
    vlan 14
     aggregate-vlan
     access-vlan 149 to 164 304
    vlan 15
     aggregate-vlan
     access-vlan 165 to 180 305
    #
    interface Vlanif11
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.1
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
     vrrp vrid 1 track interface gigabitethernet1/0/1 reduced 100
     vrrp vrid 1 track interface gigabitethernet1/0/2 reduced 100
     vrrp advertise send-mode 301
    #
    interface Vlanif12
     ip address 10.1.2.2 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.2.1
     vrrp vrid 2 priority 120
     vrrp vrid 2 preempt-mode timer delay 20
     vrrp vrid 2 track interface gigabitethernet1/0/1 reduced 100
     vrrp vrid 2 track interface gigabitethernet1/0/2 reduced 100
     vrrp advertise send-mode 302
    #
    interface Vlanif13
     ip address 10.1.3.2 255.255.255.0
     vrrp vrid 3 virtual-ip 10.1.3.1
     vrrp vrid 3 priority 120
     vrrp vrid 3 preempt-mode timer delay 20
     vrrp vrid 3 track interface gigabitethernet1/0/1 reduced 100
     vrrp vrid 3 track interface gigabitethernet1/0/2 reduced 100
     vrrp advertise send-mode 303
    #
    interface Vlanif14
     ip address 10.1.4.2 255.255.255.0
     vrrp vrid 4 virtual-ip 10.1.4.1
     vrrp vrid 4 priority 120
     vrrp vrid 4 preempt-mode timer delay 20
     vrrp vrid 4 track interface gigabitethernet1/0/1 reduced 100
     vrrp vrid 4 track interface gigabitethernet1/0/2 reduced 100
     vrrp advertise send-mode 304
    #
    interface Vlanif15
     ip address 10.1.5.2 255.255.255.0
     vrrp vrid 5 virtual-ip 10.1.5.1
     vrrp vrid 5 priority 120
     vrrp vrid 5 preempt-mode timer delay 20
     vrrp vrid 5 track interface gigabitethernet1/0/1 reduced 100
     vrrp vrid 5 track interface gigabitethernet1/0/2 reduced 100
     vrrp advertise send-mode 305
    #
    interface Vlanif400
     ip address 192.168.1.1 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 301 to 305
     mode lacp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 101 to 180
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4
     eth-trunk 1
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 11 to 15 101 to 180 200 301 to 305
    #
    vlan 11
     aggregate-vlan
     access-vlan 101 to 116 301
    vlan 12
     aggregate-vlan
     access-vlan 117 to 132 302
    vlan 13
     aggregate-vlan
     access-vlan 133 to 148 303
    vlan 14
     aggregate-vlan
     access-vlan 149 to 164 304
    vlan 15
     aggregate-vlan
     access-vlan 165 to 180 305
    #
    interface Vlanif11
     ip address 10.1.1.3 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.1
     vrrp advertise send-mode 301
    #
    interface Vlanif12
     ip address 10.1.2.3 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.2.1
     vrrp advertise send-mode 302
    #
    interface Vlanif13
     ip address 10.1.3.3 255.255.255.0
     vrrp vrid 3 virtual-ip 10.1.3.1
     vrrp advertise send-mode 303
    #
    interface Vlanif14
     ip address 10.1.4.3 255.255.255.0
     vrrp vrid 4 virtual-ip 10.1.4.1
     vrrp advertise send-mode 304
    #
    interface Vlanif15
     ip address 10.1.5.3 255.255.255.0
     vrrp vrid 5 virtual-ip 10.1.5.1
     vrrp advertise send-mode 305
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 301 to 305
     mode lacp
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 101 to 180
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    interface GigabitEthernet1/0/4
     eth-trunk 1
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif300
     ip address 172.16.1.1 255.255.255.0
    #
    interface Vlanif400
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 300
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • Archivo de configuración del switch

    #
    sysname Switch
    #
    vlan batch 11 to 15 101 to 180
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 to 15 101 to 180
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 11 to 15 101 to 180
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15840

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente