No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la asignación de VLAN basada en la interfaz

Ejemplo para configurar la asignación de VLAN basada en la interfaz

Descripción general

Las VLAN se pueden asignar en base a las interfaces, las direcciones MAC, las subredes IP, los protocolos y las políticas (direcciones MAC, direcciones IP e interfaces). Tabla 6-4 compara diferentes modos de asignación de VLAN.
Tabla 6-4  Comparaciones entre modos de asignación de VLAN

Modo de asignación de VLAN

Implementación

Ventaja

Desventaja

Escenario de uso

Asignación de VLAN basada en la interfaz

Las VLAN se asignan en base a las interfaces.

Un administrador de red preconfigura un PVID para cada interfaz en un switch. Cuando un marco sin etiqueta llega a una interfaz, el switch agrega el PVID de la interfaz al marco. El marco se transmite en la VLAN especificada por el PVID.

Es simple definir miembros de VLAN.

El administrador de la red debe reconfigurar las VLAN cuando cambian los miembros de VLAN.

Se aplica a redes de cualquier escala y con dispositivos en ubicaciones fijas.

Asignación de VLAN basada en direcciones MAC

Las VLAN se asignan en base a las direcciones MAC de origen de los marcos.

Un administrador de red preconfigura las asignaciones entre las direcciones MAC y los ID de VLAN. Cuando se recibe un marco sin etiqueta, el switch agrega la etiqueta de VLAN mapeando la dirección MAC del marco al marco. Luego, el marco se transmite en la VLAN especificada.

Cuando las ubicaciones físicas de los usuarios cambian, el administrador de la red no debe reconfigurar las VLAN para los usuarios. Esto mejora la seguridad y la flexibilidad de acceso en una red.

El administrador de red debe predefinir VLAN para todos los miembros en una red.

Se aplica a las redes de pequeña escala en las que los terminales de usuario a menudo cambian las ubicaciones físicas, pero sus NIC rara vez cambian, por ejemplo, las computadoras portátiles.

Asignación de VLAN basada en subredes IP

Las VLAN se asignan en base a las direcciones IP de origen y las máscaras de subred.

Un administrador de red preconfigura mapeos entre las direcciones IP y los ID de VLAN. Cuando se recibe un marco sin etiqueta, el switch agrega la etiqueta de VLAN mapeando la dirección IP del marco al marco. Luego, el marco se transmite en la VLAN especificada.

  • Cuando las ubicaciones físicas de los usuarios cambian, el administrador de la red no debe reconfigurar las VLAN para los usuarios.
  • Este modo reduce el tráfico de comunicación y permite que un dominio de difusión abarque múltiples switches.

Los usuarios están distribuidos uniformemente y varios usuarios están en el mismo segmento de red.

Se aplica a escenarios en los que existen altos requisitos de movilidad y administración simplificada y bajos requisitos de seguridad. Por ejemplo, este modo se puede usar si una PC con múltiples direcciones IP debe acceder a servidores en diferentes segmentos de red o si una PC debe unirse a una nueva VLAN automáticamente después de que la dirección IP del PC cambie.

Asignación de VLAN basada en protocolo

Las VLAN se asignan en base a los tipos de protocolo (suite) y los formatos de encapsulación de los marcos.

Un administrador de red preconfigura mapeos entre los tipos de protocolo y los ID de VLAN. Al recibir una trama no etiquetada, el switch agrega el mapeo de la etiqueta VLAN al tipo de protocolo de la trama. El marco se transmite en la VLAN especificada.

Este modo vincula los tipos de servicio a las VLAN, lo que facilita la administración y el mantenimiento.

  • El administrador de la red debe preconfigurar los mapeos entre todos los tipos de protocolos y los ID de VLAN.
  • El switch debe analizar formatos de dirección de protocolo y convertir los formatos, lo que consume recursos excesivos. Por lo tanto, este modo ralentiza el tiempo de respuesta del switch.

Se aplica a las redes que usan múltiples protocolos.

Asignación de VLAN basada en políticas (direcciones MAC, direcciones IP e interfaces)

Las VLAN se asignan en base a políticas tales como combinaciones de interfaces, direcciones MAC y direcciones IP.

Un administrador de red preconfigura las políticas. Cuando se recibe un marco sin etiqueta que coincide con una política configurada, el switch agrega una etiqueta de VLAN especificada al marco. El marco se transmite en la VLAN especificada.

  • Este modo proporciona alta seguridad. Las direcciones MAC o las direcciones IP de los usuarios que se han vinculado a VLAN no pueden modificarse.
  • El administrador de la red puede seleccionar de manera flexible qué políticas usar de acuerdo con el modo de gestión y los requisitos.

Cada política debe configurarse manualmente.

Se aplica a las redes complejas.

La asignación de VLAN basada en la interfaz es el método más simple y más comúnmente utilizado.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-10, el switch de una empresa se conecta a muchos usuarios, y los usuarios que acceden al mismo servicio se conectan a la red de la empresa a través de diferentes dispositivos. Para garantizar la seguridad de la comunicación y evitar las tormentas de difusión, la empresa requiere que los usuarios que utilizan el mismo servicio se comuniquen entre sí y que los usuarios que acceden a servicios diferentes estén aislados. Usted puede configurar la asignación de VLAN basada en la interfaz en el switch para que el switch agregue las interfaces conectadas a los usuarios que utilizan el mismo servicio a la misma VLAN. Los usuarios en diferentes VLAN no pueden comunicarse entre sí en Capa 2, y los usuarios en la misma VLAN pueden comunicarse entre sí.

Figura 6-10  Redes de la asignación de VLAN basada en la interfaz

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree VLAN y agregue interfaces que conectan a los usuarios con las VLAN para aislar el tráfico de Capa 2 de diferentes servicios.
  2. Configure los tipos de enlace de las interfaces entre SwitchA y SwitchB y las VLAN permitidas por las interfaces para que los usuarios que accedan al mismo servicio puedan comunicarse entre sí a través de SwitchA y SwitchB.

Procedimiento

  1. Cree VLAN 2 y VLAN 3 en SwitchA y agregue interfaces conectadas a usuarios a las VLAN. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 2 3   //Cree VLAN 2 y VLAN 3 en un lote.
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access  //La interfaz conectada al dispositivo de acceso debe ser la interfaz de acceso. El tipo de enlace por defecto de una interfaz no es el de acceso, por lo que debe configurar manualmente la interfaz de acceso.
    [SwitchA-GigabitEthernet1/0/1] port default vlan 2   //Agregue GE1/0/1 a VLAN 2.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 3   //Agregue GE1/0/2 a VLAN 3.
    [SwitchA-GigabitEthernet1/0/2] quit
    

  2. Configure el tipo de enlace de la interfaz en SwitchA que está conectado a SwitchB y la VLAN permitida por la interfaz. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk   //El tipo de enlace de las interfaces que conectan los switches debe ser Trunk. El tipo de enlace por defecto de una interfaz no es Trunk, por lo que debe configurar manualmente la interfaz Trunk.
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 3    //Agregue GE1/0/3 a VLAN 2 y VLAN 3.

  3. Verifique la configuración

    User1 y User2 están en el mismo segmento de red, por ejemplo, 192.168.100.0/24; User3 y User4 están en el mismo segmento de red, por ejemplo, 192.168.200.0/24.

    User1 y User2 pueden hacer ping entre ellos, pero no pueden hacer ping a User3 o User4. User3 y User4 pueden hacer ping entre sí, pero no pueden hacer ping a User1 o User2.

Archivos de configuración

Archivo de configuración de SwitchA

#
sysname SwitchA
#
vlan batch 2 to 3
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 2
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 3
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 3
#
return

Archivo de configuración de SwitchB

#
sysname SwitchB
#
vlan batch 2 to 3
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 2
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 3
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 2 to 3
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15553

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente