No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la asignación de VLAN basada en la interfaz (Dispositivo de acceso utilizado como gateway)

Ejemplo para configurar la asignación de VLAN basada en la interfaz (Dispositivo de acceso utilizado como gateway)

Descripción general

Las VLAN se pueden asignar en base a las interfaces, las direcciones MAC, las subredes IP, los protocolos y las políticas (direcciones MAC, direcciones IP e interfaces). La asignación de VLAN basada en la interfaz es la más simple y comúnmente utilizada.

La asignación de VLAN basada en la interfaz indica que las VLAN se asignan en base a las interfaces. Un administrador de red preconfigura un PVID para cada interfaz en un switch. Cuando un marco sin etiqueta llega a una interfaz, el switch agrega el PVID de la interfaz al marco. Luego, el marco se transmite en una VLAN especificada.

En una red jerárquica típica, cuando el switch de acceso es un switch de Capa 3, el switch de acceso puede usarse como el gateway de los PC para simplificar la configuración del switch de agregación.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-11, PC1 y PC2 pertenecen a VLAN 2 y VLAN 3, respectivamente. PC1 y PC2 se conectan al switch de agregación SW1 a través del switch de acceso SW2. PC3 pertenece a VLAN 4 y se conecta a SW1 a través de SW3. SW2 funciona como el gateway de PC1 y PC2, y SW3 se utiliza como el gateway de PC3. Las rutas estáticas están configuradas en los switches para que los PC puedan comunicarse entre sí y puedan conectarse al router.

Figura 6-11  Configuración de los dispositivos de acceso como gateways

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure la asignación basada en la interfaz en el switch de acceso para implementar el interfuncionamiento de Capa 2.
  2. Configure los switches de acceso como gateways de los PC para implementar la comunicación entre los PC en diferentes segmentos de red.
  3. Configure las rutas estáticas en el switch de agregación para que los PC puedan comunicarse con el router.

Procedimiento

  1. Configure SW2.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname SW2  //Cambie el nombre del dispositivo a SW2 para una fácil identificación.
    [SW2] vlan batch 2 to 3  //Cree VLAN 2 y VLAN 3 en un lote.

    # Agregue interfaces a las VLAN.

    [SW2] interface gigabitethernet 1/0/23
    [SW2-GigabitEthernet1/0/23] port link-type access  //Configure la interfaz conectada al PC como la interfaz de acceso.
    [SW2-GigabitEthernet1/0/23] port default vlan 2  //Agregue PC1 a VLAN 2.
    [SW2-GigabitEthernet1/0/23] quit
    [SW2] interface gigabitethernet 1/0/24
    [SW2-GigabitEthernet1/0/24] port link-type access
    [SW2-GigabitEthernet1/0/24] port default vlan 3  //Agregue PC2 a VLAN 3.
    [SW2-GigabitEthernet1/0/24] quit

    # Configure las interfaces VLANIF y configure las direcciones IP para las interfaces VLANIF como direcciones de gateway de los PC.

    [SW2] interface vlanif 2  //Cree VLANIF 2.
    [SW2-Vlanif2] ip address 192.168.2.1 24  //Configure una dirección IP para VLANIF 2. La dirección IP es la dirección de gateway del PC1.
    [SW2-Vlanif2] quit
    [SW2] interface vlanif 3  //Cree VLANIF 3.
    [SW2-Vlanif3] ip address 192.168.3.1 24  //Configure una dirección IP para VLANIF 3. La dirección IP es la dirección de gateway del PC2.
    [SW2-Vlanif3] quit

    # Conecte SW2 a SW1.

    [SW2] vlan batch 5  //Cree VLAN 5.
    [SW2] interface gigabitethernet 1/0/1
    [SW2-GigabitEthernet1/0/1] port link-type access
    [SW2-GigabitEthernet1/0/1] port default vlan 5  //Configure SW2 y SW1 para comunicarse en modo sin etiqueta.
    [SW2-GigabitEthernet1/0/1] quit
    [SW2] interface vlanif 5  //Cree VLANIF 5.
    [SW2-Vlanif5] ip address 192.168.5.2 24  //Configure una dirección IP para VLANIF 5. La dirección IP es la dirección IP de la interfaz interconectada entre SW1 y SW2.
    [SW2-Vlanif5] quit
    [SW2] ip route-static 0.0.0.0 0.0.0.0 192.168.5.1  //Configure una ruta por defecto para que el PC pueda acceder al router. La dirección del siguiente salto es la dirección IP de la interfaz conectada a SW1.
    

  2. Configure SW3.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname SW3  //Cambie el nombre del dispositivo a SW3.
    [SW3] vlan batch 4  //Cree VLAN 4.

    # Agregue interfaces a las VLAN.

    [SW3] interface gigabitethernet 1/0/2
    [SW3-GigabitEthernet1/0/2] port link-type access  //Configure la interfaz conectada al PC como la interfaz de acceso.
    [SW3-GigabitEthernet1/0/2] port default vlan 4  //Agregue PC3 a VLAN 4.
    [SW3-GigabitEthernet1/0/2] quit
    

    # Configure las interfaces VLANIF y configure las direcciones IP para las interfaces VLANIF como direcciones de gateway de los PC.

    [SW3] interface vlanif 4  //Cree VLANIF 4.
    [SW3-Vlanif4] ip address 192.168.4.1 24  //Configure una dirección IP para VLANIF 4. La dirección IP es la dirección de gateway del PC3.
    [SW3-Vlanif4] quit
    

    # Conecte SW3 a SW1.

    [SW3] vlan batch 5  //Cree VLAN 5.
    [SW3] interface gigabitethernet 1/0/1
    [SW3-GigabitEthernet1/0/1] port link-type access
    [SW3-GigabitEthernet1/0/1] port default vlan 5  //Configure SW3 y SW1 para comunicarse en modo sin etiqueta.
    [SW3-GigabitEthernet1/0/1] quit
    [SW3] interface vlanif 5  //Cree VLANIF 5.
    [SW3-Vlanif5] ip address 192.168.5.3 24  //Configure una dirección IP para VLANIF 5. La dirección IP es la dirección IP de la interfaz interconectada entre SW3 y SW1.
    [SW3-Vlanif5] quit
    [SW3] ip route-static 0.0.0.0 0.0.0.0 192.168.5.1  //Configure una ruta por defecto para que el PC pueda acceder al router. La dirección del siguiente salto es la dirección IP de la interfaz conectada a SW1.
    

  3. Configure SW1.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname SW1  //Cambie el nombre del dispositivo a SW1.
    [SW1] vlan batch 5  //Cree VLAN 5.

    # Agregue interfaces conectadas a los PC para las VLAN.

    [SW1] interface gigabitethernet 1/0/1
    [SW1-GigabitEthernet1/0/1] port link-type access  //Configure la interfaz conectada al router como la interfaz de acceso.
    [SW1-GigabitEthernet1/0/1] port default vlan 5
    [SW1-GigabitEthernet1/0/1] quit
    [SW1] interface gigabitethernet 1/0/2
    [SW1-GigabitEthernet1/0/2] port link-type access  //Configure la interfaz conectada a SW2 como la interfaz de acceso.
    [SW1-GigabitEthernet1/0/2] port default vlan 5
    [SW1-GigabitEthernet1/0/2] quit
    [SW1] interface gigabitethernet 1/0/3
    [SW1-GigabitEthernet1/0/3] port link-type access  //Configure la interfaz conectada a SW3 como la interfaz de acceso.
    [SW1-GigabitEthernet1/0/3] port default vlan 5
    [SW1-GigabitEthernet1/0/3] quit

    # Configure las interfaces VLANIF para que los PC puedan conectarse al router.

    [SW1] interface vlanif 5  //Cree VLANIF 5.
    [SW1-Vlanif5] ip address 192.168.5.1 24  //Configure una dirección IP para VLANIF 5. La dirección IP es la dirección de la interfaz conectada al router.
    [SW1-Vlanif5] quit
    

    # Configure una ruta estática para que los PC en diferentes segmentos de red puedan comunicarse entre sí.

    [SW1] ip route-static 192.168.2.0 255.255.255.0 192.168.5.2  //Configure una ruta estática. Los paquetes con la dirección IP de destino de 192.168.2.0/24 se envían a la dirección del siguiente salto de 192.168.5.2. La dirección del siguiente salto es la dirección IP de la interfaz VLANIF conectada a SW2.
    [SW1] ip route-static 192.168.3.0 255.255.255.0 192.168.5.2  //Configure una ruta estática. Los paquetes con la dirección IP de destino de 192.168.3.0/24 se envían a la dirección del siguiente salto de 192.168.5.2. La dirección del siguiente salto es la dirección IP de la interfaz VLANIF conectada a SW2.
    [SW1] ip route-static 192.168.4.0 255.255.255.0 192.168.5.3  //Configure una ruta estática. Los paquetes con la dirección IP de destino de 192.168.4.0/24 se envían a la dirección del siguiente salto de 192.168.5.3. La dirección del siguiente salto es la dirección IP de la interfaz VLANIF conectada a SW3.

    # Configure una ruta por defecto para que los PC puedan comunicarse con el router.

    [SW1] ip route-static 0.0.0.0 0.0.0.0 192.168.5.4  //La dirección IP es la dirección IP de la interfaz conectada a SW1.

  4. Verifique la configuración

    PC1, PC2 y PC3 pueden accederse entre sí y comunicarse con el router.

Archivos de configuración

Archivo de configuración de SW1

#
sysname SW1
#
vlan batch 5
#
interface Vlanif5
 ip address 192.168.5.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 5
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 5
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 5
#
ip route-static 0.0.0.0 0.0.0.0 192.168.5.4
ip route-static 192.168.2.0 255.255.255.0 192.168.5.2
ip route-static 192.168.3.0 255.255.255.0 192.168.5.2
ip route-static 192.168.4.0 255.255.255.0 192.168.5.3
#
return

Archivo de configuración de SW2

#
sysname SW2
#
vlan batch 2 to 3 5
#
#
interface Vlanif2
 ip address 192.168.2.1 255.255.255.0
#
interface Vlanif3
 ip address 192.168.3.1 255.255.255.0
#
interface Vlanif5
 ip address 192.168.5.2 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 5
#
interface GigabitEthernet1/0/23
 port link-type access
 port default vlan 2
#
interface GigabitEthernet1/0/24
 port link-type access
 port default vlan 3
#
ip route-static 0.0.0.0 0.0.0.0 192.168.5.1
#
return

Archivo de configuración de SW3

#
sysname SW3
#
vlan batch 4 to 5
#
interface Vlanif4
 ip address 192.168.4.1 255.255.255.0
#
interface Vlanif5
 ip address 192.168.5.3 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 5
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 4
#
ip route-static 0.0.0.0 0.0.0.0 192.168.5.1
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15504

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente