No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la asignación de VLAN basada en la interfaz (dispositivo de agregación utilizado como gateway)

Ejemplo para configurar la asignación de VLAN basada en la interfaz (dispositivo de agregación utilizado como gateway)

Descripción general

Las VLAN se pueden asignar en base a las interfaces, las direcciones MAC, las subredes IP, los protocolos y las políticas (direcciones MAC, direcciones IP e interfaces). La asignación de VLAN basada en la interfaz es la más simple y comúnmente utilizada.

La asignación de VLAN basada en la interfaz indica que las VLAN se asignan en base a las interfaces. Un administrador de red preconfigura un PVID para cada interfaz en un switch. Cuando un marco sin etiqueta llega a una interfaz, el switch agrega el PVID de la interfaz al marco. Luego, el marco se transmite en una VLAN especificada.

En una red jerárquica típica, cuando el switch de acceso es un switch de Capa 2, el switch de agregación se puede usar como el gateway de los PC. La configuración del switch de acceso se simplifica y los PC acceden a la red externa a través de una interfaz de salida, lo que facilita el mantenimiento y la administración.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-12, PC1 y PC2 pertenecen a VLAN 2 y VLAN 3, respectivamente. PC1 y PC2 se conectan al switch de agregación SW1 a través del switch de acceso SW2. PC3 pertenece a VLAN 4 y se conecta a SW1 a través de SW3. No se realiza ninguna configuración en SW3, y SW3 funciona como el hub y es plug-and-play. SW1 funciona como el gateway de PC1, PC2 y PC3 para que los PC puedan comunicarse entre sí y puedan conectarse al router.

Figura 6-12  Configuración del dispositivo de agregación como el gateway

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure la asignación basada en la interfaz en el switch de acceso para implementar el interfuncionamiento de Capa 2.
  2. Configure el switch de agregación como el gateway de los PC para implementar el interfuncionamiento de Capa 3 entre los PC en diferentes segmentos de red.
  3. Configure la interfaz que conecta el switch de agregación y el router.

Procedimiento

  1. Configure SW2.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname SW2  //Cambie el nombre del dispositivo a SW2 para una fácil identificación.
    [SW2] vlan batch 2 3  //Cree VLAN 2 y VLAN 3 en un lote.

    # Agregue interfaces a las VLAN.

    [SW2] interface gigabitethernet 1/0/23
    [SW2-GigabitEthernet1/0/23] port link-type access  //Configure la interfaz conectada al PC como la interfaz de acceso.
    [SW2-GigabitEthernet1/0/23] port default vlan 2  //Agregue PC1 a VLAN 2.
    [SW2-GigabitEthernet1/0/23] quit
    [SW2] interface gigabitethernet 1/0/24
    [SW2-GigabitEthernet1/0/24] port link-type access
    [SW2-GigabitEthernet1/0/24] port default vlan 3  //Agregue PC1 a VLAN 2.
    [SW2-GigabitEthernet1/0/24] quit
    [SW2] interface gigabitethernet 1/0/1
    [SW2-GigabitEthernet1/0/1] port link-type trunk  //Configure la interfaz conectada al switch de agregación como la interfaz trunk.
    [SW2-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 3  //Agregue la interfaz a VLAN 2 y VLAN 3.
    [SW2-GigabitEthernet1/0/1] quit

  2. Configure SW1.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname SW1  //Cambie el nombre del dispositivo a SW1.
    [SW1] vlan batch 2 to 5  //Cree VLAN 2 a 5.

    # Agregue interfaces conectadas a los PC para las VLAN.

    [SW1] interface gigabitethernet 1/0/2
    [SW1-GigabitEthernet1/0/2] port link-type trunk  //Configure la interfaz conectada a SW1 como la interfaz trunk.
    [SW1-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3  //Agregue la interfaz a VLAN 2 y VLAN 3.
    [SW1-GigabitEthernet1/0/2] quit
    [SW1] interface gigabitethernet 1/0/3
    [SW1-GigabitEthernet1/0/3] port link-type access  //Configure la interfaz conectada al PC3 como la interfaz de acceso.
    [SW1-GigabitEthernet1/0/3] port default vlan 4  //Agregue PC3 a VLAN 4.
    [SW1-GigabitEthernet1/0/3] quit

    # Configure las interfaces VLANIF y configure las direcciones IP para las interfaces VLANIF como direcciones de gateway de los PC.

    [SW1] interface vlanif 2  //Cree VLANIF 2.
    [SW1-Vlanif2] ip address 192.168.2.1 24  //Configure una dirección IP para VLANIF 2. La dirección IP es la dirección de gateway del PC1.
    [SW1-Vlanif2] quit
    [SW1] interface vlanif 3  //Cree VLANIF 3.
    [SW1-Vlanif3] ip address 192.168.3.1 24  //Configure una dirección IP para VLANIF 3. La dirección IP es la dirección de gateway del PC2.
    [SW1-Vlanif3] quit
    [SW1] interface vlanif 4  //Cree VLANIF 4.
    [SW1-Vlanif4] ip address 192.168.4.1 24  //Configure una dirección IP para VLANIF 4. La dirección IP es la dirección de gateway del PC3.
    [SW1-Vlanif4] quit

    # Agregue interfaces conectadas a los routers a las VLAN.

    [SW1] interface gigabitethernet 1/0/1
    [SW1-GigabitEthernet1/0/1] port link-type access  //Configure la interfaz conectada al router como la interfaz de acceso. La interfaz se comunica con el router en modo sin etiqueta.
    [SW1-GigabitEthernet1/0/1] port default vlan 5  //Agregue el router a VLAN 5.
    [SW1-GigabitEthernet1/0/1] quit

    # Configure las interfaces VLANIF para que los PC puedan conectarse al router.

    [SW1] interface vlanif 5  //Cree VLANIF 5.
    [SW1-Vlanif5] ip address 192.168.5.1 24  //Configure una dirección IP para VLANIF 5. La dirección IP es usada para la interconexión con el router.
    [SW1-Vlanif5] quit
    

  3. Verifique la configuración

    PC1, PC2 y PC3 pueden accederse entre sí y comunicarse con el router.

Archivos de configuración

Archivo de configuración de SW1

#
sysname SW1
#
vlan batch 2 to 5
#
interface Vlanif2
 ip address 192.168.2.1 255.255.255.0
#
interface Vlanif3
 ip address 192.168.3.1 255.255.255.0
#
interface Vlanif4
 ip address 192.168.4.1 255.255.255.0
#
interface Vlanif5
 ip address 192.168.5.1 255.255.255.0
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 5
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 2 to 3
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 4
#
return

Archivo de configuración de SW2

#
sysname SW2
#
vlan batch 2 to 3
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 2 to 3
#
interface GigabitEthernet1/0/23
 port link-type access
 port default vlan 2
#
interface GigabitEthernet1/0/24
 port link-type access
 port default vlan 3
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15601

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente