No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la asignación de VLAN basada en direcciones MAC

Ejemplo para configurar la asignación de VLAN basada en direcciones MAC

Descripción general

La asignación de VLAN basada en direcciones MAC se aplica a redes de pequeña escala donde los terminales de los usuarios a menudo cambian las ubicaciones físicas, pero sus NIC rara vez cambian, por ejemplo, las computadoras móviles.

Las VLAN se pueden asignar en base a las interfaces, las direcciones MAC, las subredes IP, los protocolos y las políticas (direcciones MAC, direcciones IP e interfaces). Tabla 6-5 compara diferentes modos de asignación de VLAN.
Tabla 6-5  Comparaciones entre modos de asignación de VLAN

Modo de asignación de VLAN

Implementación

Ventaja

Desventaja

Escenario de uso

Asignación de VLAN basada en la interfaz

Las VLAN se asignan en base a las interfaces.

Un administrador de red preconfigura un PVID para cada interfaz en un switch. Cuando un marco sin etiqueta llega a una interfaz, el switch agrega el PVID de la interfaz al marco. El marco se transmite en la VLAN especificada por el PVID.

Es simple definir miembros de VLAN.

El administrador de la red debe reconfigurar las VLAN cuando cambian los miembros de VLAN.

Se aplica a redes de cualquier escala y con dispositivos en ubicaciones fijas.

Asignación de VLAN basada en direcciones MAC

Las VLAN se asignan en base a las direcciones MAC de origen de los marcos.

Un administrador de red preconfigura las asignaciones entre las direcciones MAC y los ID de VLAN. Cuando se recibe un marco sin etiqueta, el switch agrega la etiqueta de VLAN mapeando la dirección MAC del marco al marco. Luego, el marco se transmite en la VLAN especificada.

Cuando las ubicaciones físicas de los usuarios cambian, el administrador de la red no debe reconfigurar las VLAN para los usuarios. Esto mejora la seguridad y la flexibilidad de acceso en una red.

El administrador de red debe predefinir VLAN para todos los miembros en una red.

Se aplica a las redes de pequeña escala en las que los terminales de usuario a menudo cambian las ubicaciones físicas, pero sus NIC rara vez cambian, por ejemplo, las computadoras portátiles.

Asignación de VLAN basada en subredes IP

Las VLAN se asignan en base a las direcciones IP de origen y las máscaras de subred.

Un administrador de red preconfigura mapeos entre las direcciones IP y los ID de VLAN. Cuando se recibe un marco sin etiqueta, el switch agrega la etiqueta de VLAN mapeando la dirección IP del marco al marco. Luego, el marco se transmite en la VLAN especificada.

  • Cuando las ubicaciones físicas de los usuarios cambian, el administrador de la red no debe reconfigurar las VLAN para los usuarios.
  • Este modo reduce el tráfico de comunicación y permite que un dominio de difusión abarque múltiples switches.

Los usuarios están distribuidos uniformemente y varios usuarios están en el mismo segmento de red.

Se aplica a escenarios en los que existen altos requisitos de movilidad y administración simplificada y bajos requisitos de seguridad. Por ejemplo, este modo se puede usar si una PC con múltiples direcciones IP debe acceder a servidores en diferentes segmentos de red o si una PC debe unirse a una nueva VLAN automáticamente después de que la dirección IP del PC cambie.

Asignación de VLAN basada en protocolo

Las VLAN se asignan en base a los tipos de protocolo (suite) y los formatos de encapsulación de los marcos.

Un administrador de red preconfigura mapeos entre los tipos de protocolo y los ID de VLAN. Al recibir una trama no etiquetada, el switch agrega el mapeo de la etiqueta VLAN al tipo de protocolo de la trama. El marco se transmite en la VLAN especificada.

Este modo vincula los tipos de servicio a las VLAN, lo que facilita la administración y el mantenimiento.

  • El administrador de la red debe preconfigurar los mapeos entre todos los tipos de protocolos y los ID de VLAN.
  • El switch debe analizar formatos de dirección de protocolo y convertir los formatos, lo que consume recursos excesivos. Por lo tanto, este modo ralentiza el tiempo de respuesta del switch.

Se aplica a las redes que usan múltiples protocolos.

Asignación de VLAN basada en políticas (direcciones MAC, direcciones IP e interfaces)

Las VLAN se asignan en base a políticas tales como combinaciones de interfaces, direcciones MAC y direcciones IP.

Un administrador de red preconfigura las políticas. Cuando se recibe un marco sin etiqueta que coincide con una política configurada, el switch agrega una etiqueta de VLAN especificada al marco. El marco se transmite en la VLAN especificada.

  • Este modo proporciona alta seguridad. Las direcciones MAC o las direcciones IP de los usuarios que se han vinculado a VLAN no pueden modificarse.
  • El administrador de la red puede seleccionar de manera flexible qué políticas usar de acuerdo con el modo de gestión y los requisitos.

Cada política debe configurarse manualmente.

Se aplica a las redes complejas.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-13, interfaces de GE1/0/1 en SwitchA y SwitchB se conectan a dos salas de conferencia, respectivamente. Laptop1 y Laptop2 son computadoras portátiles utilizadas en las dos salas de conferencia. Laptop1 y Laptop2 pertenecen a dos departamentos, que pertenecen a VLAN 100 y VLAN 200, respectivamente. Independientemente de la sala de conferencia en la que se utilicen Laptop1 y Laptop2, se requieren Laptop1 y Laptop2 para acceder a los servidores de sus respectivos departamentos (Server1 y Server2, respectivamente). Las direcciones MAC de Laptop1 y Laptop2 son 0001-00ef-00c0 y 0001-00ef-00c1.

Figura 6-13  Redes de la asignación de VLAN basada en direcciones MAC

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree VLAN en SwitchA y SwitchB y agregue interfaces a VLAN para implementar la conectividad de Capa 2.

  2. Configure la asignación de VLAN basada en la dirección MAC en SwitchA y SwitchB.

  3. Configure la transmisión transparente de los paquetes etiquetados de VLAN en el switch para que Laptop1 y Laptop2 puedan acceder al Server1 y al Server2 de sus respectivos departamentos.

Procedimiento

  1. Configure SwitchA. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 200   //Cree VLAN 100 y VLAN 200.
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk   //El tipo de enlace de las interfaces que conectan a los switches debe ser Trunk. El tipo de enlace por defecto de una interfaz no es Trunk, por lo que debe configurar manualmente la interfaz Trunk.
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 200   //Agregue GE1/0/2 a VLAN 100 y VLAN 200.
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] vlan 100
    [SwitchA-vlan100] mac-vlan mac-address 0001-00ef-00c0   //Los paquetes con la dirección MAC de 0001-00ef-00c0 se transmiten en VLAN 100.
    [SwitchA-vlan100] quit
    [SwitchA] vlan 200
    [SwitchA-vlan200] mac-vlan mac-address 0001-00ef-00c1   //Los paquetes con la dirección MAC de 0001-00ef-00c1 se transmiten en VLAN 200.
    [SwitchA-vlan200] quit
    [SwitchA] interface gigabitethernet 1/0/1 
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 100 200   //El tipo de enlace por defecto de una interfaz no es híbrido, por lo que no debe configurar el tipo de enlace.
    [SwitchA-GigabitEthernet1/0/1] mac-vlan enable   //Habilite la  asignación de VLAN basada en direcciones MAC en la interfaz.
    [SwitchA-GigabitEthernet1/0/1] quit
    

  2. Configure el switch. Las configuraciones de GE1/0/2, GE1/0/3, y GE1/0/4 son similares a la configuración de GE1/0/1, y no se mencionan aquí.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 200
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type trunk
    [Switch-GigabitEthernet1/0/1] port trunk allow-pass vlan 100 200  //Agregue GE1/0/1 a VLAN 100 y VLAN 200.
    [Switch-GigabitEthernet1/0/1] quit

  3. Verifique la configuración

    # Ejecute el comando display mac-vlan mac-address all en cualquier vista para verificar la configuración de la asignación de VLAN basada en direcciones MAC.

    [SwitchA] display mac-vlan mac-address all
    ---------------------------------------------------                             
    MAC Address     MASK            VLAN    Priority                                
    ---------------------------------------------------                             
    0001-00ef-00c0  ffff-ffff-ffff  100     0                                       
    0001-00ef-00c1  ffff-ffff-ffff  200     0                                       
                                                                                    
    Total MAC VLAN address count: 2 
    

Archivos de configuración

Archivo de configuración de SwitchA

#
sysname SwitchA
#
vlan batch 100 200
#
interface GigabitEthernet1/0/1
 port hybrid untagged vlan 100 200
 mac-vlan enable
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
vlan 100                                                                        
 mac-vlan mac-address 0001-00ef-00c0 priority 0                                 
vlan 200                                                                        
 mac-vlan mac-address 0001-00ef-00c1 priority 0 
#
return

Archivo de configuración de SwitchB

#
sysname SwitchB
#
vlan batch 100 200
#
interface GigabitEthernet1/0/1
 port hybrid untagged vlan 100 200
 mac-vlan enable
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
vlan 100                                                                        
 mac-vlan mac-address 0001-00ef-00c0 priority 0                                 
vlan 200                                                                        
 mac-vlan mac-address 0001-00ef-00c1 priority 0 
#
return

Archivo de configuración de switch

#
sysname Switch
#
vlan batch 100 200
#
interface GigabitEthernet1/0/1
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
interface GigabitEthernet1/0/4
 port link-type trunk
 port trunk allow-pass vlan 100 200
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15720

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente