No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la asignación de VLAN basada en subredes IP

Ejemplo para configurar la asignación de VLAN basada en subredes IP

Descripción general de la asignación de VLAN basada en subredes IP

La asignación de VLAN basada en subredes IP se aplica a escenarios en los que existen altos requisitos de movilidad y administración simplificada y bajos requisitos de seguridad. Por ejemplo, este modo se puede usar si una PC con múltiples direcciones IP debe acceder a servidores en diferentes segmentos de red o si una PC debe unirse a una nueva VLAN automáticamente después de que la dirección IP del PC cambie.

Las VLAN se pueden asignar en base a las interfaces, las direcciones MAC, las subredes IP, los protocolos y las políticas (direcciones MAC, direcciones IP e interfaces). Tabla 6-6 compara diferentes modos de asignación de VLAN.
Tabla 6-6  Comparaciones entre modos de asignación de VLAN

Modo de asignación de VLAN

Implementación

Ventaja

Desventaja

Escenario de uso

Asignación de VLAN basada en la interfaz

Las VLAN se asignan en base a las interfaces.

Un administrador de red preconfigura un PVID para cada interfaz en un switch. Cuando un marco sin etiqueta llega a una interfaz, el switch agrega el PVID de la interfaz al marco. El marco se transmite en la VLAN especificada por el PVID.

Es simple definir miembros de VLAN.

El administrador de la red debe reconfigurar las VLAN cuando cambian los miembros de VLAN.

Se aplica a redes de cualquier escala y con dispositivos en ubicaciones fijas.

Asignación de VLAN basada en direcciones MAC

Las VLAN se asignan en base a las direcciones MAC de origen de los marcos.

Un administrador de red preconfigura las asignaciones entre las direcciones MAC y los ID de VLAN. Cuando se recibe un marco sin etiqueta, el switch agrega la etiqueta de VLAN mapeando la dirección MAC del marco al marco. Luego, el marco se transmite en la VLAN especificada.

Cuando las ubicaciones físicas de los usuarios cambian, el administrador de la red no debe reconfigurar las VLAN para los usuarios. Esto mejora la seguridad y la flexibilidad de acceso en una red.

El administrador de red debe predefinir VLAN para todos los miembros en una red.

Se aplica a las redes de pequeña escala en las que los terminales de usuario a menudo cambian las ubicaciones físicas, pero sus NIC rara vez cambian, por ejemplo, las computadoras portátiles.

Asignación de VLAN basada en subredes IP

Las VLAN se asignan en base a las direcciones IP de origen y las máscaras de subred.

Un administrador de red preconfigura mapeos entre las direcciones IP y los ID de VLAN. Cuando se recibe un marco sin etiqueta, el switch agrega la etiqueta de VLAN mapeando la dirección IP del marco al marco. Luego, el marco se transmite en la VLAN especificada.

  • Cuando las ubicaciones físicas de los usuarios cambian, el administrador de la red no debe reconfigurar las VLAN para los usuarios.
  • Este modo reduce el tráfico de comunicación y permite que un dominio de difusión abarque múltiples switches.

Los usuarios están distribuidos uniformemente y varios usuarios están en el mismo segmento de red.

Se aplica a escenarios en los que existen altos requisitos de movilidad y administración simplificada y bajos requisitos de seguridad. Por ejemplo, este modo se puede usar si una PC con múltiples direcciones IP debe acceder a servidores en diferentes segmentos de red o si una PC debe unirse a una nueva VLAN automáticamente después de que la dirección IP del PC cambie.

Asignación de VLAN basada en protocolo

Las VLAN se asignan en base a los tipos de protocolo (suite) y los formatos de encapsulación de los marcos.

Un administrador de red preconfigura mapeos entre los tipos de protocolo y los ID de VLAN. Al recibir una trama no etiquetada, el switch agrega el mapeo de la etiqueta VLAN al tipo de protocolo de la trama. El marco se transmite en la VLAN especificada.

Este modo vincula los tipos de servicio a las VLAN, lo que facilita la administración y el mantenimiento.

  • El administrador de la red debe preconfigurar los mapeos entre todos los tipos de protocolos y los ID de VLAN.
  • El switch debe analizar formatos de dirección de protocolo y convertir los formatos, lo que consume recursos excesivos. Por lo tanto, este modo ralentiza el tiempo de respuesta del switch.

Se aplica a las redes que usan múltiples protocolos.

Asignación de VLAN basada en políticas (direcciones MAC, direcciones IP e interfaces)

Las VLAN se asignan en base a políticas tales como combinaciones de interfaces, direcciones MAC y direcciones IP.

Un administrador de red preconfigura las políticas. Cuando se recibe un marco sin etiqueta que coincide con una política configurada, el switch agrega una etiqueta de VLAN especificada al marco. El marco se transmite en la VLAN especificada.

  • Este modo proporciona alta seguridad. Las direcciones MAC o las direcciones IP de los usuarios que se han vinculado a VLAN no pueden modificarse.
  • El administrador de la red puede seleccionar de manera flexible qué políticas usar de acuerdo con el modo de gestión y los requisitos.

Cada política debe configurarse manualmente.

Se aplica a las redes complejas.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-14, una empresa tiene múltiples servicios, incluidos IPTV, VoIP y acceso a Internet. Cada servicio usa una subred IP diferente. Para facilitar la administración, la compañía requiere que los paquetes del mismo servicio se transmitan en la misma VLAN y paquetes de diferentes servicios en diferentes VLAN. El switch recibe paquetes de servicios múltiples como datos, IPTV y servicios de voz, y los dispositivos de usuario de estos servicios usan direcciones IP en diferentes subredes IP. El switch debe asignar las VLAN a paquetes de diferentes servicios para que el router pueda transmitir paquetes con diferentes ID de VLAN a diferentes servidores.

Figura 6-14  Redes de la asignación de VLAN basada en subredes IP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree VLAN y agregue interfaces a VLAN para que las interfaces permitan las VLAN basadas en subredes IP.
  2. Habilite la asignación de VLAN basada en subredes IP y asocie las subredes IP con las VLAN para que el switch determine las VLAN en base a las direcciones IP de origen o los segmentos de red de los paquetes.

Procedimiento

  1. Cree VLAN

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 100 200 300   //Cree VLAN100, VLAN 200 y VLAN 300 en un lote.

  2. Configure interfaces

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100 200 300   //El tipo de enlace por defecto de una interfaz es híbrido, por lo que no debe configurar el tipo de enlace.
    [Switch-GigabitEthernet1/0/1] ip-subnet-vlan enable   //Habilite la  asignación de VLAN basada en subredes IP.
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type trunk  //Configure el tipo de enlace de la interfaz como Trunk.
    [Switch-GigabitEthernet1/0/2] port trunk allow-pass vlan 100 200 300
    [Switch-GigabitEthernet1/0/2] quit

  3. Configure la asignación de VLAN basada en subredes IP.

    [Switch] vlan 100
    [Switch-vlan100] ip-subnet-vlan 1 ip 192.168.1.2 24 priority 2   //Configure el dispositivo para reenviar paquetes con la dirección IP de 192.168.1.2/24 y la prioridad de 2 en VLAN 100.
    [Switch-vlan100] quit
    [Switch] vlan 200
    [Switch-vlan200] ip-subnet-vlan 1 ip 192.168.2.2 24 priority 3   //Configure el dispositivo para reenviar paquetes con la dirección IP de 192.168.2.2/24 y la prioridad de 3 en VLAN 200.
    [Switch-vlan200] quit
    [Switch] vlan 300
    [Switch-vlan300] ip-subnet-vlan 1 ip 192.168.3.2 24 priority 4   //Configure el dispositivo para reenviar paquetes con la dirección IP de 192.168.3.2/24 y la prioridad de 4 en VLAN 300.
    [Switch-vlan300] quit

  4. Verifique la configuración

    # Ejecute el comando display ip-subnet-vlan vlan all en el switch. La siguiente información es la mostrada:

    [Switch] display ip-subnet-vlan vlan all
    ----------------------------------------------------------------
     Vlan    Index   IpAddress           SubnetMask          Priority
     ----------------------------------------------------------------
     100     1       192.168.1.2         255.255.255.0       2
     200     1       192.168.2.2         255.255.255.0       3
     300     1       192.168.3.2         255.255.255.0       4
     ----------------------------------------------------------------
     ip-subnet-vlan count: 3                  total count: 3 

Archivos de configuración

Archivo de configuración de switch

#
sysname Switch
#
vlan batch 100 200 300
#
vlan 100
 ip-subnet-vlan 1 ip 192.168.1.2 255.255.255.0 priority 2
vlan 200
 ip-subnet-vlan 1 ip 192.168.2.2 255.255.255.0 priority 3
vlan 300
 ip-subnet-vlan 1 ip 192.168.3.2 255.255.255.0 priority 4
#
interface GigabitEthernet1/0/1
 port hybrid untagged vlan 100 200 300
 ip-subnet-vlan enable
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 100 200 300
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15820

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente