No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para conectar un terminal a un gateway de Capa 3 a través de un switch de Capa 2

Ejemplo para conectar un terminal a un gateway de Capa 3 a través de un switch de Capa 2

12

Descripción general

Después de que se hayan asignado las VLAN, los paquetes de difusión solo se reenviarán dentro de la misma VLAN. Es decir, los hosts en diferentes VLAN no pueden comunicarse en Capa 2 porque la tecnología VLAN aísla los dominios de difusión. En las aplicaciones del mundo real, los hosts en diferentes VLAN a menudo deben comunicarse, por lo que la comunicación entre VLAN debe implementarse para resolver esto. Se requiere enrutamiento de capa 3 o tecnología de VLAN para implementar la comunicación entre VLAN.

Huawei ofrece una variedad de tecnologías para implementar comunicación entre VLAN. Las siguientes dos tecnologías se usan comúnmente:
  • Interfaz VLANIF

    Una interfaz VLANIF es una interfaz lógica de Capa 3. Usted puede configurar una dirección IP para una interfaz VLANIF para implementar la comunicación entre VLAN de Capa 3.

  • Subinterfaz de terminación Dot1q

    Similar a una interfaz VLANIF, una subinterfaz es también una interfaz lógica de Capa 3. Puede configurar la terminación dot1q y una dirección IP para una subinterfaz para implementar la comunicación entre VLAN de Capa 3.

La comunicación entre VLAN a través de una subinterfaz de terminación dot1q se usa en escenarios donde una interfaz Ethernet se conecta a muchas VLAN. Debido a que los flujos de datos de diferentes VLAN se adelantan al ancho de banda de la interfaz Ethernet principal, pueden producirse cuellos de botella en la comunicación cuando la red está ocupada.

La interfaz VLANIF y la subinterfaz de terminación Dot1q solo pueden permitir que los hosts en diferentes segmentos de red en diferentes VLAN se comuniquen, mientras que la super-VLAN (agregación de VLAN) y la función VLAN Switch permiten que los hosts en el mismo segmento de red en diferentes VLAN se comuniquen.

Notas de configuración

  • Solo tarjetas de la serie E, tarjetas de la serie X, tarjetas de la serie F y tarjetas SC entre la serie S son compatibles con la subinterfaz de terminación. Para más detalles, consulte la clasificación de la tarjeta en Hardware Description.

    Las tarjetas X1E entre la serie X son compatibles con la subinterfaz de terminación en V200R007C00 y versiones posteriores.
  • Para las interfaces de Capa 2, solo las interfaces híbridas y trunk son compatibles con subinterfaces de terminación.
  • Los ID de VLAN terminados por una subinterfaz no pueden crearse en la vista del sistema o mostrarse.
  • Cuando los paquetes IP deben enviarse desde la subinterfaz de terminación y no hay una entrada ARP correspondiente en el dispositivo. Si la difusión ARP no está habilitada en la subinterfaz de terminación a través del comando arp broadcast enable, el sistema no envía ni reenvía los paquetes ARP de difusión para aprender las entradas ARP. En este caso, los paquetes IP se descartan directamente.
  • Este ejemplo se aplica a todas las versiones de los switches modulares.

Requisitos de redes

En Figura 6-16, Host A y Host B pertenecen al departamento de I&D, y Host C y Host D pertenecen al departamento de calidad. Los dos departamentos están conectados a través de un switch de Capa 2 y requieren aislamiento de Capa 2 y conectividad de Capa 3.

Figura 6-16  Redes para conectar un terminal a un gateway de Capa 3 a través de un switch de Capa 2

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure la asignación basada en la interfaz en el switch de Capa 2 para implementar el aislamiento de Capa 2.

  2. Configure la terminación de la subinterfaz en el switch de Capa 3 para implementar la conectividad de Capa 3.

Procedimiento

  1. Configure el switch de Capa 2 SwitchA.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname SwitchA  //Cambie el nombre del dispositivo a SwitchA para una fácil identificación.
    [SwitchA] vlan batch 2 to 3  //Cree VLAN 2 y VLAN 3 en un lote.

    # Agregue la interfaz conectada al host a las VLAN.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access  //Configure la interfaz conectada al PC como la interfaz de acceso.
    [SwitchA-GigabitEthernet1/0/1] port default vlan 2  //Agregue Host A a VLAN 2.
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 2  //Agregue Host B a VLAN 2.
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type access  //Configure la interfaz conectada al PC como la interfaz de acceso.
    [SwitchA-GigabitEthernet1/0/3] port default vlan 3  //Agregue Host C a VLAN 2.
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface gigabitethernet 1/0/4
    [SwitchA-GigabitEthernet1/0/4] port link-type access
    [SwitchA-GigabitEthernet1/0/4] port default vlan 3  //Agregue Host D a VLAN 2.
    [SwitchA-GigabitEthernet1/0/4] quit

    # Habilite la interfaz conectada al switch de Capa 3 para transmitir paquetes de manera transparente desde una VLAN especificada.

    [SwitchA] interface gigabitethernet 1/0/5
    [SwitchA-GigabitEthernet1/0/5] port link-type trunk  //Configure la interfaz conectada al switch como la interfaz trunk.
    [SwitchA-GigabitEthernet1/0/5] port trunk allow-pass vlan 2 to 3  //Agregue la interfaz a VLAN 2 y VLAN 3.
    [SwitchA-GigabitEthernet1/0/5] quit

  2. Configure el switch de Capa 3 SwitchB.

    <Quidway> system-view
    [Quidway] sysname SwitchB  //Cambie el nombre del dispositivo a SwitchB.
    [SwitchB] interface gigabitethernet 1/0/1.1   //Cree una subinterfaz e ingrese en la vista de la subinterfaz.
    [SwitchB-GigabitEthernet1/0/1.1] dot1q termination vid 2   //Establezca el ID de VLAN para la terminación de dot1q en GE1/0/1.1 a VLAN 2.
    [SwitchB-GigabitEthernet1/0/1.1] ip address 1.1.1.1 24
    [SwitchB-GigabitEthernet1/0/1.1] arp broadcast enable   //Una subinterfaz de terminación descarta directamente los paquetes de difusión, por lo que la subinterfaz debe configurarse para reenviar los paquetes de difusión ARP.
    [SwitchB-GigabitEthernet1/0/1.1] quit
    [SwitchB] interface gigabitethernet 1/0/1.2   //Cree una subinterfaz e introduzca la vista de la subinterfaz.
    [SwitchB-GigabitEthernet1/0/1.2] dot1q termination vid 3   //Establezca el ID de VLAN para la terminación de dot1q en GE1/0/1.2 a VLAN 3.
    [SwitchB-GigabitEthernet1/0/1.2] ip address 2.2.2.1 24 
    [SwitchB-GigabitEthernet1/0/1.2] arp broadcast enable
    [SwitchB-GigabitEthernet1/0/1.2] quit
    

  3. Verifique la configuración

    Configure la dirección IP 1.1.1.2/24 para Host A y la dirección de gateway por defecto como la dirección IP 1.1.1.1.1/24 de GE1/0/1.1.

    Configure la dirección IP 1.1.1.2/24 para Host B y la dirección de gateway por defecto como la dirección IP 1.1.1.1.1/24 de GE1/0/1.1.

    Configure la dirección IP 1.1.1.2/24 para Host C y la dirección de gateway por defecto como la dirección IP 1.1.1.1.1/24 de GE1/0/1.2.

    Configure la dirección IP 1.1.1.2/24 para Host D y la dirección de gateway por defecto como la dirección IP 1.1.1.1.1/24 de GE1/0/1.2.

    Una vez completada la configuración, Host A, Host B, Host C y Host D pueden hacer ping entre ellos y comunicarse en Capa 3.

Archivos de configuración

Archivo de configuración de SwitchA

#
sysname SwitchA
#
vlan batch 2 to 3
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 2
#
interface GigabitEthernet1/0/2
 port link-type access
 port default vlan 2
#
interface GigabitEthernet1/0/3
 port link-type access
 port default vlan 3
#
interface GigabitEthernet1/0/4
 port link-type access
 port default vlan 3
#
interface GigabitEthernet1/0/5
 port link-type trunk
 port trunk allow-pass vlan 2 to 3
#
return

Archivo de configuración de SwitchB

#
sysname SwitchB
#
interface GigabitEthernet1/0/1.1
 dot1q termination vid 2
 ip address 1.1.1.1 255.255.255.0
 arp broadcast enable
#
interface GigabitEthernet1/0/1.2
 dot1q termination vid 3
 ip address 2.2.2.1 255.255.255.0
 arp broadcast enable
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15678

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente