No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar la comunicación entre diferentes segmentos de red a través de rutas estáticas

Ejemplo para configurar la comunicación entre diferentes segmentos de red a través de rutas estáticas

Descripción general

Además de configurar una dirección IP para una interfaz VLANIF, se debe configurar una ruta estática o un protocolo de enrutamiento dinámico cuando los PC en diferentes segmentos de red a través de varios switches se deben comunicar. Esto se debe a que solo se genera una ruta directa para la dirección IP de la interfaz VLANIF en el switch y una interfaz VLANIF solo puede empalar el interfuncionamiento entre los PC en diferentes segmentos de red a través de un switch.

Las rutas estáticas se pueden configurar fácilmente y tienen pocos requisitos en el sistema. Son aplicables a redes simples, estables y de pequeña escala. Sin embargo, las rutas estáticas no se pueden adaptar automáticamente a los cambios en la topología de la red, y se requiere una intervención manual.

Con los algoritmos de enrutamiento, los protocolos de enrutamiento dinámico pueden adaptarse automáticamente a los cambios en la topología de red. Son aplicables a la red donde se implementan algunos dispositivos de Capa 3. Las configuraciones de las rutas dinámicas son complejas. Las rutas dinámicas tienen mayores requisitos en el sistema que las estáticas y consumen más recursos de la red y del sistema.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-17, para garantizar la seguridad y facilitar la administración, una empresa asigna una VLAN para un servidor. El dispositivo del usuario pertenece a VLAN 10, y el servidor pertenece a VLAN 20. Los switches de acceso, agregación y core se implementan entre el usuario y el servidor. Los switches de acceso son switches de capa 2, y los switches de agregación y core son switches de Capa 3. El usuario y el servidor deben comunicarse entre sí debido a los requisitos del servicio.

Figura 6-17  Redes para configurar la comunicación entre diferentes segmentos de red a través de rutas estáticas

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure la asignación de VLAN basada en la interfaz para implementar la comunicación de Capa 2.
  2. Configure VLANIF 10 en el switch de agregación AGG y configure una dirección IP para VLANIF 10 como la dirección de gateway del usuario; configure VLANIF 20 en el switch de core CORE y configure una dirección IP para VLANIF 20 como la dirección de gateway del servidor.
  3. En el switch de agregación AGG, configure una ruta estática desde AGG al segmento de red de la VLANIF 20; en el switch de core CORE, configure una ruta estática desde CORE al segmento de red de la VLANIF 10. Por lo tanto, se implementa la comunicación a través de los segmentos de red.

Procedimiento

  1. Configure el switch de acceso ACC1.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname ACC1  //Cambie el nombre del dispositivo a ACC1 para una fácil identificación.
    [ACC1] vlan batch 10  //Cree VLAN 10 en un lote.

    # Agregue interfaces a las VLAN.

    [ACC1] interface gigabitethernet 1/0/1
    [ACC1-GigabitEthernet1/0/1] port link-type access  //Configure la interfaz conectada a un host de usuario como la interfaz de acceso.
    [ACC1-GigabitEthernet1/0/1] port default vlan 10  //Agregue el dispositivo del usuario a VLAN 10.
    [ACC1-GigabitEthernet1/0/1] quit
    [ACC1] interface gigabitethernet 1/0/2
    [ACC1-GigabitEthernet1/0/2] port link-type trunk  //Configure la interfaz conectada al switch de agregación como la interfaz trunk.
    [ACC1-GigabitEthernet1/0/2] port trunk allow-pass vlan 10  //Agregue la interfaz conectada al switch de agregación a VLAN 10.
    [ACC1-GigabitEthernet1/0/2] quit

  2. Configure el switch de acceso ACC2.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname ACC2  //Cambie el nombre del dispositivo a ACC2.
    [ACC2] vlan batch 20  //Cree VLAN 20 en un lote.

    # Agregue interfaces a las VLAN.

    [ACC2] interface gigabitethernet 1/0/1
    [ACC2-GigabitEthernet1/0/1] port link-type access  //Configure la interfaz conectada a un host de usuario como la interfaz de acceso.
    [ACC2-GigabitEthernet1/0/1] port default vlan 20  //Agregue el dispositivo del usuario a VLAN 20.
    [ACC2-GigabitEthernet1/0/1] quit
    [ACC2] interface gigabitethernet 1/0/2
    [ACC2-GigabitEthernet1/0/2] port link-type trunk  //Configure la interfaz conectada al switch de core como la interfaz trunk.
    [ACC2-GigabitEthernet1/0/2] port trunk allow-pass vlan 20  //Agregue la interfaz conectada al switch de core a VLAN 20.
    [ACC2-GigabitEthernet1/0/2] quit

  3. Configure el switch de agregación AGG.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname AGG  //Cambie el nombre del dispositivo a AGG.
    [AGG] vlan batch 10 30  //Cree VLAN 10 y VLAN 30 en un lote.

    # Agregue interfaces a las VLAN.

    [AGG] interface gigabitethernet 1/0/2
    [AGG-GigabitEthernet1/0/2] port link-type trunk  //Configure la interfaz como la interfaz trunk.
    [AGG-GigabitEthernet1/0/2] port trunk allow-pass vlan 10  //Agregue la interfaz a VLAN 10.
    [AGG-GigabitEthernet1/0/2] quit
    [AGG] interface gigabitethernet 1/0/3
    [AGG-GigabitEthernet1/0/3] port link-type trunk  //Configure la interfaz como la interfaz trunk.
    [AGG-GigabitEthernet1/0/3] port trunk allow-pass vlan 30  //Agregue la interfaz conectada al switch de core a VLAN 30.
    [AGG-GigabitEthernet1/0/3] quit

    # Cree VLANIF 10 y configure una dirección IP para VLANIF 10 como la dirección de gateway.

    [AGG] interface vlanif 10  //Cree VLANIF 10.
    [AGG-Vlanif10] ip address 10.1.1.1 24  //Configure una dirección IP para VLANIF 10. La dirección IP es la dirección de gateway.
    [AGG-Vlanif10] quit

    # Cree VLANIF 30 y configure una dirección IP para VLANIF 30.

    [AGG] interface vlanif 30  //Cree VLANIF 30.
    [AGG-Vlanif30] ip address 10.10.30.1 24  //Configure una dirección IP para VLANIF 30. La dirección IP no puede tener conflicto con las direcciones IP del usuario y del servidor.
    [AGG-Vlanif30] quit

    # Configure una ruta estática para que el PC pueda acceder al servidor.

    [AGG] ip route-static 192.168.1.0 255.255.255.0 10.10.30.2  //Configure una ruta estática. Los paquetes con la dirección IP de destino de 192.168.1.0/24 se envían a la dirección IP 10.10.30.2 de VLANIF 30 en el switch de core.

  4. Configure el switch de core CORE.

    # Cree las VLAN.

    <Quidway> system-view
    [Quidway] sysname CORE  //Cambie el nombre del dispositivo a CORE.
    [CORE] vlan batch 20 30  //Cree VLAN 20 y VLAN 30 en un lote.

    # Agregue interfaces a las VLAN.

    [CORE] interface gigabitethernet 1/0/2
    [CORE-GigabitEthernet1/0/2] port link-type trunk  //Configure la interfaz como la interfaz trunk.
    [CORE-GigabitEthernet1/0/2] port trunk allow-pass vlan 20  //Agregue la interfaz a VLAN 20.
    [CORE-GigabitEthernet1/0/2] quit
    [CORE] interface gigabitethernet 1/0/3
    [CORE-GigabitEthernet1/0/3] port link-type trunk  //Configure la interfaz como la interfaz trunk.
    [CORE-GigabitEthernet1/0/3] port trunk allow-pass vlan 30  //Agregue la interfaz a VLAN 30.
    [CORE-GigabitEthernet1/0/3] quit

    # Cree VLANIF 20 y configure una dirección IP para VLANIF 20 como la dirección de gateway del servidor.

    [CORE] interface vlanif 20  //Cree VLANIF 20.
    [CORE-Vlanif20] ip address 192.168.1.1 24  //Configure una dirección IP para VLANIF 20. La dirección IP es la dirección de gateway del servidor.
    [CORE-Vlanif20] quit

    # Cree VLANIF 30 y configure una dirección IP para VLANIF 30.

    [CORE] interface vlanif 30  //Cree VLANIF 30.
    [CORE-Vlanif30] ip address 10.10.30.2 24  //Configure una dirección IP para VLANIF 30.
    [CORE-Vlanif30] quit

    # Configure una ruta estática para que el servidor y el PC puedan accederse entre sí.

    [CORE] ip route-static 10.1.1.0 255.255.255.0 10.10.30.1  //Configure una ruta estática. Los paquetes con la dirección IP de destino de 10.1.1.0/24 se envían a la dirección IP 10.10.30.1 de VLANIF 30 en el switch de agregación.

  5. Verifique la configuración

    Configure la dirección IP de 10.1.1.2/24 para el PC en VLAN 10 y la dirección de gateway por defecto como 10.1.1.1 (dirección IP de VLANIF 10).

    Configure la dirección IP de 192.168.1.2/24 para el servidor en VLAN 20 y la dirección de gateway por defecto como 192.168.1.1 (dirección IP de VLANIF 20).

    Una vez completada la configuración, el PC en VLAN 10 y el servidor en VLAN 20 pueden accederse entre sí.

Archivos de configuración

Archivo de configuración de ACC1

#
sysname ACC1
#
vlan batch 10
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 10
#
return

Archivo de configuración de ACC2

#
sysname ACC2
#
vlan batch 20
#
interface GigabitEthernet1/0/1
 port link-type access
 port default vlan 20
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
return

Archivo de configuración de AGG

#
sysname AGG
#
vlan batch 10 30
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
#
interface Vlanif30
 ip address 10.10.30.1 255.255.255.0
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 10
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 30
#
ip route-static 192.168.1.0 255.255.255.0 10.10.30.2
#
return

Archivo de configuración de CORE

#
sysname CORE
#
vlan batch 20 30
#
interface Vlanif20
 ip address 192.168.1.1 255.255.255.0
#
interface Vlanif30
 ip address 10.10.30.2 255.255.255.0
#
interface GigabitEthernet1/0/2
 port link-type trunk
 port trunk allow-pass vlan 20
#
interface GigabitEthernet1/0/3
 port link-type trunk
 port trunk allow-pass vlan 30
#
ip route-static 10.1.1.0 255.255.255.0 10.10.30.1
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15506

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente