No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar QinQ básico

Ejemplo para configurar QinQ básico

Descripción general de QinQ

802.1Q-in-802.1Q (QinQ) expande el espacio VLAN añadiendo una etiqueta 802.1Q adicional a los paquetes etiquetados 802.1Q. Permite que los servicios en una VLAN privada se transmitan de forma transparente a través de una red pública.

QinQ básico, también llamado túnel QinQ, se realiza en las interfaces. Cuando una interfaz habilitada con QinQ básico recibe un paquete, el dispositivo agrega la etiqueta de VLAN por defecto de su interfaz al paquete. Si el paquete recibido está etiquetado, tiene etiquetas de VLAN dobles. Si el paquete recibido no tiene etiqueta, tiene la etiqueta de VLAN por defecto de la interfaz.

Cuando se requieren demasiadas VLAN, usted puede configurar QinQ básico. QinQ básico, al agregar una etiqueta externa, expande el espacio VLAN y resuelve el problema de escasez de VLAN.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

Como se muestra en Figura 6-20, una red tiene dos empresas: empresa 1 y empresa 2. Ambas empresas tienen dos sucursales. Las redes, empresa 1 y empresa 2, se conectan a SwitchA y SwitchB, respectivamente, de la red ISP. Además, hay dispositivos que no son de Huawei en la red pública y el TPID en la etiqueta de VLAN externa es 0x9100.

Los requisitos son los siguientes:
  • Las VLAN deben asignarse de forma independiente a la empresa 1 y a la empresa 2.
  • El tráfico entre las dos sucursales de cada empresa se transmite de forma transparente a través de la red pública. Los usuarios que acceden al mismo servicio en diferentes sucursales de cada empresa pueden comunicarse y los usuarios que acceden a diferentes servicios deben estar aislados.
QinQ se puede usar para cumplir los requisitos anteriores. Configure VLAN 100 y VLAN 200 para implementar la conectividad de la empresa 1 y la empresa 2, respectivamente, y aislar la empresa 1 y la empresa 2; configure el TPID en la etiqueta de VLAN externa en las interfaces de conmutación conectadas a dispositivos que no sean de Huawei para que los switches de Huawei puedan comunicarse con los dispositivos que no son de Huawei.
Figura 6-20  Redes de QinQ básico

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree VLAN 100 y VLAN 200 en SwitchA y SwitchB, configure las interfaces conectadas como interfaces QinQ y agregue las interfaces a las VLAN para que se agreguen diferentes etiquetas de VLAN a los paquetes de diferentes servicios.

  2. Agregue las interfaces de SwitchA y SwitchB que están conectadas a la red pública a las VLAN para que los paquetes de VLAN 100 y VLAN 200 puedan pasar.

  3. Configure el TPID en la etiqueta de VLAN externa en las interfaces de SwitchA y SwitchB que están conectadas a la red pública para que SwitchA y SwitchB puedan comunicarse con dispositivos que no sean de Huawei.

Procedimiento

  1. Cree las VLAN.

    # Cree VLAN 100 y VLAN 200 en SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 200
    

    # Cree VLAN 100 y VLAN 200 en SwitchB.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan batch 100 200
    

  2. Ajuste el tipo del enlace de las interfaces a QinQ.

    # Configure GE1/0/1 y GE1/0/2 de SwitchA como interfaces de QinQ, y ajuste la VLAN por defecto de GE1/0/1 para VLAN 100 y la VLAN por defecto de GE para VLAN 200. VLAN 100 y VLAN 200 se agregan a las etiquetas externas. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type dot1q-tunnel //Configure el tipo de enlace de la interfaz como QinQ.
    [SwitchA-GigabitEthernet1/0/1] port default vlan 100
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type dot1q-tunnel //Configure el tipo de enlace de la interfaz como QinQ.
    [SwitchA-GigabitEthernet1/0/2] port default vlan 200
    [SwitchA-GigabitEthernet1/0/2] quit
    

  3. Configure las interfaces de conmutación conectadas a la red pública.

    # Agregue GE1/0/3 en Switch A para VLAN 100 y VLAN 200. La configuración de SwitchB es similar a la configuración de SwitchA, y no se menciona aquí.

    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 100 200
    [SwitchA-GigabitEthernet1/0/3] quit

  4. Configure el TPID en la etiqueta de VLAN externa.

    # Ajuste el TPID en la etiqueta de VLAN externa para 0x9100 en SwitchA.

    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] qinq protocol 9100 //Establezca el TPID en la etiqueta VLAN externa a 0x9100.
    

    # Ajuste el TPID en la etiqueta de VLAN externa para 0x9100 en SwitchB.

    [SwitchB] interface gigabitethernet 1/0/3
    [SwitchB-GigabitEthernet1/0/3] qinq protocol 9100 //Establezca el TPID en la etiqueta VLAN externa a 0x9100.
    

  5. Verifique la configuración

    En una PC en una VLAN de una sucursal en la empresa 1, haga ping a una PC en la misma VLAN de la otra sucursal en la empresa 1. La operación de ping tiene éxito, lo que indica que las sucursales de la empresa 1 pueden comunicarse entre sí.

    En una PC en una VLAN de una sucursal en la empresa 2, haga ping a una PC en la misma VLAN de la otra sucursal en la empresa 2. La operación de ping tiene éxito, lo que indica que las sucursales de la empresa 2 pueden comunicarse entre sí.

    En una PC en una VLAN de una sucursal en la empresa 1, haga ping a una PC en la misma VLAN de la otra sucursal en la empresa 2. La operación de ping tiene éxito, lo que indica que las sucursales de la empresa 1 y la empresa 2 pueden comunicarse entre sí.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface GigabitEthernet1/0/3
     qinq protocol 9100
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/1
     port link-type dot1q-tunnel
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type dot1q-tunnel
     port default vlan 200
    #
    interface GigabitEthernet1/0/3
     qinq protocol 9100
     port link-type trunk
     port trunk allow-pass vlan 100 200
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15395

Descargas: 127

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente