No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el QinQ selectivo basado en VLAN ID

Ejemplo para configurar el QinQ selectivo basado en VLAN ID

Descripción general de QinQ

802.1Q-in-802.1Q (QinQ) expande el espacio VLAN añadiendo una etiqueta 802.1Q adicional a los paquetes etiquetados 802.1Q. Permite que los servicios en una VLAN privada se transmitan de forma transparente a través de una red pública.

QinQ selectivo, también llamado apilamiento de VLAN o apilamiento de QinQ, es una extensión de QinQ. El QinQ selectivo se realiza en base a interfaces e ID de VLAN. Además de las funciones de QinQ básico, QinQ selectivo toma diferentes acciones para los paquetes recibidos por la misma interfaz basados ​​en las VLAN.

QinQ selectivo basado en ID de VLAN agrega diferentes etiquetas de VLAN externas a paquetes con diferentes ID de VLAN internas.

Notas de configuración

Al configurar QinQ selectivo en el switch, preste atención a los siguientes puntos:

  • Antes de configurar QinQ selectivo en un switch fijo, debe ejecutar el comando qinq vlan-translation enable para habilitar la traducción de VLAN.
  • Selective QinQ solo se puede habilitar en interfaces híbridas en la dirección de entrada.
  • La VLAN externa debe crearse antes de que se realice QinQ selectivo.
  • Cuando una interfaz configurada con apilamiento de VLAN necesita eliminar la etiqueta externa de las tramas salientes, la interfaz debe unirse a la VLAN especificada por stack-vlan en modo sin etiqueta. Si no es necesario eliminar la VLAN externa, la interfaz debe unirse a la VLAN especificada por stack-vlan en modo etiquetado.
  • El dispositivo configurado con QinQ selectivo puede agregar solo una etiqueta de VLAN externa a un marco con una etiqueta de VLAN interna en una interfaz.
  • Si solo se deben transmitir transparentemente paquetes con una sola etiqueta desde una VLAN, no especifique la VLAN como VLAN interna del QinQ selectivo.
  • La asignación de VLAN (por ejemplo, port vlan-mapping vlan 20 map-vlan 20) debe configurarse para mapear la VLAN a sí misma desde la cual los paquetes de una sola etiqueta deben transmitirse de forma transparente después de que QinQ selectivo esté configurado en las siguientes tarjetas y dispositivos:
    • Tarjetas LE0MG24CA y LE0MG24SA

    • S5300EI, S3300EI, y S3300SI
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

Como se muestra en Figura 6-21, los usuarios de acceso a Internet (que usan PC) y VoIP (que usan teléfonos VoIP) se conectan a la red ISP a través de SwitchA y SwitchB y se comunican entre sí a través de la red ISP.

En la empresa, VLAN 100 se asigna a los PC y VLAN 300 se asigna a los teléfonos VoIP.

Se requiere que los paquetes de PC y teléfonos VoIP se etiqueten como VLAN 2 y VLAN 3 respectivamente cuando los paquetes se transmiten a través de la red ISP.

Figura 6-21  Redes de QinQ selectivo basado en VLAN ID

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree VLAN en SwitchA y SwitchB.

  2. Configure los tipos de enlace de las interfaces y agregue interfaces a las VLAN en SwitchA y SwitchB.

  3. Configure QinQ selectivo en las interfaces de SwitchA y SwitchB.

Procedimiento

  1. Cree las VLAN

    # En SwitchA, cree VLAN 2 y VLAN 3, es decir, los ID de VLAN de la etiqueta de VLAN externa que se agregará.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 2 3

    # En SwitchB, cree VLAN 2 y VLAN 3, es decir, los ID de VLAN de la etiqueta de VLAN externa que se agregará.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan batch 2 3

  2. Configure QinQ selectivo en las interfaces.

    NOTA:

    Cuando se utilice un switch fijo, debe ejecutar el comando qinq vlan-translation enable en la vista de interfaz para habilitar la traducción de VLAN.

    # Configure GE1/0/1 en SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3  //Agregue la interfaz híbrida a las VLAN en modo sin etiqueta.
    [SwitchA-GigabitEthernet1/0/1] port vlan-stacking vlan 100 stack-vlan 2  //Configure la etiqueta de VLAN interna como VLAN 100 y agregue VLAN 2 en la etiqueta de VLAN externa.
    [SwitchA-GigabitEthernet1/0/1] port vlan-stacking vlan 300 stack-vlan 3  //Configure la etiqueta de VLAN interna como VLAN 300 y agregue VLAN 3 en la etiqueta de VLAN externa.
    [SwitchA-GigabitEthernet1/0/1] quit

    # Configure GE1/0/1 en SwitchB.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3  //Agregue la interfaz híbrida a las VLAN en modo sin etiqueta.
    [SwitchB-GigabitEthernet1/0/1] port vlan-stacking vlan 100 stack-vlan 2  //Configure la etiqueta de VLAN interna como VLAN 100 y agregue VLAN 2 en la etiqueta de VLAN externa.
    [SwitchB-GigabitEthernet1/0/1] port vlan-stacking vlan 300 stack-vlan 3  //Configure la etiqueta de VLAN interna como VLAN 300 y agregue VLAN 3 en la etiqueta de VLAN externa.
    [SwitchB-GigabitEthernet1/0/1] quit

  3. Configure otras interfaces.

    # Agregue GE1/0/2 en SwitchA para VLAN 2 y VLAN 3.

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3
    [SwitchA-GigabitEthernet1/0/2] quit

    # Agregue GE1/0/2 en SwitchB para VLAN 2 y VLAN 3.

    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3
    [SwitchB-GigabitEthernet1/0/2] quit

  4. Verifique la configuración

    Si las configuraciones en SwitchA y SwitchB son correctas, usted puede obtener la siguiente información:

    • los PC pueden comunicarse entre sí a través de la red ISP.

    • Los teléfonos VoIP pueden comunicarse entre sí a través de la red ISP.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 2 to 3
    #
    interface GigabitEthernet1/0/1
     port hybrid untagged vlan 2 to 3
     port vlan-stacking vlan 100 stack-vlan 2
     port vlan-stacking vlan 300 stack-vlan 3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 2 to 3
    #
    interface GigabitEthernet1/0/1
     port hybrid untagged vlan 2 to 3
     port vlan-stacking vlan 100 stack-vlan 2
     port vlan-stacking vlan 300 stack-vlan 3
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15425

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente