No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar QinQ selectivo basado en flujo

Ejemplo para configurar QinQ selectivo basado en flujo

Descripción general de QinQ

802.1Q-in-802.1Q (QinQ) expande el espacio VLAN añadiendo una etiqueta 802.1Q adicional a los paquetes etiquetados 802.1Q. Permite que los servicios en una VLAN privada se transmitan de forma transparente a través de una red pública.

QinQ selectivo, también llamado apilamiento de VLAN o apilamiento de QinQ, es una extensión de QinQ. El QinQ selectivo se realiza en base a interfaces e ID de VLAN. Además de las funciones de QinQ básico, QinQ selectivo toma diferentes acciones para los paquetes recibidos por la misma interfaz basados ​​en las VLAN.

QinQ selectivo basado en flujo agrega etiquetas de VLAN externas basadas en políticas de tráfico. Puede proporcionar servicios diferenciados según los tipos de servicio.

Notas de configuración

Al configurar QinQ selectivo en el switch, preste atención a los siguientes puntos:

  • Selective QinQ solo se puede habilitar en interfaces híbridas en la dirección de entrada.
  • La VLAN externa debe crearse antes de que se realice QinQ selectivo.
  • Cuando una interfaz configurada con apilamiento de VLAN necesita eliminar la etiqueta externa de las tramas salientes, la interfaz debe unirse a la VLAN especificada por stack-vlan en modo sin etiqueta. Si no es necesario eliminar la VLAN externa, la interfaz debe unirse a la VLAN especificada por stack-vlan en modo etiquetado.
  • El dispositivo configurado con QinQ selectivo puede agregar solo una etiqueta de VLAN externa a un marco con una etiqueta de VLAN interna en una interfaz.
  • Si solo se deben transmitir transparentemente paquetes con una sola etiqueta desde una VLAN, no especifique la VLAN como VLAN interna del QinQ selectivo.
  • Este ejemplo se aplica a todas las versiones de los switches modulares.

Requisitos de redes

Como se muestra en Figura 6-22, los usuarios de acceso a Internet (que usan PC) y VoIP (que usan teléfonos VoIP) se conectan a la red ISP a través de SwitchA y SwitchB y se comunican entre sí a través de la red ISP.

Se requiere que los paquetes de PC y teléfonos VoIP se etiqueten como VLAN 2 y VLAN 3 respectivamente cuando los paquetes se transmiten a través de la red ISP. QinQ selectivo basado en flujo puede configurarse para cumplir con el requisito.

Figura 6-22  Redes de QinQ selectivo basado en flujo

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree VLAN en SwitchA y SwitchB.

  2. Configure clasificadores de tráfico, comportamientos de tráfico y políticas de tráfico en SwitchA y SwitchB.

  3. Configure los tipos de enlace de las interfaces en SwitchA y SwitchB y agregue las interfaces a las VLAN.

  4. Aplique las políticas de tráfico a las interfaces en SwitchA y SwitchB para implementar QinQ selectivo.

Procedimiento

  1. Cree las VLAN

    # En SwitchA, cree VLAN 2 y VLAN 3, es decir, los ID de VLAN de la etiqueta de VLAN externa que se agregará.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 2 3

    # En SwitchB, cree VLAN 2 y VLAN 3, es decir, los ID de VLAN de la etiqueta de VLAN externa que se agregará.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan batch 2 3

  2. Configure clasificadores de tráfico, comportamientos de tráfico y políticas de tráfico en SwitchA y SwitchB.

    # Configure los clasificadores de tráfico, los comportamientos de tráfico y la política de tráfico en SwitchA.

    [SwitchA] traffic classifier name1  //Configure un clasificador de tráfico llamado name1.
    [SwitchA-classifier-name1] if-match vlan-id 100 to 200  //Configure una regla de coincidencia para que coincida con los paquetes de las VLAN 100 a 200.
    [SwitchA-classifier-name1] quit
    [SwitchA] traffic behavior name1  //Configure un comportamiento de tráfico llamado name1.
    [SwitchA-behavior-name1] nest top-most vlan-id 2  //Configure una acción de agregar VLAN 2 en una etiqueta de VLAN externa en un comportamiento de tráfico. En V200R009 y versiones posteriores, el comando se cambia a add-tag vlan-id.
    [SwitchA-behavior-name1] quit
    [SwitchA] traffic classifier name2  //Configure un clasificador de tráfico llamado name2.
    [SwitchA-classifier-name2] if-match vlan-id 300 to 400  //Configure una regla de coincidencia para que coincida con los paquetes de las VLAN 300 a 400.
    [SwitchA-classifier-name2] quit
    [SwitchA] traffic behavior name2  //Configure un comportamiento de tráfico llamado name2.
    [SwitchA-behavior-name2] nest top-most vlan-id 3  //Configure una acción de agregar VLAN 3 en una etiqueta de VLAN externa en un comportamiento de tráfico. En V200R009 y versiones posteriores, el comando se cambia a add-tag vlan-id.
    [SwitchA-behavior-name2] quit
    [SwitchA] traffic policy name1  //Configure una política de tráfico llamada name1.
    [SwitchA-trafficpolicy-name1] classifier name1 behavior name1 
    [SwitchA-trafficpolicy-name1] classifier name2 behavior name2 
    [SwitchA-trafficpolicy-name1] quit
    

    # Configure los clasificadores de tráfico, el comportamiento del tráfico y la política de tráfico en SwitchB.

    [SwitchB] traffic classifier name1 //Configure un clasificador de tráfico llamado name1.
    [SwitchB-classifier-name1] if-match vlan-id 100 to 200  //Configure una regla de coincidencia para que coincida con los paquetes de las VLAN 100 a 200.
    [SwitchB-classifier-name1] quit
    [SwitchB] traffic behavior name1  //Configure un comportamiento de tráfico llamado name1.
    [SwitchB-behavior-name1] nest top-most vlan-id 2  //Configure una acción de agregar VLAN 2 en una etiqueta de VLAN externa en un comportamiento de tráfico. En V200R009 y versiones posteriores, el comando se cambia a add-tag vlan-id.
    [SwitchB-behavior-name1] quit
    [SwitchB] traffic classifier name2  //Configure un clasificador de tráfico llamado name2.
    [SwitchB-classifier-name2] if-match vlan-id 300 to 400  //Configure una regla de coincidencia para que coincida con los paquetes de las VLAN 300 a 400.
    [SwitchB-classifier-name2] quit
    [SwitchB] traffic behavior name2  //Configure un comportamiento de tráfico llamado name2.
    [SwitchB-behavior-name2] nest top-most vlan-id 3  //Configure una acción de agregar VLAN 3 en una etiqueta de VLAN externa en un comportamiento de tráfico. En V200R009 y versiones posteriores, el comando se cambia a add-tag vlan-id.
    [SwitchB-behavior-name2] quit
    [SwitchB] traffic policy name1  //Configure una política de tráfico llamada name1.
    [SwitchB-trafficpolicy-name1] classifier name1 behavior name1 
    [SwitchB-trafficpolicy-name1] classifier name2 behavior name2 
    [SwitchB-trafficpolicy-name1] quit
    

  3. Aplique las políticas de tráfico a las interfaces en SwitchA y SwitchB para implementar QinQ selectivo.

    # Configure GE1/0/1 en SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3
    [SwitchA-GigabitEthernet1/0/1] traffic-policy name1 inbound  //Aplique el name1 de la política de tráfico a la interfaz en la dirección entrante.
    [SwitchA-GigabitEthernet1/0/1] quit

    # Configure GE1/0/1 en SwitchB.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type hybrid
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 2 3
    [SwitchB-GigabitEthernet1/0/1] traffic-policy name1 inbound  //Aplique el name1 de la política de tráfico a la interfaz en la dirección entrante.
    [SwitchB-GigabitEthernet1/0/1] quit

  4. Configure otras interfaces.

    # Agregue GE1/0/2 en SwitchA a VLAN 2 y VLAN 3.

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3
    [SwitchA-GigabitEthernet1/0/2] quit

    # Agregue GE1/0/2 en SwitchB a VLAN 2 y VLAN 3.

    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 3
    [SwitchB-GigabitEthernet1/0/2] quit

  5. Verifique la configuración

    Si las configuraciones en SwitchA y SwitchB son correctas, puede obtener la siguiente información:

    • los PC pueden comunicarse entre sí a través de la red ISP.

    • Los teléfonos VoIP pueden comunicarse entre sí a través de la red ISP.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 operator or precedence 5
     if-match vlan-id 100 to 200
    traffic classifier name2 operator or precedence 10
     if-match vlan-id 300 to 400
    #
    traffic behavior name1
     permit
     nest top-most vlan-id 2
    traffic behavior name2
     permit
     nest top-most vlan-id 3
    #
    traffic policy name1 match-order config
     classifier name1 behavior name1
     classifier name2 behavior name2
    #
    interface GigabitEthernet1/0/1
     port hybrid untagged vlan 2 to 3
     traffic-policy name1 inbound
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 2 to 3
    #
    traffic classifier name1 operator or precedence 5
     if-match vlan-id 100 to 200
    traffic classifier name2 operator or precedence 10
     if-match vlan-id 300 to 400
    #
    traffic behavior name1
     permit
     nest top-most vlan-id 2
    traffic behavior name2
     permit
     nest top-most vlan-id 3
    #
    traffic policy name1 match-order config
     classifier name1 behavior name1
     classifier name2 behavior name2
    #
    interface GigabitEthernet1/0/1
     port hybrid untagged vlan 2 to 3
     traffic-policy name1 inbound
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15776

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente