No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar MSTP

Ejemplo para configurar MSTP

Descripción general

En general, los enlaces redundantes se utilizan en una red de conmutación de Ethernet para proporcionar la copia de seguridad del enlace y mejorar la confiabilidad de la red. El uso de los enlaces redundantes, sin embargo, puede producir bucles, causando tormentas de difusión y volviendo inestable la tabla de direcciones MAC. Como resultado, la calidad de la comunicación se deteriora y los servicios de comunicación pueden interrumpirse. El Protocolo del árbol de expansión (STP) se usa para resolver estos problemas. STP evita bucles. Los dispositivos que ejecutan STP descubren bucles en la red intercambiando información entre ellos y bloquean algunos puertos para eliminar bucles.

STP se refiere a STP definido en IEEE 802.1D, Protocolo del árbol de expansión rápida (RSTP) definido en IEEE 802.1W y Protocolo de los árboles múltiples de expansión(MSTP) definido en IEEE 802.1S.

MSTP es compatible con RSTP y STP, y RSTP es compatible con STP. Tabla 6-10 Comparan STP, RSTP, y MSTP.
Tabla 6-10  Comparaciones entre STP, RSTP y MSTP

Protocolo del árbol de expansión

Características

Escenario de aplicación

STP

  • Forma un árbol sin bucles para evitar tormentas de difusión e implementar redundancia.

  • Proporciona una convergencia lenta.

No es necesario diferenciar el tráfico del usuario o del servicio, y todas las VLAN comparten un árbol de expansión.

RSTP

  • Forma un árbol sin bucles para evitar tormentas de difusión e implementar redundancia.
  • Proporciona una convergencia rápida.

MSTP

  • Forma árboles múltiples sin bucles para evitar tormentas de difusión e implementar redundancia.
  • Proporciona una convergencia rápida.
  • Implementa el equilibrio de carga entre VLAN y reenvía el tráfico en diferentes VLAN a lo largo de diferentes rutas.

El tráfico del usuario o del servicio debe diferenciarse y equilibrarse en la carga. El tráfico desde diferentes VLAN se reenvía a través de los diferentes árboles de expansión independientes entre sí.

Notas de configuración

  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.
  • Los puertos conectados a los terminales no participan en el cálculo MSTP. Por lo tanto, configure los puertos como puertos de borde o deshabilite STP en los puertos.

Requisitos de redes

Para implementar la redundancia en una red compleja, los diseñadores de redes tienden a desplegar múltiples enlaces físicos entre dos dispositivos, uno de los cuales es el enlace primario y los otros son enlaces de reserva. Pueden producirse bucles, lo que causa tormentas de difusión o hace que la tabla de direcciones MAC se quede inestable. MSTP se puede usar para evitar bucles. MSTP bloquea enlaces redundantes y corta una red en una topología de árbol libre de bucles.

En Figura 6-25, SwitchA, SwitchB, SwitchC, y SwitchD ejecutan MSTP. MSTP utiliza instancias múltiples para implementar el equilibrio de carga del tráfico en VLAN 2 a 10 y VLAN 11 a 20. Se puede usar la tabla de mapeo de VLAN que define el mapeo entre VLAN y MSTI.

Figura 6-25  Redes de MSTP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure las funciones básicas de MSTP en los dispositivos de conmutación de la red en anillo.

  2. Habilite las funciones de protección para proteger dispositivos o enlaces. Por ejemplo, habilite la protección de root en el puerto designado del root bridge en cada MSTI.

    NOTA:

    Cuando el enlace entre el root bridge y el secondary root bridge esté en Down, el puerto habilitado con protección de root se convierte en Discarding porque la protección de root tiene efecto.

    Para mejorar la confiabilidad, se recomienda vincular el enlace entre el root bridge y el secondary root bridge a un Eth-Trunk.

  3. Configure el reenvío de Capa 2 en los dispositivos.

Procedimiento

  1. Configure las funciones básicas de MSTP.

    1. Configure SwitchA, SwitchB, SwitchC y SwitchD (switches de acceso) en la región MST RG1 y cree MSTI 1 y MSTI 2.

      NOTA:
      Dos switches pertenecen a la misma región MST cuando tienen el mismo:
      • Nombre de la región MST

      • Mapeo entre VLAN y MSTI

      • Nivel de revisión de la región MST

      # Configure una región MST del el root bridge SwitchA en MSTI 1.

      <Quidway> system-view
      [Quidway] sysname SwitchA
      [SwitchA] stp region-configuration
      [SwitchA-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchA-mst-region] instance 1 vlan 2 to 10 //Mapee las VLAN 2 a 10 a MSTI 1.
      [SwitchA-mst-region] instance 2 vlan 11 to 20 //Mapee  las VLAN 11 a 20 a MSTI 2.
      [SwitchA-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchA-mst-region] quit

      # Configure una región MST del root bridge SwitchB en MSTI 1.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] stp region-configuration
      [SwitchB-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchB-mst-region] instance 1 vlan 2 to 10 //Mapee  las VLAN 2 a 10 a MSTI 1.
      [SwitchB-mst-region] instance 2 vlan 11 to 20 //Mapee  las VLAN 11 a 20 a MSTI 2.
      [SwitchB-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchB-mst-region] quit

      # Configure una región MST de SwitchC.

      <Quidway> system-view
      [Quidway] sysname SwitchC
      [SwitchC] stp region-configuration
      [SwitchC-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchC-mst-region] instance 1 vlan 2 to 10 //Mapee  las VLAN 2 a 10 a MSTI 1.
      [SwitchC-mst-region] instance 2 vlan 11 to 20 //Mapee  las VLAN 11 a 20 a MSTI 2.
      [SwitchC-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchC-mst-region] quit

      # Configure una región MST de SwitchD.

      <Quidway> system-view
      [Quidway] sysname SwitchD
      [SwitchD] stp region-configuration
      [SwitchD-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchD-mst-region] instance 1 vlan 2 to 10 //Mapee  las VLAN 2 a 10 a MSTI 1.
      [SwitchD-mst-region] instance 2 vlan 11 to 20 //Mapee  las VLAN 11 a 20 a MSTI 2.
      [SwitchD-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchD-mst-region] quit
    2. Configure los root bridge y los secondary root bridge de MSTI 1 y MSTI 2 en la región MST RG1.

      • Configure el root bridge y el secondary root bridge en MSTI 1.

        # Configure SwitchA como el root bridge en MSTI 1.

        [SwitchA] stp instance 1 root primary

        # Configure SwitchB como el secondary root bridge en MSTI 1.

        [SwitchB] stp instance 1 root secondary
      • Configure el root bridgez y el secondary root bridge en MSTI 2.

        # Configure SwitchB como el root bridge en MSTI 2.

        [SwitchB] stp instance 2 root primary

        # Configure SwitchA como el secondary root bridge en MSTI 2.

        [SwitchA] stp instance 2 root secondary
    3. Ajuste que los costos de la ruta de los puertos a ser bloqueados en MSTI 1 y MSTI 2 sean mayores que los valores por defecto.

      NOTA:
      • El rango del costo de la ruta depende del algoritmo. El algoritmo patentado de Huawei se usa como ejemplo. Ajuste los costos de la ruta de los puertos a ser bloqueados en MSTI 1 y MSTI 2 a 20000.

      • Los dispositivos de conmutación en la misma red deben usar el mismo algoritmo para calcular el costo de la ruta de los puertos.

      Configure SwitchA para usar el algoritmo patentado de Huawei para calcular el costo de la ruta.

      [SwitchA] stp pathcost-standard legacy

      # Configure SwitchB para usar el algoritmo patentado de Huawei para calcular el costo de la ruta.

      [SwitchB] stp pathcost-standard legacy

      # Configure SwitchC para utilizar el algoritmo patentado de Huawei para calcular el costo de la ruta y ajuste el costo de la ruta de GE1/0/2 a 20000 en MSTI 2.

      [SwitchC] stp pathcost-standard legacy
      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] stp instance 2 cost 20000
      [SwitchC-GigabitEthernet1/0/2] quit

      # Configure SwitchD para usar el algoritmo patentado de Huawei para calcular el costo de la ruta y ajuste el costo de la ruta de GE1/0/2 a 20000 en MSTI 1.

      [SwitchD] stp pathcost-standard legacy
      [SwitchD] interface gigabitethernet 1/0/2
      [SwitchD-GigabitEthernet1/0/2] stp instance 1 cost 20000
      [SwitchD-GigabitEthernet1/0/2] quit
    4. Habilite MSTP para eliminar bucles.

      • Habilite MSTP globalmente en dispositivos.

        [SwitchA] stp enable

        # Habilite MSTP en SwitchB.

        [SwitchB] stp enable

        # Habilite MSTP en SwitchC.

        [SwitchC] stp enable

        # Habilite MSTP en SwitchD.

        [SwitchD] stp enable
      • Configure los puertos conectados al terminal como puertos de borde.

        # Configure GE1/0/1 de SwitchC como un puerto de borde.

        [SwitchC] interface gigabitethernet 1/0/1
        [SwitchC-GigabitEthernet1/0/1] stp edged-port enable
        [SwitchC-GigabitEthernet1/0/1] quit

        (Opcional) Configure la protección BPDU en SwitchC.

        [SwitchC] stp bpdu-protection

        # Configure GE1/0/1 de SwitchC como un puerto de borde.

        [SwitchD] interface gigabitethernet 1/0/1
        [SwitchD-GigabitEthernet1/0/1] stp edged-port enable
        [SwitchD-GigabitEthernet1/0/1] quit

        (Opcional) Configure la protección BPDU en SwitchD.

        [SwitchD] stp bpdu-protection
        NOTA:
        Si los puertos de borde están conectados a dispositivos de red que tienen STP habilitado y la protección BPDU está habilitada, los puertos de borde se apagarán y sus atributos permanecerán sin cambios después de recibir BPDU.

  2. Habilite las funciones de protección. Por ejemplo, habilite la protección de root en el puerto designado del root bridge en cada MSTI.

    # Habilite la protección de root en GE1/0/1 de SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp root-protection
    [SwitchA-GigabitEthernet1/0/1] quit

    # Habilite la protección de root en GE1/0/1 de SwitchB.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] stp root-protection
    [SwitchB-GigabitEthernet1/0/1] quit

  3. Configure el reenvío de Capa 2 en los switches de la red en anillo.

    • Cree VLAN 2 a 20 en SwitchA, SwitchB, SwitchC y SwitchD.

      # Cree VLAN 2 a 20 en SwitchA.

      [SwitchA] vlan batch 2 to 20

      # Cree VLAN 2 a 20 en SwitchB.

      [SwitchB] vlan batch 2 to 20

      # Cree VLAN 2 a 20 en SwitchC.

      [SwitchC] vlan batch 2 to 20

      # Crear VLAN 2 a 20 en SwitchD.

      [SwitchD] vlan batch 2 to 20
    • Agregue los puertos conectados al anillo a las VLAN.

      # Agregue GE1/0/1 en SwitchA a las VLAN.

      [SwitchA] interface gigabitethernet 1/0/1
      [SwitchA-GigabitEthernet1/0/1] port link-type trunk
      [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 20
      [SwitchA-GigabitEthernet1/0/1] quit

      # Agregue Eth-Trunk1 en SwitchA a las VLAN.

      [SwitchA] interface Eth-Trunk 1
      [SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/2
      [SwitchA-Eth-Trunk1] trunkport gigabitethernet 1/0/3
      [SwitchA-Eth-Trunk1] port link-type trunk
      [SwitchA-Eth-Trunk1] port trunk allow-pass vlan 2 to 20
      [SwitchA-Eth-Trunk1] quit

      # Agregue GE1/0/1 en SwitchB a las VLAN.

      [SwitchB] interface gigabitethernet 1/0/1
      [SwitchB-GigabitEthernet1/0/1] port link-type trunk
      [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 20
      [SwitchB-GigabitEthernet1/0/1] quit

      # Agregue Eth-Trunk1 en SwitchB a las VLAN.

      [SwitchB] interface Eth-Trunk 1
      [SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/2
      [SwitchB-Eth-Trunk1] trunkport gigabitethernet 1/0/3
      [SwitchB-Eth-Trunk1] port link-type trunk
      [SwitchB-Eth-Trunk1] port trunk allow-pass vlan 2 to 20
      [SwitchB-Eth-Trunk1] quit

      # Agregue GE1/0/1 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/1
      [SwitchC-GigabitEthernet1/0/1] port link-type access
      [SwitchC-GigabitEthernet1/0/1] port default vlan 2
      [SwitchC-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] port link-type trunk
      [SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 20
      [SwitchC-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/3
      [SwitchC-GigabitEthernet1/0/3] port link-type trunk
      [SwitchC-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 to 20
      [SwitchC-GigabitEthernet1/0/3] quit

      # Agregue GE1/0/1 en SwitchD a las VLAN.

      [SwitchD] interface gigabitethernet 1/0/1
      [SwitchD-GigabitEthernet1/0/1] port link-type access
      [SwitchD-GigabitEthernet1/0/1] port default vlan 11
      [SwitchD-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchD a las VLAN.

      [SwitchD] interface gigabitethernet 1/0/2
      [SwitchD-GigabitEthernet1/0/2] port link-type trunk
      [SwitchD-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 20
      [SwitchD-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchD a las VLAN.

      [SwitchD] interface gigabitethernet 1/0/3
      [SwitchD-GigabitEthernet1/0/3] port link-type trunk
      [SwitchD-GigabitEthernet1/0/3] port trunk allow-pass vlan 2 to 20
      [SwitchD-GigabitEthernet1/0/3] quit

  4. Verifique la configuración

    Una vez que sea completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración.

    NOTA:

    MSTI 1 y MSTI 2 se utilizan como ejemplos, por lo que no es necesario verificar el estado del puerto en MSTI 0.

    # Ejecute el comando display stp brief en SwitchA para ver el estado del puerto y el tipo de la protección. La información mostrada es la siguiente:

    [SwitchA] display stp brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       0    Eth-Trunk1                  DESI  FORWARDING      NONE
       1    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       1    Eth-Trunk1                  DESI  FORWARDING      NONE
       2    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       2    Eth-Trunk1                  ROOT  FORWARDING      NONE

    En MSTI 1, Eth-Trunk1 y GE1/0/1 en SwitchA son puertos designados porque SwitchA es el puente root. En MSTI 2, GE1/0/1 en SwitchA es el puerto designado y Eth-Trunk1 es el root bridge.

    # Ejecute el comando display stp brief en SwitchB. La siguiente información es la mostrada:

    [SwitchB] display stp brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       0    Eth-Trunk1                  ROOT  FORWARDING      NONE
       1    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       1    Eth-Trunk1                  ROOT  FORWARDING      NONE
       2    GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       2    Eth-Trunk1                  DESI  FORWARDING      NONE

    En MSTI 2, GE1/0/1 y Eth-Trunk1 en SwitchB son puertos designados porque SwitchB es el root bridge. En MSTI 1, GE1/0/1 en SwitchB es el puerto diseñado y Eth-Trunk1 es el root bridge.

    # Ejecute el comando display stp interface brief en SwitchC. La siguiente información es la mostrada:

    [SwitchC] display stp interface gigabitethernet 1/0/3 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       1    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       2    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
    [SwitchC] display stp interface gigabitethernet 1/0/2 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/2        DESI  FORWARDING      NONE
       1    GigabitEthernet1/0/2        DESI  FORWARDING      NONE
       2    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE

    GE1/0/3 en SwitchC es el root bridge en MSTI 1 and MSTI 2. GE1/0/2 em SwitchC es bloqueado en MSTI 2 and es el puerto designado en MSTI 1.

    # Ejecute el comando display stp interface brief en SwitchD. La siguiente información es la mostrada:

    [SwitchD] display stp interface gigabitethernet 1/0/3 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       1    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
       2    GigabitEthernet1/0/3        ROOT  FORWARDING      NONE
    [SwitchD] display stp interface gigabitethernet 1/0/2 brief
     MSTID  Port                        Role  STP State       Protection
       0    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE
       1    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE
       2    GigabitEthernet1/0/2        DESI  FORWARDING      NONE

    GE1/0/3 en SwitchD es el root bridge en MSTI 1 y MSTI 2. GE1/0/2 en SwitchD es bloqueado en MSTI 1 and es el puerto designado en MSTI 2.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 2 to 20
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp root-protection
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 2 to 20
    #
    stp instance 1 root secondary
    stp instance 2 root primary
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface Eth-Trunk1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp root-protection
    #
    interface GigabitEthernet1/0/2
     eth-trunk 1
    #
    interface GigabitEthernet1/0/3
     eth-trunk 1
    #
    return
  • Archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 2 to 20
    #
    stp bpdu-protection
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 2
     stp edged-port enable 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp instance 2 cost 20000
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    return
  • Archivo de configuración de SwitchD

    #
    sysname SwitchD
    #
    vlan batch 2 to 20
    #
    stp bpdu-protection
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2 to 10
     instance 2 vlan 11 to 20
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 11
     stp edged-port enable 
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
     stp instance 1 cost 20000
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 2 to 20
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15555

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente