No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar MSTP y VRRP

Ejemplo para configurar MSTP y VRRP

Descripción general

Cuando VRRP se implementa en una red, varios dispositivos transmiten servicios simultáneamente. Cada dispositivo virtual consta de un Master y varias Backup. Si es necesario implementar enlaces redundantes para la copia de seguridad de acceso, se debe implementar MSTP para eliminar bucles y garantizar el equilibrio de carga del tráfico.

Notas de configuración

  • A continuación se describen los modelos y versiones de producto aplicables.
    Tabla 6-11  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.
  • Los puertos conectados a los terminales no participan en el cálculo MSTP. Por lo tanto, configure los puertos como puertos de borde o deshabilite STP en los puertos.

Requisitos de redes

En Figura 6-26, hosts se conectan a la red a través de SwitchC. SwitchC está dual-homed a SwitchA y SwitchB y se conecta a Internet. Los enlaces redundantes se implementan para la copia de seguridad de acceso. El uso de los enlaces redundantes, sin embargo, puede producir bucles, causando tormentas de difusión y volviendo inestable la tabla de direcciones MAC.

Es necesario evitar los bucles de red cuando se implementen enlaces redundantes, el tráfico se conmuta a otro enlace cuando se desconecte un enlace, y se usa efectivamente el ancho de banda de la red.

MSTP se puede configurar en la red. MSTP bloquea enlaces redundantes y corta una red en una topología de árbol libre de bucles. VRRP se puede configurar en SwitchA y SwitchB. HostA se conecta a Internet con SwitchA como gateway por defecto y SwitchB como gateway de reserva; HostB se conecta a Internet con SwitchB como gateway por defecto y SwitchA como gateway de reserva. Este ajuste implementa confiabilidad y equilibrio de carga del tráfico.

Figura 6-26  Redes para configurar MSTP y VRRP

Dispositivo

Interfaz

Interfaz VLANIF

Dirección IP

SwitchA

GE1/0/1 y GE1/0/2

VLANIF 2

10.1.2.102/24

GE1/0/1 y GE1/0/2

VLANIF 3

10.1.3.102/24

GE1/0/3

VLANIF 4

10.1.4.102/24

SwitchB

GE1/0/1 y GE1/0/2

VLANIF 2

10.1.2.103/24

GE1/0/1 y GE1/0/2

VLANIF 3

10.1.3.103/24

GE1/0/3

VLANIF 5

10.1.5.103/24

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure las funciones básicas de MSTP en los dispositivos de conmutación de la red en anillo.
    1. Configure una región MST y cree múltiples instancias, y mapee VLAN 2 a MSTI 1 y VLAN 3 a MSTI 2 para el equilibrio de carga del tráfico.

    2. Configure el root bridge y el secondary root bridge en cada región MST.

    3. Configure el costo de la ruta de un puerto en cada MSTI para que el puerto pueda ser bloqueado.

    4. Habilite MSTP para evitar bucles.
      • Habilite MSTP globalmente.

      • Habilite MSTP en todos los puertos excepto en los puertos conectados a los hosts.

  2. Habilite las funciones de protección para proteger dispositivos o enlaces. Por ejemplo, habilite la protección de root en el puerto designado del root bridge en cada MSTI.

  3. Configure el reenvío de Capa 2 en los dispositivos.

  4. Asigne una dirección IP a cada interfaz y configure un protocolo de enrutamiento para garantizar la conectividad de la red.
    NOTA:
    En este ejemplo, SwitchA y SwitchB necesitan ser compatibles con VRPP y OSPF. Para obtener detalles sobre los modelos compatibles con VRRP y OSPF, consulte la documentación.
  5. Cree el grupo 1 y 2 de VRRP en SwitchA y SwitchB. En el grupo 1 de VRRP, configure SwitchA como el Master y SwitchB como el Backup. En el grupo 2 de VRRP, configure SwitchB como el Master y SwitchA como el Backup.

Procedimiento

  1. Configure las funciones básicas de MSTP.

    1. Configure SwitchA, SwitchB y SwitchC en la región MST RG1 y cree MSTI 1 y MSTI 2.

      # Configure una región MST en SwitchA.

      <Quidway> system-view
      [Quidway] sysname SwitchA
      [SwitchA] stp region-configuration //Introduzca la vista de la región.
      [SwitchA-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchA-mst-region] instance 1 vlan 2 //Mapee  VLAN 2 a MSTI 1.
      [SwitchA-mst-region] instance 2 vlan 3 //Mapee  VLAN 3 a MSTI 2.
      [SwitchA-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchA-mst-region] quit

      # Configure una región MST en SwitchB.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] stp region-configuration //Introduzca la vista de la región.
      [SwitchB-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchB-mst-region] instance 1 vlan 2 //Mapee  VLAN 2 a MSTI 1.
      [SwitchB-mst-region] instance 2 vlan 3 //Mapee  VLAN 3 a MSTI 2.
      [SwitchB-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchB-mst-region] quit

      # Configure una región MST en SwitchC.

      <Quidway> system-view
      [Quidway] sysname SwitchC
      [SwitchC] stp region-configuration //Introduzca la vista de la región.
      [SwitchC-mst-region] region-name RG1 //Configure el nombre de la región como RG1.
      [SwitchC-mst-region] instance 1 vlan 2 //Mapee  VLAN 2 a MSTI 1.
      [SwitchC-mst-region] instance 2 vlan 3 //Mapee  VLAN 3 a MSTI 2.
      [SwitchC-mst-region] active region-configuration //Active la configuración de la región MST.
      [SwitchC-mst-region] quit
    2. Configure el root bridge y el secondary root bridge de MSTI 1 y MSTI 2 en la región MST RG1.

      • Configure el root bridge y el secondary root bridge en MSTI 1.

        # Configure SwitchA como el root bridge en MSTI 1.

        [SwitchA] stp instance 1 root primary

        # Configure SwitchB como el secondary root bridge en MSTI 1.

        [SwitchB] stp instance 1 root secondary
      • Configure el root bridge y el secondary root bridge en MSTI 2.

        # Configure SwitchB como el root bridge en MSTI 2.

        [SwitchB] stp instance 2 root primary

        # Configure SwitchA como el secondary root bridge en MSTI 2.

        [SwitchA] stp instance 2 root secondary
    3. Ajuste que los costos de la ruta de los puertos a ser bloqueados en MSTI 1 y MSTI 2 sean mayores que los valores por defecto.

      NOTA:
      • El rango del costo de la ruta depende del algoritmo. El algoritmo patentado de Huawei se usa como ejemplo. Ajuste los costos de la ruta de los puertos a ser bloqueados en MSTI 1 y MSTI 2 a 20000.

      • Los dispositivos de conmutación en la misma red deben usar el mismo algoritmo para calcular el costo de la ruta de los puertos.

      # Configure SwitchA para usar el algoritmo patentado de Huawei para calcular el costo de la ruta.

      [SwitchA] stp pathcost-standard legacy

      # Configure SwitchB para usar el algoritmo patentado de Huawei para calcular el costo de la ruta.

      [SwitchB] stp pathcost-standard legacy

      # Configure SwitchC para usar el algoritmo patentado de Huawei para calcular el costo de la ruta, y ajuste el costo de la ruta de GE1/0/1 en MSTI 2 a 20000 y el costo de la ruta de GE1/0/4 en MSTI 1 a 20000.

      [SwitchC] stp pathcost-standard legacy
      [SwitchC] interface gigabitethernet 1/0/1
      [SwitchC-GigabitEthernet1/0/1] stp instance 2 cost 20000
      [SwitchC-GigabitEthernet1/0/1] quit
      [SwitchC] interface gigabitethernet 1/0/4
      [SwitchC-GigabitEthernet1/0/4] stp instance 1 cost 20000
      [SwitchC-GigabitEthernet1/0/4] quit
    4. Habilite MSTP para eliminar bucles.

      • Habilite MSTP globalmente en dispositivos.

        # Habilite MSTP en SwitchA.

        [SwitchA] stp enable

        # Habilite MSTP en SwitchB.

        [SwitchB] stp enable

        # Habilite MSTP en SwitchC.

        [SwitchC] stp enable
      • Configure los puertos conectados a los hosts como puertos de borde.

        [SwitchC] interface gigabitethernet 1/0/2
        [SwitchC-GigabitEthernet1/0/2] stp edged-port enable
        [SwitchC-GigabitEthernet1/0/2] quit
        [SwitchC] interface gigabitethernet 1/0/3
        [SwitchC-GigabitEthernet1/0/3] stp edged-port enable
        [SwitchC-GigabitEthernet1/0/3] quit

        (Opcional) Configure la protección BPDU en SwitchC.

        [SwitchC] stp bpdu-protection
      • Configure los puertos conectados al router como puertos de borde.

        # Configure el SwitchA.

        [SwitchA] interface gigabitethernet 1/0/3
        [SwitchA-GigabitEthernet1/0/3] stp edged-port enable
        [SwitchA-GigabitEthernet1/0/3] quit

        (Opcional) Configure la protección BPDU en SwitchA.

        [SwitchA] stp bpdu-protection

        # Configure el SwitchB.

        [SwitchB] interface gigabitethernet 1/0/3
        [SwitchB-GigabitEthernet1/0/3] stp edged-port enable
        [SwitchB-GigabitEthernet1/0/3] quit

        (Opcional) Configure la protección BPDU en SwitchB.

        [SwitchB] stp bpdu-protection
        NOTA:
        Si los puertos de borde están conectados a dispositivos de red que tienen STP habilitado y la protección BPDU está habilitada, los puertos de borde se apagarán y sus atributos permanecerán sin cambios después de recibir BPDU.

  2. Habilite las funciones de protección. Por ejemplo, habilite la protección de root en el puerto designado del root bridge en cada MSTI.

    # Habilite la protección de root en GE1/0/1 de SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] stp root-protection
    [SwitchA-GigabitEthernet1/0/1] quit

    # Habilite la protección de root en GE1/0/1 de SwitchB.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] stp root-protection
    [SwitchB-GigabitEthernet1/0/1] quit

  3. Configure el reenvío de Capa 2 en los switches de la red en anillo.

    • Cree VLAN 2 y VLAN 3 en SwitchA, SwitchB y SwitchC.

      # Cree VLAN 2 y VLAN 3 en SwitchA.

      [SwitchA] vlan batch 2 to 3

      # Cree VLAN 2 y VLAN 3 en SwitchB.

      [SwitchB] vlan batch 2 to 3

      # Cree VLAN 2 y VLAN 3 en SwitchC.

      [SwitchC] vlan batch 2 to 3
    • Agregue los puertos conectados al anillo a las VLAN.

      # Agregue GE1/0/1 en SwitchA a las VLAN.

      [SwitchA] interface gigabitethernet 1/0/1
      [SwitchA-GigabitEthernet1/0/1] port link-type trunk
      [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 3
      [SwitchA-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchA a las VLAN.

      [SwitchA] interface gigabitethernet 1/0/2
      [SwitchA-GigabitEthernet1/0/2] port link-type trunk
      [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 3
      [SwitchA-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/1 en SwitchB a las VLAN.

      [SwitchB] interface gigabitethernet 1/0/1
      [SwitchB-GigabitEthernet1/0/1] port link-type trunk
      [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 3
      [SwitchB-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchB a las VLAN.

      [SwitchB] interface gigabitethernet 1/0/2
      [SwitchB-GigabitEthernet1/0/2] port link-type trunk
      [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 2 to 3
      [SwitchB-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/1 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/1
      [SwitchC-GigabitEthernet1/0/1] port link-type trunk
      [SwitchC-GigabitEthernet1/0/1] port trunk allow-pass vlan 2 to 3
      [SwitchC-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] port link-type access
      [SwitchC-GigabitEthernet1/0/2] port default vlan 2
      [SwitchC-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/3
      [SwitchC-GigabitEthernet1/0/3] port link-type access
      [SwitchC-GigabitEthernet1/0/3] port default vlan 3
      [SwitchC-GigabitEthernet1/0/3] quit

      # Agregue GE1/0/4 en SwitchC a las VLAN.

      [SwitchC] interface gigabitethernet 1/0/4
      [SwitchC-GigabitEthernet1/0/4] port link-type trunk
      [SwitchC-GigabitEthernet1/0/4] port trunk allow-pass vlan 2 to 3
      [SwitchC-GigabitEthernet1/0/4] quit

  4. Verifique la configuración

    Una vez que sea completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración.

    NOTA:

    MSTI 1 y MSTI 2 se utilizan como ejemplos, por lo que no es necesario verificar el estado del puerto en MSTI 0.

    # Ejecute el comando display stp brief en SwitchA para ver el estado del puerto y el tipo de la protección. La información mostrada es la siguiente:

    [SwitchA] display stp brief
     MSTID      Port                        Role  STP State       Protection
       0        GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       0        GigabitEthernet1/0/2        DESI  FORWARDING      NONE
       1        GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       1        GigabitEthernet1/0/2        DESI  FORWARDING      NONE
       2        GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       2        GigabitEthernet1/0/2        ROOT  FORWARDING      NONE

    En MSTI 1, GE1/0/2 y GE1/0/1 en SwitchA son puertos designados porque SwitchA es el root bridge. En MSTI 2, GE1/0/1 en SwitchA es el puerto designado y GE1/0/2 es el root bridge.

    # Ejecute el comando display stp brief en SwitchB. La información mostrada es la siguiente:

    [SwitchB] display stp brief
     MSTID      Port                        Role  STP State       Protection
       0        GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       0        GigabitEthernet1/0/2        ROOT  FORWARDING      NONE
       1        GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       1        GigabitEthernet1/0/2        ROOT  FORWARDING      NONE
       2        GigabitEthernet1/0/1        DESI  FORWARDING      ROOT
       2        GigabitEthernet1/0/2        DESI  FORWARDING      NONE

    En MSTI 2, GE1/0/1 y GE1/0/2 en SwitchB son puertos designados porque SwitchB es el root bridge. En MSTI 1, GE1/0/1 en SwitchB es el puerto designado y GE1/0/2 es el root bridge.

    # Ejecute el comando display stp interface brief en SwitchC. La información mostrada es la siguiente:

    [SwitchC] display stp interface gigabitethernet 1/0/1 brief
     MSTID      Port                        Role  STP State       Protection
       0        GigabitEthernet1/0/1        ROOT  FORWARDING      NONE
       1        GigabitEthernet1/0/1        ROOT  FORWARDING      NONE
       2        GigabitEthernet1/0/1        ALTE  DISCARDING      NONE
    [SwitchC] display stp interface gigabitethernet 1/0/4 brief
     MSTID      Port                        Role  STP State       Protection
       0        GigabitEthernet1/0/4        ALTE  DISCARDING      NONE
       1        GigabitEthernet1/0/4        ALTE  DISCARDING      NONE
       2        GigabitEthernet1/0/4        ROOT  FORWARDING      NONE

    GE1/0/1 en SwitchC es el root bridge en MSTI 1 y es bloqueado en MSTI 2. GE1/0/4 en SwitchC es bloqueado en MSTI 1 y es el puerto designado en MSTI 2.

  5. Configure los dispositivos para garantizar la conectividad de la red.

    # Asigne una dirección IP a cada interfaz. SwitchA se usa como un ejemplo. La configuración de SwitchB es similar a la de SwitchA, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] vlan batch 4
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 4
    [SwitchA-GigabitEthernet1/0/3] quit
    [SwitchA] interface vlanif 2
    [SwitchA-Vlanif2] ip address 10.1.2.102 24
    [SwitchA-Vlanif2] quit
    [SwitchA] interface vlanif 3
    [SwitchA-Vlanif3] ip address 10.1.3.102 24
    [SwitchA-Vlanif3] quit
    [SwitchA] interface vlanif 4
    [SwitchA-Vlanif4] ip address 10.1.4.102 24
    [SwitchA-Vlanif4] quit

    # Configure OSPF entre SwitchA, SwitchB, y router. SwitchA se usa como un ejemplo. La configuración de SwitchB es similar a la de SwitchA, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  6. Configure los grupos de VRRP.

    # Configure el grupo 1 de VRRP en SwitchA y SwitchB, configure la prioridad de SwitchA a 120 y el retardo de preferencia a 20s y ajuste la prioridad por defecto para SwitchB.

    [SwitchA] interface vlanif 2 
    [SwitchA-Vlanif2] vrrp vrid 1 virtual-ip 10.1.2.100 //Cree el grupo 1 de VRRP y Establezca la dirección IP virtual a 10.1.2.100.
    [SwitchA-Vlanif2] vrrp vrid 1 priority 120 //Establezca la prioridad del grupo 1 de VRRP a 120.
    [SwitchA-Vlanif2] vrrp vrid 1 preempt-mode timer delay 20 //Establezca el retraso de prioridad del grupo 1 de VRRP a 20 segundos.
    [SwitchA-Vlanif2] quit
    [SwitchB] interface vlanif 2
    [SwitchB-Vlanif2] vrrp vrid 1 virtual-ip 10.1.2.100 //Cree el grupo 1 de VRRP y Establezca la dirección IP virtual a 10.1.2.100.
    [SwitchB-Vlanif2] quit

    # Configure el grupo 2 de VRRP en SwitchA y SwitchB, configure la prioridad de SwitchB a 120 y el retardo de preferencia a 20s, y configure la prioridad por defecto para SwitchA.

    [SwitchB] interface vlanif 3
    [SwitchB-Vlanif3] vrrp vrid 2 virtual-ip 10.1.3.100 //Cree el grupo 2 de VRRP y Establezca la dirección IP virtual a 10.1.3.100.
    [SwitchB-Vlanif3] vrrp vrid 2 priority 120 //Establezca la prioridad del grupo 2 de VRRP a 120.
    [SwitchB-Vlanif3] vrrp vrid 2 preempt-mode timer delay 20 //Establezca el retraso de prioridad del grupo 2 de VRRP a 20 segundos.
    [SwitchB-Vlanif3] quit
    [SwitchA] interface vlanif 3
    [SwitchA-Vlanif3] vrrp vrid 2 virtual-ip 10.1.3.100 //Cree el grupo 2 de VRRP y Establezca la dirección IP virtual a 10.1.3.100.
    [SwitchA-Vlanif3] quit
    

    # Configure la dirección IP virtual 10.1.2.100 del grupo 1 de VRRP como gateway por defecto de HostA, y la dirección IP virtual 10.1.3.100 del grupo 2 de VRRP como gateway por defecto de HostB.

  7. Verifique la configuración

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchA. La salida siguiente muestra que SwitchA es el Master en el grupo 1 de VRRP y el Backup en el grupo 2 de VRRP.

    [SwitchA] display vrrp
      Vlanif2 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.2.100
        Master IP : 10.1.2.102
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s                                           
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-05-11 11:39:18                                           
        Last change time : 2012-05-26 11:38:58
    
      Vlanif3 | Virtual Router 2
        State : Backup
        Virtual IP : 10.1.3.100
        Master IP : 10.1.3.103
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s                                            
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0102                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-05-11 11:40:18                                           
        Last change time : 2012-05-26 11:48:58
    

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchB. La salida siguiente muestra que SwitchB es el Backup en el grupo 1 de VRRP y el Master en el grupo 2 de VRRP.

    [SwitchB] display vrrp
      Vlanif2 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.2.100
        Master IP : 10.1.2.102
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s                                            
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-05-11 11:39:18                                           
        Last change time : 2012-05-26 11:38:58
    
      Vlanif3 | Virtual Router 2
        State : Master
        Virtual IP : 10.1.3.100
        Master IP : 10.1.3.103
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s                                            
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0102                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-05-11 11:40:18                                           
        Last change time : 2012-05-26 11:48:58 
    

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 2 to 4
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    stp bpdu-protection
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     active region-configuration  
    #
    interface Vlanif2
     ip address 10.1.2.102 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.2.100
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    interface Vlanif3
     ip address 10.1.3.102 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.3.100
    #
    interface Vlanif4
     ip address 10.1.4.102 255.255.255.0
     #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     stp root-protection
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 4
     stp edged-port enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 2 to 3 5
    #
    stp instance 1 root secondary
    stp instance 2 root primary
    stp bpdu-protection
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     active region-configuration  
    #
    interface Vlanif2
     ip address 10.1.2.103 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.2.100
    #
    interface Vlanif3
     ip address 10.1.3.103 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.3.100
     vrrp vrid 2 priority 120
     vrrp vrid 2 preempt-mode timer delay 20
    #
    interface Vlanif5
     ip address 10.1.5.103 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     stp root-protection
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 5
     stp edged-port enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
    #
    return
  • Archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 2 to 3
    #
    stp bpdu-protection
    stp pathcost-standard legacy
    stp enable 
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     active region-configuration  
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     stp instance 2 cost 20000
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 2
     stp edged-port enable
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 3
     stp edged-port enable
    #
    interface GigabitEthernet1/0/4
     port link-type trunk
     port trunk allow-pass vlan 2 to 3
     stp instance 1 cost 20000
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15572

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente