No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un solo anillo RRPP con una instancia única

Ejemplo para configurar un solo anillo RRPP con una instancia única

Descripción general

En la mayoría de las situaciones, la topología de red en anillo se aplica a las MAN y redes empresariales para mejorar la confiabilidad de la red. Cuando ocurre una falla en un nodo o en un enlace entre nodos, los servicios de datos se cambian al enlace standby para garantizar la continuidad del servicio. Sin embargo, las tormentas de difusión pueden ocurrir en una red en anillo.

Muchos protocolos pueden evitar tormentas de difusión en redes en anillo. Sin embargo, si ocurre una falla en una red en anillo, lleva tiempo que los dispositivos cambien los servicios de datos al enlace standby. Si el tiempo de convergencia es demasiado largo, los servicios se interrumpen.

Para acortar el tiempo de convergencia y eliminar el impacto de la escala de red en el tiempo de convergencia, Huawei desarrolló el Protocolo de protección rápida de anillo (RRPP). Comparada con otras tecnologías de anillo de Ethernet, RRPP tiene las siguientes ventajas:

  • RRPP es adecuado para redes compuestas por muchos nodos de red porque el número de nodos no afecta el tiempo de convergencia.

  • RRPP evita las tormentas de difusión causadas por los bucles de datos cuando se completa un anillo de Ethernet.

  • Cuando falla un enlace en una red de anillo de Ethernet, el enlace de reserva puede restablecer rápidamente la comunicación entre los nodos de red en anillo de Ethernet.

Notas de configuración

  • STP y Smart Link deben estar deshabilitados en la interfaz agregada a un dominio RRPP.
  • Las reglas de limitación de direcciones DHCP y MAC no se pueden configurar en una VLAN de control de RRPP.
  • Cuando se necesita configurar el mapeo entre la instancia protegida y la MUX VLAN, se recomienda configurar la VLAN principal, la VLAN de grupo subordinado y la VLAN separada subordinada en la MUX VLAN en la instancia protegida. De lo contrario, pueden producirse bucles.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-27, SwitchA, SwitchB, y SwitchC constituye una red en anillo. La red es necesaria para evitar bucles cuando el anillo está completo y para implementar una convergencia rápida para restaurar rápidamente la comunicación entre los nodos en el anillo cuando falla el anillo. Usted puede habilitar RRPP en SwitchA, SwitchB, y SwitchC para cumplir este requisito.

Figura 6-27  Redes de un solo anillo RRPP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree un dominio RRPP y su VLAN de control.

  2. Mapee las VLAN a partir de las cuales los datos deben pasar en el anillo RRPP a la instancia 1, incluidas las VLAN de datos 100 a 300 y las VLAN de control 20 y 21 (VLAN 21 es la VLAN de subcontrol generada por el dispositivo).

  3. Configure las interfaces que se agregarán al dominio RRPP en los dispositivos para que los datos puedan pasar a través de las interfaces. Deshabilite los protocolos que tengan conflicto con RRPP, como STP.

  4. En el dominio RRPP, configure una VLAN protegida, cree un anillo RRPP y configure SwitchA, SwitchB, y SwitchC como nodos en el anillo 1 en el dominio 1. Configure SwitchA como el nodo principal en el anillo 1 y configure SwitchB y SwitchC como nodos de tránsito en el anillo 1.

  5. Habilite el anillo RRPP y el RRPP en los dispositivos.

Procedimiento

  1. Cree un dominio RRPP y su VLAN de control.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] control-vlan 20    //Cada dominio RRPP tiene una VLAN de control principal y una VLAN de subcontrol. Solo debe especificar la VLAN principal de control. El sistema usa la VLAN cuyo ID es mayor que el ID de la VLAN principal de control como la VLAN de subcontrol.
    [SwitchA-rrpp-domain-region1] quit

  2. Instancia de mapeo 1 para controlar la VLAN 20 y la 21 y las VLAN de datos de 100 a 300.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] vlan batch 100 to 300
    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 1 vlan 20 21 100 to 300  //Agregue la VLAN principal de control, la VLAN de subcontrol y las VLAN de datos a la instancia 1.
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit

  3. Configure las interfaces que se agregarán al anillo RRPP como interfaces trunk, configure las interfaces para permitir que las VLAN 100 a 300 pasen, y deshabilite STP en las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type trunk
    [SwitchA-GigabitEthernet2/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/1] port trunk allow-pass vlan 100 to 300  
    [SwitchA-GigabitEthernet2/0/1] stp disable
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type trunk
    [SwitchA-GigabitEthernet2/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/2] port trunk allow-pass vlan 100 to 300 
    [SwitchA-GigabitEthernet2/0/2] stp disable
    [SwitchA-GigabitEthernet2/0/2] quit

  4. Especifique una VLAN protegida, y cree y habilite un anillo RRPP.

    # Configure SwitchA.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] protected-vlan reference-instance 1  //Configure la instancia 1 como la instancia protegida del dominio RRPP.
    [SwitchA-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchA-rrpp-domain-region1] ring 1 enable
    [SwitchA-rrpp-domain-region1] quit

    # Configure SwitchB.

    [SwitchB] rrpp domain 1
    [SwitchB-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchB-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchB-rrpp-domain-region1] ring 1 enable
    [SwitchB-rrpp-domain-region1] quit

    # Configure SwitchC.

    [SwitchC] rrpp domain 1
    [SwitchC-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
    [SwitchC-rrpp-domain-region1] ring 1 enable
    [SwitchC-rrpp-domain-region1] quit

  5. Habilite RRPP.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] rrpp enable

  6. Verifique la configuración

    Una vez completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración. La visualización en SwitchA se usa como ejemplo.

    # Ejecute el comando display rrpp brief en SwitchA. La siguiente información es la mostrada:

    [SwitchA] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status:  Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 1
    
    Domain Index  : 1
    Control VLAN  : major 20    sub 21
    Protected VLAN : Reference Instance 1
    Hello Timer   : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
    
     Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
     ID     Level   Mode     Port                     Port                    Enabled
     ----------------------------------------------------------------------------
     1      0       M        GigabitEthernet2/0/1     GigabitEthernet2/0/2    Yes

    De acuerdo con la información anterior, RRPP está habilitado en SwitchA. La VLAN principal de control del dominio 1 de RRPP es la VLAN 20 y la VLAN del subcontrol es la VLAN 21. SwitchA es el nodo principal en el anillo 1. La interfaz primaria es GigabitEthernet2/0/1 y la interfaz secundaria es GigabitEthernet2/0/2.

    # Ejecute el comando display rrpp verbose domain en SwitchA. La siguiente información es la mostrada:

    [SwitchA] display rrpp verbose domain 1
    Domain Index   : 1
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Master
    Ring State     : Complete
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet2/0/1         Port status: UP
    Secondary port : GigabitEthernet2/0/2         Port status: BLOCKED

    La salida del comando muestra que el anillo RRPP está completo.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    return
    
  • Archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    return
  • Archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 20 to 21 100 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21 100 to 300 
     stp disable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15431

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente