No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar anillos RRPP tangentes

Ejemplo para configurar anillos RRPP tangentes

Descripción general

En general, una red de Ethernet metropolitana utiliza anillos de dos capas:

  • Una capa es la capa de agregación entre los dispositivos de agregación PE-AGG, por ejemplo, el domain 1 de RRPP en Figura 6-28.

  • La otra capa es la capa de acceso entre PE-AGG y UPE, por ejemplo, el domain 2 de RRPP y el domain 3 de RRPP en Figura 6-28.

En Figura 6-28, se pueden usar anillos de intersección RRPP. Los anillos RRPP se configuran en capas de agregación y acceso, y las dos capas se conectan a través de anillos RRPP tangentes.

Figura 6-28  Tangent RRPP rings

Dos anillos tangentes no pueden pertenecer al mismo dominio de RRPP. El punto tangente de los dos anillos tangentes pertenece a dos dominios de RRPP, y el nodo principal se puede ubicar en el punto tangente.

Cuando hay múltiples anillos tangentes de RRPP, una falla en un anillo no afecta otros dominios y el proceso de convergencia de los anillos de RRPP en un dominio es el mismo que el de un solo anillo.

Notas de configuración

  • STP y Smart Link deben estar deshabilitados en la interfaz agregada a un dominio RRPP.
  • Las reglas de limitación de direcciones DHCP y MAC no se pueden configurar en una VLAN de control de RRPP.
  • Cuando se necesita configurar el mapeo entre la instancia protegida y la MUX VLAN, se recomienda configurar la VLAN principal, la VLAN de grupo subordinado y la VLAN separada subordinada en la MUX VLAN en la instancia protegida. De lo contrario, pueden producirse bucles.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En Figura 6-28, la red es necesaria para evitar bucles cuando el anillo está completo y para implementar una convergencia rápida para restaurar rápidamente la comunicación entre los nodos en el anillo cuando falla el anillo. RRPP puede cumplir este requisito. RRPP admite múltiples anillos. Puede configurar anillos de RRPP en las capas de agregación y acceso. Los dos anillos son tangentes, lo que simplifica la configuración de la red.

SwitchA, SwitchB, SwitchC, SwitchD, y SwitchE en Figura 6-29 corresponde a UPE1, UPE2, PE-AGG3, PE-AGG2 y PE-AGG1 en Figura 6-28, respectivamente. Figura 6-29 se usa como ejemplo para describir cómo configurar anillos RRPP tangentes con una sola instancia.

Figura 6-29  Tangent RRPP rings

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Cree dominios de RRPP y controle las VLAN para configurar anillos RRPP.

  2. Mapee las VLAN que deben pasar por el ring 1 a la instancia 1, incluidas las VLAN de datos y las VLAN de control, que se utilizan para configurar VLAN protegidas.

    Mapee las VLAN que deben pasar por el ring 2 a la instancia 2, incluidas las VLAN de datos y las VLAN de control, que se utilizan para configurar VLAN protegidas.

  3. Configure las interfaces que se agregarán al dominio de RRPP en los dispositivos para que los datos puedan pasar a través de las interfaces. Deshabilite los protocolos que tengan conflicto con RRPP, como STP.

  4. Configure VLAN protegidas y cree anillos RRPP en dominios de RRPP.
    1. Configure SwitchA, SwitchB, y SwitchC para que estén en el ring 2 del domain 2 de RRPP.

    2. Configure SwitchC, SwitchD, y SwitchE para que estén en el ring 1 del domain 1 de RRPP.

    3. Configure SwitchA como el nodo principal en el ring 2, y configure SwitchB y SwitchC como nodos de tránsito en el ring 2.

    4. Configure SwitchE como el nodo principal en el ring 1, y configure SwitchC y SwitchD como nodos de tránsito en el ring 1.

  5. Habilite el anillo RRPP y el RRPP en los dispositivos.

Procedimiento

  1. Cree dominios de RRPP y configure las VLAN de control y las VLAN protegidas de los dominios de RRPP.

    # Configure SwitchE. Las configuraciones de SwitchA, SwitchB, SwitchC, y SwitchD son similares a la configuración de SwitchE, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    <Quidway> system-view
    [Quidway] sysname SwitchE
    [SwitchE] rrpp domain 1
    [SwitchE-rrpp-domain-region1] control-vlan 10  //Cada dominio RRPP tiene una VLAN de control principal y una VLAN de subcontrol. Solo debe especificar la VLAN principal de control. El sistema usa la VLAN cuyo ID es mayor que el ID de la VLAN principal de control como la VLAN de subcontrol.
    [SwitchE-rrpp-domain-region1] protected-vlan reference-instance 1   //Configure la instancia 1 como la instancia protegida del dominio RRPP.
    [SwitchE-rrpp-domain-region1] quit

  2. Configure la instancia 2 y mapéela a las VLAN de datos y controle las VLAN permitidas por la interfaz de RRPP.

    # Configure SwitchA. Las configuraciones de SwitchB, SwitchC, SwitchD, y SwitchE son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] vlan batch 201 to 300
    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 2 vlan 20 21 201 to 300  ///Agregue la VLAN principal de control y la VLAN de subcontrol a la instancia 2.
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit

  3. Configure las interfaces que se agregarán a los anillos RRPP como interfaces trunk y deshabilite STP en las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB, SwitchC, SwitchD, y SwitchE son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] interface gigabitethernet 2/0/1
    [SwitchA-GigabitEthernet2/0/1] port link-type trunk
    [SwitchA-GigabitEthernet2/0/1] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/1] stp disable
    [SwitchA-GigabitEthernet2/0/1] quit
    [SwitchA] interface gigabitethernet 2/0/2
    [SwitchA-GigabitEthernet2/0/2] port link-type trunk
    [SwitchA-GigabitEthernet2/0/2] undo port trunk allow-pass vlan 1
    [SwitchA-GigabitEthernet2/0/2] stp disable
    [SwitchA-GigabitEthernet2/0/2] quit

  4. Cree y habilite el anillo RRPP.

    • Configure nodos en el ring 2.

      # Configure SwitchA como el nodo principal en el ring 2 y especifique la interfaz primaria y la secundaria.

      [SwitchA] rrpp domain 2
      [SwitchA-rrpp-domain-region2] ring 2 node-mode master primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
      [SwitchA-rrpp-domain-region2] ring 2 enable
      [SwitchA-rrpp-domain-region2] quit

      # Configure SwitchB como un nodo de tránsito en el ring 2 (anillo principal) y especifique la interfaz primaria y la secundaria.

      [SwitchB] rrpp domain 2
      [SwitchB-rrpp-domain-region2] ring 2 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
      [SwitchB-rrpp-domain-region2] ring 2 enable
      [SwitchB-rrpp-domain-region2] quit

      # Configure SwitchC como un nodo de tránsito en el ring 2 y especifique la interfaz primaria y la secundaria.

      [SwitchC] rrpp domain 2
      [SwitchC-rrpp-domain-region2] ring 2 node-mode transit primary-port gigabitethernet 2/0/1 secondary-port gigabitethernet 2/0/2 level 0
      [SwitchC-rrpp-domain-region2] ring 2 enable
      [SwitchC-rrpp-domain-region2] quit
    • Configure nodos en el ring 1.

      # Configure SwitchE como el nodo principal en el ring 1 (anillo principal) y especifique la interfaz primaria y la secundaria.

      [SwitchE] rrpp domain 1
      [SwitchE-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
      [SwitchE-rrpp-domain-region1] ring 1 enable
      [SwitchE-rrpp-domain-region1] quit

      # Configure SwitchC como un nodo de tránsito en el ring 1 y especifique la interfaz primaria y la secundaria.

      [SwitchC] rrpp domain 1
      [SwitchC-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
      [SwitchC-rrpp-domain-region1] ring 1 enable
      [SwitchC-rrpp-domain-region1] quit

      # Configure SwitchD como un nodo de tránsito en el ring 1 y especifique la interfaz primaria y la secundaria.

      [SwitchD] rrpp domain 1
      [SwitchD-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
      [SwitchD-rrpp-domain-region1] ring 1 enable
      [SwitchD-rrpp-domain-region1] quit

  5. Habilite RRPP.

    # Configure SwitchA. Las configuraciones de SwitchB, SwitchC, SwitchD, y SwitchE son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] rrpp enable

  6. Verifique la configuración

    Una vez completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración. El punto tangente SwitchC se usa como ejemplo.

    # Ejecute el comando display rrpp brief en SwitchC. La siguiente información es la mostrada:

    [SwitchC] display rrpp brief
    Abbreviations for Switch Node Mode :
    M - Master , T - Transit , E - Edge , A - Assistant-Edge
    
    RRPP Protocol Status:  Enable
    RRPP Working Mode: HW
    RRPP Linkup Delay Timer: 0 sec (0 sec default)
    Number of RRPP Domains: 2
    
    Domain Index   : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
     Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
     ID     Level   Mode     Port                     Port                    Enabled
     ----------------------------------------------------------------------------
     1      0       T        GigabitEthernet1/0/1     GigabitEthernet1/0/2    Yes
    
    Domain Index   : 2
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 2
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
     Ring   Ring    Node     Primary/Common           Secondary/Edge          Is
     ID     Level   Mode     Port                     Port                    Enabled
     ----------------------------------------------------------------------------
     2      0       T        GigabitEthernet2/0/1     GigabitEthernet2/0/2    Yes
    

    De acuerdo con la información anterior, RRPP está habilitado en SwitchC. La VLAN principal de control del domain 1 de RRPP es la VLAN 10 y la VLAN de subcontrol es la VLAN 11. SwitchC es el nodo principal en el ring 1. La interfaz primaria es GigabitEthernet1/0/1 y la interfaz secundaria es GigabitEthernet1/0/2.

    La VLAN principal de control de SwitchC en el domain 2 de RRPP es la VLAN 20 y la VLAN de subcontrol es la VLAN 21. SwitchC es el nodo de tránsito en el ring 2. La interfaz primaria es GigabitEthernet2/0/1 y la interfaz secundaria es GigabitEthernet2/0/2.

    En SwitchC, ejecute el comando display rrpp verbose domain. La siguiente información es la mostrada.

    # Verifique la información detallada sobre el domain 1 de RRPP en SwitchC.

    [SwitchC] display rrpp verbose domain 1
    Domain Index  : 1
    Control VLAN   : major 10    sub 11
    Protected VLAN : Reference Instance 1 
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 1
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet1/0/1         Port status: UP
    Secondary port : GigabitEthernet1/0/2         Port status: UP

    # Verifique la información detallada sobre el domain 2 de RRPP en SwitchC.

    [SwitchC] display rrpp verbose domain 2
    Domain Index   : 2
    Control VLAN   : major 20    sub 21
    Protected VLAN : Reference Instance 2 
    Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
    
    RRPP Ring      : 2
    Ring Level     : 0
    Node Mode      : Transit
    Ring State     : LinkUp
    Is Enabled     : Enable                       Is Active: Yes
    Primary port   : GigabitEthernet2/0/1         Port status: UP
    Secondary port : GigabitEthernet2/0/2         Port status: UP

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 20 to 21 201 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 2 vlan 20 to 21 201 to 300
     active region-configuration
    #
    rrpp domain 2
     control-vlan 20
     protected-vlan reference-instance 2
     ring 2 node-mode master primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 2 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 to 21 201 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 2 vlan 20 to 21 201 to 300
     active region-configuration
    #
    rrpp domain 2
     control-vlan 20
     protected-vlan reference-instance 2
     ring 2 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 2 enable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    return
  • Archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 10 to 11 20 to 21 100 to 300
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 to 11 100 to 200
     instance 2 vlan 20 to 21 201 to 300
     active region-configuration
    #
    rrpp domain 1
     control-vlan 10
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    rrpp domain 2
     control-vlan 20
     protected-vlan reference-instance 2
     ring 2 node-mode transit primary-port GigabitEthernet2/0/1 secondary-port GigabitEthernet2/0/2 level 0
     ring 2 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    interface GigabitEthernet2/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 to 21
     stp disable
    #
    return
  • Archivo de configuración de SwitchD

    #
    sysname SwitchD
    #
    vlan batch 10 to 11 100 to 200
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 to 11 100 to 200
     active region-configuration
    #
    rrpp domain 1
     control-vlan 10
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    return
  • Archivo de configuración de SwitchE

    #
    sysname SwitchE
    #
    vlan batch 10 to 11 100 to 200
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 to 11 100 to 200
     active region-configuration
    #
    rrpp domain 1
     control-vlan 10
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 to 11
     stp disable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15661

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente