No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar RRPP Snooping en una red VPLS

Ejemplo para configurar RRPP Snooping en una red VPLS

Descripción general

RRPP snooping notifica una red VPLS de cambios en un anillo RRPP. Después de que RRPP snooping está habilitado en sub-interfaces o interfaces de VLANIF, la red VPLS puede transmitir transparentemente paquetes de RRPP, detectar cambios en el anillo RRPP y actualizar entradas de reenvío. Esto asegura que el tráfico se puede cambiar rápidamente a una ruta sin bloqueo.

En Figura 6-30, UPE constituyen un anillo RRPP y se conectan a la red VPLS donde se ubican los NPE. Los NPE están conectados a través de un PW, por lo que no pueden servir como nodos de RRPP para responder a los paquetes de RRPP. Como resultado, la red VPLS no puede detectar cambios en el estado del anillo RRPP. Cuando la topología de anillo RRPP cambia, cada nodo de la red VPLS reenvía datos de enlace descendente según la tabla de direcciones MAC generada antes de que cambie la topología de anillo RRPP. En consecuencia, el tráfico de enlace descendente no se puede reenviar

Figura 6-30  Redes para configurar RRPP snooping en una red VPLS

Usted puede habilitar RRPP snooping en la interfaz secundaria o la interfaz de VLANIF de NPED y asociar la interfaz con las VSI en el dispositivo local. Cuando el anillo RRPP está defectuoso, NPED en la red VPLS elimina las entradas de reenvío de las VSI (incluidas las VSI asociadas) en el nodo local y las entradas de reenvío de NPEB para volver a aprender las entradas de reenvío. Esto asegura que el tráfico se puede cambiar a una ruta normal y el tráfico de enlace descendente se puede reenviar correctamente.

Notas de configuración

  • RRPP y RRPP snooping no se pueden configurar en la misma interfaz.
  • Las tarjetas de la serie SA y las interfaces XGE conectadas a las tarjetas LE1D2FW00S01 no son compatibles con RRPP snooping. En versiones anteriores de V200R007C00, las tarjetas de la serie X1E no son compatibles con RRPP snooping.
  • A continuación se describen los modelos de productos y versiones aplicables.
    Tabla 6-12  Modelos de productos y versiones aplicables

    Producto

    Modelo del producto

    Versión del software

    S5300

    S5300HI

    V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R009C00, V200R010C00, V200R011C10, V200R012C10

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R005(C00&C01)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9300E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En Figura 6-31, SwitchA, SwitchB, SwitchC, y SwitchD constituye un anillo RRPP. La red es necesaria para evitar bucles cuando el anillo está completo y para implementar una convergencia rápida para restaurar rápidamente la comunicación entre los nodos en el anillo cuando falla el anillo. La red VPLS puede transmitir transparentemente paquetes de RRPP, detectar cambios de estado del anillo RRPP y actualizar entradas de reenvío para que el tráfico pueda cambiarse rápidamente a una ruta normal de acuerdo con el estado del anillo.

Figura 6-31  Redes de RRPP snooping

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure una red VPLS.

  2. Configure un anillo RRPP para evitar bucles e implementar convergencia rápida cuando falla un dispositivo.

  3. Habilite RRPP snooping para que la red VPLS pueda transmitir de forma transparente los paquetes de RRPP y detectar el cambio de estado del anillo RRPP.

  4. Asocie interfaces con las VSI para que SwitchC y SwitchD en la red VPLS puedan eliminar las tablas de direcciones MAC de sus VSI cuando se produzca un error en la red en anillo RRPP.

Procedimiento

  1. Configure VPLS. SwitchC se usa como ejemplo. La configuración de SwitchD es similar a la configuración de SwitchC, y no se menciona aquí. Para más detalles, vea los archivos de configuración.

    NOTA:

    Este ejemplo proporciona solo configuraciones de sub-interfaces en SwitchC y SwitchD conectadas al anillo RRPP. Las configuraciones de dispositivos en la red VPLS no se mencionan.

    # Configure GE2/0/0.10 en SwitchC para permitir que los paquetes de la VLAN 10 pasen y enlace GE2/0/0.10 a VSI 10.

    <Quidway> system-view
    [Quidway] sysname SwitchC
    [SwitchC] interface gigabitethernet 2/0/0
    [SwitchC-GigabitEthernet2/0/0] undo portswitch
    [SwitchC-GigabitEthernet2/0/0] quit
    [SwitchC] interface gigabitethernet 2/0/0.10
    [SwitchC-GigabitEthernet2/0/0.10] dot1q termination vid 10
    [SwitchC-GigabitEthernet2/0/0.10] l2 binding vsi VSI10  //Enlace la VSI a la subinterfaz.
    [SwitchC-GigabitEthernet2/0/0.10] quit

    # Configure GE2/0/0.20 en SwitchC para permitir que los paquetes de VLAN 20 (VLAN de control del RRPP) pasen y vincule GE2/0/0.20 a VSI 20.

    [SwitchC] interface gigabitethernet 2/0/0.20
    [SwitchC-GigabitEthernet2/0/0.20] dot1q termination vid 20
    [SwitchC-GigabitEthernet2/0/0.20] l2 binding vsi VSI20
    [SwitchC-GigabitEthernet2/0/0.20] quit

  2. Cree un dominio de RRPP y su VLAN de control.

    # Cree VLAN 10 en SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10
    [SwitchA] stp region-configuration
    [SwitchA-mst-region] instance 1 vlan 10 20 21  //Agregue la VLAN principal de control, la VLAN de subcontrol y las VLAN de datos a la instancia 1.
    [SwitchA-mst-region] active region-configuration
    [SwitchA-mst-region] quit

    # Configure SwitchA (nodo principal en el ring 1) en el domain 1 de RRPP y VLAN 20 como la VLAN de control.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] protected-vlan reference-instance 1  //Configure la instancia 1 como la instancia protegida del dominio RRPP.
    [SwitchA-rrpp-domain-region1] control-vlan 20                      //Cada dominio RRPP tiene una VLAN de control principal y una VLAN de subcontrol. Solo debe especificar la VLAN principal de control. El sistema usa la VLAN cuyo ID es mayor que el ID de la VLAN principal de control como la VLAN de subcontrol.
    [SwitchA-rrpp-domain-region1] quit

    # Cree VLAN 10 en SwitchB.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan batch 10
    [SwitchB] stp region-configuration
    [SwitchB-mst-region] instance 1 vlan 10 20 21
    [SwitchB-mst-region] active region-configuration
    [SwitchB-mst-region] quit

    # Configure SwitchB (nodo de tránsito en el ring 1) en el domain 1 de RRPP y VLAN 20 como la VLAN de control.

    [SwitchB] rrpp domain 1
    [SwitchB-rrpp-domain-region1] protected-vlan reference-instance 1
    [SwitchB-rrpp-domain-region1] control-vlan 20
    [SwitchB-rrpp-domain-region1] quit

  3. Deshabilite STP en las interfaces que se agregarán al anillo RRPP.

    # Deshabilite STP en las interfaces que se agregarán al anillo RRPP en SwitchA.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] stp disable
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] stp disable
    [SwitchA-GigabitEthernet1/0/2] quit

    # Deshabilite STP en las interfaces que se agregarán al anillo RRPP en SwitchB.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port link-type trunk
    [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/1] stp disable
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface gigabitethernet 1/0/2
    [SwitchB-GigabitEthernet1/0/2] port link-type trunk
    [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchB-GigabitEthernet1/0/2] stp disable
    [SwitchB-GigabitEthernet1/0/2] quit

  4. Cree un anillo RRPP.

    # Configure SwitchA como el nodo principal en el ring 1 y especifique la interfaz primaria y la secundaria.

    [SwitchA] rrpp domain 1
    [SwitchA-rrpp-domain-region1] ring 1 node-mode master primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
    [SwitchA-rrpp-domain-region1] ring 1 enable
    [SwitchA-rrpp-domain-region1] quit

    # Configure SwitchB como un nodo de tránsito en el ring 1 (anillo principal) y especifique la interfaz primaria y la secundaria.

    [SwitchB] rrpp domain 1
    [SwitchB-rrpp-domain-region1] ring 1 node-mode transit primary-port gigabitethernet 1/0/1 secondary-port gigabitethernet 1/0/2 level 0
    [SwitchB-rrpp-domain-region1] ring 1 enable
    [SwitchB-rrpp-domain-region1] quit

  5. Habilite RRPP.

    # Habilite RRPP en SwitchA.

    [SwitchA] rrpp enable

    # Habilite RRPP en SwitchB.

    [SwitchB] rrpp enable

  6. Configure RRPP snooping.

    # Habilite RRPP snooping en GE2/0/0.20 de SwitchC.

    [SwitchC] interface gigabitethernet 2/0/0.20
    [SwitchC-GigabitEthernet2/0/0.20] rrpp snooping enable

    # Habilite RRPP snooping en GE2/0/0.20 de SwitchD.

    [SwitchD] interface gigabitethernet 2/0/0.20
    [SwitchD-GigabitEthernet2/0/0.20] rrpp snooping enable

  7. Configure la asociación entre interfaces y VSI.

    # Asocie VSI 10 con GE2/0/0.20 en SwitchC.

    [SwitchC-GigabitEthernet2/0/0.20] rrpp snooping vsi VSI10
    [SwitchC-GigabitEthernet2/0/0.20] quit

    # Asocie VSI 10 con GE2/0/0.20 en SwitchD.

    [SwitchD-GigabitEthernet2/0/0.20] rrpp snooping vsi VSI10
    [SwitchD-GigabitEthernet2/0/0.20] quit

  8. Verifique la configuración

    Una vez completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración. SwitchA se usa como ejemplo.

    • Ejecute el comando display rrpp brief en SwitchA. La siguiente información es la mostrada:

      [SwitchA] display rrpp brief
      Abbreviations for Switch Node Mode :
      M - Master , T - Transit , E - Edge , A - Assistant-Edge
      
      RRPP Protocol Status: Enable
      RRPP Working Mode: HW
      RRPP Linkup Delay Timer: 0 sec (0 sec default)
      Number of RRPP Domains: 1
      
      Domain Index   : 1
      Control VLAN   : major 20    sub 21
      Protected VLAN : Reference Instance 1
      Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec)
      
       Ring   Ring    Node     Primary/Common        Secondary/Edge        Is
       ID     Level   Mode     Port                  Port                  Enabled
       ----------------------------------------------------------------------------
       1      0       M        GigabitEthernet1/0/1  GigabitEthernet1/0/2  Yes

      De acuerdo con la información anterior, RRPP está habilitado en SwitchA. La VLAN principal de control del domain 1 de RRPP es la VLAN 20 y la VLAN de subcontrol es la VLAN 21. SwitchA es el nodo principal en el ring 1. La interfaz primaria es GE1/0/1 y la interfaz secundaria es GE1/0/2.

    • Ejecute el comando display rrpp verbose domain en SwitchA. La siguiente información es la mostrada.

      # Verifique la información detallada sobre el domain 1 de RRPP en SwitchA.

      [SwitchA] display rrpp verbose domain 1
      Domain Index   : 1
      Control VLAN   : major 20    sub 21
      Protected VLAN : Reference Instance 1
      Hello Timer    : 1 sec(default is 1 sec)  Fail Timer : 6 sec(default is 6 sec) 
      
      RRPP Ring      : 1
      Ring Level     : 0
      Node Mode      : Master
      Ring State     : Complete
      Is Enabled     : Enable                       Is Active : Yes
      Primary port   : GigabitEthernet1/0/1         Port status: UP
      Secondary port : GigabitEthernet1/0/2         Port status: BLOCKED

      # Verifique la configuración de RRPP snooping en GE2/0/0.20 de SwitchC.

      [SwitchC] display rrpp snooping enable interface gigabitethernet 2/0/0.20
        Port                            VsiName           Vlan  
      --------------------------------------------------------------------------- 
        GigabitEthernet2/0/0.20         VSI20             20

      La información anterior muestra que VSI 20 y VLAN 20 están asociadas con GE2/0/0.20.

      # Verifique la información sobre otras VSI asociadas con GE2/0/0.20 en SwitchC.

      [SwitchC] display rrpp snooping vsi interface gigabitethernet 2/0/0.20
        Port                               VsiName
      --------------------------------------------------------------------- 
        GigabitEthernet2/0/0.20            VSI10
        GigabitEthernet2/0/0.20            VSI20

      La información anterior muestra que GE2/0/0.20 está asociada con VSI 10 y VSI 20.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 to 21
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 20 to 21
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode master primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 to 21
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 20 to 21
     stp disable
    #
    return
    
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20 to 21
    #
    rrpp enable
    #
    stp region-configuration
     instance 1 vlan 10 20 to 21
     active region-configuration
    #
    rrpp domain 1
     control-vlan 20
     protected-vlan reference-instance 1
     ring 1 node-mode transit primary-port GigabitEthernet1/0/1 secondary-port GigabitEthernet1/0/2 level 0
     ring 1 enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10 20 to 21
     stp disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10 20 to 21
     stp disable
    #
    return
  • Archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    interface GigabitEthernet2/0/0
     undo portswitch
    #
    interface GigabitEthernet2/0/0.10
     dot1q termination vid 10
     l2 binding vsi VSI10
    #
    interface GigabitEthernet2/0/0.20
     dot1q termination vid 20
     l2 binding vsi VSI20
     rrpp snooping enable
     rrpp snooping vsi VSI10
    #
    return
  • Archivo de configuración de SwitchD

    #
    sysname SwitchD
    #
    interface GigabitEthernet2/0/0
     undo portswitch
    #
    interface GigabitEthernet2/0/0.10
     dot1q termination vid 10
     l2 binding vsi VSI10
    #
    interface GigabitEthernet2/0/0.20
     dot1q termination vid 20
     l2 binding vsi VSI20
     rrpp snooping enable
     rrpp snooping vsi VSI10
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15608

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente