No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar SEP y MSTP en una red

Ejemplo para configurar SEP y MSTP en una red

Descripción general

Generalmente, los enlaces redundantes se usan para proporcionar la copia de seguridad del enlace y mejorar la confiabilidad de la red. El uso de enlaces redundantes, sin embargo, puede producir bucles. Los bucles provocan un bucle infinito de paquetes, lo que genera tormentas de difusión e inestabilidad de la tabla de direcciones MAC. Como resultado, la calidad de la comunicación se deteriora y los servicios de comunicación pueden interrumpirse. Para bloquear enlaces redundantes y garantizar que se puedan restaurar inmediatamente para reanudar la comunicación cuando se produzca un error de enlace en una red en anillo, puede implementar SEP y MSTP en la red en anillo.

Notas de configuración

Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

La empresa A necesita desplegar múltiples dispositivos de acceso de Capa 2. En Figura 6-32, los dispositivos de conmutación de Capa 2 forman un anillo en la capa de acceso, y los dispositivos de Capa 3 forman un anillo en la capa de agregación. La capa de agregación usa MSTP para eliminar enlaces redundantes. La empresa A requiere que los servicios se cambien rápidamente para evitar la interrupción del tráfico cuando falla un enlace en la capa de acceso.

Puede implementar múltiples dispositivos de Capa 2 en un anillo y configurar SEP para cumplir los siguientes requisitos de la empresa A:

  • Cuando haya un enlace no defectuoso en la red de anillo, SEP puede eliminar bucles.

  • Cuando un enlace falla en la red en anillo, SEP puede restablecer rápidamente la comunicación entre los nodos en el anillo.

  • La función de notificación de cambio de topología se configura en un dispositivo periférico en un segmento SEP para que los dispositivos en la red de capa superior puedan detectar rápidamente los cambios de topología en la red de capa inferior. Después de recibir una notificación de cambio de topología de una red de capa inferior, un dispositivo en una red de capa superior envía un paquete de TC para notificar a otros dispositivos que eliminen las direcciones MAC originales y aprendan nuevas direcciones MAC. Esto asegura el reenvío continuo del tráfico.

Figura 6-32  Redes de SEP y MSTP

NOTA:

En este ejemplo, NPE1 y NPE2 usan NE40E ejecutando V600R008C00.

Para garantizar la fiabilidad de toda la red, se recomiendan configurar las siguientes funciones:
  • Grupo VRRP entre NPE1 y NPE2 para mejorar la confiabilidad del dispositivo

  • Sesión BFD entre NPE1 y NPE2 para detectar el estado del enlace y, por lo tanto, implementar una conmutación rápida en el grupo VRRP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure las funciones básicas de SEP.

    1. Configure el segmento 1 de SEP en LSW1 a LSW3 y configure la VLAN 10 como VLAN de control del segmento 1 de SEP.

    2. Agregue LSW1 a LSW3 al segmento 1 de SEP y configure los roles de interfaz en los dispositivos de borde (LSW1 y LSW2) del segmento SEP.

      NOTA:

      PE1 y PE2 no son compatibles con el protocolo SEP; por lo tanto, las interfaces de LSW1 y LSW2 conectadas a los PE deben ser interfaces de borde no vecinas.

    3. En el dispositivo donde se ubica la interfaz de borde primario no-vecina, especifique la interfaz en el medio del segmento SEP como la interfaz para bloquear.

    4. Configure prioridad manual.

    5. Configure la función de notificación de cambio de topología para que la red de capa superior que ejecuta MSTP pueda ser notificada de los cambios de topología en el segmento SEP.

  2. Configure las funciones básicas de MSTP.

    1. Agregue PE1 a PE4, LSW1 y LSW2 a la región MST RG1.

    2. Cree las VLAN en PE1 a PE4, LSW1 y LSW2 y agregue interfaces en el anillo STP a las VLAN.

    3. Configure PE3 como root bridge y PE4 como secondary root bridge.

  3. Configure una sesión BFD de un solo salto entre NPE1 y NPE2 para detectar el estado de las interfaces configuradas con VRRP. Luego, informe el resultado de la detección a VRRP para completar la conmutación rápida de VRRP.

  4. Configure VRRP.

    1. Cree el grupo 1 de VRRP en GE 1/0/1 de NPE1, y ajuste una prioridad de VRRP más alta para NPE1 para garantizar que NPE1 funcione como Master.

    2. Cree el grupo 1 de VRRP en la vista de la interfaz GE 1/0/1 de NPE2 y permita que NPE2 use la prioridad VRRP por defecto.

    3. Enlace una sesión BFD al grupo 1 de VRRP.

  5. Configure el reenvío de Capa 2 en el CE y LSW1 a LSW3.

NOTA:

Los PE1 y PE2 son switches de agregación, PE3 es el root bridge, PE4 es el secondary root bridge, los LSW son switches de acceso y los CE son switches del lado del usuario.

Procedimiento

  1. Configure las funciones básicas de SEP.

    1. Configure el segmento 1 de SEP en LSW1 a LSW3 y configure la VLAN 10 como VLAN de control del segmento 1 de SEP.

      # Configure el switch de acceso LSW1.

      <Quidway> system-view
      [Quidway] sysname LSW1
      [LSW1] sep segment 1 //Cree segmento 1 de SEP.
      [LSW1-sep-segment1] control-vlan 10 //Configure VLAN 10 como la VLAN de control del segmento 1 de SEP.
      [LSW1-sep-segment1] protected-instance all //Configure todas las instancias protegidas del segmento 1 de SEP.
      [LSW1-sep-segment1] quit

      # Configure el switch de acceso LSW2.

      <Quidway> system-view
      [Quidway] sysname LSW2
      [LSW2] sep segment 1 //Cree segmento 1 de SEP.
      [LSW2-sep-segment1] control-vlan 10 //Configure VLAN 10 como la VLAN de control del segmento 1 de SEP.
      [LSW2-sep-segment1] protected-instance all //Configure todas las instancias protegidas del segmento 1 de SEP.
      [LSW2-sep-segment1] quit

      # Configure el switch de acceso LSW3.

      <Quidway> system-view
      [Quidway] sysname LSW3
      [LSW3] sep segment 1 //Cree segmento 1 de SEP.
      [LSW3-sep-segment1] control-vlan 10 //Configure VLAN 10 como la VLAN de control del segmento 1 de SEP.
      [LSW3-sep-segment1] protected-instance all //Configure todas las instancias protegidas del segmento 1 de SEP.
      [LSW3-sep-segment1] quit
      NOTA:
      • La VLAN de control debe ser una VLAN que no ha sido creada o utilizada. Sin embargo, el comando para crear una VLAN común se muestra automáticamente en el archivo de configuración después de crear la VLAN de control.

      • Cada segmento SEP debe tener una VLAN de control. Después de agregar una interfaz a un segmento SEP que tiene una VLAN de control, la interfaz se agrega automáticamente a la VLAN de control.

    2. Agregue el switch de acceso LSW1 a LSW3 al segmento 1 de SEP y configure los roles de interfaz.

      NOTA:

      Por defecto, STP está habilitado en las interfaces de Capa 2. Antes de agregar una interfaz a un segmento SEP, deshabilite STP en la interfaz.

      # Configure el switch de acceso LSW1.

      [LSW1] interface gigabitethernet 1/0/1
      [LSW1-GigabitEthernet1/0/1] sep segment 1 edge no-neighbor primary //Configure la interfaz como la interfaz de borde primaria sin vecinos y agréguela al segmento 1 de SEP.
      [LSW1-GigabitEthernet1/0/1] quit
      [LSW1] interface gigabitethernet 1/0/2
      [LSW1-GigabitEthernet1/0/2] stp disable //Deshabilite STP.
      [LSW1-GigabitEthernet1/0/2] sep segment 1 //Agregue la interfaz al segmento 1 de SEP.
      [LSW1-GigabitEthernet1/0/2] quit

      # Configure el switch de acceso LSW2.

      [LSW2] interface gigabitethernet 1/0/1
      [LSW2-GigabitEthernet1/0/1] sep segment 1 edge no-neighbor secondary //Configure la interfaz como la interfaz de borde secundaria sin vecinos y agréguela al segmento 1 de SEP.
      [LSW2-GigabitEthernet1/0/1] quit
      [LSW2] interface gigabitethernet 1/0/2
      [LSW2-GigabitEthernet1/0/2] stp disable //Deshabilite STP.
      [LSW2-GigabitEthernet1/0/2] sep segment 1 //Agregue la interfaz al segmento 1 de SEP.
      [LSW2-GigabitEthernet1/0/2] quit

      # Configure el switch de acceso LSW3.

      [LSW3] interface gigabitethernet 1/0/1
      [LSW3-GigabitEthernet1/0/1] stp disable //Deshabilite STP.
      [LSW3-GigabitEthernet1/0/1] sep segment 1 //Agregue la interfaz al segmento 1 de SEP.
      [LSW3-GigabitEthernet1/0/1] quit
      [LSW3] interface gigabitethernet 1/0/2
      [LSW3-GigabitEthernet1/0/2] stp disable //Deshabilite STP.
      [LSW3-GigabitEthernet1/0/2] sep segment 1 //Agregue la interfaz al segmento 1 de SEP.
      [LSW3-GigabitEthernet1/0/2] quit
    3. Especifique una interfaz de bloqueo.

      # En el segmento 1 de SEP, ajuste el modo de bloqueo de una interfaz en el switch de acceso LSW1 donde la interfaz de borde primario no-vecina está ubicada para bloquear la interfaz en el medio del segmento SEP.

      [LSW1] sep segment 1
      [LSW1-sep-segment1] block port middle
    4. Configure un modo de preferencia.

      # Configure la preferencia manual en el switch de acceso LSW1.

      [LSW1-sep-segment1] preempt manual
    5. Configure la función de notificación de cambio de topología SEP.

      Configure los dispositivos en el segmento 1 de SEP para notificar a la red MSTP de los cambios de topología.

      # Configure el switch de acceso LSW1.

      [LSW1-sep-segment1] tc-notify stp
      [LSW1-sep-segment1] quit

      # Configure el switch de acceso LSW2.

      [LSW2] sep segment 1
      [LSW2-sep-segment1] tc-notify stp
      [LSW2-sep-segment1] quit

  2. Configure las funciones básicas de MSTP.

    1. Configure una región MST.

      # Configure el switch de agregación PE1.

      <Quidway> system-view
      [Quidway] sysname PE1
      [PE1] stp region-configuration //Introduzca la vista de la región MST.
      [PE1-mst-region] region-name RG1 //Configure el nobre de la región MST como RG1.
      [PE1-mst-region] active region-configuration //Active la configuración de la región MST.
      [PE1-mst-region] quit

      # Configure el switch de agregación PE2.

      <Quidway> system-view
      [Quidway] sysname PE2
      [PE2] stp region-configuration //Introduzca la vista de la región MST.
      [PE2-mst-region] region-name RG1 //Configure the MST region name as RG1.
      [PE2-mst-region] active region-configuration //Active la configuración de la región MST.
      [PE2-mst-region] quit

      # Configure el switch de agregación PE3.

      <Quidway> system-view
      [Quidway] sysname PE3
      [PE3] stp region-configuration //Introduzca la vista de la región MST.
      [PE3-mst-region] region-name RG1 //Configure el nombre de la región MST como RG1.
      [PE3-mst-region] active region-configuration //Active la configuración de la región MST.
      [PE3-mst-region] quit

      # Configure el switch de agregación PE4.

      <Quidway> system-view
      [Quidway] sysname PE4
      [PE4] stp region-configuration //Introduzca la vista de la región MST.
      [PE4-mst-region] region-name RG1 //Configure el nombre de la región MST como RG1.
      [PE4-mst-region] active region-configuration //Active la configuración de la región MST.
      [PE4-mst-region] quit

      # Configure el switch de acceso LSW1.

      [LSW1] stp region-configuration //Introduzca la vista de la región MST.
      [LSW1-mst-region] region-name RG1 //Configure el nombre de la región MST como RG1.
      [LSW1-mst-region] active region-configuration //Active la configuración de la región MST.
      [LSW1-mst-region] quit

      # Configure el switch de acceso LSW2.

      [LSW2] stp region-configuration //Introduzca la vista de la región MST.
      [LSW2-mst-region] region-name RG1 //Configure el nombre de la región MST como RG1.
      [LSW2-mst-region] active region-configuration //Active la configuración de la región MST.
      [LSW2-mst-region] quit
    2. Cree una VLAN y agregue interfaces en la red en anillo a la VLAN.

      # En el switch de agregación PE1, cree la VLAN 100 y agregue GE1/0/1, GE1/0/2 y GE1/0/3 a la VLAN 100.

      [PE1] vlan 100
      [PE1-vlan100] quit
      [PE1]interface gigabitethernet 1/0/1
      [PE1-GigabitEthernet1/0/1] port hybrid tagged vlan 100
      [PE1-GigabitEthernet1/0/1] quit
      [PE1]interface gigabitethernet 1/0/2
      [PE1-GigabitEthernet1/0/2] port hybrid tagged vlan 100
      [PE1-GigabitEthernet1/0/2] quit
      [PE1]interface gigabitethernet 1/0/3
      [PE1-GigabitEthernet1/0/3] port hybrid tagged vlan 100
      [PE1-GigabitEthernet1/0/3] quit

      # En el switch de agregación PE2, PE3 y PE4, cree la VLAN 100 y agregue GE1/0/1, GE1/0/2 y GE1/0/3 a la VLAN 100.

      Las configuraciones del switch de agregación PE2, PE3 y PE4 son similares a la configuración del switch de agregación PE1, y no se mencionan aquí. Para más detalles, vea los archivos de configuración en este ejemplo.

      En el switch de acceso LSW1 y LSW2, cree la VLAN 100 y agregue GE1/0/1 a la VLAN 100. Las configuraciones del switch de acceso LSW1 y LSW2 son similares a la configuración del switch de agregación PE1, y no se mencionan aquí. Para más detalles, vea los archivos de configuración en este ejemplo.

    3. Habilite MSTP.

      # Configure el switch de agregación PE1.

      [PE1] stp enable

      # Configure el switch de agregación PE2.

      [PE2] stp enable

      # Configure el switch de agregación PE3.

      [PE3] stp enable

      # Configure el switch de agregación PE4.

      [PE4] stp enable

      # Configure el switch de acceso LSW1.

      [LSW1] stp enable

      # Configure el switch de acceso LSW2.

      [LSW2] stp enable
    4. Configure el switch de agregación PE3 como el root bridge y el switch de agregación PE4 como el secondary root bridge.

      # Ajuste la prioridad del switch de agregación PE3 a 0 en MSTI 0 para garantizar que el switch de agregación PE3 funcione como el root bridge.

      [PE3] stp root primary

      # Ajuste la prioridad del switch de agregación PE4 a 4096 en MSTI 0 para garantizar que el switch de agregación PE4 funcione como el secondary root bridge.

      [PE4] stp root secondary

  3. Configure VLAN 100 para transmitir paquetes VRRP y VLAN 200 para transmitir paquetes BFD.

    # Configure el switch de agregación PE3.

    [PE3] vlan batch 100 200
    [PE3] interface gigabitethernet 1/0/2
    [PE3-GigabitEthernet1/0/2] port hybrid tagged vlan 100 200
    [PE3-GigabitEthernet1/0/2] quit
    [PE3] interface gigabitethernet 1/0/3
    [PE3-GigabitEthernet1/0/2] port hybrid tagged vlan 100 200
    [PE3-GigabitEthernet1/0/2] quit
    

    # Configure el switch de agregación PE4.

    [PE4] vlan batch 100 200
    [PE4] interface gigabitethernet 1/0/2
    [PE4-GigabitEthernet1/0/2] port hybrid tagged vlan 100 200
    [PE4-GigabitEthernet1/0/2] quit
    [PE4] interface gigabitethernet 1/0/3
    [PE4-GigabitEthernet1/0/3] port hybrid tagged vlan 100 200
    [PE4-GigabitEthernet1/0/3] quit
    

  4. Configure una sesión BFD.

    1. Configure las direcciones IP para las interfaces.

      # Configure una dirección IP para una interfaz en NPE1 y cree una sub-interfaz para la interfaz.

      <Quidway> system-view
      [Quidway] sysname NPE1
      [NPE1] vlan 100
      [NPE1-vlan100] quit
      [NPE1] interface gigabitethernet 1/0/1
      [NPE1-GigabitEthernet1/0/1] undo shutdown
      [NPE1-GigabitEthernet1/0/1] ip address 10.2.1.1 24
      [NPE1-GigabitEthernet1/0/1] quit
      [NPE1] interface gigabitethernet 1/0/1.1
      [NPE1-GigabitEthernet1/0/1.1] undo shutdown
      [NPE1-GigabitEthernet1/0/1.1] vlan-type dot1q 100
      [NPE1-GigabitEthernet1/0/1.1] ip address 10.1.1.1 24
      [NPE1-GigabitEthernet1/0/1.1] quit
      

      # Configure una dirección IP para una interfaz en NPE2 y cree una sub-interfaz para la interfaz.

      <Quidway> system-view
      [Quidway] sysname NPE2
      [NPE2] vlan 100
      [NPE2-vlan100] quit
      [NPE2] interface gigabitethernet 1/0/1
      [NPE2-GigabitEthernet1/0/1] undo shutdown
      [NPE2-GigabitEthernet1/0/1] ip address 10.2.1.2 24
      [NPE2-GigabitEthernet1/0/1] quit
      [NPE2] interface gigabitethernet 1/0/1.1
      [NPE2-GigabitEthernet1/0/1.1] undo shutdown
      [NPE2-GigabitEthernet1/0/1.1] vlan-type dot1q 100
      [NPE2-GigabitEthernet1/0/1.1] ip address 10.1.1.2 24
      [NPE2-GigabitEthernet1/0/1.1] quit
      
    2. Cree una sesión BFD.

      # Habilite BFD en NPE1 y configure una sesión BFD entre NPE1 y NPE2.

      [NPE1] bfd
      [NPE1-bfd] quit
      [NPE1] bfd NPE2 bind peer-ip default-ip interface gigabitethernet 1/0/1 //Configure una sesión BFD estática para monitorear el enlace del grupo VRRP.
      [NPE1-bfd-session-npe2] discriminator local 1
      [NPE1-bfd-session-npe2] discriminator remote 2
      [NPE1-bfd-session-npe2] commit
      [NPE1-bfd-session-npe2] quit
      

      # Habilite BFD en NPE2 y configure una sesión BFD entre NPE1 y NPE2.

      [NPE2] bfd
      [NPE2-bfd] quit
      [NPE2] bfd NPE1 bind peer-ip default-ip interface gigabitethernet 1/0/1 //Configure una sesión BFD estática para monitorear el enlace del grupo VRRP.
      [NPE2-bfd-session-npe1] discriminator local 2
      [NPE2-bfd-session-npe1] discriminator remote 1
      [NPE2-bfd-session-npe1] commit
      [NPE2-bfd-session-npe1] quit
      

      # Después de completar la configuración, ejecute display bfd session all en NPE1 y NPE2. La salida del comando muestra que la sesión BFD está configurada entre NPE1 y NPE2 y su estado es Up.

      Use la visualización en NPE1 como ejemplo.

      [NPE1] display bfd session all
      --------------------------------------------------------------------------------
      Local Remote PeerIpAddr      State     Type        InterfaceName
      --------------------------------------------------------------------------------
      1     2      224.0.0.184     Up        S_IP_IF     GigabitEthernet1/0/1
      --------------------------------------------------------------------------------
           Total UP/DOWN Session Number : 1/0 
    3. Configure la asociación entre el estado de BFD y el estado de la sub-interfaz.

      # Configure NPE1.

      [NPE1] bfd
      [NPE1-bfd] quit
      [NPE1] bfd NPE2
      [NPE1-bfd-session-npe2] process-interface-status sub-if
      [NPE1-bfd-session-npe2] commit
      [NPE1-bfd-session-npe2] quit
      

      # Configure NPE2.

      [NPE2] bfd
      [NPE2-bfd] quit
      [NPE2] bfd NPE1
      [NPE2-bfd-session-npe1] process-interface-status sub-if
      [NPE2-bfd-session-npe1] commit
      [NPE2-bfd-session-npe1] quit
      

      Después de completar las configuraciones anteriores, ejecute el comando display bfd session all verbose en NPE1 y NPE2. Verifique que el campo Proc interface status muestre Enable (Sub-If).

      Use la visualización en NPE1 como ejemplo.

      [NPE1] display bfd session all verbose
      --------------------------------------------------------------------------------
      Session MIndex : 257       (One Hop) State : Up        Name : npe2
      --------------------------------------------------------------------------------
        Local Discriminator    : 1                Remote Discriminator   : 2
        Session Detect Mode    : Asynchronous Mode Without Echo Function
        BFD Bind Type          : Interface(GigabitEthernet1/0/1)
        Bind Session Type      : Static
        Bind Peer IP Address   : 224.0.0.184
        NextHop Ip Address     : 224.0.0.184
        Bind Interface         : GigabitEthernet1/0/1
        FSM Board Id           : 0                TOS-EXP                : 7
        Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
        Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
        Local Detect Multi     : 3                Detect Interval (ms)   : 3000
        Echo Passive           : Disable          Acl Number             : -
        Destination Port       : 3784             TTL                    : 255
        Proc Interface Status  : Enable(Sub-If)   Process PST            : Disable
        WTR Interval (ms)      : -                Local Demand Mode      : Disable
        Active Multi           : 3
        Last Local Diagnostic  : No Diagnostic
        Bind Application       : IFNET
        Session TX TmrID       : 93               Session Detect TmrID   : 94
        Session Init TmrID     : -                Session WTR TmrID      : -
        Session Echo Tx TmrID  : -
        PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
        Session Description    : -
      --------------------------------------------------------------------------------
      
           Total UP/DOWN Session Number : 1/0 

  5. Configure VRRP.

    • # Configure una dirección IP para una interfaz en NPE1, cree el grupo 1 de VRRP, y ajuste la prioridad VRRP de NPE1 para 120 para que NPE1 pueda funcionar como Master.

      [NPE1] interface gigabitethernet 1/0/1.1
      [NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 virtual-ip 10.1.1.10
      [NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 priority 120 //La prioridad por defecto de un dispositivo en un grupo VRRP es de 100. Cambie la prioridad del principal para que sea más alta que la de la copia de seguridad.
      [NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 preempt-mode timer delay 10 //Un dispositivo en un grupo VRRP usa prioridad inmediata por defecto. Cambie la demora de preferencia del principal para evitar interrupciones de servicio en una red inestable donde los dispositivos en el grupo VRRP se adelantan como Master.
      
    • # Configure una dirección IP para una interfaz en NPE2, cree el grupo 1 de VRRP, y permita que NPE2 use el valor por defecto para que NPE1 pueda funcionar como Backup.

      [NPE2] interface gigabitethernet 1/0/1.1
      [NPE2-GigabitEthernet1/0/1.1] vrrp vrid 1 virtual-ip 10.1.1.10
      
    • # En NPE1, enlace el grupo VRRP y la sesión BFD.

      [NPE1-GigabitEthernet1/0/1.1] vrrp vrid 1 track bfd-session 1 peer
      [NPE1-GigabitEthernet1/0/1.1] quit
      
    • # En NPE2, enlace el grupo VRRP y la sesión BFD.

      [NPE2-GigabitEthernet1/0/1.1] vrrp vrid 1 track bfd-session 2 peer
      [NPE2-GigabitEthernet1/0/1.1] quit
      
    Después de completar las configuraciones anteriores, ejecute el comando display vrrp en NPE1. Verifique que el estado de NPE1 sea Master. Ejecute el comando display vrrp en NPE2. Verifique que el estado de NPE2 sea Backup.
    [NPE1] display vrrp
    GigabitEthernet1/0/1.1 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.10
        Master IP      : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 120
        Preempt : YES   Delay Time : 10
        TimerRun : 1
        TimerConfig : 1
        Auth Type : NONE
        Virtual Mac :  0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Config track link-bfd down-number : 0
        Track BFD : 1  type: peer
        BFD-session state : UP
        Create time : 2013-12-29 22:46:32 UTC+07:00
        Last change time : 2013-12-29 22:46:35 UTC+07:00
    [NPE2] display vrrp
    GigabitEthernet1/0/1.1 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.10
        Master IP      : 10.1.1.2
        PriorityRun : 100
        PriorityConfig : 100
        MasterPriority : 120
        Preempt : YES   Delay Time : 0
        TimerRun : 1
        TimerConfig : 1
        Auth Type : NONE
        Virtual Mac :  0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Config track link-bfd down-number : 0
        Track BFD : 2  type: peer
        BFD-session state : UP
        Create time : 2013-12-29 22:46:32 UTC+07:00
        Last change time : 2013-12-29 22:46:35 UTC+07:00

  6. Configure la función de reenvío de Capa 2 en el switch CE del lado del usuario y acceda al switch LSW1 a LSW3.

    Los detalles de configuración no se mencionan aquí. Para más detalles, vea los archivos de configuración en este ejemplo.

  7. Verifique la configuración

    Una vez completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración.

    • # Ejecute el comando shutdown en GE1/0/1 de LSW2 para simular una falla, y luego ejecute el comando display sep interface en LSW3 para verificar si GE1/0/2 en LSW3 cambia del estado discarding al estado forwarding.

      <LSW3> display sep interface gigabitethernet 1/0/2
      SEP segment 1
      ----------------------------------------------------------------
      Interface           Port Role     Neighbor Status     Port Status
      ----------------------------------------------------------------
      GE1/0/2             common        up                  forwarding 
    • Ejecute el comando shutdown en GE1/0/1.1 en NPE1 para simular una falla de interfaz, y luego ejecute el comando display vrrp en NPE2 para verificar si el estado de NPE2 cambia de Backup a Master.

      [NPE2] display vrrp
      GigabitEthernet1/0/1.1 | Virtual Router 1
          State : Master
          Virtual IP : 10.1.1.10
          Master IP      : 10.1.1.2
          PriorityRun : 100
          PriorityConfig : 100
           MasterPriority : 100
          Preempt : YES   Delay Time : 0
          TimerRun : 1
          TimerConfig : 1
          Auth Type : NONE
          Virtual Mac :  0000-5e00-0101
          Check TTL : YES
          Config type : normal-vrrp
          Backup-forward : disabled
          Config track link-bfd down-number : 0
          Track BFD : 2  type: peer
          BFD-session state : DOWN  
          Create time : 2013-12-29 22:46:32 UTC+07:00
          Last change time : 2013-12-30 00:12:10 UTC+07:00

Archivos de configuración

  • Archivo de configuración de LSW1

    #
    sysname LSW1
    #
    vlan batch 10 100
    #
    stp enable
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    sep segment 1
     control-vlan 10
     block port middle
     tc-notify stp
     protected-instance 0 to 4094
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 10 100
     sep segment 1 edge no-neighbor primary 
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • Archivo de configuración de LSW2

    #
    sysname LSW2
    #
    vlan batch 10 100
    #
    stp enable
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    sep segment 1
     control-vlan 10
     tc-notify stp
     protected-instance 0 to 4094
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 10 100
     sep segment 1 edge no-neighbor secondary
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    return
  • Archivo de configuración de LSW3

    #
    sysname LSW3
    #
    vlan batch 10 100
    #
    sep segment 1
     control-vlan 10
     protected-instance 0 to 4094
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 10 100
     stp disable
     sep segment 1
    #
    interface GigabitEthernet1/0/3
     port hybrid tagged vlan vlan 100
    #
    return
  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 100
    #
    stp enable
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/3
     port hybrid tagged vlan 100
    #
    return            
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
    vlan batch 100
    #
    stp enable
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/3
     port hybrid tagged vlan 100
    #
    return
  • Archivo de configuración de PE3

    #
    sysname PE3
    #
    vlan batch 100
    #
    stp instance 0 root primary
    stp enable
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 100 200
    #
    interface GigabitEthernet1/0/3
     port hybrid tagged vlan 100 200
    #
    return
  • Archivo de configuración de PE4

    #
    sysname PE4
    #
    vlan batch 100
    #
    stp instance 0 root secondary
    stp enable
    #
    stp region-configuration
     region-name RG1
     active region-configuration
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid tagged vlan 100 200
    #
    interface GigabitEthernet1/0/3
     port hybrid tagged vlan 100 200
    #
    return
  • Archivo de configuración de NPE1

    #
     sysname NPE1
    #
     vlan batch 100
    #
     bfd
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1.1
     vlan-type dot1q 100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.10
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 10
     vrrp vrid 1 track bfd-session 1 peer
    #
    bfd npe2 bind peer-ip default-ip interface GigabitEthernet1/0/1
     discriminator local 1
     discriminator remote 2
     process-interface-status sub-if
     commit
    #
    return
  • Archivo de configuración de NPE2

    #
     sysname NPE2
    #
     vlan batch 100
    #
     bfd
    #
    interface GigabitEthernet1/0/1
     undo shutdown
     ip address 10.2.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1.1
     vlan-type dot1q 100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.10
     vrrp vrid 1 track bfd-session 2 peer
    #
    bfd npe1 bind peer-ip default-ip interface GigabitEthernet1/0/1
     discriminator local 2
     discriminator remote 1
     process-interface-status sub-if
     commit
    #
    return
  • Archivo de configuración de CE
    #
    sysname CE
    #
    vlan batch 100
    #
    interface GigabitEthernet1/0/1
     port hybrid tagged vlan 100
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15790

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente