No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar VBST

Ejemplo para configurar VBST

Descripción general

El Árbol de expansión basado en VLAN (VBST) construye un árbol de expansión en cada VLAN para que el tráfico de diferentes VLAN se pueda reenviar a través de diferentes árboles de expansión. VBST es de propiedad de Huawei que es equivalente al Protocolo de árbol de expansión (STP) o Protocolo de árbol de expansión rápida (RSTP) que se ejecuta en cada VLAN. Los árboles de expansión en diferentes VLAN son independientes entre sí.

Actualmente, los tres protocolos de árbol de expansión estándar son STP, RSTP y Protocolo de árbol de expansión múltiple (MSTP). STP y RSTP no pueden implementar el equilibrio de carga basado en VLAN, porque todas las VLAN en una LAN comparten un árbol de expansión y los paquetes en todas las VLAN se reenvían a lo largo de este árbol de expansión. Además, el enlace bloqueado no lleva ningún tráfico, lo que desperdicia ancho de banda y puede evitar que algunas VLAN reenvíen paquetes. Generalmente, se prefiere MSTP porque es compatible con STP y RSTP, garantiza una convergencia rápida y proporciona múltiples rutas para equilibrar la carga del tráfico.

En las redes empresariales, los usuarios empresariales necesitan funciones que sean fáciles de usar y mantener, mientras que la configuración de MSTP de múltiples instancias y procesos múltiples es compleja y requiere un conocimiento profundo.

Para abordar este problema, Huawei desarrolló VBST. VBST construye un árbol de expansión en cada VLAN para que el tráfico de diferentes VLAN se equilibre en la carga a lo largo de diferentes árboles de expansión. Además, VBST es fácil de configurar y mantener.

Notas de configuración

Este ejemplo se aplica a todos los modelos de V200R005C00 y versiones posteriores.

Al configurar VBST en el switch, preste atención a los siguientes puntos:
  • Cuando HVRP está habilitado en un switch modular, no cambie el modo STP a VBST.

  • Cuando VBST está habilitado en una red en anillo, VBST inicia inmediatamente el cálculo del árbol de expansión. Los parámetros como la prioridad del dispositivo y la prioridad del puerto afectan el cálculo del árbol de expansión, y los cambios de estos parámetros pueden causar un aleteo de la red. Para garantizar un cálculo del árbol de expansión rápido y estable, realice configuraciones básicas en el switch y las interfaces antes de habilitar VBST.

  • Si la instancia protegida se ha configurado en un segmento SEP o anillo ERPS pero el mapeo entre instancias protegidas y VLAN no está configurada, VBST no se puede habilitar.

  • VBST no se puede habilitar en la VLAN ignorada ni en la VLAN de control utilizada por ERPS, RRPP, SEP o Smart Link.

  • Si se ha configurado el mapeo de 1:N (N>1) entre las MSTI y las VLAN en el switch, debe eliminar el mapeo antes de cambiar el modo de funcionamiento de STP a VBST.
  • Si stp vpls-subinterface enable ha sido configurado en el switch, debe ejecutar el comando undo stp vpls-subinterface enable en la interfaz antes de cambiar el modo de funcionamiento de STP a VBST.
  • Si el dispositivo se ha configurado como el root bridge o como el secondary root bridge, ejecute el comando undo stp vlan { vlan-id1 [ to vlan-id2 ] } &<1-10> root para deshabilitar la función del root bridge o secondary root bridge y ejecute el comando stp vlan { vlan-id1 [ to vlan-id2 ] } &<1-10> priority priority para cambiar la prioridad del dispositivo.

  • Cuando se especifique dinámicamente más de 128 MSTI, STP se deshabilita en una VLAN creada en el archivo de configuración, por ejemplo, stp vlan 100 disable.

  • Para evitar el aleteo frecuente de la red, asegúrese de que los valores de Hello time, Forward Delay, y Max Age estén conforme a las siguientes fórmulas:

    • 2 x (Forward Delay - 1.0 second) >= Max Age

    • Max Age >= 2 x (Hello Time + 1.0 second)

  • Se recomienda usar una convergencia rápida en modo normal. Si se usa el modo fast, borrar con frecuencia las entradas de ARP puede dar como resultado un uso de CPU del 100% de la MPU y la LPU. Como resultado, el procesamiento de paquetes expira y se produce un aleteo de la red.

  • Después de que todos los puertos estén configurados como puertos de borde y puertos de filtro de BPDU en la vista del sistema, ninguno de los puertos del switch envía BPDU o negocia el estado de VBST con los puertos directamente conectados en el dispositivo del otro extremo. Todos los puertos están en estado de reenvío. Esto puede causar bucles en la red, lo que lleva a tormentas de difusión. Tenga precaución cuando configure un puerto como puerto de borde y puerto de filtro de BPDU.

  • Después de que un puerto se configure como un puerto de borde y un puerto de filtro de BPDU en la vista de interfaz, el puerto no procesa ni envía BPDU. El puerto no puede negociar el estado de VBST con el puerto directamente conectado en el dispositivo del otro extremo. Tenga precaución cuando configure un puerto como un puerto de borde y un puerto de filtro de BPDU.

  • La protección de root solo tiene efecto en los puertos designados.

  • Un puerto alternativo es la copia de seguridad del root bridge. Si un switch tiene un puerto alternativo, configure la protección de bucle tanto en el root bridge como en el alternativo.

Requisitos de redes

En Figura 6-34, SwitchC y SwitchD (switches de acceso) están dual-homed para SwitchA and SwitchB (switches de agregación). SwitchC transmite el tráfico desde VLAN 10 y VLAN 20, y SwitchD transmite el tráfico desde VLAN 20 y VLAN 30. Se forma una red en anillo entre la capa de acceso y la capa de agregación. La empresa requiere que el tráfico del servicio en cada VLAN se reenvíe correctamente y que el tráfico del servicio de diferentes VLAN se equilibre en la carga para mejorar la eficacia del uso del enlace.

Figura 6-34  Redes de VBST

Hoja de ruta de configuración

VBST se puede usar para eliminar bucles entre la capa de acceso y la capa de agregación y garantiza que el tráfico del servicio en cada VLAN se reenvíe correctamente. Además, el tráfico de diferentes VLAN se puede equilibrar en la carga. La hoja de ruta de configuración es la siguiente:

  1. Configure el reenvío de Capa 2 en los switches de acceso y agregación.
  2. Configure las funciones básicas de VBST en SwitchA, SwitchB, SwitchC, y SwitchD. Realice las siguientes operaciones para que un árbol de expansión mostrado en Figura 6-34 se forme a través del cálculo:

    • Configure SwitchA y SwitchB como el root bridge y el secondary root bridge de la VLAN 10 respectivamente, configure SwitchA y SwitchB como el root bridge y el secondary root bridge de la VLAN 20 respectivamente, y configure SwitchB y SwitchA como el root bridge y el secondary root bridge de la VLAN 30 respectivamente.
    • Ajuste un costo de ruta mayor para GE1/0/2 en SwitchC en VLAN 10 y VLAN 20 para que GE1/0/2 esté bloqueada en árboles de expansión de VLAN 10 y VLAN 20. Ajuste un costo de ruta mayor para GE1/0/2 en SwitchD en VLAN 20 y VLAN 30 para que GE1/0/2 está bloqueada en el árbol de expansión de VLAN 20 y VLAN 30.
  3. Configure los puertos en SwitchC y SwitchD conectados a los terminales como puertos de borde para reducir el cálculo de topología VBST y mejorar la convergencia de topología.

Procedimiento

  1. Configure el reenvío de Capa 2 en los switches de la red en anillo.

    • Cree VLAN 10, VLAN 20, y VLAN 30 en SwitchA, SwitchB, SwitchC, y SwitchD.

      # Cree VLAN 10, VLAN 20 y VLAN 30 en el switch de agregación SwitchA.

      <Quidway> system-view
      [Quidway] sysname SwitchA
      [SwitchA] vlan batch 10 20 30

      # Cree VLAN 10, VLAN 20 y VLAN 30 en el switch de agregación SwitchB.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] vlan batch 10 20 30

      # Cree VLAN 10 y VLAN 20 en el switch de acceso SwitchC.

      <Quidway> system-view
      [Quidway] sysname SwitchC
      [SwitchC] vlan batch 10 20

      # Cree VLAN 20 y VLAN 30 en el switch de acceso SwitchD.

      <Quidway> system-view
      [Quidway] sysname SwitchD
      [SwitchD] vlan batch 20 30
    • Agregue los puertos conectados al anillo a las VLAN.

      # Agregue GE1/0/1 en SwitchA a VLAN 10, VLAN 20 y VLAN 30.

      [SwitchA] interface gigabitethernet 1/0/1
      [SwitchA-GigabitEthernet1/0/1] port link-type trunk
      [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20 30
      [SwitchA-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchA a VLAN 20 y VLAN 30.

      [SwitchA] interface gigabitethernet 1/0/2
      [SwitchA-GigabitEthernet1/0/2] port link-type trunk
      [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20 30
      [SwitchA-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchA a VLAN 10 y VLAN 20.

      [SwitchA] interface gigabitethernet 1/0/3
      [SwitchA-GigabitEthernet1/0/3] port link-type trunk
      [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 10 20
      [SwitchA-GigabitEthernet1/0/3] quit

      # Agregue GE1/0/1 en SwitchB a VLAN 10, VLAN 20 y VLAN 30.

      [SwitchB] interface gigabitethernet 1/0/1
      [SwitchB-GigabitEthernet1/0/1] port link-type trunk
      [SwitchB-GigabitEthernet1/0/1] port trunk allow-pass vlan 10 20 30
      [SwitchB-GigabitEthernet1/0/1] quit

      # Agregue GE1/0/2 en SwitchB a VLAN 10 y VLAN 20.

      [SwitchB] interface gigabitethernet 1/0/2
      [SwitchB-GigabitEthernet1/0/2] port link-type trunk
      [SwitchB-GigabitEthernet1/0/2] port trunk allow-pass vlan 10 20
      [SwitchB-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchB a VLAN 20 y VLAN 30.

      [SwitchB] interface gigabitethernet 1/0/3
      [SwitchB-GigabitEthernet1/0/3] port link-type trunk
      [SwitchB-GigabitEthernet1/0/3] port trunk allow-pass vlan 20 30
      [SwitchB-GigabitEthernet1/0/3] quit

      # Agregue GE1/0/2 en SwitchC a VLAN 10 y VLAN 20.

      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] port link-type trunk
      [SwitchC-GigabitEthernet1/0/2] port trunk allow-pass vlan 10 20
      [SwitchC-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchC a VLAN 10 y VLAN 20.

      [SwitchC] interface gigabitethernet 1/0/3
      [SwitchC-GigabitEthernet1/0/3] port link-type trunk
      [SwitchC-GigabitEthernet1/0/3] port trunk allow-pass vlan 10 20
      [SwitchC-GigabitEthernet1/0/3] quit

      # Agregue GE1/0/4 en SwitchC a VLAN 10 y GE1/0/5 en VLAN 20.

      [SwitchC] interface gigabitethernet 1/0/4
      [SwitchC-GigabitEthernet1/0/4] port link-type access
      [SwitchC-GigabitEthernet1/0/4] port default vlan 10
      [SwitchC-GigabitEthernet1/0/4] quit
      [SwitchC] interface gigabitethernet 1/0/5
      [SwitchC-GigabitEthernet1/0/5] port link-type access
      [SwitchC-GigabitEthernet1/0/5] port default vlan 20
      [SwitchC-GigabitEthernet1/0/5] quit

      # Agregue GE1/0/2 en SwitchD a VLAN 20 y VLAN 30.

      [SwitchD] interface gigabitethernet 1/0/2
      [SwitchD-GigabitEthernet1/0/2] port link-type trunk
      [SwitchD-GigabitEthernet1/0/2] port trunk allow-pass vlan 20 30
      [SwitchD-GigabitEthernet1/0/2] quit

      # Agregue GE1/0/3 en SwitchD a VLAN 20 y VLAN 30.

      [SwitchD] interface gigabitethernet 1/0/3
      [SwitchD-GigabitEthernet1/0/3] port link-type trunk
      [SwitchD-GigabitEthernet1/0/3] port trunk allow-pass vlan 20 30
      [SwitchD-GigabitEthernet1/0/3] quit

      # Agregue GE1/0/4 en SwitchD a VLAN 20 y GE1/0/5 en VLAN 30.

      [SwitchD] interface gigabitethernet 1/0/4
      [SwitchD-GigabitEthernet1/0/4] port link-type access
      [SwitchD-GigabitEthernet1/0/4] port default vlan 20
      [SwitchD-GigabitEthernet1/0/4] quit
      [SwitchD] interface gigabitethernet 1/0/5
      [SwitchD-GigabitEthernet1/0/5] port link-type access
      [SwitchD-GigabitEthernet1/0/5] port default vlan 30
      [SwitchD-GigabitEthernet1/0/5] quit

  2. Configure las funciones básicas de VBST.

    1. Configure los switches en la red del anillo para funcionar en el modo VBST.

      # Configure SwitchA para funcionar en modo VBST.

      [SwitchA] stp mode vbst

      # Configure SwitchB para funcionar en modo VBST.

      [SwitchB] stp mode vbst

      # Configure SwitchC para funcionar en modo VBST.

      [SwitchC] stp mode vbst

      # Configure SwitchD para funcionar en modo VBST.

      [SwitchD] stp mode vbst
    2. Configure el y root bridge y el secondary root bridge.

      • Configure el root bridge y el secondary root bridge en VLAN 10.

        # Configure SwitchA como el root bridge en VLAN 10.

        [SwitchA] stp vlan 10 root primary

        # Configure SwitchB como el secondary root bridge en VLAN 10.

        [SwitchB] stp vlan 10 root secondary
      • Configure el root bridge y el secondary root bridge en VLAN 20.

        # Configure SwitchA como el root bridge en VLAN 20.

        [SwitchA] stp vlan 20 root primary

        # Configure SwitchB como el secondary root bridge en VLAN 20.

        [SwitchB] stp vlan 20 root secondary
      • Configure el root bridge y el secondary root bridge en VLAN 30.

        # Configure SwitchB como el root bridge en VLAN 30.

        [SwitchB] stp vlan 30 root primary

        # Configure SwitchA como el secondary root bridge en VLAN 30.

        [SwitchA] stp vlan 30 root secondary
    3. Configure el costo de la ruta para un puerto en cada VLAN para que el puerto pueda ser bloqueado.

      NOTA:
      • El rango del costo de la ruta depende del algoritmo. El estándar IEEE 802.1t se usa como ejemplo. Ajuste los costos de la ruta de los puertos a ser bloqueados a 2000000.

      • Todos los switches en la misma red deben usar el mismo método de cálculo del costo de la ruta.

      # Ajuste el costo de ruta de GE1/0/2 en SwitchC a 2000000 en VLAN 10 y VLAN 20.

      [SwitchC] interface gigabitethernet 1/0/2
      [SwitchC-GigabitEthernet1/0/2] stp vlan 10 cost 2000000
      [SwitchC-GigabitEthernet1/0/2] stp vlan 20 cost 2000000
      [SwitchC-GigabitEthernet1/0/2] quit

      # Ajuste el costo de ruta de GE1/0/2 en SwitchD a 2000000 en VLAN 20 y VLAN 30.

      [SwitchD] interface gigabitethernet 1/0/2
      [SwitchD-GigabitEthernet1/0/2] stp vlan 20 cost 2000000
      [SwitchD-GigabitEthernet1/0/2] stp vlan 30 cost 2000000
      [SwitchD-GigabitEthernet1/0/2] quit
    4. Habilite VBST para eliminar los bucles.

      • Deshabilite VBST en VLAN 1 en todos los dispositivos.

        NOTA:

        Por defecto, todos los puertos que se unen a VLAN 1 y VBST están habilitados en VLAN 1. Para reducir el cálculo del árbol de expansión, deshabilite VBST en VLAN 1. Para evitar los bucles en VLAN 1 después de que VBST esté deshabilitado, elimine los puertos desde VLAN 1.

        # Deshabilite VBST en VLAN 1 en SwitchA.

        [SwitchA] stp vlan 1 disable

        # Deshabilite VBST en VLAN 1 en SwitchB.

        [SwitchB] stp vlan 1 disable

        # Deshabilite VBST en VLAN 1 en SwitchC.

        [SwitchC] stp vlan 1 disable

        # Deshabilite VBST en VLAN 1 en SwitchD.

        [SwitchD] stp vlan 1 disable
        # Borre GE1/0/1, GE1/0/2, y GE1/0/3 en SwitchA desde VLAN 1.
        [SwitchA] interface gigabitethernet 1/0/1
        [SwitchA-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
        [SwitchA-GigabitEthernet1/0/1] quit
        [SwitchA] interface gigabitethernet 1/0/2
        [SwitchA-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
        [SwitchA-GigabitEthernet1/0/2] quit
        [SwitchA] interface gigabitethernet 1/0/3
        [SwitchA-GigabitEthernet1/0/3] undo port trunk allow-pass vlan 1
        [SwitchA-GigabitEthernet1/0/3] quit
        # Borre GE1/0/1, GE1/0/2, y GE1/0/3 en SwitchB desde VLAN 1.
        [SwitchB] interface gigabitethernet 1/0/1
        [SwitchB-GigabitEthernet1/0/1] undo port trunk allow-pass vlan 1
        [SwitchB-GigabitEthernet1/0/1] quit
        [SwitchB] interface gigabitethernet 1/0/2
        [SwitchB-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
        [SwitchB-GigabitEthernet1/0/2] quit
        [SwitchB] interface gigabitethernet 1/0/3
        [SwitchB-GigabitEthernet1/0/3] undo port trunk allow-pass vlan 1
        [SwitchB-GigabitEthernet1/0/3] quit
        # Borre GE1/0/2, y GE1/0/3 en SwitchB desde VLAN 1.
        [SwitchC] interface gigabitethernet 1/0/2
        [SwitchC-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
        [SwitchC-GigabitEthernet1/0/2] quit
        [SwitchC] interface gigabitethernet 1/0/3
        [SwitchC-GigabitEthernet1/0/3] undo port trunk allow-pass vlan 1
        [SwitchC-GigabitEthernet1/0/3] quit
        # Borre GE1/0/2, y GE1/0/3 en SwitchD desde VLAN 1.
        [SwitchD] interface gigabitethernet 1/0/2
        [SwitchD-GigabitEthernet1/0/2] undo port trunk allow-pass vlan 1
        [SwitchD-GigabitEthernet1/0/2] quit
        [SwitchD] interface gigabitethernet 1/0/3
        [SwitchD-GigabitEthernet1/0/3] undo port trunk allow-pass vlan 1
        [SwitchD-GigabitEthernet1/0/3] quit
      • Habilite VBST globalmente.

        # Habilite VBST en SwitchA globalmente.

        [SwitchA] stp enable

        # Habilite VBST en SwitchB globalmente.

        [SwitchB] stp enable

        # Habilite VBST en SwitchC globalmente.

        [SwitchC] stp enable

        # Habilite VBST en SwitchD globalmente.

        [SwitchD] stp enable
      • Habilite VBST en una VLAN.

        Por defecto, VBST está habilitado en una VLAN.

        Ejecute el comando display stp vlan para verificar el estado de VBST. Si se muestra el mensaje "The protocol is disabled", VBST está deshabilitado en la VLAN. Ejecute el comando stp vlan vlan-id enable en la vista del sistema para habilitar VBST en la VLAN.

      • Habilite VBST en un puerto.

        Por defecto, VBST está habilitado en una interfaz de Ethernet de Capa 2.

        Ejecute el comando display stp interface interface-type interface-number para verificar el estado de VBST en un puerto. Si se muestra el mensaje "The protocol is disabled", VBST está deshabilitado en el puerto. Ejecute el comando stp enable en la vista de interfaz para habilitar VBST en el puerto.

  3. Configure los puertos conectados a los terminales como puertos de borde para mejorar la convergencia de topología.

    # En SwitchC y SwitchD, configure GE1/0/4 y GE1/0/5 conectados a los terminales como puertos de borde.

    [SwitchC] interface gigabitethernet 1/0/4
    [SwitchC-GigabitEthernet1/0/4] stp edged-port enable
    [SwitchC-GigabitEthernet1/0/4] quit
    [SwitchC] interface gigabitethernet 1/0/5
    [SwitchC-GigabitEthernet1/0/5] stp edged-port enable
    [SwitchC-GigabitEthernet1/0/5] quit
    [SwitchD] interface gigabitethernet 1/0/4
    [SwitchD-GigabitEthernet1/0/4] stp edged-port enable
    [SwitchD-GigabitEthernet1/0/4] quit
    [SwitchD] interface gigabitethernet 1/0/5
    [SwitchD-GigabitEthernet1/0/5] stp edged-port enable
    [SwitchD-GigabitEthernet1/0/5] quit

  4. Verifique la configuración

    Una vez completada la configuración y la topología de red se vuelva estable, realice las siguientes operaciones para verificar la configuración.

    # Ejecute el comando display stp bridge local en SwitchA para verificar el modo de funcionamiento de STP.

    [SwitchA] display stp bridge local
    VLAN-ID          Bridge ID Hello Max Forward Protocol
                                Time Age   Delay
    ----- -------------------- ----- --- ------- ---------------------------
       10     0.0200-0000-6703     2  20      15 VBST
       20     0.0200-0000-6703     2  20      15 VBST
       30  4096.0200-0000-6703     2  20      15 VBST

    La información anterior muestra que se usa el modo VBST.

    # Ejecute el comando display stp brief en SwitchA para verificar el estado del puerto.

    [SwitchA] display stp brief
     VLAN-ID   Port                        Role  STP State     Protection
          10   GigabitEthernet1/0/1        DESI  FORWARDING    NONE
          10   GigabitEthernet1/0/3        DESI  FORWARDING    NONE
          20   GigabitEthernet1/0/1        DESI  FORWARDING    NONE
          20   GigabitEthernet1/0/2        DESI  FORWARDING    NONE
          20   GigabitEthernet1/0/3        DESI  FORWARDING    NONE
          30   GigabitEthernet1/0/1        ROOT  FORWARDING    NONE
          30   GigabitEthernet1/0/2        DESI  FORWARDING    NONE

    La información anterior muestra que SwitchA participa en el cálculo del árbol de expansión en VLAN 10, VLAN 20 y VLAN 30. Por ejemplo, SwitchA es el root bridge en VLAN 10 y VLAN 20, por lo que GE1/0/1 y GE1/0/3 en VLAN 10 se seleccionan como puertos designados. GE1/0/1, GE1/0/2 y GE1/0/3 en VLAN 20 se seleccionan como puertos designados. SwitchA es el secondary root bridge en VLAN 30, por lo que GE1/0/1 se selecciona como el root bridge y GE1/0/2 se selecciona como el puerto designado en VLAN 30.

    # Ejecute el comando display stp vlan 10 en SwitchA para verificar información detallada sobre VLAN 10.

    [SwitchA] display stp vlan 10
    -------[VLAN 10 Global Info]-------                                             
    Bridge ID           :0    .0200-0000-6703                                       
    Config Times        :Hello 2s MaxAge 20s FwDly 15s                              
    Active Times        :Hello 2s MaxAge 20s FwDly 15s                              
    Root ID / RPC       :0    .0200-0000-6703 / 0 (This bridge is the root)         
    RootPortId          :0.0                                                        
    Root Type           :Primary                                                    
     ----[Port4093(GigabitEthernet1/0/1)][FORWARDING]----                           
     Port Role          :Designated Port                                            
     Port Priority      :128                                                        
     Port Cost(Dot1T)  :Config=Auto / Active=20000                                  
     Desg. Bridge/Port  :0    .0200-0000-6703 / 128.4093                            
     Port Edged         :Config=Default / Active=Disabled                           
     Point-to-point     :Config=Auto / Active=true                                  
     Transit Limit      :6 packets/hello                                            
     Protection Type    :None                                                       
     ----[Port4092(GigabitEthernet1/0/3)][FORWARDING]----                          
     Port Role          :Designated Port                                            
     Port Priority      :128                                                        
     Port Cost(Dot1T)  :Config=Auto / Active=199999                                 
     Desg. Bridge/Port  :0    .0200-0000-6703 / 128.4092                            
     Port Edged         :Config=Default / Active=Disabled                           
     Point-to-point     :Config=Auto / Active=true                                  
     Transit Limit      :6 packets/hello                                            
     Protection Type    :None

    La información anterior muestra que SwitchA se selecciona como el root bridge en VLAN 10 y GE1/0/1 y GE1/0/3 se seleccionan como puertos designados en el estado FORWARDING.

    # Ejecute el comando display stp brief en SwitchB, SwitchC, y SwitchD para verificar el estado del puerto.

    [SwitchB] display stp brief
     VLAN-ID   Port                        Role  STP State     Protection
          10   GigabitEthernet1/0/1        ROOT  FORWARDING    NONE
          10   GigabitEthernet1/0/2        DESI  FORWARDING    NONE
          20   GigabitEthernet1/0/1        ROOT  FORWARDING    NONE
          20   GigabitEthernet1/0/2        DESI  FORWARDING    NONE
          20   GigabitEthernet1/0/3        DESI  FORWARDING    NONE
          30   GigabitEthernet1/0/1        DESI  FORWARDING    NONE
          30   GigabitEthernet1/0/3        DESI  FORWARDING    NONE
    [SwitchC] display stp brief
     VLAN-ID   Port                        Role  STP State     Protection
          10   GigabitEthernet1/0/2        ALTE  DISCARDING    NONE
          10   GigabitEthernet1/0/3        ROOT  FORWARDING    NONE
          10   GigabitEthernet1/0/4        DESI  FORWARDING    NONE
          20   GigabitEthernet1/0/2        ALTE  DISCARDING    NONE
          20   GigabitEthernet1/0/3        ROOT  FORWARDING    NONE
          20   GigabitEthernet1/0/5        DESI  FORWARDING    NONE
    [SwitchD] display stp brief
     VLAN-ID   Port                        Role  STP State     Protection
          20   GigabitEthernet1/0/2        ALTE  DISCARDING    NONE
          20   GigabitEthernet1/0/3        ROOT  FORWARDING    NONE
          20   GigabitEthernet1/0/4        DESI  FORWARDING    NONE
          30   GigabitEthernet1/0/2        ALTE  DISCARDING    NONE
          30   GigabitEthernet1/0/3        ROOT  FORWARDING    NONE
          30   GigabitEthernet1/0/5        DESI  FORWARDING    NONE

    La información anterior muestra que SwitchB participa en el cálculo del árbol de expansión en VLAN 10, VLAN 20 y VLAN 30, SwitchC participa en el cálculo del árbol de expansión en VLAN 10 y VLAN 20, y SwitchD participa en el cálculo del árbol de expansión en VLAN 20 y VLAN 30. Después de completar el cálculo, los puertos se seleccionan como roles diferentes para eliminar los bucles.

    Se forman diferentes árboles de expansión en VLAN 10, VLAN 20 y VLAN 30, y el tráfico en VLAN 10, VLAN 20 y VLAN 30 se envía a lo largo de diferentes árboles de expansión para implementar el equilibrio de carga.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 30
    #
    stp mode vbst
    stp enable
    #
    stp vlan 1 disable
    stp vlan 30 root secondary
    stp vlan 10 20 root primary
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 20 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 30
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 20
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20 30
    #
    stp mode vbst
    stp enable
    #
    stp vlan 1 disable
    stp vlan 10 20 root secondary
    stp vlan 30 root primary
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 20 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 30
    #
    return
  • Archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    stp mode vbst
    stp enable
    #
    stp vlan 1 disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 20
     stp vlan 10 20 cost 2000000
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/4
     port link-type access
     port default vlan 10
     stp edged-port enable
    #
    interface GigabitEthernet1/0/5
     port link-type access
     port default vlan 20
     stp edged-port enable
    #
    return
  • Archivo de configuración de SwitchD

    #
    sysname SwitchD
    #
    vlan batch 20 30
    #
    stp mode vbst
    stp enable
    #
    stp vlan 1 disable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 30
     stp vlan 20 30 cost 2000000
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20 30
    #
    interface GigabitEthernet1/0/4
     port link-type access
     port default vlan 20
     stp edged-port enable
    #
    interface GigabitEthernet1/0/5
     port link-type access
     port default vlan 30
     stp edged-port enable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15512

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente