No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el dispositivo como un servidor DHCP (Basado en el grupo de direcciones de la interfaz)

Ejemplo para configurar el dispositivo como un servidor DHCP (Basado en el grupo de direcciones de la interfaz)

Descripción general del servidor DHCP

Los usuarios requieren que todos los terminales en una red obtengan dinámicamente parámetros de red tales como direcciones IP, dirección IP del servidor DNS, información de enrutamiento e información del gateway. Los usuarios no deben configurar manualmente los parámetros de red, incluidas las direcciones IP de los terminales. Además, algunos terminales móviles (por ejemplo, teléfonos móviles, tabletas y computadoras portátiles) deben ser compatibles con Plug-and-Play, sin modificación en los parámetros de red cada vez. Para cumplir con estos requisitos, la función del servidor DHCP se puede configurar en un gateway de usuario de la capa de agregación o en un dispositivo de la capa de core para asignar parámetros de red, como direcciones IP, a los terminales.

El Protocolo de configuración de host dinámica (DHCP) utiliza el modo cliente/servidor para configurar dinámicamente y gestionar uniformemente los parámetros de red para los usuarios. El servidor DHCP usa un grupo de direcciones para asignar parámetros de red, como direcciones IP, a los usuarios. Se puede usar el grupo de direcciones global o un grupo de direcciones de interfaz.

La configuración de un grupo de direcciones de interfaz es simple, y solo se puede usar cuando los usuarios y el servidor DHCP pertenecen al mismo segmento de red y el servidor solo puede asignar parámetros de red a los usuarios en la interfaz. Es aplicable a redes pequeñas con un número limitado de dispositivos y una carga de trabajo de configuración y mantenimiento controlable. Después de que la función del servidor DHCP basada en el grupo de direcciones de interfaz se configura en el gateway del usuario, los hosts y los terminales móviles en la interfaz pueden obtener automáticamente parámetros de red como direcciones IP, sin configuración y modificación manual.

En comparación con un grupo de direcciones de interfaz, el grupo de direcciones global se puede aplicar a redes grandes. La función del servidor DHCP basada en el grupo global de direcciones debe configurarse en un dispositivo de core, o se debe usar un servidor DHCP exclusivo para asignar parámetros de red, como direcciones IP. El gateway de usuario solo debe estar habilitado con la función de retransmisión DHCP. Para obtener más detalles, consulte Ejemplo para configurar el dispositivo como una retransmisión DHCP (en la misma red).

Notas de configuración

Tabla 7-2  Modelos de productos y versiones aplicables

Serie

Modelo del producto

Versión del software

S2300

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI, S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 7-3, una empresa divide dos segmentos de red para terminales de oficina: 10.1.1.0/24 para empleados con terminales de oficina fija y 10.1.2.0/24 para empleados en viajes de negocios para acceder temporalmente a la red. La empresa requiere que DHCP se utilice para asignar direcciones IP a empleados con terminales de oficina fija y empleados en viajes de negocios. Un PC (DHCP Client_1) requiere una dirección IP fija 10.1.1.100/24 para cumplir con los requisitos del servicio.

Figura 7-3  Diagrama de redes para configurar el dispositivo como un servidor DHCP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

Configure la función del servidor DHCP en el Switch para asignar dinámicamente direcciones IP a los terminales en los dos segmentos de red. Configure la concesión de la dirección IP a 30 días para los empleados con terminales de oficina fija en 10.1.1.0/24 y un día para los empleados en viajes de negocios en 10.1.2.0/24 para acceder temporalmente a la red.

NOTA:

Configure los tipos de enlace de interfaz y las VLAN en LSW_1 y LSW_2 para implementar la comunicación de Capa 2.

Procedimiento

  1. Habilite el servicio DHCP. Por defecto, el servicio está deshabilitado.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] dhcp enable

  2. Agregue interfaces a las VLAN.

    # Agregue GE0/0/1 a VLAN 10.

    [Switch] vlan batch 10 to 11
    [Switch] interface gigabitethernet 0/0/1
    [Switch-GigabitEthernet0/0/1] port link-type access
    [Switch-GigabitEthernet0/0/1] port default vlan 10
    [Switch-GigabitEthernet0/0/1] quit

    # Agregue GE0/0/2 a VLAN 11.

    [Switch] interface gigabitethernet 0/0/2
    [Switch-GigabitEthernet0/0/2] port link-type access
    [Switch-GigabitEthernet0/0/2] port default vlan 11
    [Switch-GigabitEthernet0/0/2] quit

  3. Configure las direcciones IP para las interfaces VLANIF.

    # Configure una dirección IP para VLANIF 10.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 10.1.1.1 24  //Segmento de red asignado por la empresa para terminales de oficina fija
    [Switch-Vlanif10] quit

    # Configure una dirección IP para VLANIF 11.

    [Switch] interface vlanif 11
    [Switch-Vlanif11] ip address 10.1.2.1 24  //Segmento de red asignado por la empresa para empleados en viajes de negocios
    [Switch-Vlanif11] quit

  4. Configure un grupo de direcciones de interfaz.

    # Configure los terminales conectados a VLANIF 10 para obtener direcciones IP del grupo de direcciones de interfaz.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] dhcp select interface  //Habilite la función del servidor DHCP en función del grupo de direcciones de interfaz en la interfaz. Por defecto, la función está deshabilitada.
    [Switch-Vlanif10] dhcp server lease day 30  //El arrendamiento predeterminado es un día. Modifique el arrendamiento a 30 días.
    [Switch-Vlanif10] dhcp server static-bind ip-address 10.1.1.100 mac-address 286e-d488-b684  //Asigne una dirección IP fija a Client_1.
    [Switch-Vlanif10] quit

    # Configure los terminales conectados a VLANIF 11 para obtener direcciones IP del grupo de direcciones de interfaz. La concesión predeterminada (un día) se usa y no se debe configurar.

    [Switch] interface vlanif 11
    [Switch-Vlanif11] dhcp select interface  //Habilite la función del servidor DHCP en función del grupo de direcciones de interfaz en la interfaz. Por defecto, la función está deshabilitada.
    [Switch-Vlanif11] quit

  5. Habilite el dispositivo para guardar datos DHCP en el dispositivo de almacenamiento. Si se produce un error en el dispositivo, puede ejecutar el comando dhcp server database recover después de que el sistema se reinicie para restaurar los datos DHCP desde los archivos en el dispositivo de almacenamiento.

    [Switch] dhcp server database enable

  6. Configure cada terminal (usando el PC con Windows 7 como ejemplo) para obtener automáticamente una dirección IP.

    1. Haga clic con el botón derecho en Network y elija Properties para visualizar la ventana Network and Sharing Center.
    2. Haga clic en Local Area Connection para visualizar la ventana Local Area Connection Status.
    3. Haga clic en Properties para mostrar la ventana Local Area Connection Properties.
    4. Seleccione Internet Protocol Version 4 (TCP/IPv4) y haga clic en Properties para visualizar la ventana Internet Protocol Version 4 (TCP/IPv4) Properties. Seleccione Obtain an IP address automatically, y haga clic en OK.

  7. Verifique la configuración.

    Ejecute el comando display ip pool en el Switch para verificar la configuración de VLANIF 10 y VLANIF 11. Por ejemplo, la empresa tiene 100 empleados con terminales de oficina fija y 3 empleados en viajes de negocios.

    [Switch] display ip pool interface vlanif10
      Pool-name        : Vlanif10
      Pool-No          : 0
      Lease            : 30 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : -
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Interface       Status             : Unlocked
      Gateway-0        : 10.1.1.1
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :100
                         Idle        :153       Expired     :0
                         Conflict    :0         Disable     :0
    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.1.1      10.1.1.254     253     100        153(0)       0     0
     -------------------------------------------------------------------------------
    
    [Switch] display ip pool interface vlanif11
      Pool-name        : Vlanif11
      Pool-No          : 1
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : -
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Interface       Status             : Unlocked
      Gateway-0        : 10.1.2.1
      Network          : 10.1.2.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :3
                         Idle        :250       Expired     :0
                         Conflict    :0         Disable     :0
    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.2.1      10.1.2.254     253     3          250(0)       0     0
     -------------------------------------------------------------------------------

    Verifique la información de la dirección IP en Client_1 (usando el sistema operativo Windows 7). La dirección IP 10.1.1.100/24 ha sido asignada a Client_1.

    C:\Documents and Settings\Administrator>ipconfig
    
    Windows IP Configuration
    
    
    Ethernet adapter Local Area Connection 2:
    
       Connection-specific DNS Suffix  . :
       IPv4 Address. . . . . . . . . . . : 10.1.1.100
       Subnet Mask . . . . . . . . . . . : 255.255.254.0
       Default Gateway . . . . . . . . . : 10.1.1.1

    Verifique la información de la dirección IP de otro cliente DHCP (por ejemplo, un terminal perteneciente al segmento de red 10.1.1.0/24 y utilizando el sistema operativo Windows 7). Se ha asignado una dirección IP.

    C:\Documents and Settings\Administrator>ipconfig
    
    Windows IP Configuration
    
    
    Ethernet adapter Local Area Connection 2:
    
       Connection-specific DNS Suffix  . :
       IPv4 Address. . . . . . . . . . . : 10.1.1.51
       Subnet Mask . . . . . . . . . . . : 255.255.254.0
       Default Gateway . . . . . . . . . : 10.1.1.1

Archivos de configuración

Archivo de configuración del Switch

#
sysname Switch
#
vlan batch 10 to 11
#
dhcp enable
#
dhcp server database enable
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
 dhcp select interface
 dhcp server static-bind ip-address 10.1.1.100 mac-address 286e-d488-b684
 dhcp server lease day 30 hour 0 minute 0
#
interface Vlanif11
 ip address 10.1.2.1 255.255.255.0
 dhcp select interface
#
interface GigabitEthernet0/0/1
 port link-type access
 port default vlan 10
#
interface GigabitEthernet0/0/2
 port link-type access
 port default vlan 11
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15491

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente