No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un servidor DHCP para asignar diferentes parámetros de red desde el grupo global de direcciones a clientes dinámicos y estáticos

Ejemplo para configurar un servidor DHCP para asignar diferentes parámetros de red desde el grupo global de direcciones a clientes dinámicos y estáticos

Descripción general del servidor DHCP

Los usuarios requieren que todos los terminales en una red obtengan dinámicamente parámetros de red tales como direcciones IP, dirección IP del servidor DNS, información de enrutamiento e información del gateway. Los usuarios no deben configurar manualmente los parámetros de red, incluidas las direcciones IP de los terminales. Además, algunos terminales móviles (por ejemplo, teléfonos móviles, tabletas y computadoras portátiles) deben ser compatibles con Plug-and-Play, sin modificación en los parámetros de red cada vez. Para cumplir con estos requisitos, la función del servidor DHCP se puede configurar en un gateway de usuario de la capa de agregación o en un dispositivo de la capa de core para asignar parámetros de red, como direcciones IP, a los terminales.

El Protocolo de configuración de host dinámica (DHCP) utiliza el modo cliente/servidor para configurar dinámicamente y gestionar uniformemente los parámetros de red para los usuarios. El servidor DHCP usa un grupo de direcciones para asignar parámetros de red, como direcciones IP, a los usuarios. Se puede usar el grupo de direcciones global o un grupo de direcciones de interfaz.

La configuración de un grupo de direcciones de interfaz es simple, y solo se puede usar cuando los usuarios y el servidor DHCP pertenecen al mismo segmento de red y el servidor solo puede asignar parámetros de red a los usuarios en la interfaz. Es aplicable a redes pequeñas con un número limitado de dispositivos y una carga de trabajo de configuración y mantenimiento controlable. Después de que la función del servidor DHCP basada en el grupo de direcciones de interfaz se configura en el gateway del usuario, los hosts y los terminales móviles en la interfaz pueden obtener automáticamente parámetros de red como direcciones IP, sin configuración y modificación manual.

En comparación con un grupo de direcciones de interfaz, el grupo de direcciones global se puede aplicar a redes grandes. La función del servidor DHCP basada en el grupo global de direcciones debe configurarse en un dispositivo de core, o se debe usar un servidor DHCP exclusivo para asignar parámetros de red, como direcciones IP. El gateway de usuario solo debe estar habilitado con la función de retransmisión DHCP. Para obtener más detalles, consulte Ejemplo para configurar el dispositivo como una retransmisión DHCP (en la misma red).

Notas de configuración

Tabla 7-4  Modelos de productos y versiones aplicables

Serie

Modelo del producto

Versión del software

S2300

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI, S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 7-5, el teléfono IP y los PC son dispositivos en un área de oficina. Para administrar de manera uniforme los dispositivos y reducir los costos de configuración manual, el administrador debe configurar hosts para obtener direcciones IP dinámicamente a través de DHCP. Los PC son terminales fijos en la sala de tareas. Deben estar siempre en línea y usar nombres de dominio para acceder a los dispositivos de red. Además de obtener una dirección IP de forma dinámica, los PC requieren una concesión ilimitada de direcciones IP y deben obtener información sobre el servidor DNS. El teléfono IP usa una dirección IP fija 10.1.1.4/24 y su dirección MAC es dcd2-fc96-e4c0. Además de obtener una dirección IP, el teléfono IP debe obtener dinámicamente el archivo de configuración de inicio. El archivo de configuración de inicio configuration.ini se almacena en el servidor FTP. Las rutas entre el servidor FTP y el teléfono IP deben ser accesibles. La dirección del gateway de los PC y del teléfono IP es 10.1.1.1/24.

Figura 7-5  Diagrama de redes para configurar un dispositivo como servidor DHCP

Hoja de ruta de configuración

  1. Cree una plantilla de DHCP Option en SwitchA. En la vista de la plantilla de DHCP Option, configure el archivo de configuración de inicio para el teléfono IP del cliente estático, y especifique la dirección IP del servidor FTP para el teléfono IP.
  2. Cree un grupo de direcciones global en SwitchA. En la vista del grupo de direcciones global, configure la concesión de la dirección IP y la información sobre el servidor DNS para los PC del cliente dinámico. Enlace una dirección IP y la plantilla de DHCP Option a la dirección MAC del teléfono IP del cliente estático. De esta forma, el servidor DHCP puede asignar diferentes parámetros de red a clientes dinámicos y estáticos.

Procedimiento

  1. Cree una VLAN y configure una dirección IP para la interfaz VLANIF.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 255.255.255.0
    [SwitchA-Vlanif10] quit
    

  2. Habilite el servicio DHCP.

    [SwitchA] dhcp enable

  3. Cree una plantilla de DHCP Option. En la vista de la plantilla de DHCP Option, configure el archivo de configuración de inicio para el teléfono IP del cliente estático, y especifique la dirección IP del servidor de archivos para el teléfono IP.

    [SwitchA] dhcp option template template1
    [SwitchA-dhcp-option-template-template1] gateway-list 10.1.1.1
    [SwitchA-dhcp-option-template-template1] bootfile configuration.ini 
    [SwitchA-dhcp-option-template-template1] next-server 10.1.1.3
    [SwitchA-dhcp-option-template-template1] quit

  4. Cree un grupo de direcciones IP. En la vista del grupo de direcciones IP, configure la dirección del gateway, la concesión de la dirección IP, y la dirección IP del servidor DNS para los PC. Asigne una dirección IP fija al teléfono IP y configure el archivo de configuración de inicio.

    [SwitchA] ip pool pool1
    [SwitchA-ip-pool-pool1] network 10.1.1.0 mask 255.255.255.0
    [SwitchA-ip-pool-pool1] dns-list 10.1.1.2
    [SwitchA-ip-pool-pool1] gateway-list 10.1.1.1
    [SwitchA-ip-pool-pool1] excluded-ip-address 10.1.1.2 10.1.1.3
    [SwitchA-ip-pool-pool1] lease unlimited
    [SwitchA-ip-pool-pool1] static-bind ip-address 10.1.1.4 mac-address dcd2-fc96-e4c0 option-template template1 
    [SwitchA-ip-pool-pool1] quit

  5. Habilite la función del servidor DHCP en la interfaz VLANIF 10.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] dhcp select global
    [SwitchA-Vlanif10] quit

  6. Habilite el dispositivo para guardar datos DHCP en el dispositivo de almacenamiento. Si se produce un error en el dispositivo, puede ejecutar el comando dhcp server database recover después de que el sistema se reinicie para restaurar los datos DHCP de los archivos en el dispositivo de almacenamiento.

    [SwitchA] dhcp server database enable

  7. Verifique la configuración.

    # Ejecute el comando display ip pool name pool1 en SwitchA para ver la configuración del grupo de direcciones. A continuación, se usa la salida del comando en V200R011C10 como ejemplo.

    [SwitchA] display ip pool name pool1
      Pool-name        : pool1
      Pool-No          : 0
      Lease            : unlimited
      Domain-name      : -
      DNS-server0      : 10.1.1.2        
      NBNS-server0     : -               
      Netbios-type     : -               
      Position         : Local           
      Status           : Unlocked
      Gateway-0        : 10.1.1.1        
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :1          
                         Idle        :250       Expired     :0          
                         Conflict    :0         Disabled    :2      
    
     -------------------------------------------------------------------------------
      Network section 
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.1.1      10.1.1.254     253       4        249(0)       0     2
     -------------------------------------------------------------------------------

    # Ejecute el comando display dhcp option template name template1 en SwitchA para ver la configuración de la plantilla de DHCP Option.

    [SwitchA] display dhcp option template name template1
     -----------------------------------------------------------------------------  
      Template-Name  : template1                                                    
      Template-No    : 0                                                            
      Next-server    : 10.1.1.3                                                     
      Domain-name    : -                                                            
      DNS-server0    : -                                                            
      NBNS-server0   : -                                                            
      Netbios-type   : -                                                            
      Gateway-0      : 10.1.1.1                                                     
      Bootfile       : configuration.ini                                            

Archivos de configuración

Archivo de configuración de SwitchA

#
sysname SwitchA
#
vlan batch 10
#
dhcp enable
#
dhcp server database enable
#
dhcp option template template1
 gateway-list 10.1.1.1
 next-server 10.1.1.3
 bootfile configuration.ini  
#
ip pool pool1
 gateway-list 10.1.1.1
 network 10.1.1.0 mask 255.255.255.0
 excluded-ip-address 10.1.1.2 10.1.1.3
 static-bind ip-address 10.1.1.4 mac-address dcd2-fc96-e4c0 option-template template1
 lease unlimited
 dns-list 10.1.1.2
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.0
 dhcp select global
#
interface GigabitEthernet1/0/1
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10
#
return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15442

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente