No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el dispositivo como una retransmisión DHCP (en la misma red)

Ejemplo para configurar el dispositivo como una retransmisión DHCP (en la misma red)

Descripción general de la retransmisión DHCP

Una retransmisión DHCP reenvía paquetes DHCP entre el servidor DHCP y los clientes. Cuando el servidor DHCP y los clientes pertenecen a diferentes segmentos de red, la retransmisión DHCP debe configurarse. Para clientes DHCP, la retransmisión DHCP es el servidor DHCP; para el servidor DHCP, la retransmisión DHCP es un cliente DHCP.

La función de retransmisión DHCP se aplica a las redes grandes con muchos gateways de usuarios distribuidos de forma dispersa. Para reducir la carga de trabajo de mantenimiento, el administrador de red no desea configurar la función del servidor DHCP en cada switch de agregación (gateway de usuario) y requiere que la función del servidor DHCP esté configurada en un dispositivo de core o que se implemente un servidor DHCP exclusivo en el área del servidor En este caso, los switches de agregación que funcionan como los gateways de usuario deben configurarse con la función de retransmisión DHCP para implementar el intercambio de paquetes DHCP entre el servidor DHCP y los clientes.

Notas de configuración

Tabla 7-5  Modelos de productos y versiones aplicables

Serie

Modelo del producto

Versión del software

S2300

S2320EI

V200R011C10, V200R012C00

S2350EI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S3300

S3300SI, S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300LI

V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300SI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 7-6, una empresa implementa el servidor DHCP en el switch de core. El servidor DHCP y los terminales de la empresa pertenecen a diferentes segmentos de red. La empresa requiere que el servidor DHCP asigne dinámicamente direcciones IP a los terminales.

Figura 7-6  Diagrama de redes para configurar el dispositivo como una retransmisión DHCP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure la retransmisión DHCP en SwitchA (gateway de usuario) para reenviar paquetes DHCP entre los terminales y el servidor DHCP.

  2. En SwitchB, configure el servidor DHCP en función del grupo de direcciones global para que el servidor DHCP pueda asignar direcciones IP desde el grupo global de direcciones a los terminales.

NOTA:

Utilice un switch de la serie S de Huawei como ejemplo para el servidor DHCP (SwitchB).

En el LSW, configure el tipo de enlace de interfaz y la VLAN para implementar la comunicación de Capa 2.

Procedimiento

  1. Configure la retransmisión DHCP en SwitchA.

    # Agregue la interfaz a la VLAN.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 200
    [SwitchA] interface gigabitethernet 0/0/1
    [SwitchA-GigabitEthernet0/0/1] port link-type trunk
    [SwitchA-GigabitEthernet0/0/1] port trunk allow-pass vlan 200
    [SwitchA-GigabitEthernet0/0/1] quit
    [SwitchA] interface gigabitethernet 0/0/2
    [SwitchA-GigabitEthernet0/0/2] port link-type access
    [SwitchA-GigabitEthernet0/0/2] port default vlan 100
    [SwitchA-GigabitEthernet0/0/2] quit
    [SwitchA] interface vlanif 200 
    [SwitchA-Vlanif200] ip address 192.168.20.1 24
    [SwitchA-Vlanif200] quit
    

    # Habilite la función de retransmisión DHCP en la interfaz.

    [SwitchA] dhcp enable  //Habilite el servicio DHCP. Por defecto, el servicio está deshabilitado
    .
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.10.20.1 24
    [SwitchA-Vlanif100] dhcp select relay   //Habilite la función de retransmisión DHCP. Por defecto, la función está deshabilitada.
    [SwitchA-Vlanif100] dhcp relay server-ip 192.168.20.2  //Configure la dirección IP del servidor DHCP para el agente de retransmisión DHCP.
    [SwitchA-Vlanif100] quit

  2. Configure la función del servidor DHCP en función del grupo de direcciones global en SwitchB.

    # Habilite el servicio DHCP. Por defecto, el servicio está deshabilitado.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] dhcp enable

    # Configure VLANIF 200 para que funcione en el modo del grupo de direcciones global.

    [SwitchB] vlan 200 
    [SwitchB-vlan200] quit
    [SwitchB] interface gigabitethernet 0/0/1
    [SwitchB-GigabitEthernet0/0/1] port link-type trunk
    [SwitchB-GigabitEthernet0/0/1] port trunk allow-pass vlan 200
    [SwitchB-GigabitEthernet0/0/1] quit
    [SwitchB] interface vlanif 200 
    [SwitchB-Vlanif200] ip address 192.168.20.2 24
    [SwitchB-Vlanif200] dhcp select global  //Habilite la función del servidor DHCP en función del grupo de direcciones global en la interfaz. Por defecto, la función está deshabilitada.
    [SwitchB-Vlanif200] quit

    # Cree un grupo de direcciones y configure los atributos. La concesión predeterminada (un día) se usa y no se debe configurar.

    [SwitchB] ip pool pool1
    [SwitchB-ip-pool-pool1] network 10.10.20.0 mask 24  //Configure el segmento de red y la máscara del global de direcciones grupo.
    [SwitchB-ip-pool-pool1] gateway-list 10.10.20.1  //Configure la dirección del gateway asignada a los terminales.
    [SwitchB-ip-pool-pool1] quit

  3. Configure las rutas estáticas a los terminales en SwitchB.

    [SwitchB] ip route-static 10.10.20.0 255.255.255.0 192.168.20.1 
    

  4. Configure cada terminal (usando el PC con Windows 7 como ejemplo) para obtener automáticamente una dirección IP.

    1. Haga clic con el botón derecho en Network y elija Properties para visualizar la ventana Network and Sharing Center.
    2. Haga clic en Local Area Connection para visualizar la ventana Local Area Connection Status.
    3. Haga clic en Properties para visualizar la ventana Local Area Connection Properties.
    4. Seleccione Internet Protocol Version 4 (TCP/IPv4) y haga clic en Properties para visualizar la ventana Internet Protocol Version 4 (TCP/IPv4) Properties. Seleccione Obtain an IP address automatically, y haga clic en OK.

  5. Verifique la configuración.

    # Ejecute el comando display dhcp relay interface vlanif 100 en SwitchA para verificar la configuración de la retransmisión DHCP.

    [SwitchA] display dhcp relay interface vlanif 100
     DHCP relay agent running information of interface Vlanif100 : 
     Server IP address [00] : 192.168.20.2
     Gateway address in use : 10.10.20.1
    

    # Ejecute el comando display ip pool en SwitchB para verificar la asignación de la dirección IP de pool1. Por ejemplo, la empresa tiene 100 terminales. A continuación, se usa la salida del comando en V200R011C10 como ejemplo.

    [SwitchB] display ip pool name pool1
      Pool-name        : pool1
      Pool-No          : 0
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : -               
      NBNS-server0     : -               
      Netbios-type     : -               
      Position         : Local           
      Status           : Unlocked
      Gateway-0        : 10.10.20.1      
      Network          : 10.10.20.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :1          
                         Idle        :252       Expired     :0          
                         Conflict    :0         Disabled    :0      
    
     -------------------------------------------------------------------------------
      Network section 
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
          10.10.20.1    10.10.20.254     253       1        252(0)       0     0
     -------------------------------------------------------------------------------

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100 200
    #
    dhcp enable
    #
    interface Vlanif100
     ip address 10.10.20.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 192.168.20.2
    #
    interface Vlanif200
     ip address 192.168.20.1 255.255.255.0
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet0/0/2
     port link-type access
     port default vlan 100
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 200
    #
    dhcp enable
    #
    ip pool pool1
     gateway-list 10.10.20.1
     network 10.10.20.0 mask 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.20.2 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet0/0/1
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ip route-static 10.10.20.0 255.255.255.0 192.168.20.1
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15787

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente