No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el dispositivo como una retransmisión DHCP (a través de un túnel GRE)

Ejemplo para configurar el dispositivo como una retransmisión DHCP (a través de un túnel GRE)

Descripción general de la retransmisión DHCP

Una retransmisión DHCP reenvía paquetes DHCP entre el servidor DHCP y los clientes. Cuando el servidor DHCP y los clientes pertenecen a diferentes segmentos de red, la retransmisión DHCP debe configurarse. Para clientes DHCP, la retransmisión DHCP es el servidor DHCP; para el servidor DHCP, la retransmisión DHCP es un cliente DHCP.

La función de retransmisión DHCP se aplica a las redes grandes con muchos gateways de usuarios distribuidos de forma dispersa. Para reducir la carga de trabajo de mantenimiento, el administrador de red no desea configurar la función del servidor DHCP en cada switch de agregación (gateway de usuario) y requiere que la función del servidor DHCP esté configurada en un dispositivo de core o que se implemente un servidor DHCP exclusivo en el área del servidor En este caso, los switches de agregación que funcionan como los gateways de usuario deben configurarse con la función de retransmisión DHCP para implementar el intercambio de paquetes DHCP entre el servidor DHCP y los clientes.

La retransmisión DHCP y el servidor DHCP se pueden implementar a través de una red VPN (como GRE o MPLS L3VPN). Un túnel GRE se utiliza como ejemplo para describir cómo configurar una retransmisión DHCP.

Notas de configuración

Tabla 7-6  Modelos de productos y versiones aplicables

Serie

Modelo del producto

Versión del software

S5300

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 7-7, una empresa implementa su sede central y sucursal en diferentes áreas. Se implementa un túnel GRE entre la sede central y la sucursal para permitirles comunicarse a través de Internet. Para facilitar la administración unificada, el administrador de la empresa implementa el servidor DHCP en Switch_1 en la sede central para asignar direcciones IP a los terminales en la sede central y la sucursal. Los segmentos de red 10.1.1.0/24 y 10.2.1.0/24 están planificados para la sede central y la sucursal, respectivamente.

Figura 7-7  Diagrama de redes para configurar el dispositivo como una retransmisión DHCP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Ejecute OSPF entre Switch_1, Switch_2 y Switch_3 para garantizar la comunicación entre dispositivos.

  2. En Switch_1 y Switch_3, configure las interfaces del túnel y cree un túnel GRE.

  3. En Switch_1, configure el servidor DHCP en función del grupo de direcciones global para que el servidor DHCP pueda asignar direcciones IP desde el grupo global de direcciones a los terminales en la sede central y la sucursal.

  4. En Switch_3, configure la función de retransmisión DHCP para que funcione como el gateway de la sucursal para reenviar paquetes DHCP entre los terminales y los servidores DHCP para que los terminales puedan aplicar direcciones IP al servidor DHCP.

NOTA:

Use un switch de la serie S de Huawei como ejemplo para el servidor DHCP (Switch_1).

Configure los tipos de enlace de interfaz y las VLAN en LSW_1 y LSW_2 para implementar la comunicación de Capa 2.

Procedimiento

  1. Configure una dirección IP para cada interfaz física en Switch_1 a través de Switch_3.

    # Configure Switch_1.

    <Quidway> system-view
    [Quidway] sysname Switch_1
    [Switch_1] vlan batch 10 30
    [Switch_1] interface gigabitethernet 1/0/0
    [Switch_1-GigabitEthernet1/0/0] port link-type trunk
    [Switch_1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [Switch_1-GigabitEthernet1/0/0] quit
    [Switch_1] interface gigabitethernet 2/0/0
    [Switch_1-GigabitEthernet2/0/0] port link-type trunk
    [Switch_1-GigabitEthernet2/0/0] port trunk allow-pass vlan 30
    [Switch_1-GigabitEthernet2/0/0] quit
    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] ip address 20.1.1.1 24
    [Switch_1-Vlanif10] quit
    [Switch_1] interface vlanif 30
    [Switch_1-Vlanif30] ip address 10.1.1.1 24
    [Switch_1-Vlanif30] quit

    # Configure Switch_2.

    <Quidway> system-view
    [Quidway] sysname Switch_2
    [Switch_2] vlan batch 10 20
    [Switch_2] interface gigabitethernet 1/0/0
    [Switch_2-GigabitEthernet1/0/0] port link-type trunk
    [Switch_2-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [Switch_2-GigabitEthernet1/0/0] quit
    [Switch_2] interface gigabitethernet 2/0/0
    [Switch_2-GigabitEthernet2/0/0] port link-type trunk
    [Switch_2-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [Switch_2-GigabitEthernet2/0/0] quit
    [Switch_2] interface vlanif 10
    [Switch_2-Vlanif10] ip address 20.1.1.2 24
    [Switch_2-Vlanif10] quit
    [Switch_2] interface vlanif 20
    [Switch_2-Vlanif20] ip address 30.1.1.1 24
    [Switch_2-Vlanif20] quit

    # Configure Switch_3.

    <Quidway> system-view
    [Quidway] sysname Switch_3
    [Switch_3] vlan batch 20 30
    [Switch_3] interface gigabitethernet 1/0/0
    [Switch_3-GigabitEthernet1/0/0] port link-type trunk
    [Switch_3-GigabitEthernet1/0/0] port trunk allow-pass vlan 20
    [Switch_3-GigabitEthernet1/0/0] quit
    [Switch_3] interface gigabitethernet 2/0/0
    [Switch_3-GigabitEthernet2/0/0] port link-type trunk
    [Switch_3-GigabitEthernet2/0/0] port trunk allow-pass vlan 30
    [Switch_3-GigabitEthernet2/0/0] quit
    [Switch_3] interface vlanif 20
    [Switch_3-Vlanif20] ip address 30.1.1.2 24
    [Switch_3-Vlanif20] quit
    [Switch_3] interface vlanif 30
    [Switch_3-Vlanif30] ip address 10.2.1.1 24
    [Switch_3-Vlanif30] quit

  2. Ejecute OSPF entre Switch_1, Switch_2 y Switch_3.

    # Configure Switch_1.

    [Switch_1] ospf 1
    [Switch_1-ospf-1] area 0
    [Switch_1-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [Switch_1-ospf-1-area-0.0.0.0] quit
    [Switch_1-ospf-1] quit

    # Configure Switch_2.

    [Switch_2] ospf 1
    [Switch_2-ospf-1] area 0
    [Switch_2-ospf-1-area-0.0.0.0] network 20.1.1.0 0.0.0.255
    [Switch_2-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [Switch_2-ospf-1-area-0.0.0.0] quit
    [Switch_2-ospf-1] quit

    # Configure Switch_3.

    [Switch_3] ospf 1
    [Switch_3-ospf-1] area 0
    [Switch_3-ospf-1-area-0.0.0.0] network 30.1.1.0 0.0.0.255
    [Switch_3-ospf-1-area-0.0.0.0] quit
    [Switch_3-ospf-1] quit

  3. Configure rutas estáticas.

    # Configure una ruta estática al segmento de red en Switch_1.
    [Switch_1] ip route-static 10.2.1.0 255.255.255.0 tunnel 1
    # Configure una ruta estática al segmento del servidor en Switch_3.
    [Switch_3] ip route-static 10.1.1.0 255.255.255.0 tunnel 1

  4. Configure interfaces de túnel.

    # Configure Switch_1.

    [Switch_1] interface tunnel 1
    [Switch_1-Tunnel1] tunnel-protocol gre
    [Switch_1-Tunnel1] ip address 40.1.1.1 24
    [Switch_1-Tunnel1] source 20.1.1.1
    [Switch_1-Tunnel1] destination 30.1.1.2
    [Switch_1-Tunnel1] quit

    # Configure Switch_3.

    [Switch_3] interface tunnel 1
    [Switch_3-Tunnel1] tunnel-protocol gre
    [Switch_3-Tunnel1] ip address 40.1.1.2 24
    [Switch_3-Tunnel1] source 30.1.1.2
    [Switch_3-Tunnel1] destination 20.1.1.1
    [Switch_3-Tunnel1] quit

  5. Configure la función del servidor DHCP en Switch_1.

    # Habilite el servicio DHCP. Por defecto, el servicio está deshabilitado.

    [Switch_1] dhcp enable

    # Cree un grupo de direcciones global y configure parámetros relacionados.

    [Switch_1] ip pool pool1
    [Switch_1-ip-pool-pool1] network 10.2.1.0 mask 255.255.255.0  //Segmento de red para terminales en la rama
    [Switch_1-ip-pool-pool1] gateway-list 10.2.1.1  //Dirección de gateway para terminales en la rama
    [Switch_1-ip-pool-pool1] quit
    [Switch_1] ip pool pool2
    [Switch_1-ip-pool-pool2] network 10.1.1.0 mask 255.255.255.0  //Segmento de red para terminales en la sede
    [Switch_1-ip-pool-pool2] gateway-list 10.1.1.1  //Dirección de gateway para terminales en la sede
    [Switch_1-ip-pool-pool2] quit
    # Configure los terminales conectados a VLANIF30 para obtener direcciones IP del grupo de direcciones global.
    [Switch_1] interface vlanif 30
    [Switch_1-Vlanif30] dhcp select global  //Habilite la función del servidor DHCP en función del grupo de direcciones global en la interfaz. Por defecto, la función está deshabilitada.
    [Switch_1-Vlanif30] quit

  6. # Configure la función de retransmisión DHCP en Switch_3.

    # Habilite el servicio DHCP. Por defecto, el servicio está deshabilitado.

    [Switch_3] dhcp enable
    # Configure la función de retransmisión DHCP en VLANIF 30 y especifique la dirección del servidor DHCP para la retransmisión.
    [Switch_3] interface vlanif 30
    [Switch_3-Vlanif30] dhcp select relay   //Habilite la función de retransmisión DHCP. Por defecto, la función está deshabilitada.
    [Switch_3-Vlanif30] dhcp relay server-ip 10.1.1.1  //Configure la dirección IP del servidor DHCP para el agente de retransmisión DHCP.
    [Switch_3-Vlanif30] quit

  7. Configure cada terminal (usando el PC con Windows 7 como ejemplo) para obtener automáticamente una dirección IP.

    1. Haga clic con el botón derecho en Network y elija Properties para visualizar la ventana Network and Sharing Center.
    2. Haga clic en Local Area Connection para visualizar la ventana Local Area Connection Status.
    3. Haga clic en Properties para mostrar la ventana Local Area Connection Properties.
    4. Seleccione Internet Protocol Version 4 (TCP/IPv4) y haga clic en Properties para visualizar la ventana Internet Protocol Version 4 (TCP/IPv4) Properties. Seleccione Obtain an IP address automatically, y haga clic en OK.

  8. Verifique la configuración. A continuación, se usa la salida del comando en V200R010C00 como ejemplo.

    # Ejecute el comando display dhcp relay interface vlanif 30 en Switch_3 para verificar la configuración de la retransmisión DHCP.

    [Switch_3] display dhcp relay interface vlanif 30
     DHCP relay agent running information of interface Vlanif30 :
     Server IP address [00] : 10.1.1.1
     Gateway address in use : 10.2.1.1

    # Ejecute el comando display ip pool en Switch_1 para verificar la asignación de direcciones IP de pool1 y pool2. Por ejemplo, la sede central tiene 100 terminales y la sucursal tiene 50 terminales.

    [Switch_1] display ip pool name pool1
      Pool-name        : pool1
      Pool-No          : 0
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : -
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Local           Status             : Unlocked
      Gateway-0        : 10.2.1.1
      Network          : 10.2.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :50
      Idle        :203       Expired     :0
      Conflict    :0         Disable     :0
    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.2.1.1      10.2.1.254     253      50        203(0)       0     0
     -------------------------------------------------------------------------------
    [Switch_1] display ip pool name pool2
      Pool-name        : pool2
      Pool-No          : 1
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : -
      NBNS-server0     : -
      Netbios-type     : -
      Position         : Local           Status             : Unlocked
      Gateway-0        : 10.1.1.1
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :50
      Idle        :203       Expired     :0
      Conflict    :0         Disable     :0
    
     -------------------------------------------------------------------------------
      Network section
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
            10.1.1.1      10.1.1.254     253     100        153(0)       0     0
     -------------------------------------------------------------------------------

Archivos de configuración

  • Archivo de configuración de Switch_1

    #
    sysname Switch_1
    #
    vlan batch 10 30
    #
    dhcp enable
    # 
    ip pool pool1
     gateway-list 10.2.1.1
     network 10.2.1.0 mask 255.255.255.0
    # 
    ip pool pool2
     gateway-list 10.1.1.1
     network 10.1.1.0 mask 255.255.255.0
    # 
    interface Vlanif10
     ip address 20.1.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface Tunnel1
     ip address 40.1.1.1 255.255.255.0
     tunnel-protocol gre
     source 20.1.1.1
     destination 30.1.1.2
    #
    ospf 1
     area 0.0.0.0
      network 20.1.1.0 0.0.0.255
    #
    ip route-static 10.2.1.0 255.255.255.0 Tunnel1
    #
    return
  • Archivo de configuración de Switch_2

    #
    sysname Switch_2
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 20.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 30.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1
     area 0.0.0.0
      network 20.1.1.0 0.0.0.255
      network 30.1.1.0 0.0.0.255
    #
    return
  • Archivo de configuración de Switch_3

    #
    sysname Switch_3
    #
    vlan batch 20 30
    #
    dhcp enable
    # 
    interface Vlanif20
     ip address 30.1.1.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.2.1.1 255.255.255.0
     dhcp select relay
     dhcp relay server-ip 10.1.1.1  
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface Tunnel1
     ip address 40.1.1.2 255.255.255.0
     tunnel-protocol gre
     source 30.1.1.2
     destination 20.1.1.1
    #
    ospf 1
     area 0.0.0.0
      network 30.1.1.0 0.0.0.255
    #
    ip route-static 10.1.1.0 255.255.255.0 Tunnel1
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15693

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente