No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un cliente DHCP

Ejemplo para configurar un cliente DHCP

Descripción general del cliente DHCP

Un dispositivo puede funcionar como un cliente DHCP y obtener dinámicamente los parámetros de red, incluida la dirección IP de un servidor DHCP. Este mecanismo reduce los costos manuales, reduce los errores y facilita la administración unificada.

Notas de configuración

Este ejemplo se aplica a:
  • Switches chasis: V200R005 y versiones posteriores
  • Switches fijos: V100R006 y versiones posteriores
NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 7-8, Switch_1 funciona como el cliente DHCP para obtener dinámicamente información que incluye la dirección IP, la dirección del servidor DNS y la dirección del gateway del servidor DHCP (Switch_2).

Figura 7-8  Diagrama de redes para configurar un dispositivo como servidor DHCP

Hoja de ruta de configuración

  1. Configure Switch_1 como el cliente DHCP para obtener dinámicamente la dirección IP de un servidor DHCP.
  2. Configure Switch_2 como el servidor DHCP para asignar dinámicamente los parámetros de red, incluidas las direcciones IP, a Switch_1.

Procedimiento

  1. Configure Switch_1 como el cliente DHCP.

    # Cree VLAN 10 y agregue GE1/0/1 a VLAN 10.

    <Quidway> system-view
    [Quidway] sysname Switch_1
    [Switch_1] vlan 10
    [Switch_1-vlan10] quit
    [Switch_1] interface gigabitethernet 1/0/1
    [Switch_1-GigabitEthernet1/0/1] port link-type trunk
    [Switch_1-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [Switch_1-GigabitEthernet1/0/1] quit

    # Habilite la función del cliente DHCP en VLANIF 10.

    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] ip address dhcp-alloc
    [Switch_1-Vlanif10] quit

  2. Cree un grupo de direcciones global en Switch_2 y establezca los atributos correspondientes.
    1. Habilite el servicio DHCP.

      <Quidway> system-view
      [Quidway] sysname Switch_2
      [Switch_2] dhcp enable

    2. Cree VLAN 10 y agregue GE1/0/1 a VLAN 10.

      [Switch_2] vlan 10
      [Switch_2-vlan10] quit
      [Switch_2] interface gigabitethernet 1/0/1
      [Switch_2-GigabitEthernet1/0/1] port link-type trunk
      [Switch_2-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
      [Switch_2-GigabitEthernet1/0/1] quit

    3. Configure VLANIF 10 para que funcione en el modo de grupo de direcciones global.

      [Switch_2] interface vlanif 10
      [Switch_2-Vlanif10] ip address 192.168.1.1 24
      [Switch_2-Vlanif10] dhcp select global
      [Switch_2-Vlanif10] quit

    4. Cree un grupo de direcciones y establezca los atributos correspondientes.

      [Switch_2] ip pool pool1
      [Switch_2-ip-pool-pool1] network 192.168.1.0 mask 24
      [Switch_2-ip-pool-pool1] gateway-list 192.168.1.126
      [Switch_2-ip-pool-pool1] dns-list 192.168.1.2
      [Switch_2-ip-pool-pool1] excluded-ip-address 192.168.1.2
      [Switch_2-ip-pool-pool1] quit

  3. Verifique la configuración.

    # Ejecute el comando display this en VLANIF 10 de Switch_1 para ver la configuración del cliente DHCP.

    [Switch_1] interface vlanif 10
    [Switch_1-Vlanif10] display this
    #
    interface Vlanif10
     ip address dhcp-alloc
    #
    return
    [Switch_1-Vlanif10] quit
    

    # Después de que VLANIF 10 obtenga una dirección IP, ejecute el comando display dhcp client en Switch_1 para ver el estado del cliente DHCP en VLANIF 10. A continuación se usa la salida del comando en V200R011C10 como ejemplo.

    [Switch_1] display dhcp client
    DHCP client lease information on interface Vlanif10 :                                                                               
     Current machine state         : Bound                                                                                              
     Internet address assigned via : DHCP                                                                                               
     Physical address              : 0487-ea01-0506                                                                                     
     IP address                    : 192.168.1.162                                                                                      
     Subnet mask                   : 255.255.255.0                                                                                      
     Gateway ip address            : 192.168.1.126                                                                                      
     DHCP server                   : 192.168.1.1                                                                                        
     Lease obtained at             : 2017-06-23 14:52:40                                                                                
     Lease expires at              : 2017-06-24 14:52:40                                                                                
     Lease renews at               : 2017-06-24 02:52:40                                                                                
     Lease rebinds at              : 2017-06-24 11:52:40                                                                                
     DNS                           : 192.168.1.2

    # En Switch_2, ejecute el comando display ip pool name pool1 para ver la asignación de direcciones IP en el grupo de direcciones. El campo Used muestra la cantidad de direcciones IP usadas en el grupo de direcciones. A continuación, se usa la salida del comando en V200R011C10 como ejemplo.

    [Switch_2] display ip pool name pool1
      Pool-name        : pool1
      Pool-No          : 0
      Lease            : 1 Days 0 Hours 0 Minutes
      Domain-name      : -
      DNS-server0      : 192.168.1.2     
      NBNS-server0     : -               
      Netbios-type     : -               
      Position         : Local           
      Status           : Unlocked
      Gateway-0        : 192.168.1.126   
      Network          : 192.168.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Logging          : Disable
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :1          
                         Idle        :251       Expired     :0          
                         Conflict    :0         Disabled    :1      
    
     -------------------------------------------------------------------------------
      Network section 
             Start           End       Total    Used Idle(Expired) Conflict Disabled
     -------------------------------------------------------------------------------
         192.168.1.1   192.168.1.254     253       1        251(0)       0     1
     -------------------------------------------------------------------------------

Archivos de configuración

  • Archivo de configuración de Switch_1

    #
    sysname Switch_1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address dhcp-alloc
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
  • Archivo de configuración de Switch_2

    #
    sysname Switch_2
    #
    vlan batch 10
    #
    dhcp enable
    #
    ip pool pool1
     gateway-list 192.168.1.126
     network 192.168.1.0 mask 255.255.255.0
     excluded-ip-address 192.168.1.2
     dns-list 192.168.1.2
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
     dhcp select global
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15668

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente