No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar servidores DHCP basados ​​en el grupo de direcciones global en el mismo segmento de red en redes VRRP

Ejemplo para configurar servidores DHCP basados ​​en el grupo de direcciones global en el mismo segmento de red en redes VRRP

Descripción general del servidor DHCP

Los usuarios requieren que todos los terminales en una red obtengan dinámicamente parámetros de red tales como direcciones IP, dirección IP del servidor DNS, información de enrutamiento e información del gateway. Los usuarios no deben configurar manualmente los parámetros de red, incluidas las direcciones IP de los terminales. Además, algunos terminales móviles (por ejemplo, teléfonos móviles, tabletas y computadoras portátiles) deben ser compatibles con Plug-and-Play, sin modificación en los parámetros de red cada vez. Para cumplir con estos requisitos, la función del servidor DHCP se puede configurar en un gateway de usuario de la capa de agregación o en un dispositivo de la capa de core para asignar parámetros de red, como direcciones IP, a los terminales.

El Protocolo de configuración de host dinámica (DHCP) utiliza el modo cliente/servidor para configurar dinámicamente y gestionar uniformemente los parámetros de red para los usuarios. El servidor DHCP usa un grupo de direcciones para asignar parámetros de red, como direcciones IP, a los usuarios. Se puede usar el grupo de direcciones global o un grupo de direcciones de interfaz.

La configuración de un grupo de direcciones de interfaz es simple, y solo se puede usar cuando los usuarios y el servidor DHCP pertenecen al mismo segmento de red y el servidor solo puede asignar parámetros de red a los usuarios en la interfaz. Es aplicable a redes pequeñas con un número limitado de dispositivos y una carga de trabajo de configuración y mantenimiento controlable. Después de que la función del servidor DHCP basada en el grupo de direcciones de interfaz se configura en el gateway del usuario, los hosts y los terminales móviles en la interfaz pueden obtener automáticamente parámetros de red como direcciones IP, sin configuración y modificación manual.

En comparación con un grupo de direcciones de interfaz, el grupo de direcciones global se puede aplicar a redes grandes. La función del servidor DHCP basada en el grupo global de direcciones debe configurarse en un dispositivo de core, o se debe usar un servidor DHCP exclusivo para asignar parámetros de red, como direcciones IP. El gateway de usuario solo debe estar habilitado con la función de retransmisión DHCP. Para obtener más detalles, consulte Ejemplo para configurar el dispositivo como una retransmisión DHCP (en la misma red).

Notas de configuración

Tabla 7-7  Modelos de productos y versiones aplicables

Serie

Modelo del producto

Versión del software

S2300

S2320EI

V200R011C10, V200R012C00

S3300

S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320LI

V200R010C00, V200R011C10, V200R012C00

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320SI

V200R011C10, V200R012C00

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306, S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E, S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 7-9, un host en una empresa está dual-homed a SwitchA y SwitchB a través de Switch. SwitchA funciona como servidor maestro DHCP para asignar direcciones IP al host. Si falla el servidor maestro DHCP, un servidor DHCP de reserva debe asignar una dirección IP al host.

Figura 7-9  Diagrama de redes para configurar un dispositivo como servidor DHCP

Hoja de ruta de configuración

La hoja de ruta de configuración es la siguiente:

  1. Configure las direcciones IP para las interfaces que conectan SwitchA y SwitchB para implementar la conectividad de la capa de red. Configure Switch para transmitir transparentemente paquetes de Capa 2.
  2. Configure un grupo VRRP en SwitchA y SwitchB. SwitchA tiene una prioridad más alta y funciona como el servidor DHCP para asignar direcciones IP a los clientes. SwitchB tiene una prioridad más baja y funciona como un servidor de reserva DHCP.
  3. Cree grupos de direcciones globales en SwitchA y SwitchB, y establezca los atributos correspondientes.
  4. Configure un protocolo de prevención de bucle en Switch, SwitchA y SwitchB para evitar bucles. En este ejemplo, STP está configurado.

Procedimiento

  1. Configure la conectividad de la capa de red entre los dispositivos.

    # Configure las direcciones IP para las interfaces que conectan SwitchA y SwitchB. SwitchA se usa como ejemplo. La configuración en SwitchB es similar a la de SwitchA. Para más detalles, vea el archivo de configuración de SwitchB.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/5
    [SwitchA-GigabitEthernet1/0/5] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/5] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/5] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    

    # Configure la transmisión transparente de Capa 2 en Switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type access
    [Switch-GigabitEthernet1/0/3] port default vlan 100
    [Switch-GigabitEthernet1/0/3] quit
    

  2. Cree grupos de direcciones y establezca los atributos correspondientes.

    # Habilite DHCP en SwitchA.

    [SwitchA] dhcp enable

    # Cree un grupo de direcciones en SwitchA y especifique un rango de direcciones IP de 10.1.1.2 a 10.1.1.128, que es exclusivo del rango de direcciones IP del grupo de direcciones en SwitchB.

    NOTA:

    La información sobre el grupo de direcciones en el servidor maestro DHCP no se puede respaldar en un servidor DHCP de reserva en tiempo real. Para evitar conflictos de direcciones IP después de una conmutación maestra/de reserva, asegúrese de que los rangos del grupo de direcciones en los servidores DHCP maestro y de reserva sean exclusivos entre sí.

    [SwitchA] ip pool 1
    [SwitchA-ip-pool-1] network 10.1.1.0 mask 255.255.255.0
    [SwitchA-ip-pool-1] gateway-list 10.1.1.111
    [SwitchA-ip-pool-1] excluded-ip-address 10.1.1.1
    [SwitchA-ip-pool-1] excluded-ip-address 10.1.1.129 10.1.1.254
    [SwitchA-ip-pool-1] lease day 10
    [SwitchA-ip-pool-1] quit

    # Cree un grupo de direcciones en SwitchB y especifique un rango de direcciones IP de 10.1.1.130 to 10.1.1.254, que es exclusivo del rango de direcciones IP del grupo de direcciones en SwitchA.

    [SwitchB] dhcp enable
    [SwitchB] ip pool 1
    [SwitchB-ip-pool-1] network 10.1.1.0 mask 255.255.255.0
    [SwitchB-ip-pool-1] gateway-list 10.1.1.111
    [SwitchB-ip-pool-1] excluded-ip-address 10.1.1.1 10.1.1.110
    [SwitchB-ip-pool-1] excluded-ip-address 10.1.1.112 10.1.1.129
    [SwitchB-ip-pool-1] lease day 10
    [SwitchB-ip-pool-1] quit

  3. Configure un grupo VRRP.

    # Cree el grupo 1 de VRRP en SwitchA, establezca la prioridad de SwitchA en el grupo VRRP a 120, y configure clientes para obtener direcciones IP desde un grupo de direcciones global.

    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [SwitchA-Vlanif100] vrrp vrid 1 priority 120
    [SwitchA-Vlanif100] dhcp select global
    [SwitchA-Vlanif100] quit

    # Cree el grupo 1 de VRRP en SwitchB, establezca la prioridad de SwitchB en el grupo VRRP a 100 (predeterminado), y configure clientes para obtener direcciones IP desde un grupo global de direcciones.

    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [SwitchB-Vlanif100] dhcp select global
    [SwitchB-Vlanif100] quit

  4. Configure STP para evitar bucles.

    # Habilite STP globalmente en Switch. Las configuraciones en SwitchA y SwitchB son similares a las de Switch. Para más detalles, vea los archivos de configuración de SwitchA y SwitchB.

    [Switch] stp enable

    # Deshabilite STP en GE1/0/3 de Switch, y establezca el costo de ruta de GE1/0/1 a 20000.

    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] stp disable
    [Switch-GigabitEthernet1/0/3] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] stp cost 20000
    [Switch-GigabitEthernet1/0/1] quit
    

  5. Verifique la configuración.

    # Ejecuta el comando display vrrp en SwitchA y SwitchB. La salida del comando muestra que SwitchA es Master y SwitchB es Backup en el grupo VRRP.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2017-01-12 20:15:46
        Last change time : 2017-01-12 20:15:46
    
    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2017-01-12 20:15:46
        Last change time : 2017-01-12 20:15:46

    # Ejecuta el comando display ip pool en SwitchA y SwitchB. El resultado del comando muestra que SwitchA, pero no SwitchB, asignó correctamente una dirección IP al cliente. A continuación, se usa la salida del comando en V200R011C10 como ejemplo.

    [SwitchA] display ip pool
     -------------------------------------------------------------------------------
      Pool-name        : 1
      Pool-No          : 0
      Lease            : 10 Days 0 Hours 0 Minutes
      Position         : Local
      Status           : Unlocked
      Gateway-0        : 10.1.1.111
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :1
                         Idle        :125       Expired     :0
                         Conflict    :0         Disable     :127
    
    
      IP address Statistic
        Total       :253
        Used        :1          Idle        :125
        Expired     :0          Conflict    :0          Disable   :127
    
    [SwitchB] display ip pool
     -------------------------------------------------------------------------------
      Pool-name        : 1
      Pool-No          : 0
      Lease            : 10 Days 0 Hours 0 Minutes
      Position         : Local
      Status           : Unlocked
      Gateway-0        : 10.1.1.111
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :0
                         Idle        :125       Expired     :0
                         Conflict    :0         Disable     :128
    
    
      IP address Statistic
        Total       :253
        Used        :0          Idle        :125
        Expired     :0          Conflict    :0          Disable   :128
    

    # Ejecute el comando shutdown en GE1/0/2 y GE1/0/5 de SwitchA para simular un fallo.

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] shutdown
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/5
    [SwitchA-GigabitEthernet1/0/5] shutdown
    [SwitchA-GigabitEthernet1/0/5] quit

    # Ejecuta el comando display vrrp en SwitchA y SwitchB. La salida del comando muestra que SwitchA es Initialize y SwitchB es Master en el grupo VRRP.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Initialize
        Virtual IP : 10.1.1.111
        Master IP : 0.0.0.0
        PriorityRun : 120
        PriorityConfig : 120
        MasterPriority : 0
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE
        Virtual MAC : 0000-5e00-0101
        Check TTL : YES
        Config type : normal-vrrp
        Backup-forward : disabled
        Create time : 2017-01-12 20:15:46
        Last change time : 2017-01-12 20:15:46
    
    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.129
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 100                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2017-01-12 20:15:46
        Last change time : 2017-01-12 20:15:46
    

    # Ejecute el comando display ip pool en SwitchB para ver la configuración del grupo de direcciones.

    [SwitchB] display ip pool
      Pool-name        : 1
      Pool-No          : 0
      Lease            : 10 Days 0 Hours 0 Minutes
      Position         : Local
      Status           : Unlocked
      Gateway-0        : 10.1.1.111
      Network          : 10.1.1.0
      Mask             : 255.255.255.0
      VPN instance     : --
      Conflicted address recycle interval: -
      Address Statistic: Total       :253       Used        :1
                         Idle        :124       Expired     :0
                         Conflict    :0         Disabled    :128
    
    
      IP address Statistic
        Total       :253
        Used        :1          Idle        :124
        Expired     :0          Conflict    :0          Disabled  :128

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100
    #
    dhcp enable
    #
    ip pool 1
     gateway-list 10.1.1.111
     network 10.1.1.0 mask 255.255.255.0
     excluded-ip-address 10.1.1.1
     excluded-ip-address 10.1.1.129 10.1.1.254
     lease day 10 hour 0 minute 0
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
     dhcp select global
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/5
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100
    #
    dhcp enable
    #
    ip pool 1
     gateway-list 10.1.1.111
     network 10.1.1.0 mask 255.255.255.0
     excluded-ip-address 10.1.1.1 10.1.1.110
     excluded-ip-address 10.1.1.112 10.1.1.129
     lease day 10 hour 0 minute 0
    #
    interface Vlanif100
     ip address 10.1.1.129 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     dhcp select global
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/5
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
  • Archivo de configuración de Switch

    #
    sysname Switch
    #
    vlan batch 100
    #
    stp enable
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     stp instance 0 cost 20000
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 100
     stp disable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15782

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente