No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar rutas estáticas para el interfuncionamiento entre diferentes segmentos de red

Ejemplo para configurar rutas estáticas para el interfuncionamiento entre diferentes segmentos de red

Descripción general de la ruta estática

Las rutas estáticas usan menos ancho de banda que las rutas dinámicas y no usan recursos de la CPU para el cálculo de ruta y el análisis de actualización. Los administradores los configuran manualmente. Si se produce un error de red o cambios de la topología, las rutas estáticas deben reconfigurarse manualmente ya que no se pueden actualizar automáticamente. Las rutas estáticas tienen cinco parámetros: dirección IP de destino (destination IP address), máscara (mask), interfaz de salida (outbound interface), siguiente salto (next hop)y prioridad (priority).

Las rutas estáticas son generalmente instaladas para redes simples. Sin embargo, pueden usarse en redes complejas para mejorar el rendimiento de la red y garantizar el ancho de banda para aplicaciones importantes.

Notas de configuración

  • La comunicación entre dos dispositivos es bidireccional, por lo que las rutas accesibles deben estar disponibles en ambas direcciones. Para permitir que dos dispositivos se comuniquen a través de rutas estáticas, configure una ruta estática en el dispositivo local y luego configure una ruta de retorno en el dispositivo par.
  • Si una red empresarial tiene dos salidas, se pueden configurar dos rutas estáticas de igual costo para el equilibrio de carga. En este caso, se pueden configurar dos rutas estáticas no equivalentes para la copia de seguridad activa/standby. Cuando el enlace activo es defectuoso, el tráfico pasa del enlace activo al enlace standby.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

Como se muestra en Figura 8-1, los hosts en diferentes segmentos de red están conectados mediante varios switches. Cada dos hosts en diferentes segmentos de red pueden comunicarse mutualmente sin usar protocolos de enrutamiento dinámico.

Figura 8-1  Diagrama de redes de configuración de rutas estáticas para el interfuncionamiento entre diferentes segmentos de red

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Crea VLAN, agregue interfaces a las VLAN y asigne direcciones IPv4 a las interfaces VLANIF para que los dispositivos vecinos puedan comunicarse mutualmente.
  2. Configure el gateway predeterminado de IPv4 en cada host y configure rutas estáticas IPv4 o rutas estáticas predeterminadas en cada Switch para que los hosts en diferentes segmentos de red puedan comunicarse mutualmente.

Procedimiento

  1. Crea VLAN y agregue interfaces a las VLAN.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 30
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Asigne direcciones IPv4 a las interfaces VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.4.1 30
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.1.1.1 24
    [SwitchA-Vlanif30] quit

  3. Configure hosts.

    Establezca las direcciones del gateway predeterminado de PC1, PC2 y PC3 a 10.1.1.1, 10.1.2.1 y 10.1.3.1 respectivamente.

  4. Configure rutas estáticas.

    # Configure una ruta IPv4 predeterminada en SwitchA.

    [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.1.4.2

    # Configure dos rutas estáticas de IPv4 en SwitchB.

    [SwitchB] ip route-static 10.1.1.0 255.255.255.0 10.1.4.1
    [SwitchB] ip route-static 10.1.3.0 255.255.255.0 10.1.4.6

    # Configurar una ruta IPv4 predeterminada en SwitchC.

    [SwitchC] ip route-static 0.0.0.0 0.0.0.0 10.1.4.5

  5. Verifique la configuración.

    # Compruebe la tabla de enrutamiento IP en SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7
     
    Destination/Mask    Proto  Pre  Cost   Flags   NextHop      Interface
     
            0.0.0.0/0    Static 60   0        RD    10.1.4.2     Vlanif10
            10.1.1.0/24  Direct 0    0         D    10.1.1.1     Vlanif30
            10.1.1.1/32  Direct 0    0         D    127.0.0.1    Vlanif30
            10.1.4.0/30  Direct 0    0         D    10.1.4.1     Vlanif10
            10.1.4.1/32  Direct 0    0         D    127.0.0.1    Vlanif10
          127.0.0.0/8    Direct 0    0         D    127.0.0.1    InLoopBack0
          127.0.0.1/32   Direct 0    0         D    127.0.0.1    InLoopBack0
    

    # Ejecute el comando ping para verificar la conectividad.

    [SwitchA] ping 10.1.3.1
      PING 10.1.3.1: 56  data bytes, press CTRL_C to break
        Reply from 10.1.3.1: bytes=56 Sequence=1 ttl=253 time=62 ms
        Reply from 10.1.3.1: bytes=56 Sequence=2 ttl=253 time=63 ms
        Reply from 10.1.3.1: bytes=56 Sequence=3 ttl=253 time=63 ms
        Reply from 10.1.3.1: bytes=56 Sequence=4 ttl=253 time=62 ms
        Reply from 10.1.3.1: bytes=56 Sequence=5 ttl=253 time=62 ms
    
      --- 10.1.3.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 62/62/63 ms

    # Ejecute el comando tracert para verificar la conectividad.

    [SwitchA] tracert 10.1.3.1
     traceroute to  10.1.3.1(10.1.3.1), max hops: 30 ,packet length: 40,press CTRL_C to break
     1 10.1.4.2 31 ms  32 ms  31 ms
     2 10.1.3.1 62 ms  63 ms  62 ms

Archivos de configuración

  • El Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 10.1.4.1 255.255.255.252
    #
    interface Vlanif30
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 30
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.4.2
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20 40
    #
    interface Vlanif10
     ip address 10.1.4.2 255.255.255.252
    #
    interface Vlanif20
     ip address 10.1.4.5 255.255.255.252
    #
    interface Vlanif40
     ip address 10.1.2.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/3
     port link-type access
     port default vlan 40
    #
    ip route-static 10.1.1.0 255.255.255.0 10.1.4.1
    ip route-static 10.1.3.0 255.255.255.0 10.1.4.6
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 50
    #
    interface Vlanif20
     ip address 10.1.4.6 255.255.255.252
    #
    interface Vlanif50
     ip address 10.1.3.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 50
    #
    ip route-static 0.0.0.0 0.0.0.0 10.1.4.5
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15591

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente