No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar rutas estáticas para equilibrio de carga

Ejemplo para configurar rutas estáticas para equilibrio de carga

Descripción general de la ruta estática

Las rutas estáticas usan menos ancho de banda que las rutas dinámicas y no usan recursos de la CPU para el cálculo de ruta y el análisis de actualización. Los administradores los configuran manualmente. Si se produce un error de red o cambios de la topología, las rutas estáticas deben reconfigurarse manualmente ya que no se pueden actualizar automáticamente. Las rutas estáticas tienen cinco parámetros: dirección IP de destino (destination IP address), máscara (mask), interfaz de salida (outbound interface), siguiente salto (next hop)y prioridad (priority).

Las rutas estáticas son generalmente instaladas para redes simples. Sin embargo, pueden usarse en redes complejas para mejorar el rendimiento de la red y garantizar el ancho de banda para aplicaciones importantes.

Notas de configuración

  • La comunicación entre dos dispositivos es bidireccional, por lo que las rutas accesibles deben estar disponibles en ambas direcciones. Para permitir que dos dispositivos se comuniquen a través de rutas estáticas, configure una ruta estática en el dispositivo local y luego configure una ruta de retorno en el dispositivo par.
  • Si una red empresarial tiene dos salidas, se pueden configurar dos rutas estáticas de igual costo para el equilibrio de carga. En este caso, se pueden configurar dos rutas estáticas no equivalentes para la copia de seguridad activa/standby. Cuando el enlace activo es defectuoso, el tráfico pasa del enlace activo al enlace standby.
  • Tabla 8-1 enumera los productos aplicables y las versiones de este ejemplo de configuración.
    Tabla 8-1  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S3300

    S3300SI/S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300SI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En la red que se muestra en Figura 8-2, PC1 y PC2 están conectados a través de cuatro switches. El tráfico de datos se puede transmitir desde PC1 a PC2 a través de dos enlaces: PC1->SwitchA->SwitchB->SwitchC->PC2 y PC1->SwitchA->SwitchD->SwitchC->PC2. Para mejorar la eficacia del enlace, los usuarios desean desplegar el equilibrio de carga entre los dos enlaces. Es decir, el tráfico de PC1 a PC2 está equilibrado igualmente entre los dos enlaces. Cuando ocurren fallas en uno de los dos enlaces, el tráfico se cambia automáticamente al otro enlace.

NOTA:

En este escenario, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado. Si STP está habilitado y las interfaces VLANIF de los switches se utilizan para construir una red de anillo de Capa 3, una interfaz en la red se bloqueará. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 8-2  Configure rutas estáticas para el equilibrio de carga

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Crea VLAN, agregue interfaces a las VLAN y asigne direcciones IP a las interfaces VLANIF.
  2. Configure las rutas estáticas en dos direcciones de tráfico de datos.
  3. Configure la dirección IP y las puertas de enlace predeterminadas para los hosts.

Procedimiento

  1. Especifique las VLAN a las que pertenecen las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 100 400
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 400
    [SwitchA-GigabitEthernet1/0/3] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 192.168.12.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 192.168.14.1 24
    [SwitchA-Vlanif400] quit

  3. Configure las rutas estáticas desde PC1 a PC2.

    # En SwitchA, configure dos rutas estáticas de igual costo. El próximo salto de una ruta apunta a SwitchB, y la de la otra ruta apunta a SwitchD. Esta configuración puede desplegar el equilibrio de carga para el tráfico de PC1 a PC2.

    [SwitchA] ip route-static 10.1.2.0 24 192.168.12.2
    [SwitchA] ip route-static 10.1.2.0 24 192.168.14.2

    # Configure SwitchB.

    [SwitchB] ip route-static 10.1.2.0 24 192.168.23.2

    # Configure SwitchD.

    [SwitchD] ip route-static 10.1.2.0 24 192.168.34.1

  4. Configure las rutas estáticas desde PC2 a PC1.

    # En SwitchC, configure dos rutas estáticas de igual costo. El próximo salto de una ruta apunta a SwitchB, y la de la otra ruta apunta a SwitchD. Esta configuración puede desplegar el equilibrio de carga para el tráfico de PC2 a PC1.

    [SwitchC] ip route-static 10.1.1.0 24 192.168.23.1
    [SwitchC] ip route-static 10.1.1.0 24 192.168.34.2

    # Configure SwitchB.

    [SwitchB] ip route-static 10.1.1.0 24 192.168.12.1

    # Configure SwitchD.

    [SwitchD] ip route-static 10.1.1.0 24 192.168.14.1

  5. Configure hosts.

    Asigne la dirección IP 10.1.1.2/24 y la dirección IP del gateway predeterminado 10.1.1.1 al PC1; asigne la dirección IP 10.1.2.2/24 y la dirección IP del gateway predeterminado 10.1.2.1 al PC2.

  6. Verifique la configuración.

    # Compruebe la tabla de enrutamiento IP en SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 9        Routes : 10       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.1.2.0/24  Static  60   0          RD   192.168.12.2    Vlanif100
                        Static  60   0          RD   192.168.14.2    Vlanif400
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
       192.168.12.0/24  Direct  0    0           D   192.168.12.1    Vlanif100
       192.168.12.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
       192.168.14.0/24  Direct  0    0           D   192.168.14.1    Vlanif400
       192.168.14.1/32  Direct  0    0           D   127.0.0.1       Vlanif400

    La tabla de enrutamiento de IP en SwitchA contiene dos rutas de igual costo para el segmento de red 10.1.2.0/24. En esta situación, el tráfico de datos se equilibra igualmente entre dos enlaces diferentes, logrando el equilibrio de carga.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 100 400
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif100
     ip address 192.168.12.1 255.255.255.0
    #
    interface Vlanif400
     ip address 192.168.14.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    ip route-static 10.1.2.0 255.255.255.0 192.168.12.2
    ip route-static 10.1.2.0 255.255.255.0 192.168.14.2
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 192.168.12.2 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.23.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ip route-static 10.1.1.0 255.255.255.0 192.168.12.1
    ip route-static 10.1.2.0 255.255.255.0 192.168.23.2
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 200 300
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.23.2 255.255.255.0
    #
    interface Vlanif300
     ip address 192.168.34.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ip route-static 10.1.1.0 255.255.255.0 192.168.23.1
    ip route-static 10.1.1.0 255.255.255.0 192.168.34.2
    #
    return
  • El archivo de configuración SwitchD

    #
    sysname SwitchD
    #
    vlan batch 300 400
    #
    interface Vlanif300
     ip address 192.168.34.2 255.255.255.0
    #
    interface Vlanif400
     ip address 192.168.14.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ip route-static 10.1.1.0 255.255.255.0 192.168.14.1
    ip route-static 10.1.2.0 255.255.255.0 192.168.34.1
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15783

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente