No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar rutas estáticas para la copia de seguridad del enlace

Ejemplo para configurar rutas estáticas para la copia de seguridad del enlace

Descripción general de la ruta estática

Las rutas estáticas usan menos ancho de banda que las rutas dinámicas y no usan recursos de la CPU para el cálculo de ruta y el análisis de actualización. Los administradores los configuran manualmente. Si se produce un error de red o cambios de la topología, las rutas estáticas deben reconfigurarse manualmente ya que no se pueden actualizar automáticamente. Las rutas estáticas tienen cinco parámetros: dirección IP de destino (destination IP address), máscara (mask), interfaz de salida (outbound interface), siguiente salto (next hop) y prioridad (priority).

Las rutas estáticas son generalmente instaladas para redes simples. Sin embargo, pueden usarse en redes complejas para mejorar el rendimiento de la red y garantizar el ancho de banda para aplicaciones importantes.

Notas de configuración

  • La comunicación entre dos dispositivos es bidireccional, por lo que las rutas accesibles deben estar disponibles en ambas direcciones. Para permitir que dos dispositivos se comuniquen a través de rutas estáticas, configure una ruta estática en el dispositivo local y luego configure una ruta de retorno en el dispositivo par.
  • Si una red empresarial tiene dos salidas, se pueden configurar dos rutas estáticas de igual costo para el equilibrio de carga. En este caso, se pueden configurar dos rutas estáticas no equivalentes para la copia de seguridad activa/standby. Cuando el enlace activo es defectuoso, el tráfico pasa del enlace activo al enlace standby.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

En la red que se muestra en Figura 8-3, PC1 y PC2 están conectados a través de cuatro switches. El tráfico de datos de PC1 puede llegar a PC2 a través de dos enlaces: PC1->SwitchA->SwitchB->SwitchC->PC2 y PC1->SwitchA->SwitchD->SwitchC->PC2. Para mejorar la fiabilidad, los usuarios desean desplegar una copia de seguridad entre los dos enlaces. Es decir, el tráfico de PC1 a PC2 se transmite primero a través del enlace que pasa por SwitchB. Cuando se producen fallas en este enlace, el tráfico se cambia automáticamente al enlace que pasa por SwitchD.

NOTA:

En este escenario, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado. Si STP está habilitado y las interfaces VLANIF de los switches se utilizan para construir una red de anillo de Capa 3, una interfaz en la red se bloqueará. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 8-3  Configuración de rutas estáticas para la copia de seguridad de enlace

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Crea VLAN, agregue interfaces a las VLAN y asigne direcciones IP a las interfaces VLANIF.
  2. Configure las rutas estáticas en dos direcciones de tráfico de datos.
  3. Configure la dirección IP y las puertas de enlace predeterminadas para los hosts.

Procedimiento

  1. Especifique las VLAN a las que pertenecen las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 100 400
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 400
    [SwitchA-GigabitEthernet1/0/3] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 192.168.12.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 400
    [SwitchA-Vlanif400] ip address 192.168.14.1 24
    [SwitchA-Vlanif400] quit

  3. Configure las rutas estáticas desde PC1 a PC2.

    # En SwitchA, configure dos rutas estáticas con diferentes prioridades. El siguiente salto de una ruta apunta a SwitchB, y la de la otra ruta apunta a SwitchD. Posteriormente, el tráfico de datos se reenvía primero a SwitchB. Cuando ocurren fallas en el enlace que pasa por SwitchB, el tráfico cambia automáticamente a SwitchD.

    [SwitchA] ip route-static 10.1.2.0 24 192.168.12.2
    [SwitchA] ip route-static 10.1.2.0 24 192.168.14.2 preference 70

    # Configure SwitchB.

    [SwitchB] ip route-static 10.1.2.0 24 192.168.23.2

    # Configure SwitchD.

    [SwitchD] ip route-static 10.1.2.0 24 192.168.34.1

  4. Configure las rutas estáticas desde PC2 a PC1 y asegúrese de que los enlaces activos y standby en dos direcciones sean los mismos.

    # En SwitchC, configure dos rutas estáticas con diferentes prioridades. El siguiente salto de una ruta apunta a SwitchB, y la de la otra ruta apunta a SwitchD. Posteriormente, el tráfico de datos se reenvía primero a SwitchB. Cuando ocurren fallas en el enlace que pasa por SwitchB, el tráfico cambia automáticamente a SwitchD.

    [SwitchC] ip route-static 10.1.1.0 24 192.168.23.1
    [SwitchC] ip route-static 10.1.1.0 24 192.168.34.2 preference 70

    # Configure SwitchB.

    [SwitchB] ip route-static 10.1.1.0 24 192.168.12.1

    # Configure SwitchD.

    [SwitchD] ip route-static 10.1.1.0 24 192.168.14.1

  5. Configure hosts.

    Asigne la dirección IP 10.1.1.2/24 y la dirección IP del gateway predeterminado 10.1.1.1 al PC1; asigne la dirección IP 10.1.2.2/24 y la dirección IP del gateway predeterminado 10.1.2.1 al PC2.

  6. Verifique la configuración.

    # Compruebe la tabla de enrutamiento IP en SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 9        Routes : 9        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.1.2.0/24  Static  60   0          RD   192.168.12.2    Vlanif100
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
       192.168.12.0/24  Direct  0    0           D   192.168.12.1    Vlanif100
       192.168.12.1/32  Direct  0    0           D   127.0.0.1       Vlanif100
       192.168.14.0/24  Direct  0    0           D   192.168.14.1    Vlanif400
       192.168.14.1/32  Direct  0    0           D   127.0.0.1       Vlanif400

    # Compruebe la información detallada sobre la tabla de enrutamiento IP en SwitchA.

    [SwitchA] display ip routing-table 10.1.2.0 24 verbose
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Table : Public
    Summary Count : 2
    
    Destination: 10.1.2.0/24
         Protocol: Static          Process ID: 0
       Preference: 60                    Cost: 0
          NextHop: 192.168.12.2     Neighbour: 0.0.0.0
            State: Active Adv Relied      Age: 00h13m13s
              Tag: 0                 Priority: medium
            Label: NULL               QoSInfo: 0x0
       IndirectID: 0x80000001       
     RelayNextHop: 0.0.0.0          Interface: Vlanif100
         TunnelID: 0x0                  Flags: RD
    
    Destination: 10.1.2.0/24
         Protocol: Static          Process ID: 0
       Preference: 70                    Cost: 0
          NextHop: 192.168.14.2     Neighbour: 0.0.0.0
            State: Inactive Adv Relied    Age: 00h00m45s
              Tag: 0                 Priority: medium
            Label: NULL               QoSInfo: 0x0
       IndirectID: 0x80000002       
     RelayNextHop: 0.0.0.0          Interface: Vlanif400
         TunnelID: 0x0                  Flags: R
    

    La tabla de enrutamiento de IP en SwitchA contiene solo una ruta activa al segmento de red 10.1.2.0/24. Normalmente, el tráfico de datos desde PC1 a PC2 se transmite a través del enlace que pasa por SwitchB. La información detallada sobre la tabla de enrutamiento de IP eSwitchA muestra dos rutas al segmento de red 10.1.2.0/24: una ruta Active que pasa por SwitchB y la otra ruta Inactive que pasa por SwitchD. Cuando se producen fallas en el enlace activo, la ruta Inactive activará para controlar el tráfico. Esto despliega la copia de seguridad del enlace.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 100 400
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif100
     ip address 192.168.12.1 255.255.255.0
    #
    interface Vlanif400
     ip address 192.168.14.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    ip route-static 10.1.2.0 255.255.255.0 192.168.12.2
    ip route-static 10.1.2.0 255.255.255.0 192.168.14.2 preference 70
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 192.168.12.2 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.23.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ip route-static 10.1.1.0 255.255.255.0 192.168.12.1
    ip route-static 10.1.2.0 255.255.255.0 192.168.23.2
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 200 300
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
    #
    interface Vlanif200
     ip address 192.168.23.2 255.255.255.0
    #
    interface Vlanif300
     ip address 192.168.34.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ip route-static 10.1.1.0 255.255.255.0 192.168.23.1
    ip route-static 10.1.1.0 255.255.255.0 192.168.34.2 preference 70
    #
    return
  • El archivo de configuración SwitchD

    #
    sysname SwitchD
    #
    vlan batch 300 400
    #
    interface Vlanif300
     ip address 192.168.34.2 255.255.255.0
    #
    interface Vlanif400
     ip address 192.168.14.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    ip route-static 10.1.1.0 255.255.255.0 192.168.14.1
    ip route-static 10.1.2.0 255.255.255.0 192.168.34.1
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15515

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente