No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar NQA para rutas estáticas IPv4

Ejemplo para configurar NQA para rutas estáticas IPv4

Descripción general de NQA para rutas estáticas IPv4

La tecnología de análisis de calidad de red (NQA) mide el rendimiento de la red y recopila estadísticas sobre la relación de retraso, fluctuación de fase y pérdida de paquetes. NQA puede medir la QoS de la red en tiempo real y realizar diagnósticos y ubicaciones de fallas de red efectivas.

En una red simple o en una red donde la ruta al destino no puede establecerse mediante protocolos de enrutamiento dinámico, se pueden configurar rutas estáticas. A diferencia de los protocolos de enrutamiento dinámico, las rutas estáticas no tienen un mecanismo de detección dedicado. Si se produce un error, las rutas estáticas no pueden detectar el error, y el administrador de la red debe eliminar la ruta estática correspondiente. Esto retrasa la conmutación del enlace y puede causar interrupciones de servicio prolongadas.

BFD para rutas estáticas IPv4 es adaptable a los cambios de enlace, pero ambos extremos del enlace deben ser compatibles con BFD. Si alguno de los extremos de un enlace no es compatible con BFD, se pueden configurar rutas NQA para IPv4 estáticas. Cuando una instancia de prueba NQA detecta un error de enlace, instruye al módulo de gestión de enrutamiento para eliminar la ruta estática asociada de la tabla de enrutamiento IP. Luego, el tráfico de servicio cambia a una ruta sin ningún error de enlace para evitar interrupciones prolongadas del servicio.

Notas de configuración

  • La función NQA del switch está controlado por licencia. Si la licencia no está disponible, los comandos NQA se pueden ejecutar, pero la función NQA no tiene efecto.
  • Productos y versiones aplicables: V200R003C00 y versiones posteriores

Requisitos de redes

En una red de empresa que se muestra en Figura 8-4, los switches de acceso SwitchD y SwitchE se conectan a los switches de agregación SwitchB y SwitchC en modo de doble inicio a través de estática rutas para desplegar la redundancia. Los requisitos son los siguientes:
  • Se despliegue un mecanismo de detección para las rutas estáticas para que las rutas estáticas puedan detectar fallas en los enlaces y el tráfico pueda pasar de un enlace defectuoso para evitar interrupciones prolongadas del servicio.
  • En casos normales, el tráfico se transmite a lo largo del enlace principal SwitchB->SwitchD.
  • Si se produce un error en el enlace primario, el tráfico cambia al enlace de copia de seguridad SwitchC->SwitchD.
NOTA:

En este escenario, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado. Si STP está habilitado y las interfaces VLANIF de los switches se utilizan para construir una red de anillo de Capa 3, una interfaz en la red se bloqueará. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 8-4  NQA para rutas estáticas IPv4

Nombre del dispositivo

Interfaz

Dirección IP

SwitchA

VLANIF 30

192.168.3.1/24

VLANIF 40

192.168.4.1/24

SwitchB

VLANIF 30

192.168.3.2/24

VLANIF 50

192.168.5.1/24

VLANIF 10

192.168.1.1/24

SwitchC

VLANIF 40

192.168.4.2/24

VLANIF 60

192.168.6.1/24

VLANIF 20

192.168.2.1/24

SwitchD

VLANIF 10

192.168.1.2/24

VLANIF 60

192.168.6.2/24

VLANIF 70

192.168.7.1/24

SwitchE

VLANIF 20

192.168.2.2/24

VLANIF 50

192.168.5.2/24

VLANIF 80

192.168.8.1/24

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Crea una instancia de prueba NQA del Protocolo de mensajes de control de Internet (ICMP) para supervisar el estado del enlace principal.

    Crea una instancia de prueba ICMP NQA en el cliente NQA SwitchB para comprobar si el enlace principal SwitchB->Switch se está ejecutando correctamente.

  2. Configure rutas estáticas y asocie las rutas estáticas con la instancia de prueba NQA.

    Configure las rutas estáticas en los switches de agregación SwitchB y SwitchC, y asocie la estática ruta configurada en SwitchB con la instancia de prueba ICMP NQA. Cuando la instancia de prueba ICMP NQA detecta un error de enlace, instruye al módulo de gestión de enrutamiento para eliminar la ruta estática asociada de la tabla de enrutamiento IPv4.

  3. Configure un protocolo de enrutamiento dinámico.

    Configure un protocolo de enrutamiento dinámico en los switches de agregación SwitchA, SwitchB, y SwitchC para que puedan aprenderse rutas entre sí.

  4. Configure el protocolo de enrutamiento dinámico para importar rutas estáticas y establezca un mayor costo para la ruta estática utilizada para el enlace de copia de seguridad que para la ruta estática utilizada para el enlace principal a mejorar la confiabilidad del enlace.

    Configure el protocolo de enrutamiento dinámico en los switches de agregación SwitchB y SwitchC para importar estática rutas, y establezca un costo mayor para la ruta estática importada por SwitchC que para la ruta estática importada por SwitchB. Esta configuración permite que SwitchA seleccione preferentemente el enlace SwitchB->SwitchD con un costo menor.

Procedimiento

  1. Configure las VLAN a las que pertenece cada interfaz.

    # Configure SwitchA. Aseguran de que las configuraciones de SwitchB, SwitchC, SwitchD, y SwitchE son los mismos que la configuración de SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 30 40
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 40
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Aseguran de que las configuraciones de SwitchB, SwitchC, SwitchD, y SwitchE son los mismos que la configuración de SwitchA.

    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 192.168.3.1 24
    [SwitchA-Vlanif30] quit
    [SwitchA] interface vlanif 40
    [SwitchA-Vlanif40] ip address 192.168.4.1 24
    [SwitchA-Vlanif40] quit

  3. Crea una instancia de prueba NQA en SwitchB para probar el enlace entre SwitchB y SwitchD.

    [SwitchB] nqa test-instance user test   //Cree la instancia de prueba NQA con el nombre de administrador user y nombre de instancia test.
    [SwitchB-nqa-user-test] test-type icmp   //Establezca el tipo de prueba de la instancia de prueba NQA en ICMP.
    [SwitchB-nqa-user-test] destination-address ipv4 192.168.1.2   //Configure la dirección de destino de la instancia de prueba NQA en 192.168.1.2.
    [SwitchB-nqa-user-test] frequency 20   //Establezca el intervalo de instancias de prueba NQA periódicas en 20 segundos.
    [SwitchB-nqa-user-test] probe-count 2   //Establezca el número de sondeos en 2 que se enviarán cada vez en la instancia de prueba NQA.
    [SwitchB-nqa-user-test] interval seconds 5   //Establezca el intervalo en el que los paquetes de sondeo se envían en la instancia de prueba NQA en 5 segundos.
    [SwitchB-nqa-user-test] timeout 4   //Establezca el período de tiempo de espera de un sondeo en la instancia de prueba NQA en 4 segundos.
    [SwitchB-nqa-user-test] start now
    [SwitchB-nqa-user-test] quit
    

  4. Configure las rutas estáticas de IPv4.

    # Configure una ruta estática IPv4 en SwitchB y asóciela con la instancia de prueba NQA.

    [SwitchB] ip route-static 192.168.7.0 255.255.255.0 Vlanif 10 192.168.1.2 track nqa user test

    # Configurar una ruta estática de IPv4 en SwitchC.

    [SwitchC] ip route-static 192.168.7.0 255.255.255.0 Vlanif 60 192.168.6.2

  5. Configure un protocolo de enrutamiento dinámico en SwitchA, SwitchB y SwitchC. OSPF se usa en este ejemplo.

    # Configure OSPF en SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0.0.0.0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit
    

    # Configure OSPF en SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0.0.0.0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit
    

    # Configure OSPF en SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 0.0.0.0
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit
    

  6. Configure OSPF en SwitchB y SwitchC para importar rutas estáticas.

    # Configure OSPF en SwitchB para importar una ruta estática y establezca el costo en 10 para la ruta estática.

    [SwitchB] ospf 1
    [SwitchB-ospf-1] import-route static cost 10
    [SwitchB-ospf-1] quit
    

    # Configure OSPF en SwitchC para importar una ruta estática y establezca el costo en 20 para la ruta estática.

    [SwitchC] ospf 1
    [SwitchC-ospf-1] import-route static cost 20
    [SwitchC-ospf-1] quit
    

  7. Verifique la configuración.

    Una vez completada la configuración, ejecute el comando display current-configuration | include nqa en el switch de agregación Switch B en la vista del sistema. El resultado del comando muestra que la ruta estática IPv4 se ha asociado con la instancia de prueba NQA. Ejecute el comando display nqa results. El resultado del comando muestra que se ha creado una instancia de prueba NQA.

    # Compruebe configuraciones de NQA para rutas estáticas IPv4.

    [SwitchB] display current-configuration | include nqa
    ip route-static 192.168.7.0 255.255.255.0 Vlanif10 192.168.1.2 track nqa user test
    nqa test-instance user test
    

    # Compruebe los resultados de la prueba NQA.

    [SwitchB] display nqa results test-instance user test
    
     NQA entry(user, test) :testflag is active ,testtype is icmp 
      1 . Test 288 result   The test is finished
       Send operation times: 2              Receive response times: 2          
       Completion:success                 RTD OverThresholds number: 0       
       Attempts number:1                    Drop operation number:0            
       Disconnect operation number:0        Operation timeout number:0         
       System busy operation number:0       Connection fail number:0           
       Operation sequence errors number:0   RTT Status errors number:0         
       Destination ip address:192.168.1.2                                    
       Min/Max/Average Completion Time: 3/4/3                                
       Sum/Square-Sum  Completion Time: 7/25                                 
       Last Good Probe Time: 2014-09-09 09:55:38.2                           
       Lost packet ratio: 0 %
    

    El resultado del comando muestra "Lost packet ratio: 0 % ", lo que indica que el enlace se está ejecutando correctamente.

    # Compruebe la tabla de enrutamiento IP en SwitchB.

    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 10       Routes : 10       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
        192.168.3.0/24  Direct  0    0           D   192.168.3.2     Vlanif30
        192.168.3.2/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  OSPF    10   2           D   192.168.3.1     Vlanif30
        192.168.5.0/24  Direct  0    0           D   192.168.5.1     Vlanif50
        192.168.5.1/32  Direct  0    0           D   127.0.0.1       Vlanif50
        192.168.7.0/24  Static  60   0           D   192.168.1.2     Vlanif10

    # Compruebe la tabla de enrutamiento IP en el switch de agregación SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.3.0/24  Direct  0    0           D   192.168.3.1     Vlanif30
        192.168.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  Direct  0    0           D   192.168.4.1     Vlanif40
        192.168.4.1/32  Direct  0    0           D   127.0.0.1       Vlanif40
        192.168.7.0/24  O_ASE   150  10          D   192.168.3.2     Vlanif30
    

    El resultado del comando muestra que existe una ruta a 192.168.7.0/24 en la tabla de enrutamiento. La dirección del siguiente salto de la ruta es 192.168.3.2 y el costo es 10. El tráfico se transmite preferentemente a lo largo del enlace SwitchB->SwitchD.

    # Apague GigabitEthernet1/0/3 on SwitchB para simular un error de enlace.

    [SwitchB] interface GigabitEthernet1/0/3
    [SwitchB-GigabitEthernet1/0/3] shutdown
    [SwitchB-GigabitEthernet1/0/3] quit
    

    # Compruebe los resultados de la prueba NQA.

    [SwitchB] display nqa results test-instance user test
    
     NQA entry(user, test) :testflag is active ,testtype is icmp 
      1 . Test 309 result   The test is finished
       Send operation times: 2              Receive response times: 0          
       Completion:failed                 RTD OverThresholds number: 0       
       Attempts number:1                    Drop operation number:2            
       Disconnect operation number:0        Operation timeout number:0         
       System busy operation number:0       Connection fail number:0           
       Operation sequence errors number:0   RTT Status errors number:0         
       Destination ip address:192.168.1.2                                   
       Min/Max/Average Completion Time: 0/0/0                                
       Sum/Square-Sum  Completion Time: 0/0                                  
       Last Good Probe Time: 0000-00-00 00:00:00.0                           
       Lost packet ratio: 100 %

    El resultado del comando muestra "Completion: failed" y "Lost packet ratio: 100 % ", lo que indica que el enlace se está ejecutando defectuosamente.

    # Compruebe la tabla de enrutamiento IP en SwitchB.

    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8        Routes : 8        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.3.0/24  Direct  0    0           D   192.168.3.2     Vlanif30
        192.168.3.2/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  OSPF    10   2           D   192.168.3.1     Vlanif30
        192.168.5.0/24  Direct  0    0           D   192.168.5.1     Vlanif50
        192.168.5.1/32  Direct  0    0           D   127.0.0.1       Vlanif50
        192.168.7.0/24  O_ASE   150  20          D   192.168.3.1     Vlanif30
    

    El resultado del comando muestra que la ruta estática ha sido eliminada.

    # Compruebe la tabla de enrutamiento IP en SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 7        Routes : 7        
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.3.0/24  Direct  0    0           D   192.168.3.1     Vlanif30
        192.168.3.1/32  Direct  0    0           D   127.0.0.1       Vlanif30
        192.168.4.0/24  Direct  0    0           D   192.168.4.1     Vlanif40
        192.168.4.1/32  Direct  0    0           D   127.0.0.1       Vlanif40
        192.168.7.0/24  O_ASE   150  20          D   192.168.4.2     Vlanif40
    

    La ruta estática se ha asociado con la instancia de prueba NQA en SwitchB. Si NQA detecta un error de enlace, notifica rápidamente SwitchB que la ruta estática asociada no está disponible. SwitchA no puede aprender la ruta a 192.168.7.0/24 desdeSwitchB. Sin embargo, SwitchA puede aprender la ruta a 192.168.7.0/24 desde SwitchC. La dirección del próximo salto de la ruta es 192.168.4.2 y el costo es 20. El tráfico cambia al enlace SwitchC->SwitchD.

Archivos de configuración

  • El Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 30 50
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.5.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     import-route static cost 10
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
    #
    ip route-static 192.168.7.0 255.255.255.0 Vlanif10 192.168.1.2 track nqa user test
    #
    nqa test-instance user test
     test-type icmp
     destination-address ipv4 192.168.1.2
     frequency 20
     interval seconds 5
     timeout 4
     probe-count 2
     start now
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 40 60
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
    #
    interface Vlanif60
     ip address 192.168.6.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     import-route static cost 20
     area 0.0.0.0
      network 192.168.4.0 0.0.0.255
    #
    ip route-static 192.168.7.0 255.255.255.0 Vlanif60 192.168.6.2
    #
    return
  • El archivo de configuración SwitchD

    #
    sysname SwitchD
    #
    vlan batch 10 60 70
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif60
     ip address 192.168.6.2 255.255.255.0
    #
    interface Vlanif70
     ip address 192.168.7.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    interface GigabitEthernet1/0/4
     port link-type trunk
     port trunk allow-pass vlan 70
    #
    return
  • El archivo de configuración SwitchE

    #
    sysname SwitchE
    #
    vlan batch 20 50 80
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif50
     ip address 192.168.5.2 255.255.255.0
    #
    interface Vlanif80
     ip address 192.168.8.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    interface GigabitEthernet1/0/4
     port link-type trunk
     port trunk allow-pass vlan 80
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15589

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente