No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar EFM para rutas estáticas IPv4

Ejemplo para configurar EFM para rutas estáticas IPv4

Descripción general de EFM para rutas estáticas IPv4

Ethernet en la primera milla (EFM) define las especificaciones de la capa física de Ethernet para el acceso del usuario y despliegues de la gestión y el mantenimiento de Ethernet. EFM proporciona operación y Administración de nivel de enlace (OAM), por ejemplo, detección de conectividad de enlace, monitoreo de falla de enlace, notificación remota de fallas y funciones de loopback remoto en un enlace entre dos dispositivos conectados directamente.

Las rutas estáticas son fáciles de configurar y, por lo tanto, se usan ampliamente en redes con estructuras simples. A diferencia de los protocolos de enrutamiento dinámico, las rutas estáticas no tienen un mecanismo de detección dedicado. Si se produce un error, las rutas estáticas no pueden detectar el error, y el administrador de la red debe eliminar la ruta estática correspondiente. Esto retrasa la conmutación del enlace y puede causar interrupciones de servicio prolongadas. Las redes IP se utilizan con más frecuencia para transportar múltiples servicios, como servicios de voz y video. Estos servicios presentan altos requisitos de confiabilidad de la red, detección y procesamiento rápidos de fallas. EFM para rutas estáticas IPv4 se puede configurar para proporcionar el mecanismo de detección de rutas estáticas para que puedan detectar los cambios en la calidad del enlace en tiempo real y conmutar los servicios de inmediato.

Notas de configuración

  • Por defecto, EFM está desactivado en global y en las interfaces.
  • Después de habilitar EFM OAM en una interfaz, la interfaz comienza a enviar PDU OAM para realizar la detección de enlace EFM punto a punto. La detección de enlace EFM se puede implementar entre dos interfaces solo después de habilitar EFM OAM en la interfaz de igual.
  • Este ejemplo se aplica a todas las versiones de todos los switches de la serie S.

Requisitos de redes

Como se muestra en Figura 8-5, SwitchA se conecta al NMS en un segmento de red a través de SwitchB. SwitchA y SwitchB necesita detectar la calidad del enlace en tiempo real. Cuando el enlace entre ellos se vuelve defectuoso, la ruta estática correspondiente se elimina de la tabla de enrutamiento IP. Luego, el tráfico cambia del enlace defectuoso a una ruta normal para mejorar la confiabilidad de la red.

Figura 8-5  Redes para configurar EFM para una ruta estática IPv4

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Habilite EFM OAM globalmente y en interfaces de SwitchA y SwitchB para implementar detección de calidad de enlace en tiempo real.

  2. Configure una ruta estática desde SwitchA hasta el NMS y conéctelo al estado de EFM para asociar la ruta estática con EFM. Cuando un enlace donde reside la ruta estática se convierte en defectuoso, el tráfico cambia a una ruta sin fallas de enlace.

Procedimiento

  1. Especifique la VLAN a la que pertenecen las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB es similar.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB es similar.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit

  3. Configure una sesión de EFM entre SwitchA y SwitchB.

    # Habilite EFM OAM en SwitchA.

    [SwitchA] efm enable   //Habilite EFM globalmente.
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] efm enable   //Habilite EFM en una interfaz.
    [SwitchA-GigabitEthernet1/0/1] quit
    

    # Habilite EFM OAM en SwitchB.

    [SwitchB] efm enable   //Habilite EFM globalmente
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] efm enable   //Habilite EFM en una interfaz.
    [SwitchB-GigabitEthernet1/0/1] quit

  4. Configure una ruta estática y vincúlela al estado EFM.

    # Configure una ruta estática desde SwitchA a la red externa y vincúlela al estado EFM de GigabitEthernet1/0/1.

    [SwitchA] ip route-static 192.168.2.0 24 192.168.1.2 track efm-state gigabitethernet1/0/1

  5. Verifique la configuración.

    # Una vez completada la configuración, ejecute el comando display efm session all en SwitchA y SwitchB. El resultado del comando muestra que se ha configurado una sesión de EFM y está en el modo detect. Es decir, la interfaz está en estado de apretón de manos. Lo siguiente se usa mostrado en SwitchA como un ejemplo.

    [SwitchA] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet1/0/1      detect                      --

    # Compruebe la tabla de enrutamiento IP en SwitchA. La tabla de enrutamiento IP contiene la ruta estática.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5       Routes : 5       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
        192.168.2.0/24  Static  60   0          RD   192.168.1.2     Vlanif10

    # Ejecute el comando undo efm enable en la vista de GigabitEthernet1/0/1 en SwitchB para simular un error de enlace.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] undo efm enable

    # Ejecute el comando display efm session all en SwitchA. El resultado del comando muestra que el estado del protocolo EFM OAM es discovery, que indica que la interfaz está en estado de descubrimiento de OAM.

    [SwitchA] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet1/0/1      discovery                   --

    # Compruebe la tabla de enrutamiento IP en SwitchA. La tabla de enrutamiento IP no contiene la ruta estática 192.168.2.0/24. Esto se debe a que la ruta estática es vinculado al estado EFM. Después de que EFM OAM detecta un error de enlace, notifica rápidamente a SwitchA que la ruta estática no está disponible.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 4       Routes : 4       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
    

    # Ejecute el comando efm enable en la vista de GigabitEthernet1/0/1 en SwitchB para simular una recuperación de enlace.

    [SwitchB-GigabitEthernet1/0/1]efm enable

    # Ejecute el comando display efm session all en SwitchA. El resultado del comando muestra que el estado del protocolo EFM OAM es detect, lo que indica que la interfaz está en el estado de apretón de manos de nuevo.

    [SwitchA] display efm session all
      Interface                 EFM State                   Loopback Timeout
      ----------------------------------------------------------------------
      GigabitEthernet1/0/1      detect                      --

    # Compruebe la tabla de enrutamiento IP en SwitchA. La tabla de enrutamiento IP contiene la ruta estática 192.168.2.0/24 nuevamente. Después de que EFM OAM detecta que el enlace se recupera de una falla, notifica rápidamente que la ruta estática enlazada es válida nuevamente.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 5       Routes : 5       
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
        192.168.1.0/24  Direct  0    0           D   192.168.1.1     Vlanif10
        192.168.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
        192.168.2.0/24  Static  60   0          RD   192.168.1.2     Vlanif10

Archivos de configuración

  • Archivo de configuración de SwitchA

    # 
    sysname SwitchA
    #
    vlan batch 10
    #
    efm enable
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     efm enable
    #
    ip route-static 192.168.2.0 255.255.255.0 192.168.1.2 track efm-state GigabitEthernet1/0/1
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 20
    #
    efm enable
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
     efm enable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15475

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente