No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar funciones básicas de OSPF

Ejemplo para configurar funciones básicas de OSPF

Descripción general de OSPF

El Abrir la ruta más corta primero (OSPF) es un protocolo de gateway interior (IGP) de estado de enlace desarrollado por el Grupo de trabajo de ingeniería de Internet (IETF). La versión 2 de OSPF está definida en RFC 2328, que se usa en IPv4.

OSPF está libre de bucles, proporciona una rápida convergencia de ruta y admite partición de area, rutas de igual costo, autenticación y transmisión de multidifusión. Por lo tanto, OSPF es ampliamente utilizado como el principal IGP en diversas industrias, incluidas la empresa, el operador, el gobierno, las finanzas, la educación y la industria del cuidado de la salud.

OSPF utiliza el diseño jerárquico, proporciona varias políticas de enrutamiento y se aplica en redes de diferentes tamaños y topologías. OSPF suele ser la primera opción para desplegar un IGP.

Notas de configuración

  • Cada ID de router en un proceso de OSPF debe ser exclusivo en una red de OSPF. De lo contrario, la relación de vecinos de OSPF no se puede establecer y la información de enrutamiento es incorrecta. Se le recomienda configurar un ID de router exclusivo para cada proceso de OSPF en un dispositivo de OSPF.
  • OSPF divide un AS en diferentes áreas, entre las cuales la area 0 es la troncal. OSPF requiere que todas las áreas que no son troncales mantengan la conectividad con el área troncal y los dispositivos en la área troncal mantengan la conectividad entre sí.
  • Los tipos de red de interfaces en ambos extremos de un enlace deben ser iguales; de lo contrario, las dos interfaces no pueden establecer una relación de vecino OSPF. En un enlace, si el tipo de red de una interfaz OSPF es difusión y el otro es P2P, las dos interfaces OSPF aún pueden establecer una relación de vecino OSPF pero no pueden aprender la información de enrutamiento entre sí.
  • Las máscaras de direcciones IP de las interfaces OSPF en ambos extremos de un enlace deben ser las mismas; de lo contrario, las dos interfaces OSPF no pueden establecer una relación de vecino OSPF. Sin embargo, en una red P2MP, puede ejecutar el comando ospf p2mp-mask-ignore para deshabilitar que un dispositivo verifique la máscara de red, de modo que se pueda establecer una relación de vecino OSPF.
  • En una red de difusión o NBMA, se debe haber al menos una interfaz OSPF cuya prioridad de DR no sea 0 para garantizar que se pueda elegir el DR. De lo contrario, el estado vecino de los dispositivos en ambos extremos solo puede ser 2-Way.
  • Tabla 8-2 enumera los productos aplicables y las versiones de este ejemplo de configuración.
    Tabla 8-2  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 8-6, SwitchA, SwitchB, ySwitchC que residen en la red de OSPF. Los tres switches deben comunicarse entre sí, y SwitchA y SwitchB funcionan como switches centrales para admitir la expansión de la red.

Figura 8-6  Diagrama de redes para configurar funciones básicas de OSPF

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure una dirección IP para cada interfaz VLANIF en cada switch y especifique la VLAN a la que pertenecen las interfaces para desplegar la mutua compatibilidad.

  2. Configure funciones básicas de OSPF en cada switch y divide la red OSPF en la area 0 y area 1 con SwitchA como router de borde de área (ABR). En consecuencia, el área donde residen SwitchA y SwitchB se convierte en el área troncal y se puede usar para expandir la red OSPF.

Procedimiento

  1. Especifique las VLAN a las que pertenecen las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.1.1 24
    [SwitchA-Vlanif20] quit

  3. Configurar funciones básicas de OSPF.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1   //Cree un proceso OSPF 1 con el ID del router 10.1.1.1.
    [SwitchA-ospf-1] area 0   //Cree el area 0 e ingrese a la vista del area 0.
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255   //Configure un segmento de red en el area 0.
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1   //Cree el area 1 e ingrese a la vista del area 1.
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255   //Configure un segmento de red en el area 1.
    [SwitchA-ospf-1-area-0.0.0.1] return

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] return

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] return

  4. Verifique la configuración.

    # Comprobar la información sobre los vecinos de OSPF de SwitchA.

    <SwitchA> display ospf peer
    
              OSPF Process 1 with Router ID 10.1.1.1
                      Neighbors
    
     Area 0.0.0.0 interface 192.168.0.1(Vlanif10)'s neighbors
    Router ID: 10.2.2.2      Address: 192.168.0.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.0.2  BDR: 192.168.0.1   MTU: 0
       Dead timer due in 36  sec
       Retrans timer interval: 5
       Neighbor is up for 00:15:04
       Authentication Sequence: [ 0 ]
    
                      Neighbors
    
     Area 0.0.0.1 interface 192.168.1.1(Vlanif20)'s neighbors
    Router ID: 10.3.3.3       Address: 192.168.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 192.168.1.2  BDR: 192.168.1.1   MTU: 0
       Dead timer due in 39  sec
       Retrans timer interval: 5
       Neighbor is up for 00:07:32
       Authentication Sequence: [ 0 ]

    # Comprobar la información de enrutamiento de OSPF en SwitchC.

    <SwitchC> display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination      Cost  Type         NextHop         AdvRouter       Area
     192.168.1.0/24    1    Transit      192.168.1.2     10.3.3.3        0.0.0.1
     192.168.0.0/24    2    Inter-area   192.168.1.1     10.1.1.1        0.0.0.1
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

    La salida del comando anterior muestra que SwitchC tiene una ruta a 192.168.0.0/24 y ella es una ruta entre áreas.

    # Compruebe la tabla de enrutamiento en SwitchB y realice la operación de ping para probar la conectividad entre SwitchB y SwitchC.

    <SwitchB> display ospf routing
    
              OSPF Process 1 with Router ID 10.2.2.2
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop      AdvRouter       Area
     192.168.0.0/24     1     Transit    192.168.0.2  10.2.2.2        0.0.0.0
     192.168.1.0/24     2     Inter-area 192.168.0.1  10.1.1.1        0.0.0.0
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

    La salida del comando anterior muestra que SwitchB tiene una ruta a 192.168.1.0/24 y ella es una ruta entre áreas.

    # En SwitchB, realice una operación de ping para probar la conectividad entre SwitchB y SwitchC.

    <SwitchB> ping 192.168.1.2
      PING 192.168.1.2: 56  data bytes, press CTRL_C to break
        Reply from 192.168.1.2: bytes=56 Sequence=1 ttl=254 time=62 ms
        Reply from 192.168.1.2: bytes=56 Sequence=2 ttl=254 time=16 ms
        Reply from 192.168.1.2: bytes=56 Sequence=3 ttl=254 time=62 ms
        Reply from 192.168.1.2: bytes=56 Sequence=4 ttl=254 time=94 ms
        Reply from 192.168.1.2: bytes=56 Sequence=5 ttl=254 time=63 ms
    
      --- 192.168.1.2 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 16/59/94 ms

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.0.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15454

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente