No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar una área de stub de OSPF

Ejemplo para configurar una área de stub de OSPF

Descripción general del área de Stub

Una área de stub es una área que no permite que un ABR anuncie las rutas externas recibidas de AS. En una área de stub, el tamaño de la tabla de enrutamiento y el volumen de información de enrutamiento transmitido de los routers se reducen considerablemente. Una área de stub generalmente se coloca en el borde de un AS. Para garantizar la accesibilidad de un destino fuera del AS, el ABR en el área de stub genera una ruta predeterminada y la anuncia a los routers que no son ABR en el área de stub.

Supongan que un dispositivo de la Compañía H se conecta al área troncal a través de un único enlace. El dispositivo tiene bajo rendimiento y una pequeña tabla de enrutamiento. El área donde reside el dispositivo debe acceder a otras áreas o segmentos de red fuera del área OSPF, y la dirección de siguiente salto de las rutas del dispositivo es la dirección IP del dispositivo central del siguiente salto del enlace. Por lo tanto, El área donde reside el dispositivo no debe aprender una gran cantidad de rutas externas de OSPF y se puede configurar como una área de stub. Esta configuración puede reducir el tamaño de la tabla de enrutamiento del área y el consumo de recursos del dispositivo.

Notas de configuración

  • El área troncal no se puede configurar como una área de stub.
  • Un ASBR no puede existir en un área de stub. Es decir, las rutas externas no se anuncian en un área de stub.
  • Un enlace virtual no puede pasar a través de una área de stub.
  • Para configurar una área como una área de stub, configure los atributos de área de stub en todos los routers en esta área usando el comando stub.
  • Para configurar un área como un área de stub totalmente, ejecute el comando stub en todos los routers en esta área y ejecute el comando stub no-summary en el ABR en esta área.
  • El comando stub no-summary solo se puede configurar en un ABR para evitar que el ABR publique LSA de tipo 3 dentro de un área de stub. Después de configurar este comando en el ABR, el área se convierte en un área de stub totalmente, se reduce el número de entradas de enrutamiento en los routers en el área, y solo hay rutas dentro del área y una ruta predeterminada anunciada por el ABR.
  • Tabla 8-3 enumera los productos aplicables y las versiones de este ejemplo de configuración.
    Tabla 8-3  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 8-7, SwitchA, SwitchB, y SwitchC ejecute el OSPF, y la red OSPF se divide en Área 0 y Área 1.SwitchB funciona como un ASBR para comunicarse con redes externas. El tamaño de la tabla de enrutamiento de OSPF en SwitchC debe reducirse sin afectar la comunicación.

Figura 8-7  Diagrama de red para la configuración del área de stub de OSPF

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure las funciones básicas de OSPF en cada switchpara desplegar el interfuncionamiento en la red OSPF.

  2. Configure una ruta estática en SwitchB e importe la ruta a la tabla de enrutamiento de OSPF para asegurarse de que haya una ruta accesible de la red OSPF a redes externas.

  3. Configure el Área 1 como un área de stub para reducir el tamaño de la tabla de enrutamiento de OSPF en SwitchC.

  4. Prohíba que el ABR (SwitchA) en el Área 1 anuncie de LSA de Tipo 3 dentro del área de stub para configurar el Área 1 como un área de stub totalmente. Esta configuración minimiza el tamaño de la tabla de enrutamiento OSPF en SwitchC.

Procedimiento

  1. Especifique las VLAN a las que pertenecen las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.0.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 192.168.1.1 24
    [SwitchA-Vlanif20] quit

  3. Configurar funciones básicas de OSPF.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.1] quit
    [SwitchC-ospf-1] quit

  4. Configure SwitchB para importar una ruta estática.

    [SwitchB] ip route-static 10.0.0.0 8 null 0
    [SwitchB] ospf 1
    [SwitchB-ospf-1] import-route static type 1   //SwitchB funciona como ASBR e importa enrutamientos externos.
    [SwitchB-ospf-1] quit

    # Compruebe la tabla de enrutamiento de OSPF en SwitchC. El resultado del comando muestra que la tabla de enrutamiento de OSPF contiene una ruta externa de AS.

    [SwitchC] display ospf routing
    
         OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type         NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit      192.168.1.2     10.3.3.3        0.0.0.1
     192.168.0.0/24     2     Inter-area   192.168.1.1     10.1.1.1        0.0.0.1
    
     Routing for ASEs
     Destination    Cost      Type       Tag         NextHop         AdvRouter
     10.0.0.0/8    3         Type1      1           192.168.1.1     10.2.2.2
    
     Total Nets: 3
     Intra Area: 1  Inter Area: 1  ASE: 1  NSSA: 0

  5. Configure el Área 1 como un área de stub.

    # Configure SwitchA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] stub   //Configure el Área 1 como un área de stub. Todos los routers en el Área 1 deben tener configurado el comando stub.
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1
    [SwitchC-ospf-1] area 1
    [SwitchC-ospf-1-area-0.0.0.1] stub   //Configure el Área 1 como un área de stub. Todos los routers en el Área 1 deben tener configurado el comando stub.
    [SwitchC-ospf-1-area-0.0.0.1] quit
    [SwitchC-ospf-1] quit

    # Compruebe la tabla de enrutamiento de OSPF en SwitchC. El resultado del comando muestra que la tabla de enrutamiento de OSPF no contiene la ruta externa AS 10.0.0.0/8 pero contiene una ruta predeterminada a redes externas.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3         0.0.0.1
     0.0.0.0/0          2     Inter-area 192.168.1.1     10.1.1.1         0.0.0.1
     192.168.0.0/24     2     Inter-area 192.168.1.1     10.1.1.1         0.0.0.1
    
     Total Nets: 3
     Intra Area: 1  Inter Area: 2  ASE: 0  NSSA: 0

  6. Configure el Área 1 como un área de stub totalmente.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] stub no-summary   //Configure el Área 1 como un área de stub totalmente. Un ABR en el Área 1 debe tener configurado el comando stub no-summary, mientras que otros routers en el Área 1 deben tener configurado el comandostub.
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

  7. Verifique la configuración.

    # Compruebe la tabla de enrutamiento de OSPF en SwitchC. El resultado del comando muestra que la tabla de enrutamiento de OSPF contiene solo una ruta de OSPF dentro del área y una ruta predeterminada a redes externas, pero no contiene la ruta entre áreas 192.168.0.0/24.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3         0.0.0.1
     0.0.0.0/0          2     Inter-area 192.168.1.1     10.1.1.1         0.0.0.1
    
     Total Nets: 2
     Intra Area: 1  Inter Area: 1  ASE: 0  NSSA: 0

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.0.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      stub no-summary
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.0.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.2.2.2
     import-route static type 1
     area 0.0.0.0
      network 192.168.0.0 0.0.0.255
    #
    ip route-static 10.0.0.0 255.0.0.0 NULL0
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.1
      network 192.168.1.0 0.0.0.255
      stub
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15719

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente