No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar una NSSA de OSPF

Ejemplo para configurar una NSSA de OSPF

Descripción general de la NSSA

Una NSSA es un tipo especial de área OSPF. Es similar a un área de stub en el sentido de que ninguno de ellos transmite rutas aprendidas de otras áreas en el AS que residen. La diferencia es que una NSSA permite que las rutas externas de AS se importen y anuncien en todo el AS, mientras que un área de stub no lo hace. Para garantizar la accesibilidad de las rutas externas de AS, el ABR en una NSSA genera una ruta predeterminada y anuncia la ruta a los otros routers en la NSSA.

Una NSSA permite que se anuncien LSA de Tipo 7 (LSA externas de NSSA). Las LSA de Tipo 7 son generadas por ASBR de la NSSA. Al alcanzar el ABR de NSSA, estos LSA se pueden traducir en LSA de tipo 5 (LSA externas de AS) y publicitarse en otras áreas.

Supongan que un dispositivo de la Compañía H se conecta al área troncal a través de un único enlace. El dispositivo tiene bajo rendimiento y una pequeña tabla de enrutamiento. La compañía desea configurar el área donde reside el dispositivo como un área de stub para reducir el tamaño de la tabla de enrutamiento y el consumo de recursos del sistema del dispositivo. Además, las rutas externas de AS deben importarse y publicitarse a todo el AS. Sin embargo, un área de stub no puede cumplir este requisito porque no permite que se anuncien rutas externas recibidas de AS. Por lo tanto, el área debe configurarse como una NSSA.

Notas de configuración

  • El área troncal no se puede configurar como una NSSA.
  • Para configurar un área como una NSSA, configure los atributos de NSSA en todos los routers en esta área.
  • Un enlace virtual no puede pasar a través de una NSSA.
  • Para reducir el número de LSA que se transmiten a NSSA, configure no-summary en un ABR. Esto evita que el ABR transmita LSA de Tipo 3 a la NSSA, lo que hace que el área sea totalmente NSSA.
  • Tabla 8-4 enumera los productos aplicables y las versiones de este ejemplo de configuración.
    Tabla 8-4  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra que en Figura 8-8, SwitchA, SwitchB, SwitchC, y SwitchD ejecutan OSPF y la red OSPF está dividida en Area 0 y Area 1. Los dispositivos en el Area 1 deben prohibir recibir rutas externas importadas de otras áreas y comunicarse con redes externas utilizando las rutas externas importadas por ASBR en el Area 1. SwitchB transmite muchos servicios, por eso SwitchA debe traducir LSA de Tipo 7 a LSA de Tipo 5 y enviar las LSA a otras áreas OSPF.

NOTA:

En este escenario, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado. Si STP está habilitado y las interfaces VLANIF de los switches se utilizan para construir una red de anillo de Capa 3, una interfaz en la red se bloqueará. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 8-8  Diagrama de redes para la configuración de OSPF NSSA

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure las funciones básicas de OSPF en cada switch a desplegar el interfuncionamiento en la red OSPF.

  2. Configure el Área 1 como una NSSA, configure una ruta estática en SwitchD y configure SwitchD para importar la ruta estática en la tabla de enrutamiento de OSPF, de modo que los switches en el Área 1 puedan comunicarse con redes externas solo a través de SwitchD.

  3. Configure SwitchA como un traductor LSA para traducir las LSA de tipo 7 en LSA de tipo 5 y envíe las LSA a otras áreas de OSPF.

Procedimiento

  1. Especifique las VLAN a las que pertenecen las interfaces.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 192.168.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 192.168.3.1 24
    [SwitchA-Vlanif30] quit

  3. Configurar funciones básicas de OSPF.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.1.1.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] network 192.168.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.2.2.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] area 1
    [SwitchB-ospf-1-area-0.0.0.1] network 192.168.4.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.1] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.3.3.3
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] ospf 1 router-id 10.4.4.4
    [SwitchD-ospf-1] area 1
    [SwitchD-ospf-1-area-0.0.0.1] network 192.168.3.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.1] network 192.168.4.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.1] quit
    [SwitchD-ospf-1] quit

  4. Configure el Area 1 como una NSSA.

    # Configure SwitchA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] nssa   //Configure el Area 1 como NSSA. Todos los dispositivos en el Area 1 deben tener el comando nssa configurado.
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1
    [SwitchB-ospf-1] area 1
    [SwitchB-ospf-1-area-0.0.0.1] nssa   //Configure el Area 1 como NSSA. Todos los dispositivos en el Area 1 deben tener el comando nssa configurado.
    [SwitchB-ospf-1-area-0.0.0.1] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] ospf 1
    [SwitchD-ospf-1] area 1
    [SwitchD-ospf-1-area-0.0.0.1] nssa   //Configure el Area 1 como NSSA. Todos los dispositivos en el Area 1 deben tener el comando nssa configurado.
    [SwitchD-ospf-1-area-0.0.0.1] quit
    [SwitchD-ospf-1] quit

  5. Configurar SwitchD para importar a ruta estática.

    [SwitchD] ip route-static 172.16.0.0 16 null 0
    [SwitchD] ospf 1
    [SwitchD-ospf-1] import-route static   //Configure SwitchD para que funcione como un ASBR de la NSSA para importar enrutamientos externos.
    [SwitchD-ospf-1] quit

    # Compruebe la tabla de enrutamiento de OSPF en SwitchC.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3       0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     10.3.3.3       0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.1.1     10.1.1.1       0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     10.2.2.2       0.0.0.0
     Routing for ASEs
     Destination        Cost      Type       Tag    NextHop         AdvRouter
     172.16.0.0/16       1         Type2       1     192.168.1.1     10.2.2.2
    
     Total Nets: 5
     Intra Area: 2  Inter Area: 2  ASE: 1  NSSA: 0

    El resultado del comando muestra que las rutas externas de AS importadas en la NSSA se anuncian por SwitchB a otras áreas. Es decir, SwitchB traduce LSA de Tipo 7 a LSA de Tipo 5. Esto se debe a que OSPF selecciona el ABR con un ID de router más grande como un traductor LSA.

  6. Configure SwitchA como un traductor LSA.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 1
    [SwitchA-ospf-1-area-0.0.0.1] nssa translator-always
    [SwitchA-ospf-1-area-0.0.0.1] quit
    [SwitchA-ospf-1] quit

  7. Verifique la configuración.

    # Espere 40 segundos y luego compruebe la tabla de enrutamiento OSPF en SwitchC.

    [SwitchC] display ospf routing
    
              OSPF Process 1 with Router ID 10.3.3.3
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     192.168.1.0/24     1     Transit    192.168.1.2     10.3.3.3       0.0.0.0
     192.168.2.0/24     1     Transit    192.168.2.2     10.3.3.3       0.0.0.0
     192.168.3.0/24     2     Inter-area 192.168.1.1     10.1.1.1       0.0.0.0
     192.168.4.0/24     2     Inter-area 192.168.2.1     10.2.2.2       0.0.0.0
     Routing for ASEs
     Destination        Cost      Type       Tag    NextHop         AdvRouter
     172.16.0.0/16       1         Type2       1     192.168.1.1     10.1.1.1
    
     Total Nets: 5
     Intra Area: 2  Inter Area: 2  ASE: 1  NSSA: 0

    El resultado del comando muestra que las rutas externas de AS importadas en la NSSA son anunciadas por SwitchA a otras áreas. Es decir, SwitchA traduce LSA de tipo 7 a LSA de tipo 5.

    NOTA:

    Por defecto, el nuevo traductor LSA funciona con el traductor LSA anterior para traducir los LSA durante 40 segundos. Después de 40 segundos, solo el nuevo traductor LSA traduce los LSA.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    ospf 1 router-id 10.1.1.1
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      nssa translator-always
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 40
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.2.2.2
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
     area 0.0.0.1
      network 192.168.4.0 0.0.0.255
      nssa
    #
    return
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.3.3.3
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchD

    #
    sysname SwitchD
    #
    vlan batch 30 40
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.4.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.4.4.4
     import-route static
     area 0.0.0.1
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      nssa
    #
    ip route-static 172.16.0.0 255.255.0.0 NULL0
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15822

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente