No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el equilibrio de carga OSPF

Ejemplo para configurar el equilibrio de carga OSPF

Descripción general del equilibrio de carga de OSPF

La Ruta múltiple de igual costo (ECMP) balancea de manera uniforme el tráfico en múltiples rutas entre cada dos nodos de red. ECMP reduce la carga de tráfico en cada ruta y mejora la robustez de la red. Si un protocolo de enrutamiento descubre múltiples rutas hacia el mismo destino y estas rutas tienen el mismo costo, el tráfico puede equilibrarse en la carga entre las rutas. Cuando se configura el balanceo de carga, el router reenvía paquetes según cinco factores, a saber, las direcciones de origen, las direcciones de destino, los puertos de origen, los puertos de destino y los protocolos en los paquetes. Si los cinco factores son los mismos, el router siempre elige la dirección del siguiente salto que es la misma que la última para enviar paquetes. Si los cinco factores son diferentes, el router elige la ruta relativamente inactiva para reenviar paquetes.

En una red OSPF, pueden existir múltiples rutas de igual costo entre dos elementos de red (NE), mientras que una ruta única lleva todo el tráfico de servicio. Los usuarios requieren que todo el tráfico del servicio se equilibre en varias rutas para mejorar la confiabilidad de la red y el uso de los recursos. En este caso, OSPF se puede configurar.

Notas de configuración

  • El número máximo de rutas de igual costo para el equilibrio de carga se puede configurar utilizando el comando maximum load-balancing.
  • Para cancelar el equilibrio de carga, puede establecer el número máximo de rutas de igual costo en 1.
  • Tabla 8-5 enumera los productos aplicables y las versiones de este ejemplo de configuración.
    Tabla 8-5  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 8-9, todos los cuatro switches pertenecen a Area0 en la red OSPF. El equilibrio de carga debe configurarse para que el tráfico de SwitchA se envíe a SwitchD a través de SwitchB y SwitchC.

NOTA:

En este escenario, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado. Si STP está habilitado y las interfaces VLANIF de los switches se utilizan para construir una red de anillo de Capa 3, una interfaz en la red se bloqueará. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 8-9  Diagrama de redes para configurar el equilibrio de carga entre las rutas de OSPF

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure funciones básicas de OSPF en cada switch para desplegar conexiones básicas en la red OSPF.

  2. Configure el equilibrio de carga en SwitchA.

Procedimiento

  1. Configure las VLAN a las que pertenece cada interfaz.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20 50
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 50
    [SwitchA-GigabitEthernet1/0/3] quit
    

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC, y SwitchD son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 20
    [SwitchA-Vlanif20] ip address 10.1.2.1 24
    [SwitchA-Vlanif20] quit
    [SwitchA] interface vlanif 50
    [SwitchA-Vlanif50] ip address 172.16.1.1 24
    [SwitchA-Vlanif50] quit

  3. Configurar funciones básicas de OSPF.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.10.10.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.10.10.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.10.10.3
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Configure SwitchD.

    [SwitchD] ospf 1 router-id 10.10.10.4
    [SwitchD-ospf-1] area 0
    [SwitchD-ospf-1-area-0.0.0.0] network 192.168.0.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] network 172.17.1.0 0.0.0.255
    [SwitchD-ospf-1-area-0.0.0.0] quit
    [SwitchD-ospf-1] quit

    # Mostrar la tabla de enrutamiento de SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 12
     
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
     
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.1.2.0/24  Direct  0    0           D   10.1.2.1        Vlanif20
           10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif20
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
         172.16.1.0/24  Direct  0    0           D   172.16.1.1      Vlanif50
         172.16.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif50
         172.17.1.0/24  OSPF    10   3           D   10.1.2.2        Vlanif20
                        OSPF    10   3           D   10.1.1.2        Vlanif10
        192.168.0.0/24  OSPF    10   2           D   10.1.1.2        Vlanif10
        192.168.1.0/24  OSPF    10   2           D   10.1.2.2        Vlanif20

    Como se muestra en la tabla de enrutamiento, dos próximos saltos 10.1.1.2 (SwitchB) y 10.1.2.2 (SwitchC) de SwitchA se convierten en rutas válidas ya que el número máximo de rutas de igual costo es 16 para un conmutador modular y 8 para un conmutador fijo.

  4. Configure el peso de las rutas de igual costo en SwitchA.

    Si no se desea desplegar el equilibrio de carga entre SwitchB y SwitchC, establezcan el peso de las rutas de igual costo para especificar el próximo salto.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] nexthop 10.1.2.2 weight 1   //Especifique el parámetro de weight para establecer la prioridad de los enrutamientos de igual costo. El valor de weight predeterminado es 255. Un valor de prioridad más grande indica una prioridad más baja.
    [SwitchA-ospf-1] quit

    # Compruebe la tabla de enrutamiento en SwitchA.

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 11       Routes : 11
     
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
     
           10.1.1.0/24  Direct  0    0           D   10.1.1.1        Vlanif10
           10.1.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif10
           10.1.2.0/24  Direct  0    0           D   10.1.2.1        Vlanif20
           10.1.2.1/32  Direct  0    0           D   127.0.0.1       Vlanif20
          127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
          127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0
         172.16.1.0/24  Direct  0    0           D   172.16.1.1      Vlanif50
         172.16.1.1/32  Direct  0    0           D   127.0.0.1       Vlanif50
         172.17.1.0/24  OSPF    10   3           D   10.1.2.2        Vlanif20
        192.168.0.0/24  OSPF    10   2           D   10.1.1.2        Vlanif10
        192.168.1.0/24  OSPF    10   2           D   10.1.2.2        Vlanif20

    Como se muestra en la tabla de enrutamiento, la prioridad del próximo salto 10.1.2.2 (SwitchC) con el peso 1 es mayor que la de 10.1.1.2 (SwitchB), después de establecer el peso para rutas de igual costo. OSPF selecciona la ruta con el próximo salto 10.1.2.2 como una ruta óptima.

Archivos de configuración

  • El Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 50
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif20
     ip address 10.1.2.1 255.255.255.0
    #
    interface Vlanif50
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    ospf 1 router-id 10.10.10.1
     nexthop 10.1.2.2 weight 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
    #
    return
  • El archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10 30
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif30
     ip address 192.168.0.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1 router-id 10.10.10.2
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.0.0 0.0.0.255
    #
    return
  • Archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 20 40
    #
    interface Vlanif20
     ip address 10.1.2.2 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.10.10.3
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return 
  • El archivo de configuración SwitchD

    #
    sysname SwitchD
    #
    vlan batch 30 40 60
    #
    interface Vlanif30
     ip address 192.168.0.2 255.255.255.0
    #
    interface Vlanif40
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif60
     ip address 172.17.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 60
    #
    ospf 1 router-id 10.10.10.4
     area 0.0.0.0
      network 172.17.1.0 0.0.0.255
      network 192.168.0.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15488

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente