No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar BFD para OSPF

Ejemplo para configurar BFD para OSPF

Descripción general de BFD para OSPF

La Detección de reenvío bidireccional (BFD) es un mecanismo utilizado para detectar fallas de comunicación entre los motores de reenvío. BFD detecta la conectividad de un protocolo de datos en una ruta entre dos sistemas. La ruta puede ser un enlace físico o lógico. En BFD para OSPF, una sesión de BFD está asociada con OSPF. La sesión BFD detecta rápidamente un error de enlace y luego notifica a OSPF de la falla. Esto acelera la respuesta de OSPF al cambio de la topología de red.

Cualquier falla de enlace o cambio de topología en la red hará que el dispositivo vuelva a calcular las rutas. Si se utiliza el mecanismo de detección OSPF, el tiempo de recálculo de la ruta es el tiempo de convergencia del protocolo OSPF. En este caso, OSPF detecta fallas en segundos. En la transmisión de datos de alta velocidad, por ejemplo, a velocidades de gigabit, un tiempo de detección más largo que un segundo va a causar la pérdida de una gran cantidad de datos. En servicios sensibles a la demora, como la voz, un retraso de más de un segundo es inaceptable. Cuando una red OSPF requiere alta confiabilidad o los servicios que se ejecutan en la red son sensibles al retardo, se puede configurar el BFD para OSPF. BFD acelera la convergencia de la red OSPF y luego OSPF puede detectar la falla en milisegundos si ocurre una falla en el enlace entre los vecinos.

Notas de configuración

  • BFD debe configurarse en los dos extremos entre los cuales se establece la relación de vecino OSPF.
  • Los dos extremos que establecen sesiones BFD deben ubicarse en el mismo segmento de red en un área OSPF.
  • Los comandos ospf bfd enable y ospf bfd block son mutuamente excluyentes y no se pueden habilitar al mismo tiempo.
  • Tabla 8-6 enumera los productos aplicables y las versiones de este ejemplo de configuración.
    Tabla 8-6  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 8-10, OSPF se ejecuta entre SwitchA, SwitchB, y SwitchC, y el switch entre SwitchA y SwitchB solo proporciona la función de transmisión transparente. SwitchA y SwitchB deben detectar rápidamente el estado del enlace entre ellos. Cuando el enlace SwitchA->SwitchB es defectuoso, los servicios pueden cambiarse rápidamente al enlace de copia de seguridad SwitchA-> SwitchC-> SwitchB.

NOTA:

En este escenario, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado. Si STP está habilitado y las interfaces VLANIF de los switches se utilizan para construir una red de anillo de Capa 3, una interfaz en la red se bloqueará. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 8-10  Diagrama de redes de configuración de BFD para OSPF

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure las funciones básicas de OSPF en SwitchA, SwitchB y SwitchC para desplegar las conexiones básicas en la red OSPF.

  2. Configure BFD para OSPF en SwitchA, SwitchB y SwitchC para que los servicios puedan cambiarse rápidamente al enlace de copia de seguridad cuando el enlace entre SwitchA y SwitchB sea defectuoso.

Procedimiento

  1. Configure las VLAN a las que pertenece cada interfaz.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son iguales que la de SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 30
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type trunk
    [SwitchA-GigabitEthernet1/0/1] port trunk allow-pass vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type trunk
    [SwitchA-GigabitEthernet1/0/2] port trunk allow-pass vlan 30
    [SwitchA-GigabitEthernet1/0/2] quit

  2. Configure una dirección IP para cada interfaz VLANIF.

    # Configure SwitchA. Las configuraciones de SwitchB y SwitchC son similares.

    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit
    [SwitchA] interface vlanif 30
    [SwitchA-Vlanif30] ip address 10.3.3.1 24
    [SwitchA-Vlanif30] quit

  3. Configurar funciones básicas de OSPF.

    # Configure SwitchA.

    [SwitchA] ospf 1 router-id 10.10.10.1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

    # Configure SwitchB.

    [SwitchB] ospf 1 router-id 10.10.10.2
    [SwitchB-ospf-1] area 0
    [SwitchB-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 10.3.3.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] network 172.16.1.0 0.0.0.255
    [SwitchB-ospf-1-area-0.0.0.0] quit
    [SwitchB-ospf-1] quit

    # Configure SwitchC.

    [SwitchC] ospf 1 router-id 10.10.10.3
    [SwitchC-ospf-1] area 0
    [SwitchC-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] network 10.2.2.0 0.0.0.255
    [SwitchC-ospf-1-area-0.0.0.0] quit
    [SwitchC-ospf-1] quit

    # Después de las configuraciones anteriores, ejecute el comando display ospf peer. Las relaciones vecinas se configuran entre SwitchA, SwitchB, y SwitchC. El resultado del comando de SwitchA se usa como un ejemplo.

    [SwitchA] display ospf peer
    
              OSPF Process 1 with Router ID 10.10.10.1
                      Neighbors
    
     Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s neighbors
     Router ID: 10.10.10.3       Address: 10.1.1.2          
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 10.1.1.2  BDR: 10.1.1.1  MTU: 0
       Dead timer due in 38  sec
       Retrans timer interval: 5
       Neighbor is up for 00:00:15
       Authentication Sequence: [ 0 ]
    
                      Neighbors
    
     Area 0.0.0.0 interface 10.3.3.1(Vlanif30)'s neighbors
     Router ID: 10.10.10.2       Address: 10.3.3.2
       State: Full  Mode:Nbr is   Master  Priority: 1
       DR: 10.3.3.2  BDR: 10.3.3.1  MTU: 0
       Dead timer due in 25  sec
       Retrans timer interval: 5
       Neighbor is up for 00:00:59
       Authentication Sequence: [ 0 ]

    # Compruebe la tabla de enrutamiento OSPF en SwitchA. Pueden ver las entradas de enrutamiento en SwitchB y SwitchC. Sin embargo, la dirección del siguiente salto de la ruta al segmento de red de destino 172.16.1.0/24 es 10.3.3.2, lo que indica que el tráfico se transmite en el enlace Switch A → SwitchB.

    [SwitchA] display ospf routing
    
              OSPF Process 1 with Router ID 10.10.10.1
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     10.1.1.0/24        1     Transit    10.1.1.1        10.10.10.1      0.0.0.0
     10.3.3.0/24        1     Transit    10.3.3.1        10.10.10.1      0.0.0.0
     10.2.2.0/24        2     Transit    10.1.1.2        10.10.10.3      0.0.0.0
     10.2.2.0/24        2     Transit    10.3.3.2        10.10.10.3      0.0.0.0
     172.16.1.0/24      2     Stub       10.3.3.2        10.10.10.2      0.0.0.0
    
     Total Nets: 5
     Intra Area: 5  Inter Area: 0  ASE: 0  NSSA: 0

  4. Configure BFD para OSPF.

    # Configurar BFD para OSPF en SwitchA.

    [SwitchA] bfd   //Habilite BFD globalmente.
    [SwitchA-bfd] quit
    [SwitchA] ospf 1
    [SwitchA-ospf-1] bfd all-interfaces enable   //Habilite BFD en el proceso OSPF 1.
    [SwitchA-ospf-1] quit

    # Configurar BFD para OSPF en SwitchB.

    [SwitchB] bfd   //Habilite BFD globalmente.
    [SwitchB-bfd] quit
    [SwitchB] ospf 1
    [SwitchB-ospf-1] bfd all-interfaces enable   //Habilite BFD en el proceso OSPF 1.
    [SwitchB-ospf-1] quit

    # Configurar BFD para OSPF en SwitchC.

    [SwitchC] bfd   //Habilite BFD globalmente.
    [SwitchC-bfd] quit
    [SwitchC] ospf 1
    [SwitchC-ospf-1] bfd all-interfaces enable   //Habilite BFD en el proceso OSPF 1.
    [SwitchC-ospf-1] quit

    # Después de las configuraciones anteriores, ejecute el comando display ospf bfd session all en SwitchA, SwitchB o SwitchC. La sesión del BFD del peer es Up. La salida de comando de SwitchA se usa como ejemplo.

    [SwitchA] display ospf bfd session all
    
              OSPF Process 1 with Router ID 10.10.10.1
      Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s BFD Sessions
    
     NeighborId:10.10.10.3       AreaId:0.0.0.0          Interface:Vlanif10
     BFDState:up                 rx    :1000             tx       :1000
     Multiplier:3                BFD Local Dis:8195      LocalIpAdd:10.1.1.1
     RemoteIpAdd:10.1.1.2        Diagnostic Info:No diagnostic information
    
      Area 0.0.0.0 interface 10.3.3.1(Vlanif30)'s BFD Sessions
    
     NeighborId:10.10.10.2       AreaId:0.0.0.0          Interface:Vlanif30
     BFDState:up                 rx    :1000             tx       :1000
     Multiplier:3                BFD Local Dis:8194      LocalIpAdd:10.3.3.1
     RemoteIpAdd:10.3.3.2         Diagnostic Info:No diagnostic information

  5. Verifique la configuración.

    # Ejecute el comando shutdown en GE1/0/1 de SwitchB para simular el error de enlace.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] shutdown

    # Compruebe la tabla de enrutamiento de OSPF en SwitchA.

    [SwitchA] display ospf routing
    
              OSPF Process 1 with Router ID 10.10.10.1
                       Routing Tables
    
     Routing for Network
     Destination        Cost  Type       NextHop         AdvRouter       Area
     10.1.1.0/24        1     Transit    10.1.1.1        10.10.10.1      0.0.0.0
     10.2.2.0/24        2     Transit    10.1.1.2        10.10.10.3      0.0.0.0
     172.16.1.0/24      3     Stub       10.1.1.2        10.10.10.2      0.0.0.0
    
     Total Nets: 3
     Intra Area: 3  Inter Area: 0  ASE: 0  NSSA: 0

    Cuando el enlace SwitchA ->SwitchB es defectuoso, el enlace de reserva SwitchA ->SwitchC -> SwitchB entra en vigencia y la dirección del siguiente salto de la ruta al segmento de red de destino 172.16.1.0/24 cambia a 10.1.1.2.

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 30
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface Vlanif30
     ip address 10.3.3.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    ospf 1 router-id 10.10.10.1
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.3.3.0 0.0.0.255
    #
    return
  • Archivo de configuración SwitchB

    #
    sysname SwitchB
    #
    vlan batch 20 30 40
    #
    bfd
    #
    interface Vlanif20
     ip address 10.2.2.2 255.255.255.0
    #
    interface Vlanif30
     ip address 10.3.3.2 255.255.255.0
    #
    interface Vlanif40
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    ospf 1 router-id 10.10.10.2
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.2.2.0 0.0.0.255
      network 10.3.3.0 0.0.0.255
      network 172.16.1.0 0.0.0.255
    #
    return
    
  • El archivo de configuración SwitchC

    #
    sysname SwitchC
    #
    vlan batch 10 20
    #
    bfd
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip address 10.2.2.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    ospf 1 router-id 10.10.10.3
     bfd all-interfaces enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.2.2.0 0.0.0.255
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15681

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente