No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar las políticas de tráfico para desplegar el enrutamiento basado en políticas (redirección a diferentes saltos siguientes)

Ejemplo para configurar las políticas de tráfico para desplegar el enrutamiento basado en políticas (redirección a diferentes saltos siguientes)

Descripción general del enrutamiento basado en políticas

Tradicionalmente, un dispositivo busca en su tabla de enrutamiento las rutas basadas en las direcciones de destino de los paquetes recibidos y luego reenvía los paquetes según las rutas. Actualmente, más usuarios requieren enrutamiento de paquetes en función de las políticas definidas por el usuario. El Enrutamiento basado en políticas (PBR) es un mecanismo de reenvío de datos implementado en base a políticas definidas por el usuario.

En los switches de la serie S, PBR se despliega redireccionando los paquetes entrantes de Capa 3 que coinciden con las reglas de clasificación de tráfico en una interfaz a una dirección IP de siguiente salto especificada.

Cuando un flujo de datos específico necesita ser transmitido a un siguiente salto especificado, PBR puede configurarse para cumplir con este requisito. Por ejemplo, se pueden transmitir diferentes flujos de datos en diferentes enlaces para mejorar la eficacia del enlace. Los flujos de datos pueden dirigirse a dispositivos de seguridad tales como cortafuegos para el filtrado de seguridad. Los datos de servicio se pueden transmitir en un enlace con bajo costo para reducir los costos del servicio de datos de las empresas sin comprometer la calidad del servicio.

Notas de configuración

  • Si un dispositivo no tiene la entrada ARP que coincide con la dirección IP del siguiente salto especificada, el dispositivo va a activar el aprendizaje de ARP. Si el dispositivo no puede aprender la entrada ARP, los paquetes se reenvían a lo largo de la ruta de reenvío anterior sin ser redirigidos.
  • Si se configuran varias direcciones IP de siguiente salto utilizando el comando redirect ip-nexthop o redirect ipv6-nexthop, el dispositivo redirige los paquetes en el modo de enlace activo/standby. Es decir, el dispositivo determina los enlaces activos y standby de acuerdo con la secuencia en la que se configuraron las direcciones IP del siguiente salto. La primera dirección IP configurada para el siguiente salto tiene la prioridad más alta y su enlace funciona como el enlace activo, mientras que los enlaces de otras direcciones IP del siguiente salto funcionan como enlaces standby. Cuando el enlace activo está inactivo, el enlace standby de la segunda dirección IP del siguiente salto más prioritario se selecciona como el nuevo enlace activo.
  • Si se configuran varias direcciones IP de siguiente salto utilizando el comando redirect ip-multihop o redirect ipv6-multihop, el dispositivo redirige los paquetes en modo de equilibrio de carga de rutas de igual costo.
  • Tabla 8-7 enumera los productos y las versiones aplicables en este ejemplo de configuración.
    Tabla 8-7  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S2350

    V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S3300

    S3300SI y S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 8-11, una red empresarial tiene doble conexión a dos dispositivos de red externos a través del Switch. Un enlace ascendente es un enlace de alta velocidad con gateway en 10.1.20.1/24, y el otro es un enlace de baja velocidad con gateway en 10.1.30.1/24.

La intranet empresarial tiene dos segmentos de red: 192.168.1.0/24 y 192.168.2.0/24. El segmento de red 192.168.1.0/24 pertenece a la zona del servidor y requiere un alto ancho de banda de enlace. Por lo tanto, el tráfico de este segmento de red debe transmitirse en el enlace de alta velocidad. 192.168.2.0/24 se utiliza para el acceso de Internet y el tráfico de este segmento de red se transmite en el enlace de baja velocidad.

Figura 8-11  Red de PBR

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:
  1. Cree VLAN, configure interfaces y configure rutas para conectar a los usuarios empresariales con la red externa.
  2. Configure las ACL para que coincidan con los flujos de datos de los segmentos de red 192.168.1.0 y 192.168.2.0.
  3. Cree clasificadores de tráfico y haga referencia a las ACL para diferenciar paquetes.
  4. Configure comportamientos de tráfico para transmitir tráfico de datos que coincida con diferentes ACL en diferentes enlaces y permita que el tráfico transmitido entre los usuarios de la intranet pase primero.
  5. Configure una política de tráfico, vincule los clasificadores de tráfico y los comportamientos de tráfico y aplíquela a la dirección entrante de GE1/0/3/ en el Switch para desplegar PBR.

Procedimiento

  1. Cree VLAN, configure interfaces y configure rutas para el interfuncionamiento.

    # Crear VLAN 10 y 20 en SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 10 20

    # En Switch, establezca los tipos de enlace de las interfaces conectadas a los ordenadores a acceso y la interfaz conectada a Switch a tronco y añada las interfaces a las VLAN.

    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port link-type access
    [SwitchA-GigabitEthernet1/0/1] port default vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port link-type access
    [SwitchA-GigabitEthernet1/0/2] port default vlan 20
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface gigabitethernet 1/0/3
    [SwitchA-GigabitEthernet1/0/3] port link-type trunk
    [SwitchA-GigabitEthernet1/0/3] port trunk allow-pass vlan 10 20
    [SwitchA-GigabitEthernet1/0/3] quit

    # Cree VLAN 10, 20, 100 y 200 en Switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan batch 10 20 100 200

    # En Switch, configure los tipos de enlace de las interfaces conectadas a SwitchA a tronco y la interfaz conectada a la red externa para acceder, y agregue las interfaces a las VLAN.

    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port link-type access
    [Switch-GigabitEthernet1/0/1] port default vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port link-type access
    [Switch-GigabitEthernet1/0/2] port default vlan 200
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port link-type trunk
    [Switch-GigabitEthernet1/0/3] port trunk allow-pass vlan 10 20
    [Switch-GigabitEthernet1/0/3] quit

    # En Switch, configure VLANIF10 y VLANIF20 como gateways de usuario y asigne direcciones IP 192.168.1.1/24 y 192.168.2.1/24 a ellas.

    [Switch] interface vlanif 10
    [Switch-Vlanif10] ip address 192.168.1.1 24
    [Switch-Vlanif10] quit
    [Switch] interface vlanif 20
    [Switch-Vlanif20] ip address 192.168.2.1 24
    [Switch-Vlanif20] quit

    # En Switch, configure VLANIF 100 y VLANIF 200 para conectarse a dispositivos de red externos y asigne direcciones IP a 10.1.20.2/24 y 10.1.30.2/24 a ellos, respectivamente.

    [Switch] interface vlanif 100
    [Switch-Vlanif100] ip address 10.1.20.2 24
    [Switch-Vlanif100] quit
    [Switch] interface vlanif 200
    [Switch-Vlanif200] ip address 10.1.30.2 24
    [Switch-Vlanif200] quit

    # En Switch, configure dos rutas predeterminadas y establezca sus direcciones IP del siguiente salto en las direcciones IP de los dos dispositivos de red externos.

    [Switch] ip route-static 0.0.0.0 0 10.1.20.1
    [Switch] ip route-static 0.0.0.0 0 10.1.30.1

    Después de completar la configuración anterior, los usuarios de la intranet pueden acceder a la red externa. Para garantizar que los flujos de datos de los segmentos de red 192.168.1.0/24 y 192.168.2.0/24 se transmitan en el enlace de alta velocidad y en el de baja velocidad respectivamente, realicen las siguientes configuraciones.

  2. Configure ACL.

    # En Switch, cree ACL avanzadas de 3000, 3001 y 3002.

    [Switch] acl 3000   //Esta ACL se utiliza para coincidir con el tráfico de datos entre dos segmentos de red de la intranet. El tráfico de datos no debe ser redirigido. Si no se realiza esta configuración, se redirigirá el tráfico entre los segmentos de la red. Como resultado, la comunicación entre los segmentos de red fallará
    [Switch-acl-adv-3000] rule permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255
    [Switch-acl-adv-3000] rule permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255
    Switch-acl-adv-3000] quit
    [Switch] acl 3001   //Coincide con el tráfico de datos del segmento de red de intranet 192.168.1.0/24.
    [Switch-acl-adv-3001] rule permit ip source 192.168.1.0 0.0.0.255
    [Switch-acl-adv-3001] quit
    [Switch] acl 3002   //Coincide con el tráfico de datos del segmento de red de la intranet 192.168.2.0/24.
    [Switch-acl-adv-3002] rule permit ip source 192.168.2.0 0.0.0.255
    [Switch-acl-adv-3002] quit

  3. Configure clasificadores de tráfico.

    En Switch, crea clasificadores de tráfico c0, c1, y c2, y vincule c0 a ACL 3000, c1 a ACL 3001 y c2 a ACL 3002.

    [Switch] traffic classifier c0 operator or
    [Switch-classifier-c0] if-match acl 3000
    [Switch-classifier-c0] quit
    [Switch] traffic classifier c1 operator or
    [Switch-classifier-c1] if-match acl 3001
    [Switch-classifier-c1] quit
    [Switch] traffic classifier c2 operator or
    [Switch-classifier-c2] if-match acl 3002
    [Switch-classifier-c2] quit

  4. Configure los comportamientos de tráfico.

    # En Switch, crea comportamientos de tráfico b0, b1 y b2, configure la acción de permiso en b0, y configure las acciones que redirijan los paquetes a las direcciones IP 10.1.20.1 y 10.1.30.1 en b1 y b2 respectivamente.

    [Switch] traffic behavior b0
    [Switch-behavior-b0] permit
    [Switch-behavior-b0] quit
    [Switch] traffic behavior b1
    [Switch-behavior-b1] redirect ip-nexthop 10.1.20.1
    [Switch-behavior-b1] quit
    [Switch] traffic behavior b2
    [Switch-behavior-b2] redirect ip-nexthop 10.1.30.1
    [Switch-behavior-b2] quit

  5. Configure una política de tráfico y aplique la política de tráfico a una interfaz.

    # En Switch, crea una política de tráfico p1 y vincule los clasificadores de tráfico y los comportamientos de tráfico a esta política de tráfico.

    [Switch] traffic policy p1
    [Switch-trafficpolicy-p1] classifier c0 behavior b0
    [Switch-trafficpolicy-p1] classifier c1 behavior b1
    [Switch-trafficpolicy-p1] classifier c2 behavior b2
    [Switch-trafficpolicy-p1] quit

    # Aplicar la política de tráfico p1 a la dirección entrante de GE1/0/3 en la Switch.

    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] traffic-policy p1 inbound
    [Switch-GigabitEthernet1/0/3] return

  6. Verifique la configuración.

    # Compruebe la configuración de ACL.

    <Switch> display acl 3000
    Advanced ACL 3000, 2 rules
    Acl's step is 5
     rule 5 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255
     rule 10 permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255
    <Switch> display acl 3001
    Advanced ACL 3001, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.1.0 0.0.0.255
    <Switch> display acl 3002
    Advanced ACL 3002, 1 rule
    Acl's step is 5
     rule 5 permit ip source 192.168.2.0 0.0.0.255

    # Compruebe la configuración del clasificador de tráfico.

    <Switch> display traffic classifier user-defined
      User Defined Classifier Information:
       Classifier: c2
        Precedence: 15
        Operator: OR
        Rule(s) : if-match acl 3002
                 
       Classifier: c0
        Precedence: 5
        Operator: OR
        Rule(s) : if-match acl 3000
                 
       Classifier: c1
        Precedence: 10
        Operator: OR
        Rule(s) : if-match acl 3001
                 
    Total classifier number is 3 
    

    # Compruebe la configuración de la política de tráfico.

    <Switch> display traffic policy user-defined p1
      User Defined Traffic Policy Information:
      Policy: p1
       Classifier: c0
        Operator: OR
         Behavior: b0
          Permit
       Classifier: c1
        Operator: OR
         Behavior: b1
          Permit
          Redirect: no forced
            Redirect ip-nexthop
            10.1.20.1
       Classifier: c2
        Operator: OR
         Behavior: b2
          Permit
          Redirect: no forced
            Redirect ip-nexthop
            10.1.30.1

Archivos de configuración

  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10 20 
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 10
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 20
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    return
    
  • El Archivo de configuración de Switch

    #
    sysname Switch
    #
    vlan batch 10 20 100 200 
    #
    acl number 3000
     rule 5 permit ip source 192.168.1.0 0.0.0.255 destination 192.168.2.0 0.0.0.255
     rule 10 permit ip source 192.168.2.0 0.0.0.255 destination 192.168.1.0 0.0.0.255
    acl number 3001
     rule 5 permit ip source 192.168.1.0 0.0.0.255
    acl number 3002
     rule 5 permit ip source 192.168.2.0 0.0.0.255
    #
    traffic classifier c0 operator or precedence 5
     if-match acl 3000
    traffic classifier c1 operator or precedence 10
     if-match acl 3001
    traffic classifier c2 operator or precedence 15
     if-match acl 3002
    #
    traffic behavior b0
     permit
    traffic behavior b1
     permit
     redirect ip-nexthop 10.1.20.1
    traffic behavior b2
     permit
     redirect ip-nexthop 10.1.30.1
    #
    traffic policy p1 match-order config
     classifier c0 behavior b0
     classifier c1 behavior b1
     classifier c2 behavior b2
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface Vlanif100
     ip address 10.1.20.2 255.255.255.0
    #
    interface Vlanif200
     ip address 10.1.30.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port link-type access
     port default vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type access
     port default vlan 200
    #
    interface GigabitEthernet1/0/3
     port link-type trunk
     port trunk allow-pass vlan 10 20
     traffic-policy p1 inbound
    #                                                                               
    ip route-static 0.0.0.0 0.0.0.0 10.1.20.1                                       
    ip route-static 0.0.0.0 0.0.0.0 10.1.30.1
    #
    return
    
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15845

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente