No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar BGP/MPLS IP VPN

Ejemplo para configurar BGP/MPLS IP VPN

Descripción general de BGP/MPLS IP VPN

BGP/MPLS IP VPN es una L3VPN basada en MPLS que se puede desplegar flexiblemente y extender fácilmente, y es adecuada para su despliegue a gran escala. Para agregar un nuevo sitio, el administrador de red solo necesita modificar la configuración de los nodos de borde que sirven al nuevo sitio.

BGP/MPLS IP VPN es adecuado para la comunicación entre la sede y las sucursales en diferentes ubicaciones. Como los datos de comunicación deben atravesar la red de estructura básica del operador, BGP se usa para publicitar rutas VPN a través de la red de estructura básica y MPLS se utiliza para reenviar paquetes VPN en la red de estructura básica. Como los diferentes departamentos de una empresa deben aislarse, BGP/MPLS IP VPN puede aislar la ruta, el espacio de direcciones y el acceso entre diferentes VPN.

Notas de configuración

  • Las tarjetas de la serie SA no son compatibles con la función BGP/MPLS IP VPN. Las tarjetas de la serie X1E de V200R006C00 y versiones posteriores son compatible con la función BGP/MPLS IP VPN.
  • Tabla 9-1 enumera productos y versiones aplicables.
    Tabla 9-1  Productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S5300

    S5300HI

    V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306, S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9300E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

Como se muestra en Figura 9-1:
  • CE1 se conecta al área de I+D de la sede de una empresa, y CE3 se conecta al área de I+D de la sucursal. CE1 y CE3 pertenecen a vpna.
  • CE2 se conecta con el área que no es de I+D de la sede y CE4 se conecta con el área que no es de I+D de la sucursal. CE2 y CE4 pertenecen a vpnb.

La BGP/MPLS IP VPN debe desplegarse para que la empresa garantice una comunicación segura entre la sede y la sucursal, a la vez que aísla los datos entre el área de I+D y el área que no es de I+D.

Figura 9-1  Diagrama de redes para configurar BGP/MPLS IP VPN

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure OSPF entre P y PE para garantizar la conectividad de IP en la red de estructura básica.
  2. Configure las capacidades básicas MPLS y MPLS LDP en el P y el PE para establecer túneles de MPLS LSP para la transmisión de datos VPN en la red de estructura básica.
  3. Configure MP-IBGP en PE1 y PE2 para habilitarlas a intercambiar información de enrutamiento VPN.
  4. Configure las instancias de VPN vpna y vpnb en PE1 y PE2. Establezca el objetivo VPN de vpna en 111:1 y el objetivo VPN de vpnb en 222:2. Esta configuración permite a los usuarios comunicarse en la misma VPN entre ellos y aísla a los usuarios en diferentes VPN. Vincule las interfaces PE conectadas a los CE con las instancias correspondientes de VPN para proporcionar acceso a los usuarios de VPN.
  5. Configure EBGP en los CE y PE para intercambiar información de enrutamiento VPN.

Procedimiento

  1. Configure un IGP en la red de estructura básica MPLS para que los PE y P puedan comunicarse entre sí.

    # Configure PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] vlan batch 10 20 30
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port link-type trunk
    [PE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10 
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] port link-type trunk
    [PE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 20 
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] port link-type trunk
    [PE1-GigabitEthernet3/0/0] port trunk allow-pass vlan 30 
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] ip address 172.1.1.1 24
    [PE1-Vlanif30] quit
    [PE1] ospf 1 router-id 1.1.1.9
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure P.

    <Quidway> system-view
    [Quidway] sysname P
    [P] interface loopback 1
    [P-LoopBack1] ip address 2.2.2.9 32
    [P-LoopBack1] quit
    [P] vlan batch 30 60
    [P] interface gigabitethernet 1/0/0 
    [P-GigabitEthernet1/0/0] port link-type trunk
    [P-GigabitEthernet1/0/0] port trunk allow-pass vlan 30
    [P-GigabitEthernet1/0/0] quit
    [P] interface gigabitethernet 2/0/0 
    [P-GigabitEthernet2/0/0] port link-type trunk
    [P-GigabitEthernet2/0/0] port trunk allow-pass vlan 60
    [P-GigabitEthernet2/0/0] quit
    [P] interface vlanif 30
    [P-Vlanif30] ip address 172.1.1.2 24
    [P-Vlanif30] quit
    [P] interface vlanif 60
    [P-Vlanif60] ip address 172.2.1.1 24
    [P-Vlanif60] quit
    [P] ospf 1 router-id 2.2.2.9
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 172.2.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit

    # Configure PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 3.3.3.9 32
    [PE2-LoopBack1] quit
    [PE2] vlan batch 40 50 60
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] port link-type trunk
    [PE2-GigabitEthernet1/0/0] port trunk allow-pass vlan 40
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] interface gigabitethernet 2/0/0 
    [PE2-GigabitEthernet2/0/0] port link-type trunk
    [PE2-GigabitEthernet2/0/0] port trunk allow-pass vlan 50
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface gigabitethernet 3/0/0 
    [PE2-GigabitEthernet3/0/0] port link-type trunk
    [PE2-GigabitEthernet3/0/0] port trunk allow-pass vlan 60
    [PE2-GigabitEthernet3/0/0] quit
    [PE2] interface vlanif 60
    [PE2-Vlanif60] ip address 172.2.1.2 24
    [PE2-Vlanif60] quit
    [PE2] ospf 1 router-id 3.3.3.9
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 172.2.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    Después de completar la configuración, las relaciones de vecinos OSPF se establecen entre PE1 y P, y entre PE2 y P. Ejecute el comando display ospf peer. El resultado de comando muestra que el estado vecino es Full. Ejecute el comando display ip routing-table. El resultado de comando muestra que los PE aprendieron las rutas de Loopback1 el uno del otro.

    La información que se muestra en PE1 se usa como ejemplo.

    [PE1] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8       Routes : 8
    
      Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
             1.1.1.9/32   Direct 0    0           D  127.0.0.1       LoopBack1
             2.2.2.9/32   OSPF   10   1           D  172.1.1.2       Vlanif30
             3.3.3.9/32   OSPF   10   2           D  172.1.1.2       Vlanif30
            127.0.0.0/8   Direct 0    0           D  127.0.0.1       InLoopBack0
           127.0.0.1/32   Direct 0    0           D  127.0.0.1       InLoopBack0
           172.1.1.0/24   Direct 0    0           D  172.1.1.1       Vlanif30
           172.1.1.1/32   Direct 0    0           D  127.0.0.1       Vlanif30
           172.2.1.0/24   OSPF   10   2           D  172.1.1.2       Vlanif30
    
    [PE1] display ospf peer
    
              OSPF Process 1 with Router ID 1.1.1.9
                      Neighbors
    
     Area 0.0.0.0 interface 172.1.1.1(Vlanif30)'s neighbors
     Router ID: 2.2.2.9         Address: 172.1.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 172.1.1.2  BDR: 172.1.1.1  MTU: 0 
       Dead timer due in 37  sec
       Retrans timer interval: 5 
       Neighbor is up for 00:16:21
       Authentication Sequence: [ 0 ]

  2. Configure las capacidades básicas MPLS y MPLS LDP en la red de estructura básica de MPLS para establecer LSP LDP.

    # Configure PE1.

    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] mpls
    [PE1-Vlanif30] mpls ldp
    [PE1-Vlanif30] quit

    # Configure P.

    [P] mpls lsr-id 2.2.2.9
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface vlanif 30
    [P-Vlanif30] mpls
    [P-Vlanif30] mpls ldp
    [P-Vlanif30] quit
    [P] interface vlanif 60
    [P-Vlanif60] mpls
    [P-Vlanif60] mpls ldp
    [P-Vlanif60] quit

    # Configure PE2.

    [PE2] mpls lsr-id 3.3.3.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface vlanif 60
    [PE2-Vlanif60] mpls
    [PE2-Vlanif60] mpls ldp
    [PE2-Vlanif60] quit

    Después de completar la configuración, las sesiones de LDP se establecen entre PE1 y P, entre P y PE2. Ejecute el comando display mpls ldp session. El resultado de comando muestra que el ítem de Status es Operational. Ejecute el comando display mpls ldp lsp. Se muestra información sobre los LSP LDP establecidos.

    La información que se muestra en PE1 se usa como ejemplo.

    [PE1] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted. 
     ------------------------------------------------------------------------------
     PeerID            Status      LAM  SsnRole  SsnAge       KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.9:0          Operational DU   Passive  0000:00:01  6/6
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    
    
    [PE1] display mpls ldp lsp
    
    LDP LSP Information
     -------------------------------------------------------------------------------
     Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel   UpstreamPeer     NextHop     OutInterface   
     -------------------------------------------------------------------------------
     1.1.1.9/32         3/NULL        2.2.2.9          127.0.0.1   InLoop0    
    *1.1.1.9/32         Liberal/1024                   DS/2.2.2.9
     2.2.2.9/32         NULL/3        -                172.1.1.2   Vlanif30       
     2.2.2.9/32         1024/3        2.2.2.9          172.1.1.2   Vlanif30       
     3.3.3.9/32         NULL/1025     -                172.1.1.2   Vlanif30       
     3.3.3.9/32         1025/1025     2.2.2.9          172.1.1.2   Vlanif30      
     -------------------------------------------------------------------------------
     TOTAL: 5 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established 
     A '*' before a Label means the USCB or DSCB is stale 
     A '*' before a UpstreamPeer means the session is stale 
     A '*' before a DS means the session is stale 
     A '*' before a NextHop means the LSP is FRR LSP
    
    

  3. Configure instancias de VPN en PE y vincule las interfaces conectadas a los CE a las instancias de VPN.

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] route-distinguisher 100:2
    [PE1-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip binding vpn-instance vpna
    [PE1-Vlanif10] ip address 10.1.1.2 24
    [PE1-Vlanif10] quit
    [PE1] interface vlanif 20
    [PE1-Vlanif20] ip binding vpn-instance vpnb
    [PE1-Vlanif20] ip address 10.2.1.2 24
    [PE1-Vlanif20] quit

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] route-distinguisher 200:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] route-distinguisher 200:2
    [PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit
    [PE2] interface vlanif 40
    [PE2-Vlanif40] ip binding vpn-instance vpna
    [PE2-Vlanif40] ip address 10.3.1.2 24
    [PE2-Vlanif40] quit
    [PE2] interface vlanif 50
    [PE2-Vlanif50] ip binding vpn-instance vpnb
    [PE2-Vlanif50] ip address 10.4.1.2 24
    [PE2-Vlanif50] quit

    # Asigne las direcciones IP a las interfaces en el CE1 conectando al área de I+D de la sede de acuerdo con Figura 9-1. Las configuraciones de CE2, CE3 y CE4 son similares a la configuración de CE1 y no se mencionan aquí.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port link-type trunk
    [CE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10 
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface vlanif 10
    [CE1-Vlanif10] ip address 10.1.1.1 24
    [CE1-Vlanif10] quit
    

    Después de completar la configuración, ejecute el comando display ip vpn-instance verbose en los PE para comprobar la configuración de las instancias de VPN. Cada PE puede hacer ping a su CE conectado.

    NOTA:

    Si un PE tiene múltiples interfaces vinculadas a la misma instancia de VPN, especifique una dirección IP de origen configurando -a source-ip-address en el comando ping -vpn-instance vpn-instance-name -a source-ip-address dest-ip-address para hacer ping a un CE remoto. Si no se especifica la dirección IP de origen, el ping falla.

    PE1 se usa como ejemplo.

    [PE1] display ip vpn-instance verbose
     Total VPN-Instances configured : 2
     Total IPv4 VPN-Instances configured : 2
     Total IPv6 VPN-Instances configured : 0
    
     VPN-Instance Name and ID : vpna, 1
      Interfaces : Vlanif10
     Address family ipv4
      Create date : 2014-11-03 02:39:34+00:00
      Up time : 0 days, 22 hours, 24 minutes and 53 seconds
      Route Distinguisher : 100:1
      Export VPN Targets :  111:1
      Import VPN Targets :  111:1
      Label Policy : label per instance
      Per-Instance Label : 4098
      Log Interval : 5
    
     VPN-Instance Name and ID : vpnb, 2
      Interfaces : Vlanif20
     Address family ipv4
      Create date : 2014-11-03 02:39:34+00:00
      Up time : 0 days, 22 hours, 24 minutes and 53 seconds
      Route Distinguisher : 100:2
      Export VPN Targets :  222:2
      Import VPN Targets :  222:2
      Label Policy : label per instance
      Per-Instance Label : 4098
      Log Interval : 5
      
    
    [PE1] ping -vpn-instance vpna 10.1.1.1
      PING 10.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=5 ms
        Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=16 ms
    
      --- 10.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/6/16 ms

  4. Establezca relaciones de peer EBGP entre los PE y CE e importe rutas VPN a BGP.

    # Configure CE1 conectándose al área de I+D de la sede. Las configuraciones de CE2, CE3 y CE4 son similares a la configuración de CE1 y no se mencionan aquí.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit

    # Configure PE1. La configuración en PE2 es similar a la configuración en PE1 y no se menciona aquí.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-vpna] peer 10.1.1.1 as-number 65410
    [PE1-bgp-vpna] import-route direct
    [PE1-bgp-vpna] quit
    [PE1-bgp] ipv4-family vpn-instance vpnb
    [PE1-bgp-vpnb] peer 10.2.1.1 as-number 65420
    [PE1-bgp-vpnb] import-route direct
    [PE1-bgp-vpnb] quit
    [PE1-bgp] quit

    Después de completar la configuración, ejecute el comando display bgp vpnv4 vpn-instance peer en los PE. El resultado de comando muestra que las relaciones de peer BGP se han establecido (Established) entre los PE y los CE.

    La relación de peer entre PE1 y CE1 se usa como ejemplo.

    [PE1] display bgp vpnv4 vpn-instance vpna peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     VPN-Instance vpna, Router ID 1.1.1.9:
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State      PrefRcv
    
      10.1.1.1        4 65410       11        9     0 00:07:25      Established       1
    

  5. Establezca relaciones de peer MP-IBGP entre PE.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 3.3.3.9 as-number 100
    [PE1-bgp] peer 3.3.3.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 3.3.3.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 1.1.1.9 as-number 100
    [PE2-bgp] peer 1.1.1.9 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.9 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit

    Después de completar la configuración, ejecute el comando display bgp peer o display bgp vpnv4 all peer en los PE. El resultado de comando muestra que las relaciones de peer BGP se han establecido (Established) entre los PE.

    [PE1] display bgp peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State              PrefRcv
    
      3.3.3.9         4   100       12        6     0 00:02:21        Established       0
    [PE1] display bgp vpnv4 all peer
    
    BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 3                 Peers in established state : 3
    
      Peer            V    AS  MsgRcvd  MsgSent    OutQ  Up/Down    State        PrefRcv
    
      3.3.3.9         4   100   12      18         0     00:09:38   Established   0
      Peer of IPv4-family for vpn instance :
    
     VPN-Instance vpna, Router ID 1.1.1.9: 
      10.1.1.1        4   65410  25     25         0     00:17:57   Established   1
     VPN-Instance vpnb, Router ID 1.1.1.9: 
      10.2.1.1        4   65420  21     22         0     00:17:10   Established   1

  6. Verifique la configuración

    Ejecute el comando display ip routing-table vpn-instance en los PE para ver las rutas a los CE remotos.

    La información que se muestra en PE1 se usa como ejemplo.

    [PE1] display ip routing-table vpn-instance vpna
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpna
             Destinations : 3        Routes : 3
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
         10.1.1.0/24    Direct 0    0        D     10.1.1.2        Vlanif10
         10.1.1.2/32    Direct 0    0        D     127.0.0.1       Vlanif10
        10.3.1.0/24     IBGP   255  0        RD    3.3.3.9         Vlanif30
    
    [PE1] display ip routing-table vpn-instance vpnb
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpnb
             Destinations : 3        Routes : 3
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
         10.2.1.0/24    Direct 0    0        D     10.2.1.2        Vlanif20
         10.2.1.2/32    Direct 0    0        D     127.0.0.1       Vlanif20
        10.4.1.0/24    IBGP    255  0        RD    3.3.3.9         Vlanif30
    

    Los CE en la misma VPN pueden hacer ping entre sí, mientras que los CE en diferentes VPN no pueden hacerlo.

    Por ejemplo, CE1 conectándose al área de I+D de la sede puede hacer ping a CE3 conectándose al área de I+D de la sucursal en 10.3.1.1 pero no puede hacer ping a CE4 conectándose al área de la sucursal que no es de I+D en 10.4.1.1.

    [CE1] ping 10.3.1.1
      PING 10.3.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.3.1.1: bytes=56 Sequence=1 ttl=253 time=72 ms
        Reply from 10.3.1.1: bytes=56 Sequence=2 ttl=253 time=34 ms
        Reply from 10.3.1.1: bytes=56 Sequence=3 ttl=253 time=50 ms
        Reply from 10.3.1.1: bytes=56 Sequence=4 ttl=253 time=50 ms
        Reply from 10.3.1.1: bytes=56 Sequence=5 ttl=253 time=34 ms
      --- 10.3.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 34/48/72 ms  
    

Archivos de configuración

  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 10 20 30
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    # 
    interface Vlanif20
     ip binding vpn-instance vpnb
     ip address 10.2.1.2 255.255.255.0
    #
    interface Vlanif30
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    # 
    bgp 100
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.9 enable
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.1.1.1 as-number 65410
     #
     ipv4-family vpn-instance vpnb
      import-route direct
      peer 10.2.1.1 as-number 65420
    #
    ospf 1 router-id 1.1.1.9
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • Archivo de configuración de P

    #
    sysname P
    #
    vlan batch 30 60
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    # 
    interface Vlanif30
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif60
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 60
    # 
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1 router-id 2.2.2.9
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
    #
    return
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
    vlan batch 40 50 60
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 200:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 200:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 3.3.3.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif40
     ip binding vpn-instance vpna
     ip address 10.3.1.2 255.255.255.0
    #
    interface Vlanif50
     ip binding vpn-instance vpnb
     ip address 10.4.1.2 255.255.255.0
    #
    interface Vlanif60
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 50
    # 
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 60
    # 
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable 
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.3.1.1 as-number 65430
     #
     ipv4-family vpn-instance vpnb
      import-route direct
      peer 10.4.1.1 as-number 65440
    #
    ospf 1 router-id 3.3.3.9
     area 0.0.0.0
      network 3.3.3.9 0.0.0.0
      network 172.2.1.0 0.0.0.255
    # 
    return
  • Archivo de configuración de CE1 que conecta con el área de I+D de la sede

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • Archivo de configuración de CE2 que conecta con el área de la sede que no es I+D

    #
    sysname CE2
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 65420
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
  • Archivo de configuración de CE3 que conecta con el área de I+D de la sucursal

    #
    sysname CE3
    #
    vlan batch 40
    #
    interface Vlanif40
     ip address 10.3.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    bgp 65430
     peer 10.3.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.3.1.2 enable
    #
    return
  • Archivo de configuración de CE4 conectado a la sucursal área que no es I+D

    #
    sysname CE4
    #
    vlan batch 50
    #
    interface Vlanif50
     ip address 10.4.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 50
    #
    bgp 65440
     peer 10.4.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.4.1.2 enable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15388

Descargas: 127

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente