No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un MCE

Ejemplo para configurar un MCE

Descripción general de MCE

Un dispositivo de borde del cliente(CE) de multi-VPN-instance(MCE) puede funcionar como un dispositivo CE para las múltiples instancias de VPN en una red BGP/MPLS IP VPN. Esto difiere de la arquitectura tradicional de BGP/MPLS IP VPN, que requiere que cada instancia VPN use un dispositivo CE para conectarse a un dispositivo PE.

MCE es adecuado cuando los usuarios de una red privada deben dividirse en múltiples VPN o cuando los servicios de los usuarios en diferentes VPN deben estar completamente aislados. El despliegue de un dispositivo CE para cada VPN aumenta el costo de adquisición y mantenimiento del dispositivo. Por otra parte, si hay varias VPN que comparten un dispositivo CE, no se puede garantizar la seguridad de los datos porque todas las VPN usan la misma tabla de enrutamiento.

Un dispositivo MCE crea y mantiene un VRF independiente para cada VPN para garantizar la seguridad de los datos entre las diferentes VPN, al tiempo que reduce los costos de construcción y mantenimiento de la red. La aplicación Multi-VRF aísla rutas de reenvío de diferentes VPN en una red privada y anuncia las rutas de cada VPN al dispositivo PE del mismo nivel, asegurando que los paquetes VPN se transmitan correctamente en la red pública.

Notas de configuración

  • En V100R006C05, solo el S3300EI admite la función MCE.

    En otras versiones, todos los modelos de switch excepto S5300SI, S5300LI, S5306-LI y S2350EI admiten la función MCE.

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

La sede y las sucursales de una empresa necesitan comunicarse a través de MPLS VPN, y dos servicios de la empresa deben estar aislados. Para reducir los costos de hardware, la empresa quiere que la sucursal se conecte al PE a través de solo un CE.

Como se muestra en Figura 9-2, los requisitos de red son los siguientes:

  • CE1 y CE2 se conectan a la sede. CE1 pertenece a vpna, y CE2 pertenece a vpnb.
  • El MCE se conecta a vpna y vpnb de la sucursal a través de SwitchA y SwitchB.

Los usuarios en la misma VPN necesitan comunicarse entre sí, mientras que los usuarios en diferentes VPN deben estar aislados.

Figura 9-2  Diagrama de redes para configurar un MCE

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure OSPF entre los PE para que puedan comunicarse y configure MP-IBGP para intercambiar información de enrutamiento VPN.
  2. Configure las capacidades básicas MPLS y MPLS LDP en los PE para establecer LDP LSP.
  3. Cree instancias de VPN vpna y vpnb en MCE y PE para aislar servicios.
  4. Establezca relaciones de peer EBGP entre PE1 y sus CE conectadas, e importe rutas BGP a la tabla de enrutamiento VPN de PE1.
  5. Configure el enrutamiento entre los sitios (Site) de VPN y MCE, entre el MCE y el PE2.

Procedimiento

  1. Configure las VLAN en las interfaces y asigne las direcciones IP a las interfaces VLANIF e interfaces de loopback de acuerdo con Figura 9-2.

    # Configure PE1. Las configuraciones en PE2, CE1, CE2, MCE, SwitchA y SwitchB son similares a la configuración en PE1 y no se mencionan aquí.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] vlan batch 30
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] port link-type trunk
    [PE1-GigabitEthernet3/0/0] port trunk allow-pass vlan 30
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] ip address 172.1.1.1 24
    [PE1-Vlanif30] quit
    

  2. Configure OSPF en los PE de la red de estructura básica.

    # Configure PE1.

    [PE1] ospf
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit
    

    # Configure PE2.

    [PE2] ospf
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit
    

    Después de completar la configuración, los PE pueden obtener la dirección Loopback1 el uno del otro.

    La información que se muestra en PE2 se usa como ejemplo.

    [PE2] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 10        Routes : 10
    
      Destination/Mask  Proto  Pre  Cost       Flags  NextHop         Interface
    
            1.1.1.9/32  OSPF   10   1              D  172.1.1.1        Vlanif30
            2.2.2.9/32  Direct 0    0              D  127.0.0.1        LoopBack1
           10.3.1.0/24  Direct 0    0              D  10.3.1.3         Vlanif60
           10.3.1.3/32  Direct 0    0              D  127.0.0.1        Vlanif60
           10.4.1.0/24  Direct 0    0              D  10.4.1.3         Vlanif70
           10.4.1.3/32  Direct 0    0              D  127.0.0.1        Vlanif70
          127.0.0.0/8   Direct 0    0              D  127.0.0.1        InLoopBack0
          127.0.0.1/32  Direct 0    0              D  127.0.0.1        InLoopBack0
          172.1.1.0/24  Direct 0    0              D  172.1.1.2        Vlanif30
          172.1.1.2/32  Direct 0    0              D  127.0.0.1        Vlanif30
    

  3. Configure las capacidades básicas MPLS y MPLS LDP en los PE para establecer LDP LSP.

    # Configure PE1. La configuración en PE2 es similar a la configuración en PE1 y no se menciona aquí.

    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] mpls
    [PE1-Vlanif30] mpls ldp
    [PE1-Vlanif30] quit
    

    Una vez completada la configuración, ejecute el comando display mpls ldp session en los PE. El resultado de comando muestra que la sesión de MPLS LDP entre los PE se encuentra en estado(Status) Operational.

    La información que se muestra en PE2 se usa como ejemplo.

    [PE2] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted.
    ------------------------------------------------------------------------------
    PeerID             Status      LAM  SsnRole  SsnAge      KASent/Rcv
    ------------------------------------------------------------------------------ 
    1.1.1.9:0          Operational DU   Active   0000:00:04  17/17
    ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    

  4. Configure instancias de VPN en los PE. En PE1, vincule las interfaces conectadas a CE1 y CE2 a las instancias de VPN. En PE2, vincule la interfaz conectada al MCE a las instancias de VPN.

    # Configure PE1.

    [PE1] vlan batch 10 20
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port link-type trunk
    [PE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] port link-type trunk
    [PE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 20
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] ipv4-family
    [PE1-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1   //Establezca el RD a 100:1.
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both       //Agregue el valor de RT 100:1 a las rutas exportadas desde el ejemplo de VPN vpna a MP-BGP. Solo las rutas con el valor RT 100:1 se pueden importar a vpna.
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] ipv4-family
    [PE1-vpn-instance-vpnb-af-ipv4] route-distinguisher 100:2
    [PE1-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip binding vpn-instance vpna   //Vincule la interfaz a vpna.
    [PE1-Vlanif10] ip address 10.1.1.2 24
    [PE1-Vlanif10] quit
    [PE1] interface vlanif 20
    [PE1-Vlanif20] ip binding vpn-instance vpnb
    [PE1-Vlanif20] ip address 10.2.1.2 24
    [PE1-Vlanif20] quit
    

    # Configure PE2.

    [PE2] vlan batch 60 70
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] port link-type trunk
    [PE2-GigabitEthernet2/0/0] port trunk allow-pass vlan 60 70
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] ipv4-family
    [PE2-vpn-instance-vpna-af-ipv4] route-distinguisher 200:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] ipv4-family
    [PE2-vpn-instance-vpnb-af-ipv4] route-distinguisher 200:2
    [PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit
    [PE2] interface vlanif 60
    [PE2-Vlanif60] ip binding vpn-instance vpna
    [PE2-Vlanif60] ip address 10.3.1.3 24
    [PE2-Vlanif60] quit
    [PE2] interface vlanif 70
    [PE2-Vlanif70] ip binding vpn-instance vpnb
    [PE2-Vlanif70] ip address 10.4.1.3 24
    [PE2-Vlanif70] quit
    

  5. Configure las instancias de VPN en el MCE y vincule las interfaces conectadas a SwitchA y SwitchB a las instancias de VPN.

    <Quidway> system-view
    [Quidway] sysname MCE
    [MCE] vlan batch 60 70
    [MCE] interface gigabitethernet 1/0/0
    [MCE-GigabitEthernet1/0/0] port link-type trunk
    [MCE-GigabitEthernet1/0/0] port trunk allow-pass vlan 60 70
    [MCE-GigabitEthernet1/0/0] quit
    [MCE] interface gigabitethernet 3/0/0
    [MCE-GigabitEthernet3/0/0] port link-type trunk
    [MCE-GigabitEthernet3/0/0] port trunk allow-pass vlan 60
    [MCE-GigabitEthernet3/0/0] quit
    [MCE] interface gigabitethernet 4/0/0
    [MCE-GigabitEthernet4/0/0] port link-type trunk
    [MCE-GigabitEthernet4/0/0] port trunk allow-pass vlan 70
    [MCE-GigabitEthernet4/0/0] quit
    [MCE] ip vpn-instance vpna
    [MCE-vpn-instance-vpna] ipv4-family
    [MCE-vpn-instance-vpna-af-ipv4] route-distinguisher 100:1
    [MCE-vpn-instance-vpna-af-ipv4] quit
    [MCE-vpn-instance-vpna] quit
    [MCE] ip vpn-instance vpnb
    [MCE-vpn-instance-vpnb] ipv4-family
    [MCE-vpn-instance-vpnb-af-ipv4] route-distinguisher 100:2
    [MCE-vpn-instance-vpnb-af-ipv4] quit
    [MCE-vpn-instance-vpnb] quit
    [MCE] interface vlanif 60
    [MCE-Vlanif60] ip binding vpn-instance vpna
    [MCE-Vlanif60] ip address 10.3.1.2 24
    [MCE-Vlanif60] quit
    [MCE] interface vlanif 70
    [MCE-Vlanif70] ip binding vpn-instance vpnb
    [MCE-Vlanif70] ip address 10.4.1.2 24
    [MCE-Vlanif70] quit
    

  6. Establezca una relación de peer MP-IBGP entre los PE. Establezca una relación de peer EBGP entre PE1 y CE1, y entre PE1 y CE2.

    # Configure CE1. La configuración en CE2 es similar a la configuración en CE1 y no se menciona aquí.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100   //Establezca una relación de peer EBGP entre PE1 y CE1 e importe rutas de VPN.
    [CE1-bgp] import-route direct
    [CE1-bgp] quit
    

    # Configure PE1. La configuración en PE2 es similar a la configuración en PE1 y no se menciona aquí.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-vpna] peer 10.1.1.1 as-number 65410
    [PE1-bgp-vpna] import-route direct
    [PE1-bgp-vpna] quit
    [PE1-bgp] ipv4-family vpn-instance vpnb
    [PE1-bgp-vpnb] peer 10.2.1.1 as-number 65420
    [PE1-bgp-vpnb] import-route direct
    [PE1-bgp-vpnb] quit
    [PE1-bgp] quit

    Configure una relación de peer MP-IBGP entre los dispositivos PE.

    # Configure PE1. La configuración en PE2 es similar a la configuración en PE1 y no se menciona aquí.

    [PE1] bgp 100
    [PE1-bgp] peer 2.2.2.9 as-number 100
    [PE1-bgp] peer 2.2.2.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 2.2.2.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    Después de completar la configuración, ejecute el comando display bgp vpnv4 all peer en PE1. La salida de comando muestra que PE1 ha establecido una relación de peers IBGP con PE2 y una relación de peers EBGP con CE1 y CE2. Las relaciones de peers están en estado de Established.

    [PE1] display bgp vpnv4 all peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     Total number of peers : 3                 Peers in established state : 3
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State PrefRcv
    
      2.2.2.9         4   100      288      287     0 01:19:16     Established       6
    
      Peer of IPv4-family for vpn instance :
                                                                                    
     VPN-Instance vpna, Router ID 1.1.1.9:                                          
      10.1.1.1        4  65410       9       11     0 00:01:38     Established       2 
    
     VPN-Instance vpnb, Router ID 1.1.1.9:                                          
      10.2.1.1        4  65420       9       12     0 00:04:09     Established       2
    

  7. Configure el enrutamiento entre los sitios de MCE y VPN.

    El MCE se conecta directamente a vpna, que no usa ningún protocolo de enrutamiento. Configure las rutas estáticas para implementar la comunicación entre el MCE y vpna.
    • # Configure SwitchA.

      Asigne la dirección IP 192.168.1.1/24 a la interfaz conectada a vpna. Los detalles de configuración no se mencionan aquí.

      <Quidway> system-view
      [Quidway] sysname SwitchA
      [SwitchA] vlan batch 60
      [SwitchA] interface gigabitethernet 1/0/0
      [SwitchA-GigabitEthernet1/0/0] port link-type trunk
      [SwitchA-GigabitEthernet1/0/0] port trunk allow-pass vlan 60
      [SwitchA-GigabitEthernet1/0/0] quit
      [SwitchA] interface vlanif 60
      [SwitchA-Vlanif60] ip address 10.3.1.1 24
      [SwitchA-Vlanif60] quit
      [SwitchA] ip route-static 0.0.0.0 0.0.0.0 10.3.1.2   //Cree una ruta predeterminada destinada al MCE para SwitchA.
      
    • # Configure el MCE.

      [MCE] ip route-static vpn-instance vpna 192.168.1.0 24 10.3.1.1    //Cree una ruta de VPN destinada a SwitchA para el ejemplo de VPN vpna.
      
    • # Compruebe las rutas de vpna en el MCE.
      [MCE] display ip routing-table vpn-instance vpna
      Route Flags: R - relay, D - download to fib                                     
      ------------------------------------------------------------------------------  
      Routing Tables: vpna                                                            
               Destinations : 3        Routes : 3                                     
                                                                                      
      Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                      
             10.3.1.0/24  Direct  0    0           D   10.3.1.2        Vlanif60       
             10.3.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif60       
          192.168.1.0/24  Static  60   0          RD   10.3.1.1        Vlanif60       
      
      La información anterior muestra que el MCE tiene una ruta estática a vpna.

    El protocolo RIP se ejecuta en vpnb. Configure el proceso RIP 200 en el MCE y vincúlelo a vpnb para que las rutas aprendidas por RIP se agreguen a la tabla de enrutamiento de vpnb.

    • # Configure el MCE.
      [MCE] rip 200 vpn-instance vpnb
      [MCE-rip-200] version 2
      [MCE-rip-200] network 10.0.0.0
      [MCE-rip-200] import-route ospf 200   //Importe las rutas de OSPF para que SwitchB pueda aprender las rutas al MCE.
      [MCE-rip-200] quit
    • # Configure SwitchB.

      Asigne la dirección IP 192.168.2.1/24 a la interfaz conectada a vpnb. La configuración no se menciona aquí.

      <Quidway> system-view
      [Quidway] sysname SwitchB
      [SwitchB] vlan batch 70
      [SwitchB] interface gigabitethernet 1/0/0
      [SwitchB-GigabitEthernet1/0/0] port link-type trunk
      [SwitchB-GigabitEthernet1/0/0] port trunk allow-pass vlan 70
      [SwitchB-GigabitEthernet1/0/0] quit
      [SwitchB] interface vlanif 70
      [SwitchB-Vlanif70] ip address 10.4.1.1 24
      [SwitchB-Vlanif70] quit
      [SwitchB] rip 200
      [SwitchB-rip-200] version 2
      [SwitchB-rip-200] network 10.0.0.0
      [SwitchB-rip-200] network 192.168.2.0
      [SwitchB-rip-200] quit
    • # Compruebe las rutas de vpnb en el MCE.
      [MCE] display ip routing-table vpn-instance vpnb                     
      Route Flags: R - relay, D - download to fib                                     
      ------------------------------------------------------------------------------  
      Routing Tables: vpnb                                                            
               Destinations : 3        Routes : 3                                     
                                                                                      
      Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                      
             10.4.1.0/24  Direct  0    0           D   10.4.1.2        Vlanif70       
             10.4.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif70       
          192.168.2.0/24  RIP     100  1           D   10.4.1.1        Vlanif70       
      
      La información anterior muestra que el MCE ha aprendido la ruta a vpnb usando RIP. La ruta a vpnb y la ruta a vpna (192.168.1.0) se mantienen en diferentes tablas de enrutamiento VPN para que los usuarios en las dos VPN estén aislados el uno del otro.

  8. Configure las múltiples instancias de OSPF entre el MCE y el PE2.

    # Configure PE2.
    NOTA:
    Para configurar las múltiples instancias de OSPF entre MCE y PE2, complete las siguientes tareas en PE2:
    • En la vista OSPF, importe las rutas BGP y anuncie las rutas VPN de PE1 al MCE.
    • En la vista BGP, importe las rutas de los procesos OSPF y anuncie las rutas VPN del MCE a PE1.
    [PE2] ospf 100 vpn-instance vpna
    [PE2-ospf-100] import-route bgp   //Importe las rutas de BGP a OSPF 100 en vpna entre PE y MCE, para que el MCE aprenda las rutas a CE1.
    [PE2-ospf-100] area 0
    [PE2-ospf-100-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [PE2-ospf-100-area-0.0.0.0] quit
    [PE2-ospf-100] quit
    [PE2] ospf 200 vpn-instance vpnb
    [PE2-ospf-200] import-route bgp   //Importe las rutas BGP a OSPF 200 en vpnb entre PE y MCE, para que el MCE aprenda las rutas a CE2.
    [PE2-ospf-200] area 0
    [PE2-ospf-200-area-0.0.0.0] network 10.4.1.0 0.0.0.255
    [PE2-ospf-200-area-0.0.0.0] quit
    [PE2-ospf-200] quit
    [PE2] bgp 100
    [PE2-bgp] ipv4-family vpn-instance vpna
    [PE2-bgp-vpna] import-route ospf 100   //Importe OSPF 100 a BGP para que PE2 agregue el prefijo de VPNv4 a las rutas y use MP-IBGP para anunciar las rutas a PE1.
    [PE2-bgp-vpna] quit
    [PE2-bgp] ipv4-family vpn-instance vpnb
    [PE2-bgp-vpnb] import-route ospf 200   //Importe OSPF 200 a BGP para que PE2 agregue el prefijo de VPNv4 a las rutas y use MP-IBGP para anunciar las rutas a PE1.
    [PE2-bgp-vpnb] quit
    # Configure el MCE.
    NOTA:

    Importe rutas VPN a los procesos OSPF.

    [MCE] ospf 100 vpn-instance vpna           //Configure las rutas dinámicas de OSPF para la instancia VPN vpna.
    [MCE-ospf-100] import-route static              //Importe las rutas estáticas privadas de SwitchA al MCE.
    [MCE-ospf-100] vpn-instance-capability simple   //Desactive la detección de bucle para OSPF VPN, para que el MCE pueda aprender las rutas anunciadas nuevamente desde PE2.
    [MCE-ospf-100] area 0
    [MCE-ospf-100-area-0.0.0.0] network 10.3.1.0 0.0.0.255
    [MCE-ospf-100-area-0.0.0.0] quit
    [MCE-ospf-100] quit
    [MCE] ospf 200 vpn-instance vpnb                
    [MCE-ospf-200] import-route rip 200             
    [MCE-ospf-200] vpn-instance-capability simple   
    [MCE-ospf-200] area 0
    [MCE-ospf-200-area-0.0.0.0] network 10.4.1.0 0.0.0.255
    [MCE-ospf-200-area-0.0.0.0] quit
    [MCE-ospf-200] quit

  9. Verifique la configuración

    Después de completar la configuración, ejecute el comando display ip routing-table vpn-instance en el MCE para ver las rutas a los CE remotos.

    La instancia de VPN vpna se usa como ejemplo.

    [MCE] display ip routing-table vpn-instance vpna
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------  
    Routing Tables: vpna
             Destinations : 4        Routes : 4
     
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
    
           10.1.1.0/24  O_ASE   150  1           D   10.3.1.3        Vlanif60
           10.3.1.0/24  Direct  0    0           D   10.3.1.2        Vlanif60
           10.3.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif60
        192.168.1.0/24  Static  60   0          RD   10.3.1.1        Vlanif60
    

    Ejecute el comando display ip routing-table vpn-instance en los PE para ver las rutas a los CE remotos.

    La instancia de VPN vpna en PE1 se usa como ejemplo.

    [PE1] display ip routing-table vpn-instance vpna
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------  
    Routing Tables: vpna 
             Destinations : 4        Routes : 4 
    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface 
      
           10.1.1.0/24  Direct  0    0           D   10.1.1.2        Vlanif10 
           10.1.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif10 
           10.3.1.0/24  IBGP    255  0          RD   2.2.2.9         Vlanif30
        192.168.1.0/24  IBGP    255  2          RD   2.2.2.9         Vlanif30  
    

    CE1 y SwitchA pueden comunicarse entre sí. CE2 y SwitchB pueden comunicarse entre sí.

    La información que se muestra en CE1 se usa como ejemplo.

    [CE1] ping 10.3.1.1
      PING 10.3.1.1: 56 data bytes, press CTRL_C to break                           
        Reply from 10.3.1.1: bytes=56 Sequence=1 ttl=252 time=3 ms                  
        Reply from 10.3.1.1: bytes=56 Sequence=2 ttl=252 time=3 ms                  
        Reply from 10.3.1.1: bytes=56 Sequence=3 ttl=252 time=3 ms                  
        Reply from 10.3.1.1: bytes=56 Sequence=4 ttl=252 time=3 ms                  
        Reply from 10.3.1.1: bytes=56 Sequence=5 ttl=252 time=11 ms                 
                                                                                    
      --- 10.3.1.1 ping statistics ---                                              
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 3/4/11 ms                                          

    CE1 no puede hacer ping a CE2 o SwitchB. SwitchA no puede hacer ping a CE2 o SwitchB.

    El ping de CE1 a SwitchB se usa como ejemplo.

    [CE1] ping 10.4.1.1
      PING 10.4.1.1: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
    
      --- 10.4.1.1 ping statistics ---
        5 packet(s) transmitted
        0 packet(s) received
        100.00% packet loss

Archivos de configuración

  • Archivo de configuración de CE1

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • Archivo de configuración de CE2

    #
    sysname CE2
    #
    vlan batch 20
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    bgp 65420
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 10 20 30
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
    #
    interface Vlanif20
     ip binding vpn-instance vpnb
     ip address 10.2.1.2 255.255.255.0
    #
    interface Vlanif30
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 20
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 2.2.2.9 as-number 100
     peer 2.2.2.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 2.2.2.9 enable
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.1.1.1 as-number 65410
     #
     ipv4-family vpn-instance vpnb
      import-route direct
      peer 10.2.1.1 as-number 65420
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    return
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
    vlan batch 30 60 70
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 200:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family 
      route-distinguisher 200:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif30
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif60
     ip binding vpn-instance vpna
     ip address 10.3.1.3 255.255.255.0
    #
    interface Vlanif70
     ip binding vpn-instance vpnb
     ip address 10.4.1.3 255.255.255.0
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 70  
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv4-family vpn-instance vpna
      import-route ospf 100
     #
     ipv4-family vpn-instance vpnb
      import-route ospf 200
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.1.1.0 0.0.0.255
    #
    ospf 100 vpn-instance vpna
     import-route bgp
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255 
    #
    ospf 200 vpn-instance vpnb
     import-route bgp
     area 0.0.0.0
      network 10.4.1.0 0.0.0.255
    #
    return
  • Archivo de configuración del MCE

    #
    sysname MCE
    #
    vlan batch 60 70
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
    #
    interface Vlanif60
     ip binding vpn-instance vpna
     ip address 10.3.1.2 255.255.255.0
    #
    interface Vlanif70
     ip binding vpn-instance vpnb
     ip address 10.4.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 70 
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    interface GigabitEthernet4/0/0
     port link-type trunk
     port trunk allow-pass vlan 70 
    #
    ospf 100 vpn-instance vpna
     import-route static
     vpn-instance-capability simple
     area 0.0.0.0
      network 10.3.1.0 0.0.0.255 
    #
    ospf 200 vpn-instance vpnb
     import-route rip 200
     vpn-instance-capability simple
     area 0.0.0.0
      network 10.4.1.0 0.0.0.255
    #
    rip 200 vpn-instance vpnb
     version 2
     network 10.0.0.0
     import-route ospf 200
    #
    ip route-static vpn-instance vpna 192.168.1.0 255.255.255.0 10.3.1.1 
    #
    return
  • Archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 60
    #
    interface Vlanif60
     ip address 10.3.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 60 
    #
    ip route-static 0.0.0.0 0.0.0.0 10.3.1.2 
    #
    return
  • Archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 70
    #
    interface Vlanif70
     ip address 10.4.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 70 
    #
    rip 200
     version 2
     network 10.0.0.0
     network 192.168.2.0
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15430

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente