No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar el acceso a la VPN de multicast a través de dispositivos MCE

Ejemplo para configurar el acceso a la VPN de multicast a través de dispositivos MCE

Descripción general de la VPN de multicast

La tecnología de la VPN de multicast permite que los servicios de multicast se ejecuten en redes de BGP/MPLS IP VPN. Esta tecnología encapsula paquetes de multicast de una red privada para permitir que los paquetes se reenvíen a lo largo del árbol de distribución de multicast (MDT) en una red pública. Cuando los paquetes llegan a la red de destino, se revierten y se envían a los receptores como paquetes de multicast de la red privada.

La VPN de multicast se utiliza para solucionar los siguientes problemas que ocurren durante el despliegue del servicio de multicast en las redes de BGP/MPLS IP VPN:

  • Los paquetes de VPN de multicast no pueden pasar la comprobación de reenvío de ruta inversa (RPF) en la red pública.

    En el reenvío de multicast, los routers de multicast realizan comprobaciones de RPF en paquetes de multicast basados ​​en la dirección original de multicast y la interfaz de entrada. Solo se envían paquetes de multicast desde la interfaz RPF. Cada router debe conocer el enrutamiento de unicast al origen de multicast. El dispositivo proveedor (P) en una red BGP/MPLS IP VPN no conoce los enrutamientos de VPN; por lo tanto, las comprobaciones RPF fallan en el dispositivo P.

  • La superposición de direcciones de origen de multicast o direcciones de grupo en VPN conduce a la comunicación entre VPN.

    Una red BGP/MPLS IP VPN permite la superposición de direcciones en cada VPN; por lo tanto, las direcciones original de multicast o direcciones de grupo de VPN diferentes pueden superponerse. Un dispositivo PE debe reenviar correctamente paquetes de multicast desde una VPN a solo los usuarios de la misma VPN para evitar la comunicación entre diferentes VPN.

  • Los paquetes VPN se reenvían en modo de unicast en la red pública. Cuando el volumen de tráfico de multicast es alto, las cargas en la red pública aumentan considerablemente.

    La tecnología de multicast asegura que cada enlace transmita solo una copia de los paquetes de multicast. Cada dispositivo copia datos de multicast de acuerdo con la cantidad de interfaces de salida, y el ancho de banda consumido no aumenta con la cantidad de receptores. Si la red pública admite el reenvío de multicast, los paquetes de multicast solo se copian en los puntos de bifurcación en la red pública. Este mecanismo de replicación bajo demanda reduce las cargas en la red pública y ahorra el ancho de banda.

  • Todos los dispositivos PE en una VPN pueden recibir paquetes de multicast desde un origen de multicast en la misma VPN. Cuando el volumen de tráfico de multicast es alto, las cargas en los dispositivos PE aumentan considerablemente.

    Una VPN se compone de varios sitios(Site), cada uno de los cuales se conecta a un PE diferente. Algunos sitios tal vez que no tengan receptores. Si los datos de VPN de multicast se envían solo a los dispositivos PE con receptores conectados, se reducen las cargas en los dispositivos PE.

Notas de configuración

  • Si se utiliza la VPN de multicast en el modo de dominio de multicast (MD) en los switches, el modelo PIM-SM SSM no se puede utilizar en la red pública.

  • La VPN de multicast no se puede desplegar en redes VPN IPv4 BGP/MPLS entre AS.

  • La VPN de multicast no se puede desplegar en redes VPN IPv6 BGP/MPLS.

  • Las interfaces en las siguientes tarjetas de interfaz no se pueden configurar como interfaces de miembro de las interfaces de bucle invertido de multicast Eth-Trunk:

    • V200R001 a V200R003: Tarjetas de interfaz LE0MG24SA, LE0MG24CA, LE0DX12XSA00, LE0DG48SBC00 y LE0DG48TBC00 para el S9300; Tarjetas de interfaz LE0DX12XSA00, LE0DG48SBC00 y LE0DG48TBC00 para el S9300E
    • V200R005 a V200R008: Serie X1E, tarjetas de interfaz LE0MG24SA, LE0MG24CA, LE0DG48SBC00 y LE0DG48TBC00 para S9300; Serie X1E, tarjetas de interfaz LE0DG48SBC00 y LE0DG48TBC00 para S9300E
    • V200R009: Serie X1E, tarjetas de interfaz LE1D2S04SEC0, LE0MG24SA, LE0MG24CA, LE0DG48SBC00 y LE0DG48TBC00 para S9300; Serie X1E, tarjetas de interfaz LE1D2S04SEC0, LE0DG48SBC00 y LE0DG48TBC00 para S9300E.
  • La siguiente tabla enumera los productos y las versiones aplicables de este ejemplo de configuración.

    Tabla 9-2  Productos y versiones aplicables
    Producto Versión del software
    S9300, S9300X y S9300E Todas las versiones
    S5300HI Solo V200R005C01 y V200R005C02
    S5320EI, S5320HI, S6320EI V200R010C00 y versiones posteriores
    S6320HI V200R012C00 y versiones posteriores
    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

Como se muestra en Figura 9-3, una compañía despliega dos servicios, cuyos datos se transmiten en modo de multicast. El sitio de VPN Blue que usa el servicio A y el sitio de VPN White que usa el servicio B se conectan a la red backbone a través de los dispositivos MCE. La VPN de multicast en modo MD se puede desplegar para cumplir con los requisitos del servicio de multicast de la compañía. Esta configuración puede aislar datos de diferentes servicios y reduce las cargas de tráfico de multicast en la red pública.

Figura 9-3  Acceso de la VPN de multicast a través de dispositivos MCE

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure BGP/MPLS IP VPN para asegurar la conectividad de la red VPN.
  2. Configure interfaces de bucle invertido de multicast, direcciones de Share-Group e interfaces de túnel de multicast (MTI) para instancias de VPN en los dispositivos PE para implementar la VPN de multicast en el modo MD.
  3. Habilite el enrutamiento de multicast y el PIM en todos los dispositivos. Configure la función de multicast en la red pública entre los dispositivos PE y P. Configure la función de multicast en las instancias de VPN entre los dispositivos PE y MCE, y entre los dispositivos MCE y CE.

Procedimiento

  1. Configure BGP/MPLS IP VPN.
    1. Configure el protocolo Open Shortest Path First (OSPF) en la red backbone para permitir la comunicación entre los dispositivos de borde del proveedor (PE1 y PE2) y el dispositivo intermedio P.

      # Configure PE1.

      <PE1> system-view
      [PE1] interface loopback 0     //Cree una interfaz loopback.
      [PE1-LoopBack0] ip address 1.1.1.1 32
      [PE1-LoopBack0] quit
      [PE1] router id 1.1.1.1     //Configure la ID del router de PE1 a 1.1.1.1 para la administración de enrutamientos.
      [PE1] vlan batch 30
      [PE1] interface gigabitethernet 2/0/0
      [PE1-GigabitEthernet2/0/0] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [PE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 30
      [PE1-GigabitEthernet2/0/0] quit
      [PE1] interface vlanif 30     //Cree una interfaz VLANIF.
      [PE1-Vlanif30] ip address 10.1.3.1 24
      [PE1-Vlanif30] quit
      [PE1] ospf
      [PE1-ospf-1] area 0
      [PE1-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.1.3.0 y que la interfaz pertenece al Area 0.
      [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
      [PE1-ospf-1-area-0.0.0.0] quit
      [PE1-ospf-1] quit

      Las configuraciones en P y PE2 son similares a la configuración de PE1, y no se mencionan aquí.

      Una vez completada la configuración, las relaciones de vecinos OSPF pueden configurarse entre PE1 y P y entre P y PE2. Ejecute el comando display ospf peer en PE1, P y PE2, y se podrá ver que los vecinos están en estado Full. Ejecute el comando display ip routing-table, y se podrá ver que los dispositivos PE han aprendido los enrutamientos hacia Loopback0 entre sí.

    2. Habilite las capacidades MPLS básicas y MPLS LDP en los dispositivos de borde del proveedor PE1 y PE2 para configurar los LSP LDP en la red de estructura básica MPLS.

      # Configure PE1.

      [PE1] mpls lsr-id 1.1.1.1     //Establezca el ID de LSR de PE1 en 1.1.1.1.
      [PE1] mpls     //Habilite MPLS globalmente.
      [PE1-mpls] quit
      [PE1] mpls ldp     //Habilite MPLS LDP globalmente.
      [PE1-mpls-ldp] quit
      [PE1] interface vlanif 30
      [PE1-Vlanif30] mpls     //Habilite MPLS en la interfaz VLANIF.
      [PE1-Vlanif30] mpls ldp     //Habilite MPLS LDP en la interfaz VLANIF.
      [PE1-Vlanif30] quit

      Las configuraciones en P y PE2 son similares a la configuración de PE1, y no se mencionan aquí.

      Una vez completada la configuración, las sesiones LDP pueden configurarse entre PE1 y P y entre P y PE2. Ejecute el comando display mpls ldp session en los dispositivos PE y P, y se podrá ver que la sesión LDP está en el estado(Status) Operational.

    3. Establezca una relación de peers de Multiprotocol Interior Border Gateway Protocol (MP-IBGP) entre los dispositivos de borde de proveedor PE1 y PE2.

      # Configure PE1.

      [PE1] bgp 100
      [PE1-bgp] peer 3.3.3.3 as-number 100     //Cree peers BGP 3.3.3.3 y configure su número de AS en 100.
      [PE1-bgp] peer 3.3.3.3 connect-interface loopback 0     //Especifique LoopBack0 como la interfaz de origen para enviar paquetes BGP a peer BGP 3.3.3.3.
      [PE1-bgp] ipv4-family vpnv4     //Introduzca vista familiar de direcciones BGP-VPNv4.
      [PE1-bgp-af-vpnv4] peer 3.3.3.3 enable     //Habilite el switch local para intercambiar enrutamientos BGP-VPNv4 con peer BGP 3.3.3.3.
      [PE1-bgp-af-vpnv4] quit
      [PE1-bgp] quit

      # Configure PE2.

      [PE2] bgp 100
      [PE2-bgp] peer 1.1.1.1 as-number 100     //Cree peer BGP 1.1.1.1 y configure su número de AS en 100.
      [PE2-bgp] peer 1.1.1.1 connect-interface loopback 0     //Especifique LoopBack0 como la interfaz de origen para enviar paquetes BGP a 1.1.1.1.
      [PE2-bgp] ipv4-family vpnv4     //Ingrese la vista familiar de direcciones BGP-VPNv4.
      [PE2-bgp-af-vpnv4] peer 1.1.1.1 enable     //Habilite el switch local para intercambiar enrutamientos BGP-VPNv4 con peer BGP 1.1.1.1.
      [PE2-bgp-af-vpnv4] quit
      [PE2-bgp] quit

      Una vez completada la configuración, ejecute el comando display bgp vpnv4 all peer en los dispositivos PE. Pueden ver que una relación de peers BGP se ha configurado entre PE1 y PE2 y está en el estado Established.

    4. Cree instancias de VPN Blue y VPN White en los dispositivos de borde del proveedor PE1 y PE2, y dispositivos de salida agregados MCE1 y MCE2 para sucursales, para conectar el CE de salida de cada sitio de servicio a los dispositivos PE a través de los dispositivos MCE.

      # Configure PE1.

      [PE1] ip vpn-instance blue     //Cree instancia de VPN blue.
      [PE1-vpn-instance-blue] route-distinguisher 100:1     //Establezca el RD de la instancia de VPN blue en 100:1.
      [PE1-vpn-instance-blue-af-ipv4] vpn-target 111:1 both     //Agregue 111:1 a la lista del export VPN target y la lista de import VPN target de la instancia de VPN blue.
      [PE1-vpn-instance-blue-af-ipv4] quit
      [PE1-vpn-instance-blue] quit
      [PE1] ip vpn-instance white     //Cree una instancia de VPN white.
      [PE1-vpn-instance-white] route-distinguisher 200:1     //Establezca el RD de la instancia VPN white a 200: 1.
      [PE1-vpn-instance-white-af-ipv4] vpn-target 222:1 both     //Agregue 222:1 a la lista del export VPN target y la lista de import VPN target de la instancia de VPN white.
      [PE1-vpn-instance-white-af-ipv4] quit
      [PE1-vpn-instance-white] quit
      [PE1] vlan batch 10 20
      [PE1] interface gigabitethernet 1/0/0
      [PE1-GigabitEthernet1/0/0] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [PE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10 20
      [PE1-GigabitEthernet1/0/0] quit
      [PE1] interface vlanif 10
      [PE1-Vlanif10] ip binding vpn-instance blue     //Enlace la instancia de VPN blue a VLANIF10 para que VLANIF10 se convierta en una interfaz de red privada de instancia de VPN blue.
      [PE1-Vlanif10] ip address 10.1.1.1 24
      [PE1-Vlanif10] quit
      [PE1] interface vlanif 20
      [PE1-Vlanif20] ip binding vpn-instance white     //Enlace la instancia de VPN white a VLANIF20 para que VLANIF20 se convierta en una interfaz de red privada de instancia de VPN white.
      [PE1-Vlanif20] ip address 10.1.2.1 24
      [PE1-Vlanif20] quit
      

      # Configure MCE1.

      [MCE1] ip vpn-instance blue     //Cree instancia de VPN blue.
      [MCE1-vpn-instance-blue] route-distinguisher 100:1     //Establezca el RD de la instancia de VPN blue en 100: 1.
      [MCE1-vpn-instance-blue-af-ipv4] vpn-target 111:1 both     //Agregue 111:1 a la lista de export VPN target y la lista de import VPN target de la instancia VPN blue.
      [MCE1-vpn-instance-blue-af-ipv4] quit
      [MCE1-vpn-instance-blue] quit
      [MCE1] ip vpn-instance white     //Cree una instancia de VPN white.
      [MCE1-vpn-instance-white] route-distinguisher 200:1     //Establezca el RD de la instancia VPN white a 200: 1.
      [MCE1-vpn-instance-white-af-ipv4] vpn-target 222:1 both     //Agregue 222:1 a la lista de export VPN target y la lista de import VPN target de la instancia VPN white.
      [MCE1-vpn-instance-white-af-ipv4] quit
      [MCE1-vpn-instance-white] quit
      [MCE1] vlan batch 10 20 100 200
      [MCE1] interface gigabitethernet 1/0/0
      [MCE1-GigabitEthernet1/0/0] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [MCE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10 20
      [MCE1-GigabitEthernet1/0/0] quit
      [MCE1] interface gigabitethernet 1/0/1
      [MCE1-GigabitEthernet1/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [MCE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
      [MCE1-GigabitEthernet1/0/1] quit
      [MCE1] interface gigabitethernet 1/0/2
      [MCE1-GigabitEthernet1/0/2] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [MCE1-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
      [MCE1-GigabitEthernet1/0/2] quit
      [MCE1] interface vlanif 10
      [MCE1-Vlanif10] ip binding vpn-instance blue     //Enlace la instancia de VPN blue a VLANIF10 para que VLANIF10 se convierta en una interfaz de red privada de instancia de VPN blue.
      [MCE1-Vlanif10] ip address 10.1.1.2 24
      [MCE1-Vlanif10] quit
      [MCE1] interface vlanif 20
      [MCE1-Vlanif20] ip binding vpn-instance white     //Enlace la instancia de VPN white a VLANIF20 de forma que VLANIF20 se convierta en una interfaz de red privada de instancia de VPN white.
      [MCE1-Vlanif20] ip address 10.1.2.2 24
      [MCE1-Vlanif20] quit
      [MCE1] interface vlanif 100
      [MCE1-Vlanif100] ip binding vpn-instance blue     //Enlace la instancia de VPN blue a VLANIF100 para que VLANIF100 se convierta en una interfaz de red privada de la instancia de VPN blue.
      [MCE1-Vlanif100] ip address 192.168.1.1 24
      [MCE1-Vlanif100] quit
      [MCE1] interface vlanif 200
      [MCE1-Vlanif200] ip binding vpn-instance white     //Enlace la instancia de VPN white a VLANIF200 de forma que VLANIF200 se convierta en una interfaz de red privada de la instancia de VPN white.
      [MCE1-Vlanif200] ip address 192.168.2.1 24
      [MCE1-Vlanif200] quit

      # Configure PE2.

      [PE2] ip vpn-instance blue     //Cree instancia de VPN blue.
      [PE2-vpn-instance-blue] route-distinguisher 100:1     //Establezca el RD de la instancia de VPN blue en 100: 1.
      [PE2-vpn-instance-blue-af-ipv4] vpn-target 111:1 both     //Agregue 111:1 a la lista de export VPN target y a la lista de import VPN target de la instancia de VPN blue
      [PE2-vpn-instance-blue-af-ipv4] quit
      [PE2-vpn-instance-blue] quit
      [PE2] ip vpn-instance white     //Cree una instancia de VPN white.
      [PE2-vpn-instance-white] route-distinguisher 200:1     //Establezca el RD de la instancia VPN white a 200: 1.
      [PE2-vpn-instance-white-af-ipv4] vpn-target 222:1 both     //Agregue 222:1 a la lista de export VPN target y a la lista de import VPN target de la instancia VPN white.
      [PE2-vpn-instance-white-af-ipv4] quit
      [PE2-vpn-instance-white] quit
      [PE2] vlan batch 50 60
      [PE2] interface gigabitethernet 1/0/0
      [PE2-GigabitEthernet1/0/0] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [PE2-GigabitEthernet1/0/0] port trunk allow-pass vlan 50 60
      [PE2-GigabitEthernet1/0/0] quit
      [PE2] interface vlanif 50
      [PE2-Vlanif50] ip binding vpn-instance blue     //Enlace la instancia de VPN blue a VLANIF50 para que VLANIF50 se convierta en una interfaz de red privada de la instancia de VPN blue.
      [PE2-Vlanif50] ip address 10.1.5.1 24
      [PE2-Vlanif50] quit
      [PE2] interface vlanif 60
      [PE2-Vlanif60] ip binding vpn-instance white     //Enlace la instancia de VPN white a VLANIF60 de forma que VLANIF60 se convierta en una interfaz de red privada de la instancia de VPN white.
      [PE2-Vlanif60] ip address 10.1.6.1 24
      [PE2-Vlanif60] quit
      

      # Configure MCE2.

      [MCE2] ip vpn-instance blue     //Cree una instancia de VPN blue.
      [MCE2-vpn-instance-blue] route-distinguisher 100:1     //Establezca el RD de la instancia de VPN blue en 100: 1.
      [MCE2-vpn-instance-blue-af-ipv4] vpn-target 111:1 both     //Agregue 111:1 a la lista de export VPN target y a la lista de import VPN target de la instancia de VPN blue.
      [MCE2-vpn-instance-blue-af-ipv4] quit
      [MCE2-vpn-instance-blue] quit
      [MCE2] ip vpn-instance white     //Cree una instancia de VPN white.
      [MCE2-vpn-instance-white] route-distinguisher 200:1     //Establezca el RD de la instancia VPN white a 200: 1.
      [MCE2-vpn-instance-white-af-ipv4] vpn-target 222:1 both     //Agregue 222:1 a la lista de export VPN target y a la lista de import VPN target de la instancia VPN white.
      [MCE2-vpn-instance-white-af-ipv4] quit
      [MCE2-vpn-instance-white] quit
      [MCE2] vlan batch 50 60 300 400
      [MCE2] interface gigabitethernet 1/0/0
      [MCE2-GigabitEthernet1/0/0] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [MCE2-GigabitEthernet1/0/0] port trunk allow-pass vlan 50 60
      [MCE2-GigabitEthernet1/0/0] quit
      [MCE2] interface gigabitethernet 1/0/1
      [MCE2-GigabitEthernet1/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [MCE2-GigabitEthernet1/0/1] port trunk allow-pass vlan 300
      [MCE2-GigabitEthernet1/0/1] quit
      [MCE2] interface gigabitethernet 1/0/2
      [MCE2-GigabitEthernet1/0/2] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [MCE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 400
      [MCE2-GigabitEthernet1/0/2] quit
      [MCE2] interface vlanif 50
      [MCE2-Vlanif50] ip binding vpn-instance blue     //Enlace la instancia de VPN blue a VLANIF50 para que VLANIF50 se convierta en una interfaz de red privada de la instancia de VPN blue.
      [MCE2-Vlanif50] ip address 10.1.5.2 24
      [MCE2-Vlanif50] quit
      [MCE2] interface vlanif 60
      [MCE2-Vlanif60] ip binding vpn-instance white     //Enlace la instancia de VPN white a VLANIF60 de forma que VLANIF60 se convierta en una interfaz de red privada de la instancia de VPN white.
      [MCE2-Vlanif60] ip address 10.1.6.2 24
      [MCE2-Vlanif60] quit
      [MCE2] interface vlanif 300
      [MCE2-Vlanif300] ip binding vpn-instance blue     //Enlace la instancia de VPN blue a VLANIF300 para que VLANIF300 se convierta en una interfaz de red privada de instancia de VPN blue.
      [MCE2-Vlanif300] ip address 192.168.3.1 24
      [MCE2-Vlanif300] quit
      [MCE2] interface vlanif 400
      [MCE2-Vlanif400] ip binding vpn-instance white     //Enlace la instancia de VPN white a VLANIF400 de forma que VLANIF400 se convierta en una interfaz de red privada de instancia de VPN white.
      [MCE2-Vlanif400] ip address 192.168.4.1 24
      [MCE2-Vlanif400] quit

    5. Configure OSPF en los dispositivos de borde de proveedor PE1 y PE2, los dispositivos de salida agregados de sucursales MCE1 y MCE2, y el CE de salida de cada sitio de servicio. Importe enrutamientos de VPN a la tabla de enrutamiento de OSPF.

      # Configure PE1.

      [PE1] ospf 2 vpn-instance blue     //Cree un proceso OSPF para servir la instancia de VPN blue.
      [PE1-ospf-2] import-route bgp     //Importe rutas BGP
      [PE1-ospf-2] area 0
      [PE1-ospf-2-area-0.0.0.0] network 10.1.1.0 0.0.0.255     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.1.1.0 y que la interfaz pertenece al Area 0.
      [PE1-ospf-2-area-0.0.0.0] quit
      [PE1-ospf-2] quit
      [PE1] ospf 3 vpn-instance white     //Cree un proceso OSPF para servir a la instancia VPN white.
      [PE1-ospf-3] import-route bgp     //Importe rutas BGP.
      [PE1-ospf-3] area 0
      [PE1-ospf-3-area-0.0.0.0] network 10.1.2.0 0.0.0.255     //Especifique que la interfaz que ejecuta OSPF es la que está conectada al segmento de red 10.1.2.0 y que la interfaz pertenece al Area 0.
      [PE1-ospf-3-area-0.0.0.0] quit
      [PE1-ospf-3] quit
      [PE1] bgp 100
      [PE1-bgp] ipv4-family vpn-instance blue     //Entre en la vista familiar de direcciones IPv4 de la instancia BGP-VPN blue.
      [PE1-bgp-blue] import-route ospf 2     //Importe rutas del proceso OSPF 2.
      [PE1-bgp-blue] quit
      [PE1-bgp] ipv4-family vpn-instance white     //Entre en la vista familiar de direcciones IPv4 de la instancia de BGP-VPN white
      [PE1-bgp-white] import-route ospf 3     //Importe enrutamientos del proceso OSPF 3.
      [PE1-bgp-white] quit
      [PE1-bgp] quit

      # Configure MCE1.

      [MCE1] ospf 1 vpn-instance blue     //Cree un proceso OSPF para servir la instancia de VPN blue.
      [MCE1-ospf-1] vpn-instance-capability simple     //Deshabilite la detección del bucle de enrutamiento OSPF.
      [MCE1-ospf-1] area 0
      [MCE1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 10.1.1.0 y que la interfaz pertenece al Area 0.
      [MCE1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.1.0 y que la interfaz pertenece al Area 0.
      [MCE1-ospf-1-area-0.0.0.0] quit
      [MCE1-ospf-1] quit
      [MCE1] ospf 2 vpn-instance white     //Cree un proceso OSPF para servir a la instancia VPN white.
      [MCE1-ospf-2] vpn-instance-capability simple     //Deshabilite la detección del bucle de enrutamiento OSPF.
      [MCE1-ospf-2] area 0
      [MCE1-ospf-2-area-0.0.0.0] network 10.1.2.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 10.1.2.0 y que la interfaz pertenece al Area 0.
      [MCE1-ospf-2-area-0.0.0.0] network 192.168.2.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.2.0 y que la interfaz pertenece al Area 0.
      [MCE1-ospf-2-area-0.0.0.0] quit
      [MCE1-ospf-2] quit
      

      # Configure PE2.

      [PE2] ospf 2 vpn-instance blue     //Cree un proceso OSPF para servir la instancia de VPN blue.
      [PE2-ospf-2] import-route bgp     //Importe enrutamientos BGP.
      [PE2-ospf-2] area 0
      [PE2-ospf-2-area-0.0.0.0] network 10.1.5.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 10.1.5.0 y que la interfaz pertenece al Area 0.
      [PE2-ospf-2-area-0.0.0.0] quit
      [PE2-ospf-2] quit
      [PE2] ospf 3 vpn-instance white     //Cree un proceso OSPF para servir a la instancia VPN white.
      [PE2-ospf-3] import-route bgp     //Importe rutas BGP.
      [PE2-ospf-3] area 0
      [PE2-ospf-3-area-0.0.0.0] network 10.1.6.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 10.1.6.0 y que la interfaz pertenece al Area 0.
      [PE2-ospf-3-area-0.0.0.0] quit
      [PE2-ospf-3] quit
      [PE2] bgp 100
      [PE2-bgp] ipv4-family vpn-instance blue     //Entre en la vista familiar de direcciones IPv4 de la instancia BGP-VPN blue.
      [PE2-bgp-blue] import-route ospf 2     //Importe rutas del proceso OSPF 2.
      [PE2-bgp-blue] quit
      [PE2-bgp] ipv4-family vpn-instance white     //Entre en la vista familiar de direcciones IPv4 de instancia de BGP-VPN white.
      [PE2-bgp-white] import-route ospf 3     //Importe rutas del proceso OSPF 3.
      [PE2-bgp-white] quit
      [PE2-bgp] quit

      # Configure MCE2.

      [MCE2] ospf 1 vpn-instance blue     //Cree un proceso OSPF para servir la instancia de VPN blue.
      [MCE2-ospf-1] vpn-instance-capability simple     //Deshabilite la detección del bucle de enrutamiento OSPF.
      [MCE2-ospf-1] area 0
      [MCE2-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 10.1.5.0 y que la interfaz pertenece al Area 0.
      [MCE2-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.3.0 y que la interfaz pertenece al Area 0.
      [MCE2-ospf-1-area-0.0.0.0] quit
      [MCE2-ospf-1] quit
      [MCE2] ospf 2 vpn-instance white     //Cree un proceso OSPF para servir a la instancia VPN white.
      [MCE2-ospf-2] vpn-instance-capability simple     //Deshabilite la detección del bucle de enrutamiento OSPF.
      [MCE2-ospf-2] area 0
      [MCE2-ospf-2-area-0.0.0.0] network 10.1.6.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 10.1.6.0 y que la interfaz pertenece al Area 0.
      [MCE2-ospf-2-area-0.0.0.0] network 192.168.4.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.4.0 y que la interfaz pertenece al Area 0.
      [MCE2-ospf-2-area-0.0.0.0] quit
      [MCE2-ospf-2] quit
      

      # Configure CE1, salida para un sitio de servicio A.

      [CE1] vlan batch 100 101
      [CE1] interface gigabitethernet 1/0/1
      [CE1-GigabitEthernet1/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE1-GigabitEthernet1/0/1] port trunk allow-pass vlan 100
      [CE1-GigabitEthernet1/0/1] quit
      [CE1] interface gigabitethernet 2/0/1
      [CE1-GigabitEthernet2/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE1-GigabitEthernet2/0/1] port trunk allow-pass vlan 101
      [CE1-GigabitEthernet2/0/1] quit
      [CE1] interface vlanif 100
      [CE1-Vlanif100] ip address 192.168.1.2 24
      [CE1-Vlanif100] quit
      [CE1] interface vlanif 101
      [CE1-Vlanif101] ip address 192.168.11.1 24
      [CE1-Vlanif101] quit
      [CE1] ospf
      [CE1-ospf-1] area 0
      [CE1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.1.0 y que la interfaz pertenece al Area 0.
      [CE1-ospf-1-area-0.0.0.0] network 192.168.11.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.11.0 y que la interfaz pertenece al Area 0.
      [CE1-ospf-1-area-0.0.0.0] quit
      [CE1-ospf-1] quit
      

      # Configure CE2, salida para un sitio de servicio B.

      [CE2] vlan batch 200 201
      [CE2] interface gigabitethernet 1/0/2
      [CE2-GigabitEthernet1/0/2] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE2-GigabitEthernet1/0/2] port trunk allow-pass vlan 200
      [CE2-GigabitEthernet1/0/2] quit
      [CE2] interface gigabitethernet 2/0/1
      [CE2-GigabitEthernet2/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE2-GigabitEthernet2/0/1] port trunk allow-pass vlan 201
      [CE2-GigabitEthernet2/0/1] quit
      [CE2] interface vlanif 200
      [CE2-Vlanif200] ip address 192.168.2.2 24
      [CE2-Vlanif200] quit
      [CE2] interface vlanif 201
      [CE2-Vlanif201] ip address 192.168.12.1 24
      [CE2-Vlanif201] quit
      [CE2] ospf
      [CE2-ospf-1] area 0
      [CE2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.2.0 y que la interfaz pertenece al Area 0.
      [CE2-ospf-1-area-0.0.0.0] network 192.168.12.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.12.0 y que la interfaz pertenece al Area 0.
      [CE2-ospf-1-area-0.0.0.0] quit
      [CE2-ospf-1] quit
      

      # Configure CE3, salida para un sitio de servicio A.

      [CE3] vlan batch 300 301
      [CE3] interface gigabitethernet 1/0/1
      [CE3-GigabitEthernet1/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE3-GigabitEthernet1/0/1] port trunk allow-pass vlan 300
      [CE3-GigabitEthernet1/0/1] quit
      [CE3] interface gigabitethernet 2/0/1
      [CE3-GigabitEthernet2/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE3-GigabitEthernet2/0/1] port trunk allow-pass vlan 301
      [CE3-GigabitEthernet2/0/1] quit
      [CE3] interface vlanif 300
      [CE3-Vlanif300] ip address 192.168.3.2 24
      [CE3-Vlanif300] quit
      [CE3] interface vlanif 301
      [CE3-Vlanif301] ip address 192.168.13.1 24
      [CE3-Vlanif301] quit
      [CE3] ospf
      [CE3-ospf-1] area 0
      [CE3-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.3.0 y que la interfaz pertenece al Area 0.
      [CE3-ospf-1-area-0.0.0.0] network 192.168.13.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.13.0 y que la interfaz pertenece al Area 0.
      [CE3-ospf-1-area-0.0.0.0] quit
      [CE3-ospf-1] quit
      

      # Configure CE4, salida para un sitio de servicio B.

      [CE4] vlan batch 400 401
      [CE4] interface gigabitethernet 1/0/2
      [CE4-GigabitEthernet1/0/2] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE4-GigabitEthernet1/0/2] port trunk allow-pass vlan 400
      [CE4-GigabitEthernet1/0/2] quit
      [CE4] interface gigabitethernet 2/0/1
      [CE4-GigabitEthernet2/0/1] port link-type trunk     //Establezca el tipo de enlace de la interfaz en trunk, que no es el tipo de enlace predeterminado.
      [CE4-GigabitEthernet2/0/1] port trunk allow-pass vlan 401
      [CE4-GigabitEthernet2/0/1] quit
      [CE4] interface vlanif 400
      [CE4-Vlanif400] ip address 192.168.4.2 24
      [CE4-Vlanif400] quit
      [CE4] interface vlanif 401
      [CE4-Vlanif401] ip address 192.168.14.1 24
      [CE4-Vlanif401] quit
      [CE4] ospf
      [CE4-ospf-1] area 0
      [CE4-ospf-1-area-0.0.0.0] network 192.168.4.0 0.0.0.255     //Especifique que la interfaz se está ejecutando OSPF es el que está conectado al segmento de red 192.168.4.0 y que la interfaz pertenece al Area 0.
      [CE4-ospf-1-area-0.0.0.0] network 192.168.14.0 0.0.0.255     //Especifique que la interfaz se está ejecutand OSPF es el que está conectado al segmento de red 192.168.14.0 y que la interfaz pertenece al Area 0.
      [CE4-ospf-1-area-0.0.0.0] quit
      [CE4-ospf-1] quit
      

      Una vez completada la configuración, ejecute el comando display ip routing-table vpn-instance vpn-instance-name en los dispositivos PE o MCE. Pueden ver que el dispositivo PE o MCE local tiene un enrutamiento de VPN al PE remoto. Ejecute el comando display ip routing-table protocol ospf en los dispositivos CE. Pueden ver que CE1 y CE3 han aprendido enrutamientos entre sí, y CE2 y CE4 han aprendido enrutamientos entre sí.

  2. Configure interfaces de bucle invertido de multicast, direcciones de Share-Group y MTI para instancias de VPN en los dispositivos de borde de proveedor PE1 y PE2.

    # Configure PE1.

    [PE1] interface eth-trunk 10
    [PE1-Eth-Trunk10] service type multicast-tunnel     //Configure Eth-Trunk 10 como una interfaz loopback de multicast.
    [PE1-Eth-Trunk10] trunkport gigabitethernet 3/0/5     //Enlace la interfaz de miembro GE3/0/5 a Eth-Trunk 10.
    [PE1-Eth-Trunk10] quit
    [PE1] ip vpn-instance blue
    [PE1-vpn-instance-blue] multicast routing-enable      //Habilite el enrutamiento de multicast en la instancia VPN blue.
    [PE1-vpn-instance-blue] multicast-domain share-group 239.1.1.1 binding mtunnel 0     //Especifique 239.1.1.1 como el Share-Group de la instancia de VPN blue y conéctelo a la interfaz de túnel de multicast MTI0.
    [PE1-vpn-instance-blue] ipv4-family
    [PE1-vpn-instance-blue-af-ipv4] multicast-domain source-interface loopback 0     //Configure el MTI para usar la dirección de Loopback0 como la dirección predeterminada.
    [PE1-vpn-instance-blue-af-ipv4] quit
    [PE1-vpn-instance-blue] quit
    [PE1] ip vpn-instance white
    [PE1-vpn-instance-white] multicast routing-enable      //Habilite el enrutamiento de multicast en la instancia VPN white.
    [PE1-vpn-instance-white] multicast-domain share-group 239.1.2.1 binding mtunnel 10     //Especifique 239.1.2.1 como el Share-Group de la instancia VPN white y conéctelo a la interfaz de túnel de multicast MTI0.
    [PE1-vpn-instance-white] ipv4-family
    [PE1-vpn-instance-white-af-ipv4] multicast-domain source-interface loopback 0     //Configure el MTI para usar la dirección de Loopback0 como la dirección predeterminada.
    [PE1-vpn-instance-white-af-ipv4] quit
    [PE1-vpn-instance-white] quit

    # Configure PE2.

    [PE2] interface eth-trunk 10
    [PE2-Eth-Trunk10] service type multicast-tunnel     //Configure Eth-Trunk 10 como una interfaz loopback de multicast.
    [PE2-Eth-Trunk10] trunkport gigabitethernet 3/0/5     //Enlace la interfaz de miembro GE3/0/5 a Eth-Trunk 10.
    [PE2-Eth-Trunk10] quit
    [PE2] ip vpn-instance blue
    [PE2-vpn-instance-blue] multicast routing-enable      //Habilite el enrutamiento de multicast en la instancia VPN blue.
    [PE2-vpn-instance-blue] multicast-domain share-group 239.1.1.1 binding mtunnel 0     //Especifique 239.1.1.1 como el Share-Group de la instancia de VPN blue y conéctelo a la interfaz de túnel de multicast MTI0.
    [PE2-vpn-instance-blue] ipv4-family
    [PE2-vpn-instance-blue-af-ipv4] multicast-domain source-interface loopback 0     //Configure el MTI para usar la dirección de Loopback0 como la dirección predeterminada.
    [PE2-vpn-instance-blue-af-ipv4] quit
    [PE2-vpn-instance-blue] quit
    [PE2] ip vpn-instance white
    [PE2-vpn-instance-white] multicast routing-enable      //Habilite el enrutamiento de multicast en la instancia VPN white.
    [PE2-vpn-instance-white] multicast-domain share-group 239.1.2.1 binding mtunnel 10     //Especifique 239.1.2.1 como el Share-Group de la instancia VPN white y conéctelo a la interfaz de túnel de multicast MTI0.
    [PE2-vpn-instance-white] ipv4-family
    [PE2-vpn-instance-white-af-ipv4] multicast-domain source-interface loopback 0     //Configure el MTI para usar la dirección de Loopback0 como la dirección predeterminada.
    [PE2-vpn-instance-white-af-ipv4] quit
    [PE2-vpn-instance-white] quit

  3. Configure la función de multicast en las redes públicas y privadas.
    1. Configure la función de multicast en la red pública.

      Habilite PIM-SM en la red pública. Configure Loopback0 del dispositivo intermedio P del proveedor como candidate bootstrap router (C-BSR) y candidate rendezvous point (C-RP) en la red pública.

      # Configure PE1.

      [PE1] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [PE1] interface vlanif 30
      [PE1-Vlanif30] pim sm     //Habilite PIM-SM en VLANIF30.
      [PE1-Vlanif30] quit
      [PE1] interface loopback 0
      [PE1-LoopBack0] pim sm     //Habilite PIM-SM en Loopback0.
      [PE1-LoopBack0] quit

      # Configure PE2.

      [PE2] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [PE2] interface vlanif 40
      [PE2-Vlanif40] pim sm     //Habilite PIM-SM en VLANIF40.
      [PE2-Vlanif40] quit
      [PE2] interface loopback 0
      [PE2-LoopBack0] pim sm     //Habilite PIM-SM en Loopback0.
      [PE2-LoopBack0] quit

      # Configure P.

      [P] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [P] interface vlanif 30
      [P-Vlanif30] pim sm     //Habilite PIM-SM en VLANIF30.
      [P-Vlanif30] quit
      [P] interface vlanif 40
      [P-Vlanif40] pim sm     //Habilite PIM-SM en VLANIF40.
      [P-Vlanif40] quit
      [P] interface loopback 0
      [P-LoopBack0] pim sm     //Habilite PIM-SM en Loopback0.
      [P-LoopBack0] quit
      [P] pim
      [P-pim] c-bsr loopback 0      //Configure Loopback0 como una interfaz C-BSR.
      [P-pim] c-rp loopback 0     //Configure Loopback0 como una interfaz C-RP.

    2. Configure la función de multicast en la red privada.

      Habilite PIM-SM en las redes privadas. Configure VLANIF 10 del borde de proveedor PE1 como un C-BSR y C-RP de la instancia de VPN blue, y configure VLANIF 20 de PE1 como un C-BSR y C-RP de la instancia de VPN white. Configure IGMP en VLANIF 301 de la salida del sitio de servicio CE3 y VLANIF 401 de la salida del sitio de servicio CE4. (Las dos interfaces VLANIF están conectadas a segmentos de red de receptores.)

      # Configure PE1.

      [PE1] interface vlanif 10
      [PE1-Vlanif10] pim sm     //Habilite PIM-SM en VLANIF10.
      [PE1-Vlanif10] quit
      [PE1] interface vlanif 20
      [PE1-Vlanif20] pim sm     //Habilite PIM-SM en VLANIF20.
      [PE1-Vlanif20] quit
      [PE1] pim vpn-instance blue
      [PE1-pim-blue] c-bsr vlanif 10     //Configure VLANIF10 como una interfaz C-BSR para la instancia VPN blue.
      [PE1-pim-blue] c-rp vlanif 10     //Configure VLANIF10 como una interfaz C-RP para la instancia VPN blue.
      [PE1-pim-blue] quit
      [PE1] pim vpn-instance white
      [PE1-pim-white] c-bsr vlanif 20     //Configure VLANIF20 como una interfaz C-BSR para la instancia VPN white.
      [PE1-pim-white] c-rp vlanif 20     //Configure VLANIF20 como una interfaz C-RP para la instancia VPN white.
      [PE1-pim-white] quit

      # Configure MCE1.

      [MCE1] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [MCE1] ip vpn-instance blue
      [MCE1-vpn-instance-blue] multicast routing-enable     //Habilite el enrutamiento de multicast en la instancia VPN blue.
      [MCE1-vpn-instance-blue] quit
      [MCE1] ip vpn-instance white
      [MCE1-vpn-instance-white] multicast routing-enable     //Habilite el enrutamiento de multicast en la instancia VPN white.
      [MCE1-vpn-instance-white] quit
      [MCE1] interface vlanif 10
      [MCE1-Vlanif10] pim sm     //Habilite PIM-SM en VLANIF10.
      [MCE1-Vlanif10] quit
      [MCE1] interface vlanif 20
      [MCE1-Vlanif20] pim sm     //Habilite PIM-SM en VLANIF20.
      [MCE1-Vlanif20] quit
      [MCE1] interface vlanif 100
      [MCE1-Vlanif100] pim sm     //Habilite PIM-SM en VLANIF100.
      [MCE1-Vlanif100] quit
      [MCE1] interface vlanif 200
      [MCE1-Vlanif200] pim sm     //Habilite PIM-SM en VLANIF200.
      [MCE1-Vlanif200] quit

      # Configure PE2.

      [PE2] interface vlanif 50
      [PE2-Vlanif50] pim sm     //Habilite PIM-SM en VLANIF50.
      [PE2-Vlanif50] quit
      [PE2] interface vlanif 60
      [PE2-Vlanif60] pim sm     //Habilite PIM-SM en VLANIF60.
      [PE2-Vlanif60] quit

      # Configure MCE2.

      [MCE2] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [MCE2] ip vpn-instance blue
      [MCE2-vpn-instance-blue] multicast routing-enable     //Habilite el enrutamiento de multicast en la instancia VPN blue.
      [MCE2-vpn-instance-blue] quit
      [MCE2] ip vpn-instance white
      [MCE2-vpn-instance-white] multicast routing-enable     //Habilite el enrutamiento de multicast en la instancia VPN white.
      [MCE2-vpn-instance-white] quit
      [MCE2] interface vlanif 50     //Habilite PIM-SM en VLANIF50.
      [MCE2-Vlanif50] pim sm
      [MCE2-Vlanif50] quit
      [MCE2] interface vlanif 60     //Habilite PIM-SM en VLANIF60.
      [MCE2-Vlanif60] pim sm
      [MCE2-Vlanif60] quit
      [MCE2] interface vlanif 300     //Habilite PIM-SM en VLANIF300.
      [MCE2-Vlanif300] pim sm
      [MCE2-Vlanif300] quit
      [MCE2] interface vlanif 400     //Habilite PIM-SM en VLANIF400.
      [MCE2-Vlanif400] pim sm
      [MCE2-Vlanif400] quit

      # Configure CE1, salida para un sitio de servicio A.

      [CE1] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [CE1] interface vlanif 100
      [CE1-Vlanif100] pim sm     //Habilite PIM-SM en VLANIF100.
      [CE1-Vlanif100] quit
      [CE1] interface vlanif 101
      [CE1-Vlanif101] pim sm     //Habilite PIM-SM en VLANIF101.
      [CE1-Vlanif101] quit
      

      # Configure CE2, salida para un sitio de servicio B.

      [CE2] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [CE2] interface vlanif 200
      [CE2-Vlanif200] pim sm     //Habilite PIM-SM en VLANIF200.
      [CE2-Vlanif200] quit
      [CE2] interface vlanif 201
      [CE2-Vlanif201] pim sm     //Habilite PIM-SM en VLANIF201.
      [CE2-Vlanif201] quit
      

      # Configure CE3, salida para un sitio de servicio A.

      [CE3] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [CE3] interface vlanif 300
      [CE3-Vlanif300] pim sm     //Habilite PIM-SM en VLANIF300.
      [CE3-Vlanif300] quit
      [CE3] interface vlanif 301
      [CE3-Vlanif301] pim sm     //Habilite PIM-SM en VLANIF301.
      [CE3-Vlanif301] igmp enable     //Habilite IGMP en VLANIF301.
      [CE3-Vlanif301] quit

      # Configure CE4, salida para un sitio de servicio B.

      [CE4] multicast routing-enable     //Habilite el enrutamiento de multicast globalmente.
      [CE4] interface vlanif 400
      [CE4-Vlanif400] pim sm     //Habilite PIM-SM en VLANIF400.
      [CE4-Vlanif400] quit
      [CE4] interface vlanif 401
      [CE4-Vlanif401] pim sm     //Habilite PIM-SM en VLANIF401.
      [CE4-Vlanif401] igmp enable     //Habilite IGMP VLANIF401.
      [CE4-Vlanif401] quit

  4. Verifique la configuración.

    Una vez completada la configuración, los receptores en las redes privadas pueden recibir datos de multicast desde el origen de multicast.

Archivos de configuración

  • El archivo de configuración del borde PE1 del proveedor

    #
    sysname PE1
    #
    router id 1.1.1.1
    #
    vlan batch 10 20 30
    #
    multicast routing-enable
    #
    ip vpn-instance blue
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    ip vpn-instance white
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 239.1.2.1 binding mtunnel 10
    #
     mpls lsr-id 1.1.1.1
     mpls
    #
     mpls ldp
    #
    interface Vlanif10 
     ip binding vpn-instance blue
     ip address 10.1.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif20 
     ip binding vpn-instance white
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface Vlanif30
     ip address 10.1.3.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface Eth-Trunk10
     service type multicast-tunnel
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet3/0/5
     eth-trunk 10
    #
    interface LoopBack0
     ip address 1.1.1.1 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance blue
    #
    interface MTunnel10
     ip binding vpn-instance white
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable 
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable
     #
     ipv4-family vpn-instance blue
      import-route ospf 2
     #
     ipv4-family vpn-instance white
      import-route ospf 3
    #
    ospf 1 
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 10.1.3.0 0.0.0.255 
    #
    ospf 2 vpn-instance blue
     import-route bgp 
     area 0.0.0.0 
      network 10.1.1.0 0.0.0.255
    #
    ospf 3 vpn-instance white
     import-route bgp 
     area 0.0.0.0 
      network 10.1.2.0 0.0.0.255
    #
    pim vpn-instance blue
     c-bsr Vlanif10
     c-rp Vlanif10
    #
    pim vpn-instance white
     c-bsr Vlanif20
     c-rp Vlanif20
    #
    return
  • El archivo de configuración del proveedor de borde PE2

    #
    sysname PE2
    #
    router id 3.3.3.3
    #
    vlan batch 40 50 60
    #
    multicast routing-enable
    #
    ip vpn-instance blue
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 239.1.1.1 binding mtunnel 0
    #
    ip vpn-instance white
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      multicast routing-enable
      multicast-domain source-interface LoopBack0
      multicast-domain share-group 239.1.2.1 binding mtunnel 10
    #
     mpls lsr-id 3.3.3.3
     mpls
    #
     mpls ldp
    #
    interface Vlanif40
     ip address 10.1.4.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface Vlanif50 
     ip binding vpn-instance blue
     ip address 10.1.5.1 255.255.255.0
     pim sm
    #
    interface Vlanif60 
     ip binding vpn-instance white
     ip address 10.1.6.1 255.255.255.0
     pim sm
    #
    interface Eth-Trunk10
     service type multicast-tunnel
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 60
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface GigabitEthernet3/0/5
     eth-trunk 10
    #
    interface LoopBack0
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #
    interface MTunnel0
     ip binding vpn-instance blue
    #
    interface MTunnel10
     ip binding vpn-instance white
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable 
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
     #
     ipv4-family vpn-instance blue
      import-route ospf 2
     #
     ipv4-family vpn-instance white
      import-route ospf 3
    #
    ospf 1 
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0 
      network 10.1.4.0 0.0.0.255 
    #
    ospf 2 vpn-instance blue
     import-route bgp
     area 0.0.0.0 
      network 10.1.5.0 0.0.0.255
    #
    ospf 3 vpn-instance white
     import-route bgp
     area 0.0.0.0 
      network 10.1.6.0 0.0.0.255
    #
    return
  • El archivo de configuración del dispositivo intermedio del proveedor P

    #
     sysname P
    #
     router id 2.2.2.2
    #
    vlan batch 30 40
    # 
     multicast routing-enable
    #
     mpls lsr-id 2.2.2.2
     mpls
    #
     mpls ldp
    #
    interface Vlanif30 
     ip address 10.1.3.2 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface Vlanif40
     ip address 10.1.4.1 255.255.255.0
     pim sm
     mpls
     mpls ldp
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 30
    #
    interface GigabitEthernet3/0/0
     port link-type trunk
     port trunk allow-pass vlan 40
    #
    interface LoopBack0
     ip address 2.2.2.2 255.255.255.255
     pim sm
    #
    ospf 1 
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0 
      network 10.1.3.0 0.0.0.255 
      network 10.1.4.0 0.0.0.255 
    #
    pim
     c-bsr LoopBack0
     c-rp LoopBack0
    #
    return
  • El archivo de configuración de salida agregada de sucursales MCE1

    #
    sysname MCE1
    #
    vlan batch 10 20 100 200
    #
    multicast routing-enable
    #
    ip vpn-instance blue
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
    #
    ip vpn-instance white
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      multicast routing-enable
    #
    interface Vlanif10 
     ip binding vpn-instance blue
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif20 
     ip binding vpn-instance white
     ip address 10.1.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif100
     ip binding vpn-instance blue
     ip address 192.168.1.1 255.255.255.0
     pim sm
    #
    interface Vlanif200
     ip binding vpn-instance white
     ip address 192.168.2.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10 20
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    ospf 1 vpn-instance blue
     vpn-instance-capability simple
     area 0.0.0.0 
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    ospf 2 vpn-instance white
     vpn-instance-capability simple
     area 0.0.0.0 
      network 10.1.2.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • El archivo de configuración de salida agregada de sucursales MCE2

    #
    sysname MCE2
    #
    vlan batch 50 60 300 400
    #
    multicast routing-enable
    #
    ip vpn-instance blue
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
      multicast routing-enable
    #
    ip vpn-instance white
     ipv4-family
      route-distinguisher 200:1
      vpn-target 222:1 export-extcommunity
      vpn-target 222:1 import-extcommunity
      multicast routing-enable
    #
    interface Vlanif50 
     ip binding vpn-instance blue
     ip address 10.1.5.2 255.255.255.0
     pim sm
    #
    interface Vlanif60 
     ip binding vpn-instance white
     ip address 10.1.6.2 255.255.255.0
     pim sm
    #
    interface Vlanif300
     ip binding vpn-instance blue
     ip address 192.168.3.1 255.255.255.0
     pim sm
    #
    interface Vlanif400
     ip binding vpn-instance white
     ip address 192.168.4.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 50 60
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    ospf 1 vpn-instance blue
     vpn-instance-capability simple
     area 0.0.0.0 
      network 10.1.5.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    ospf 2 vpn-instance white
     vpn-instance-capability simple
     area 0.0.0.0 
      network 10.1.6.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
    #
    return
  • El archivo de configuración de CE1, salida para un sitio de servicio A

    #
     sysname CE1
    #
    vlan batch 100 to 101
    # 
     multicast routing-enable
    #
    interface Vlanif100
     ip address 192.168.1.2 255.255.255.0
     pim sm
    #
    interface Vlanif101
     ip address 192.168.11.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 101
    #
    ospf 1 
     area 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.11.0 0.0.0.255
    #
    return
  • El archivo de configuración de CE2, salida para un sitio de servicio B

    #
     sysname CE2
    #
    vlan batch 200 to 201
    # 
     multicast routing-enable
    #
    interface Vlanif200 
     ip address 192.168.2.2 255.255.255.0
     pim sm
    #
    interface Vlanif201
     ip address 192.168.12.1 255.255.255.0
     pim sm
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 200
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 201
    #
    ospf 1 
     area 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.12.0 0.0.0.255
    #
    return
  • El archivo de configuración de CE3, salida para un sitio de servicio A.

    #
     sysname CE3
    #
    vlan batch 300 to 301
    # 
     multicast routing-enable
    #
    interface Vlanif300 
     ip address 192.168.3.2 255.255.255.0
     pim sm
    #
    interface Vlanif301
     ip address 192.168.13.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/1
     port link-type trunk
     port trunk allow-pass vlan 300
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 301
    #
    ospf 1 
     area 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.13.0 0.0.0.255
    #
    return
  • El archivo de configuración de CE4, salida para un sitio de servicio B

    #
     sysname CE4
    #
    vlan batch 400 to 401
    # 
     multicast routing-enable
    #
    interface Vlanif400 
     ip address 192.168.4.2 255.255.255.0
     pim sm
    #
    interface Vlanif401
     ip address 192.168.14.1 255.255.255.0
     pim sm
     igmp enable
    #
    interface GigabitEthernet1/0/2
     port link-type trunk
     port trunk allow-pass vlan 400
    #
    interface GigabitEthernet2/0/1
     port link-type trunk
     port trunk allow-pass vlan 401
    #
    ospf 1 
     area 0.0.0.0
      network 192.168.4.0 0.0.0.255
      network 192.168.14.0 0.0.0.255
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15417

Descargas: 129

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente