No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar L3VPN y VRRP

Ejemplo para configurar L3VPN y VRRP

Descripción general de L3VPN y VRRP

L3VPN se aplica a la comunicación entre la sede y las sucursales en diferentes ubicaciones. Como los datos de comunicación deben atravesar la red de estructura básica del ISP, se utiliza BGP para publicitar rutas VPN y se usa MPLS para reenviar paquetes VPN en la red de estructura básica. Como los diferentes departamentos de una empresa deben aislarse, BGP/MPLS IP VPN puede implementar aislamiento de ruta, aislamiento de espacio de direcciones y aislamiento de acceso entre diferentes VPN.

En general, todos los hosts en el mismo segmento de red tienen la misma ruta predeterminada con la dirección de gateway como la dirección del siguiente salto. Los hosts utilizan el enrutamiento predeterminado para enviar paquetes a gateway y el gateway reenvía los paquetes a otros segmentos de red. Cuando el gateway falla, los hosts con el mismo enrutamiento predeterminado no pueden comunicarse con redes externas. La configuración de múltiples gateways de salida es un método común para mejorar la confiabilidad del sistema. Sin embargo, la selección de enrutamiento entre los gateways se convierte en un problema.

VRRP resuelve el problema. VRRP virtualiza múltiples dispositivos de enrutamiento en un router virtual sin cambiar la red y utiliza la dirección IP del router virtual como la dirección de gateway predeterminado para implementar el gateway de reserva. Cuando Master en el router virtual falla, VRRP usa Backup para transmitir el tráfico del servicio.

Se recomienda que establezca el retardo de preferencia de Backup en un grupo VRRP en 0, configure Master en el modo de preferencia y establezca el retardo de preferencia en más de 15 segundos. Estas configuraciones permiten un período para la sincronización de estado entre el enlace ascendente y el enlace descendente en una red inestable. Si no se utilizan las configuraciones anteriores, los dos Masters pueden coexistir y los dispositivos del usuario pueden aprender la dirección incorrecta del Master. Como resultado, el tráfico se interrumpe.
  • Modo de preferencia: Backup se adelanta a ser Master cuando su prioridad es mayor que Master.

  • Modo sin preferencia: Siempre que Master esté funcionando correctamente, Backup con una prioridad más alta no puede convertirse en Master.

Notas de configuración

  • Asegúrese de que cada dispositivo del mismo grupo VRRP esté configurado con el mismo VRID.
  • En V200R003 y versiones anteriores, VRRP se puede configurar solo en la interfaz VLANIF.

    En V200R005 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF y en la interfaz Ethernet de capa 3.

    Para un switch modular en V200R006 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3, subinterfaz de terminación Dot1q y subinterfaz de terminación QinQ.

    Para un switch fijo en V200R009 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3 y subinterfaz.

  • Las tarjetas de la serie SA no son compatibles con la función BGP/MPLS IP VPN. Las tarjetas de la serie X1E de V200R006C00 y versiones posteriores son compatible con la función BGP/MPLS IP VPN.
  • Tabla 9-3 enumera productos y versiones aplicables.
    Tabla 9-3  Productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S5300

    S5300HI

    V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306, S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9300E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En Figura 9-4, CE1 y CE2 pertenecen a vpna, y CE1 es dual-homed a PE1 y PE2 a través del switch. Los requisitos son los siguientes:
  • Normalmente, CE1 usa PE1 como el gateway predeterminado para comunicarse con CE2. Cuando PE1 se vuelve defectuoso, PE1 se substituye por PE2, implementando redundancia de gateway.

  • Después de que PE1 se recupera, va a ser Master para transmitir datos después de un retraso de prioridad de 20 segundos.

NOTA:

En este escenario, para evitar bucles, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado y las interfaces conectadas se eliminen de la VLAN 1. Si STP está habilitado y las interfaces VLANIF de switches se usan para construir una red de anillo de Capa 3, una interfaz en la red va a ser bloqueado. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 9-4  Redes para configurar L3VPN y VRRP

Dispositivo

Interfaz

Interfaz VLANIF

Dirección IP

PE1

GE1/0/1

VLANIF 300

192.168.1.1/24

GE1/0/2

VLANIF 100

10.1.1.1/24

GE1/0/5

VLANIF 100

10.1.1.1/24

PE2

GE1/0/1

VLANIF 200

192.168.2.1/24

GE1/0/2

VLANIF 100

10.1.1.2/24

GE1/0/5

VLANIF 100

10.1.1.2/24

PE3

GE1/0/1

VLANIF 300

192.168.1.2/24

GE1/0/2

VLANIF 200

192.168.2.2/24

GE1/0/3

VLANIF 400

172.16.1.100/24

CE1

GE1/0/3

VLANIF 100

10.1.1.100/24

CE2

GE1/0/3

VLANIF 400

172.16.1.200/24

Hoja de ruta de configuración

VRRP está configurado para implementar redundancia de gateway en L3VPN. La hoja de ruta de la configuración es la siguiente:

  1. Configure OSPF entre PE para implementar conectividad IP en la red de estructura básica.
  2. Configure funciones MPLS básicas y MPLS LDP en PE para que los LSP MPLS puedan establecerse a transmitir datos VPN.
  3. Configure instancias de VPN en PE para implementar conectividad entre VPN. Vincule las instancias de VPN a las interfaces PE conectadas a los CE para que los usuarios de VPN puedan conectarse.
  4. Configure MP-IBGP entre PE1 y PE3, y entre PE2 y PE3 para intercambiar información de enrutamiento de VPN.
  5. Configure EBGP entre CE y PE para intercambiar información de enrutamiento VPN.
  6. Configure un protocolo de prevención de bucle en PE1, PE2 y switch para evitar bucles. Aquí, se usa MSTP.
  7. Configure un grupo VRRP en PE1 y PE2. Establezca una prioridad más alta para PE1 para que el PE1 funcione como Master a reenviar el tráfico, y establezca el retardo de preferencia en 20 segundos en PE1. Establezca una prioridad más baja para PE2 para que PE2 funcione como Backup.

Procedimiento

  1. Configure un protocolo IGP en la red de estructura básica MPLS para que los PE puedan comunicarse entre sí.

    # Configure PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] vlan 300
    [PE1-vlan300] quit
    [PE1] interface gigabitethernet 1/0/1
    [PE1-GigabitEthernet1/0/1] port hybrid pvid vlan 300
    [PE1-GigabitEthernet1/0/1] port hybrid untagged vlan 300
    [PE1-GigabitEthernet1/0/1] quit
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.1 32
    [PE1-LoopBack1] quit
    [PE1] interface vlanif 300
    [PE1-Vlanif300] ip address 192.168.1.1 24
    [PE1-Vlanif300] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] vlan 200
    [PE2-vlan200] quit
    [PE2] interface gigabitethernet 1/0/1
    [PE2-GigabitEthernet1/0/1] port hybrid pvid vlan 200
    [PE2-GigabitEthernet1/0/1] port hybrid untagged vlan 200
    [PE2-GigabitEthernet1/0/1] quit
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 2.2.2.2 32
    [PE2-LoopBack1] quit
    [PE2] interface vlanif 200
    [PE2-Vlanif200] ip address 192.168.2.1 24
    [PE2-Vlanif200] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.2 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    # Configure PE3.

    <Quidway> system-view
    [Quidway] sysname PE3
    [PE3] vlan batch 200 300
    [PE3] interface gigabitethernet 1/0/1
    [PE3-GigabitEthernet1/0/1] port hybrid pvid vlan 300
    [PE3-GigabitEthernet1/0/1] port hybrid untagged vlan 300
    [PE3-GigabitEthernet1/0/1] quit
    [PE3] interface gigabitethernet 1/0/2
    [PE3-GigabitEthernet1/0/2] port hybrid pvid vlan 200
    [PE3-GigabitEthernet1/0/2] port hybrid untagged vlan 200
    [PE3-GigabitEthernet1/0/2] quit
    [PE3] interface loopback 1
    [PE3-LoopBack1] ip address 3.3.3.3 32
    [PE3-LoopBack1] quit
    [PE3] interface vlanif 200
    [PE3-Vlanif200] ip address 192.168.2.2 24
    [PE3-Vlanif200] quit
    [PE3] interface vlanif 300
    [PE3-Vlanif300] ip address 192.168.1.2 24
    [PE3-Vlanif300] quit
    [PE3] ospf 1
    [PE3-ospf-1] area 0
    [PE3-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [PE3-ospf-1-area-0.0.0.0] network 3.3.3.3 0.0.0.0
    [PE3-ospf-1-area-0.0.0.0] quit
    [PE3-ospf-1] quit

  2. Configure las funciones básicas de MPLS, habilite MPLS LDP y establezca LDP LSP en la red de estructura básica de MPLS.

    # Configure PE1.

    [PE1] mpls lsr-id 1.1.1.1
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 300
    [PE1-Vlanif300] mpls
    [PE1-Vlanif300] mpls ldp
    [PE1-Vlanif300] quit

    # Configure PE2.

    [PE2] mpls lsr-id 2.2.2.2
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface vlanif 200
    [PE2-Vlanif200] mpls
    [PE2-Vlanif200] mpls ldp
    [PE2-Vlanif200] quit

    # Configure PE3.

    [PE3] mpls lsr-id 3.3.3.3
    [PE3] mpls
    [PE3-mpls] quit
    [PE3] mpls ldp
    [PE3-mpls-ldp] quit
    [PE3] interface vlanif 200
    [PE3-Vlanif200] mpls
    [PE3-Vlanif200] mpls ldp
    [PE3-Vlanif200] quit
    [PE3] interface vlanif 300
    [PE3-Vlanif300] mpls
    [PE3-Vlanif300] mpls ldp
    [PE3-Vlanif300] quit

  3. Configure una instancia de VPN en cada PE y conecte los CE a los PE.

    # Configure el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/3] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/3] quit

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] vlan 100
    [PE1-vlan100] quit
    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [PE1-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [PE1-GigabitEthernet1/0/2] quit
    [PE1] interface gigabitethernet 1/0/5
    [PE1-GigabitEthernet1/0/5] port hybrid pvid vlan 100
    [PE1-GigabitEthernet1/0/5] port hybrid untagged vlan 100
    [PE1-GigabitEthernet1/0/5] quit
    [PE1] interface vlanif 100
    [PE1-Vlanif100] ip binding vpn-instance vpna
    [PE1-Vlanif100] ip address 10.1.1.1 24
    [PE1-Vlanif100] quit

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] route-distinguisher 100:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] vlan 100
    [PE2-vlan100] quit
    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [PE2-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [PE2-GigabitEthernet1/0/2] quit
    [PE2] interface gigabitethernet 1/0/5
    [PE2-GigabitEthernet1/0/5] port hybrid pvid vlan 100
    [PE2-GigabitEthernet1/0/5] port hybrid untagged vlan 100
    [PE2-GigabitEthernet1/0/5] quit
    [PE2] interface vlanif 100
    [PE2-Vlanif100] ip binding vpn-instance vpna
    [PE2-Vlanif100] ip address 10.1.1.2 24
    [PE2-Vlanif100] quit

    # Configure PE3.

    [PE3] ip vpn-instance vpna
    [PE3-vpn-instance-vpna] route-distinguisher 100:1
    [PE3-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE3-vpn-instance-vpna-af-ipv4] quit
    [PE3-vpn-instance-vpna] quit
    [PE3] vlan 400
    [PE3-vlan400] quit
    [PE3] interface gigabitethernet 1/0/3
    [PE3-GigabitEthernet1/0/3] port hybrid pvid vlan 400
    [PE3-GigabitEthernet1/0/3] port hybrid untagged vlan 400
    [PE3-GigabitEthernet1/0/3] quit
    [PE3] interface vlanif 400
    [PE3-Vlanif400] ip binding vpn-instance vpna
    [PE3-Vlanif400] ip address 172.16.1.100 24
    [PE3-Vlanif400] quit

    # Configure CE1.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan 100
    [CE1-vlan100] quit
    [CE1] interface gigabitethernet 1/0/3
    [CE1-GigabitEthernet1/0/3] port hybrid pvid vlan 100
    [CE1-GigabitEthernet1/0/3] port hybrid untagged vlan 100
    [CE1-GigabitEthernet1/0/3] quit
    [CE1] interface vlanif 100
    [CE1-Vlanif100] ip address 10.1.1.100 24
    [CE1-Vlanif100] quit

    # Configure CE2.

    <Quidway> system-view
    [Quidway] sysname CE2
    [CE2] vlan 400
    [CE2-vlan400] quit
    [CE2] interface gigabitethernet 1/0/3
    [CE2-GigabitEthernet1/0/3] port hybrid pvid vlan 400
    [CE2-GigabitEthernet1/0/3] port hybrid untagged vlan 400
    [CE2-GigabitEthernet1/0/3] quit
    [CE2] interface vlanif 400
    [CE2-Vlanif400] ip address 172.16.1.200 24
    [CE2-Vlanif400] quit

  4. Configure las relaciones de peers EBGP entre PE y CE e importe rutas VPN.

    # Configure CE1.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.111 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit

    # Configure CE2.

    [CE2] bgp 65430
    [CE2-bgp] peer 172.16.1.100 as-number 100
    [CE2-bgp] import-route direct
    [CE2-bgp] quit

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-vpna] peer 10.1.1.100 as-number 65410
    [PE1-bgp-vpna] import-route direct
    [PE1-bgp-vpna] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] ipv4-family vpn-instance vpna
    [PE2-bgp-vpna] peer 10.1.1.100 as-number 65410
    [PE2-bgp-vpna] import-route direct
    [PE2-bgp-vpna] quit
    [PE2-bgp] quit

    # Configure PE3.

    [PE3] bgp 100
    [PE3-bgp] ipv4-family vpn-instance vpna
    [PE3-bgp-vpna] peer 172.16.1.200 as-number 65430
    [PE3-bgp-vpna] import-route direct
    [PE3-bgp-vpna] quit
    [PE3-bgp] quit

  5. Configure las relaciones de peers de MP-IBGP entre PE.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 3.3.3.3 as-number 100
    [PE1-bgp] peer 3.3.3.3 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 3.3.3.3 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 3.3.3.3 as-number 100
    [PE2-bgp] peer 3.3.3.3 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 3.3.3.3 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit

    # Configure PE3.

    [PE3] bgp 100
    [PE3-bgp] peer 1.1.1.1 as-number 100
    [PE3-bgp] peer 2.2.2.2 as-number 100
    [PE3-bgp] peer 1.1.1.1 connect-interface loopback 1
    [PE3-bgp] peer 2.2.2.2 connect-interface loopback 1
    [PE3-bgp] ipv4-family vpnv4
    [PE3-bgp-af-vpnv4] peer 1.1.1.1 enable
    [PE3-bgp-af-vpnv4] peer 2.2.2.2 enable
    [PE3-bgp-af-vpnv4] quit
    [PE3-bgp] quit

  6. Configure MSTP para bloquear el enlace entre PE2 y el switch y evitar bucles.

    # Configure PE1 para que funcione en modo MSTP.

    [PE1] stp mode mstp

    # Configure PE2 para que funcione en modo MSTP.

    [PE2] stp mode mstp

    # Configure el switch para que funcione en modo MSTP.

    [Switch] stp mode mstp

    # Configure PE1 como root bridge.

    [PE1] stp root primary

    # Configure PE2 como root bridge secundario .

    [PE2] stp root secondary

    # Establezca el costo de ruta del puerto que conecta PE2 y el switch a 400000 para bloquear el enlace entre PE2 y el switch.

    [PE2] interface gigabitethernet 1/0/2
    [PE2-GigabitEthernet1/0/2] stp cost 400000
    [PE2-GigabitEthernet1/0/2] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] stp cost 400000
    [Switch-GigabitEthernet1/0/2] quit

    # Deshabilite STP en GigabitEthernet1/0/3 conectando SwitchA y CE1.

    [Switch] interface gigabitethernet 1/0/3
    [Switch-GigabitEthernet1/0/3] stp disable
    [Switch-GigabitEthernet1/0/3] quit

    # Habilite STP en PE1 globalmente.

    [PE1] stp enable

    # Habilite STP en PE2 globalmente.

    [PE2] stp enable

    # Habilite STP en switch globalmente.

    [Switch] stp enable

    # Una vez completada la configuración, ejecute el comando display stp brief en el switch. Puede ver que GE1/0/2 es el puerto alternativo y en estado DISCARDING.

    [Switch] display stp brief
     MSTID  Port                        Role  STP State     Protection
       0    GigabitEthernet1/0/1        ROOT  FORWARDING      NONE     
       0    GigabitEthernet1/0/2        ALTE  DISCARDING      NONE     

  7. Configure un grupo VRRP.

    # Configure el grupo VRRP 1 en PE1 y establezca la prioridad de PE1 en 120 y el retraso de preferencia en 20 segundos.

    [PE1] interface vlanif 100
    [PE1-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111   //Cree el grupo VRRP 1.
    [PE1-Vlanif100] vrrp vrid 1 priority 120   //Establezca la prioridad en 120.
    [PE1-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20   //Establezca el retardo de preferencia en 20 segundos.
    [PE1-Vlanif100] quit

    # Configure el grupo VRRP 1 en PE2. PE2 usa el valor predeterminado 100.

    [PE2] interface vlanif 100
    [PE2-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111   //Cree el grupo VRRP 1.
    [PE2-Vlanif100] quit

  8. Verifique la configuración.

    # Una vez completada la configuración, ejecute el comando display vrrp en PE1 y PE2. Pueden ver que PE1 está en estado Master y PE2 está en estado Backup.

    [PE1] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    [PE2] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46

    # Ejecute el comando shutdown en GE1/0/2 y GE1/0/5 de PE1 para simular un error de enlace.

    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] shutdown
    [PE1-GigabitEthernet1/0/2] quit
    [PE1] interface gigabitethernet 1/0/5
    [PE1-GigabitEthernet1/0/5] shutdown
    [PE1-GigabitEthernet1/0/5] quit

    # Ejecute el comando display vrrp en PE2 para comprobar el estado de VRRP. El resultado del comando muestra que PE2 está en estado Master.

    [PE2] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.2
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 100                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:18:40

    # Ejecute el comando undo shutdown en GE1/0/2 y GE1/0/5 de PE1. Después de 20 segundos, ejecute el comando display vrrp en PE1 para comprobar el estado de VRRP. PE1 restaura el estado Master.

    [PE1] interface gigabitethernet 1/0/2
    [PE1-GigabitEthernet1/0/2] undo shutdown
    [PE1-GigabitEthernet1/0/2] quit
    [PE1] interface gigabitethernet 1/0/5
    [PE1-GigabitEthernet1/0/5] undo shutdown
    [PE1-GigabitEthernet1/0/5] quit
    [PE1] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:20:56

Archivos de configuración

  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 100 300
    #
    stp instance 0 root primary
    stp enable
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    mpls lsr-id 1.1.1.1
    mpls
    #
    mpls ldp
    #
    interface Vlanif100
     ip binding vpn-instance vpna
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    interface Vlanif300
     ip address 192.168.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/5
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable 
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.1.1.100 as-number 65410
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
    #
    return
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
    vlan batch 100 200
    #
    stp instance 0 root secondary
    stp enable
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    mpls lsr-id 2.2.2.2
    mpls
    #
    mpls ldp
    #
    interface Vlanif100
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     stp instance 0 cost 400000 
    #
    interface GigabitEthernet1/0/5
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 100
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.3 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.3 enable 
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 10.1.1.100 as-number 65410
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 192.168.2.0 0.0.0.255
    #
    return
  • Archivo de configuración de PE3

    #
    sysname PE3
    #
    vlan batch 200 300 400
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    mpls lsr-id 3.3.3.3
    mpls
    #
    mpls ldp
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif300
     ip address 192.168.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif400
     ip binding vpn-instance vpna
     ip address 172.16.1.100 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 400
     port hybrid untagged vlan 400
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 172.16.1.200 as-number 65430
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • Archivo de configuración del switch

    #
    sysname Switch
    #
    vlan batch 100
    #
    stp enable
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     stp instance 0 cost 400000 
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
     stp disable
    #
    return
  • Archivo de configuración de CE1

    #
    sysname CE1
    #
    vlan batch 100
    #
    interface Vlanif100
     ip address 10.1.1.100 255.255.255.0
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    bgp 65410
     peer 10.1.1.111 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.111 enable
    #
    return
  • Archivo de configuración de CE2

    #
    sysname CE2
    #
    vlan batch 400
    #
    interface Vlanif400
     ip address 172.16.1.200 255.255.255.0
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 400
     port hybrid untagged vlan 400
    #
    bgp 65430
     peer 172.16.1.100 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 172.16.1.100 enable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15620

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente