No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar las políticas de enrutamiento para controlar el acceso mutuo entre usuarios de L3VPN

Ejemplo para configurar las políticas de enrutamiento para controlar el acceso mutuo entre usuarios de L3VPN

Descripción general

BGP/MPLS IP VPN es una L3VPN basada en MPLS que se puede desplegar flexiblemente y extender fácilmente, y es adecuada para su despliegue a gran escala. La tecnología de BGP/MPLS IP VPN se puede utilizar para implementar comunicaciones seguras o aislamiento entre sucursales en diferentes ubicaciones.

Las políticas de enrutamiento se usan para filtrar rutas y establecer atributos de ruta. Puede cambiar los atributos de ruta para cambiar una ruta sobre la cual se transmite el tráfico de red.

BGP/MPLS IP VPN se puede combinar con políticas de enrutamiento para controlar la recepción y el anuncio de rutas VPN, implementando el acceso mutuo entre usuarios de sucursales específicos.

Notas de configuración

  • Las tarjetas de la serie SA no son compatibles con la función BGP/MPLS IP VPN. Las tarjetas de la serie X1E de V200R006C00 y versiones posteriores son compatible con la función BGP/MPLS IP VPN.
  • Tabla 9-4 enumera productos y versiones aplicables.
    Tabla 9-4  Productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S5300

    S5300HI

    V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306, S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9300E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

Como se muestra en Figura 9-5, CE1 está conectado a la sucursal Site 1, y CE2 está conectado a la sucursal Site 2. Site 1 y Site 2 se comunican entre sí a través de la red de estructura básica ISP . La empresa requiere que los usuarios de L3VPN en algunos segmentos de red puedan comunicarse seguramente entre sí para cumplir con los requisitos del servicio.

Figura 9-5  Configuración de políticas de enrutamiento para controlar el acceso mutuo entre usuarios de L3VPN

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure OSPF entre los dispositivos PE para garantizar la conectividad IP en la red de estructura básica.
  2. Habilite las capacidades básicas de MPLS y MPLS LDP en los dispositivos PE para configurar túneles MPLS LSP para la transmisión de datos VPN en la red de estructura básica.
  3. Cree instancias VPN en los dispositivos PE, vincule interfaces CE a las instancias VPN y asigne diferentes objetivos VPN a las instancias VPN para aislar a los usuarios de diferentes sucursales.
  4. Configure las políticas de enrutamiento en los dispositivos PE y cambie los objetivos VPN de las rutas filtradas en función de las políticas de enrutamiento especificadas para implementar la comunicación entre los usuarios de la sucursal en un segmento de red específico.
  5. Configure las relaciones de pares EBGP entre los dispositivos CE y PE para que puedan intercambiar información de enrutamiento VPN.
  6. Configure MP-IBGP entre los dispositivos PE para habilitarles intercambiar información de enrutamiento VPN.

Procedimiento

  1. Configure un protocolo IGP en la red de estructura básica MPLS para que los dispositivos PE puedan comunicarse entre sí.

    # Configure PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] vlan batch 10 100
    [PE1] interface gigabitethernet 1/0/0
    [PE1-GigabitEthernet1/0/0] port link-type trunk
    [PE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [PE1-GigabitEthernet1/0/0] quit
    [PE1] interface gigabitethernet 2/0/0
    [PE1-GigabitEthernet2/0/0] port link-type trunk
    [PE1-GigabitEthernet2/0/0] port trunk allow-pass vlan 100
    [PE1-GigabitEthernet2/0/0] quit
    [PE1] interface vlanif 100
    [PE1-Vlanif100] ip address 172.10.1.1 24
    [PE1-Vlanif100] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 172.10.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 2.2.2.9 32
    [PE2-LoopBack1] quit
    [PE2] vlan batch 10 100
    [PE2] interface gigabitethernet 1/0/0
    [PE2-GigabitEthernet1/0/0] port link-type trunk
    [PE2-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [PE2-GigabitEthernet1/0/0] quit
    [PE2] interface gigabitethernet 2/0/0
    [PE2-GigabitEthernet2/0/0] port link-type trunk
    [PE2-GigabitEthernet2/0/0] port trunk allow-pass vlan 100
    [PE2-GigabitEthernet2/0/0] quit
    [PE2] interface vlanif 100
    [PE2-Vlanif100] ip address 172.10.1.2 24
    [PE2-Vlanif100] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 172.10.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    Después de completar la configuración, ejecute el comando display ospf peer. El resultado del comando muestra que la relación de vecinos OSPF se ha configurado entre PE1 y PE2, y que el estado vecino es Full. Ejecute el comando display ip routing-table en PE1 y PE2, y puede ver que PE1 y PE2 aprendieron las rutas a la dirección Loopback1 de cada uno.

  2. Habilite las capacidades básicas de MPLS y MPLS LDP en los dispositivos PE para configurar los LSP LDP en la red de estructura básica MPLS.

    # Configure PE1.

    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 100
    [PE1-Vlanif100] mpls
    [PE1-Vlanif100] mpls ldp
    [PE1-Vlanif100] quit

    # Configure PE2.

    [PE2] mpls lsr-id 2.2.2.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface vlanif 100
    [PE2-Vlanif100] mpls
    [PE2-Vlanif100] mpls ldp
    [PE2-Vlanif100] quit

    Después de completar la configuración, PE1 y PE2 han establecido sesiones LDP. Ejecute el comando display mpls ldp session, y puede ver que el estado(Status) de la sesión LDP es Operational.

  3. Configure una instancia VPN en cada dispositivo PE y conecte los dispositivos CE a los dispositivos PE.

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] interface vlanif 10
    [PE1-Vlanif10] ip binding vpn-instance vpna
    [PE1-Vlanif10] ip address 192.168.1.1 24
    [PE1-Vlanif10] quit
    

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] route-distinguisher 200:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 222:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] interface vlanif 10
    [PE2-Vlanif10] ip binding vpn-instance vpna
    [PE2-Vlanif10] ip address 192.168.2.1 24
    [PE2-Vlanif10] quit
    

    # Asigne direcciones IP a las interfaces en CE1 y CE2 de acuerdo a Figura 9-5.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan batch 10
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port link-type trunk
    [CE1-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface vlanif 10
    [CE1-Vlanif10] ip address 192.168.1.2 24
    [CE1-Vlanif10] quit
    
    <Quidway> system-view
    [Quidway] sysname CE2
    [CE2] vlan batch 10
    [CE2] interface gigabitethernet 1/0/0
    [CE2-GigabitEthernet1/0/0] port link-type trunk
    [CE2-GigabitEthernet1/0/0] port trunk allow-pass vlan 10
    [CE2-GigabitEthernet1/0/0] quit
    [CE2] interface vlanif 10
    [CE2-Vlanif10] ip address 192.168.2.2 24
    [CE2-Vlanif10] quit
    

    Después de completar la configuración, ejecute el comando display ip vpn-instance verbose en PE1 y PE2 para ver la configuración de la instancia de VPN. Los dispositivos PE pueden hacer ping a los dispositivos CE conectados a ellos.

    NOTA:

    Si un dispositivo PE tiene múltiples interfaces vinculadas a la misma instancia de VPN, debe especificar una dirección IP de origen cuando haga ping al dispositivo CE conectado al dispositivo PE remoto. Para especificar la dirección IP de origen, configure el parámetro -a source-ip-address en el comando ping -vpn-instance vpn-instance-name -a source-ip-address dest-ip-address. Si no se especifica una dirección IP de origen, la operación de ping falla.

  4. Configure las políticas de enrutamiento.

    # Configure PE1.

    [PE1] ip ip-prefix ipPrefix1 index 10 permit 192.168.1.0 24 greater-equal 24 less-equal 32
    [PE1] route-policy vpnroute permit node 1
    [PE1-route-policy] if-match ip-prefix ipPrefix1
    [PE1-route-policy] apply extcommunity rt 222:1
    [PE1-route-policy] quit
    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] export route-policy vpnroute
    [PE1-vpn-instance-vpna] quit

    # Configure PE2.

    [PE2] ip ip-prefix ipPrefix1 index 10 permit 192.168.2.0 24 greater-equal 24 less-equal 32
    [PE2] route-policy vpnroute permit node 1
    [PE2-route-policy] if-match ip-prefix ipPrefix1
    [PE2-route-policy] apply extcommunity rt 111:1
    [PE2-route-policy] quit
    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] export route-policy vpnroute
    [PE2-vpn-instance-vpna] quit

  5. Configure las relaciones de peers EBGP entre los dispositivos PE y CE e importe las rutas VPN.

    # Configure CE1. La configuración de CE2 es similar a la de CE1 y no se menciona aquí.

    [CE1] bgp 65410
    [CE1-bgp] peer 192.168.1.1 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit

    # Configure PE1. La configuración de PE2 es similar a la de PE1, y no se menciona aquí.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-vpna] peer 192.168.1.2 as-number 65410
    [PE1-bgp-vpna] import-route direct
    [PE1-bgp-vpna] quit
    [PE1-bgp] quit
    

    Después de completar la configuración, ejecute el comando display bgp vpnv4 vpn-instance vpna peer en PE1 y PE2. Puede ver que las relaciones de pares de BGP entre los dispositivos PE y CE se han establecido y se encuentran en el estado Established.

  6. Establezca una relación de peers MP-IBGP entre PE1 y PE2.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 2.2.2.9 as-number 100
    [PE1-bgp] peer 2.2.2.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 2.2.2.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 1.1.1.9 as-number 100
    [PE2-bgp] peer 1.1.1.9 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.9 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] quit

    Después de completar la configuración, ejecute el comando display bgp peer o display bgp vpnv4 all peer en PE1 y PE2. Puede ver que las relaciones de peers BGP se han establecido entre los dispositivos PE y están en el estado Established.

  7. Verifique la configuración

    # Ejecute el comando ping -vpn-instance en PE1 y PE2. Puede hacer ping con éxito en el Site CE que está conectado al dispositivo PE de peers.

    La visualización en PE1 se usa como un ejemplo:

    [PE1] ping -vpn-instance vpna 192.168.2.2 
      PING 192.168.2.2: 56  data bytes, press CTRL_C to break                 
        Reply from 192.168.2.2: bytes=56 Sequence=1 ttl=254 time=6 ms               
        Reply from 192.168.2.2: bytes=56 Sequence=2 ttl=254 time=5 ms               
        Reply from 192.168.2.2: bytes=56 Sequence=3 ttl=254 time=7 ms             
        Reply from 192.168.2.2: bytes=56 Sequence=4 ttl=254 time=6 ms              
        Reply from 192.168.2.2: bytes=56 Sequence=5 ttl=254 time=5 ms         
                                      
      --- 192.168.2.2 ping statistics ---               
        5 packet(s) transmitted                     
        5 packet(s) received                   
        0.00% packet loss                       
        round-trip min/avg/max = 5/5/7 ms            
            

Archivos de configuración

  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 10 100
    #
    ip vpn-instance vpna  
     ipv4-family
      route-distinguisher 100:1
      export route-policy vpnroute  
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    mpls lsr-id 1.1.1.9   
    mpls          
    #
    mpls ldp      
    #
    interface Vlanif10
     ip binding vpn-instance vpna   
     ip address 192.168.1.1 255.255.255.0
    # 
    interface Vlanif100
     ip address 172.10.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    # 
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    # 
    bgp 100            
     peer 2.2.2.9 as-number 100   
     peer 2.2.2.9 connect-interface LoopBack1 
     #
     ipv4-family unicast
      undo synchronization
      peer 2.2.2.9 enable
     #
     ipv4-family vpnv4  
      policy vpn-target
      peer 2.2.2.9 enable   
     #
     ipv4-family vpn-instance vpna
      import-route direct   
      peer 192.168.1.2 as-number 65410
    #
    ospf 1       
     area 0.0.0.0
      network 1.1.1.9 0.0.0.0
      network 172.10.1.0 0.0.0.255
    #
    route-policy vpnroute permit node 1
     if-match ip-prefix ipPrefix1
     apply extcommunity rt 222:1
    #  
    ip ip-prefix ipPrefix1 index 10 permit 192.168.1.0 24 greater-equal 24 less-equal 32
    # 
    return
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
     vlan batch 10 100
    #
    ip vpn-instance vpna
     ipv4-family
     route-distinguisher 200:1
     export route-policy vpnroute
     vpn-target 222:1 export-extcommunity
     vpn-target 222:1 import-extcommunity
    #
    mpls lsr-id 2.2.2.9
    mpls
    #
    mpls ldp
    #
    interface Vlanif10
     ip binding vpn-instance vpna
     ip address 192.168.2.1 255.255.255.0
    # 
    interface Vlanif100
     ip address 172.10.1.2 255.255.255.0 
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    interface GigabitEthernet2/0/0
     port link-type trunk
     port trunk allow-pass vlan 100
    #
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
      #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
      #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv4-family vpn-instance vpna
      import-route direct
      peer 192.168.2.2 as-number 65420
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.9 0.0.0.0
      network 172.10.1.0 0.0.0.255
    #
    route-policy vpnroute permit node 1
     if-match ip-prefix ipPrefix1
     apply extcommunity rt 111:1
    #  
    ip ip-prefix ipPrefix1 index 10 permit 192.168.2.0 24 greater-equal 24 less-equal 32
    # 
    return
  • Archivo de configuración de CE1

    #
    sysname CE1
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bgp 65410
     peer 192.168.1.1 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 192.168.1.1 enable
    #
    return

    Archivo de configuración de CE2

    #
    sysname CE2
    #
    vlan batch 10
    #
    interface Vlanif10
     ip address 192.168.2.2 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port link-type trunk
     port trunk allow-pass vlan 10
    #
    bgp 65420
     peer 192.168.2.1 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 192.168.2.1 enable
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15864

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente