No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para desplegar BGP/MPLS IP VPN y VPLS en una red ISP

Ejemplo para desplegar BGP/MPLS IP VPN y VPLS en una red ISP

Descripción general

BGP/MPLS IP VPN es una L3VPN basada en MPLS que se puede desplegar flexiblemente y extender fácilmente y se aplica al despliegue a gran escala. Para agregar un nuevo sitio, el administrador de red solo necesita modificar la configuración de los nodos de borde que sirven al nuevo sitio.

BGP/MPLS IP VPN es adecuado para la comunicación entre la sede y las sucursales en diferentes ubicaciones. Como los datos de comunicación deben atravesar la red de estructura básica del ISP, se usa BGP para publicitar rutas VPN a través de la red de estructura básica y se usa MPLS para reenviar paquetes VPN en la red de estructura básica. Como los diferentes departamentos de una empresa deben aislarse, BGP/MPLS IP VPN puede aislar la ruta, el espacio de direcciones y el acceso entre diferentes VPN.

VPLS integra las ventajas proporcionadas por Ethernet y MPLS. con la emulación de las funciones de LAN tradicionales, VPLS habilita los usuarios que están muy separados y en diferentes LAN Ethernet para que se comuniquen entre sí a través de la red IP/MPLS proporcionada por el ISP como si estuvieran en la misma LAN.

A medida que las empresas establecen cada día más sucursales en diferentes regiones y aumenta la flexibilidad de la oficina, las aplicaciones como la mensajería instantánea y las teleconferencias se usan cada vez más. Esto impone altos requisitos para las tecnologías de comunicación de datos de extremo a extremo (E2E). Múltiples sucursales de empresa distribuidas en diferentes regiones necesitan comunicarse a través de la red de área metropolitana (MAN) proporcionada por el ISP. Los paquetes de servicio de Capa 2 entre las sucursales empresariales deben transmitirse a través de MAN mediante la tecnología VPLS, de modo que las sucursales empresariales en diferentes regiones puedan comunicarse entre sí.

El ISP puede usar el mismo dispositivo PE para proporcionar servicios de VPLS y L3VPN para que las empresas reduzcan los costos de construcción de la red.

Notas de configuración

  • Las tarjetas de la serie SA no son compatibles en este ejemplo. Las tarjetas de la serie X1E de V200R007 y versiones posteriores son compatibles en este ejemplo.
  • Tabla 9-6 enumera productos y versiones aplicables.
    Tabla 9-6  Productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S5300

    S5300HI

    V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306, S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9300E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de red

Como se muestra en Figura 9-7:
  • Un ISP proporciona servicios VPLS y L3VPN.
  • CE1 conectado a la sede de la empresa A y CE3 conectado a una sucursal pertenecen al mismo VPLS para proporcionar servicios de Capa 2. CE1 y CE3 están vinculados a vpna a implementar una transmisión segura de los datos de Capa 3.
  • CE2 conectado a la sede de la empresa B y CE4 conectado a una sucursal pertenecen al mismo VPLS para proporcionar servicios de Capa 2. CE2 y CE4 están vinculados a vpna a implementar una transmisión segura de los datos de Capa 3.
  • El QinQ selectivo debe configurarse en las interfaces del lado CE en los switches para agregar las etiquetas VLAN externas especificadas por el ISP a los paquetes enviados desde los dispositivos CE. Si un switch se conecta a múltiples dispositivos CE, puede agregar la misma etiqueta VLAN a los paquetes de diferentes dispositivos CE. Esto ahorra las ID de VLAN en la red ISP.
Figura 9-7  Redes para desplegar BGP/MPLS IP VPN y VPLS en una red ISP

Plan de datos

Dispositivo

Interfaz

Subinterfaz

Dirección IP

PE1

GigabitEthernet1/0/0

GigabitEthernet1/0/0.1

10.1.1.2/24

PE1

GigabitEthernet1/0/0

GigabitEthernet1/0/0.2

-

PE1

GigabitEthernet2/0/0

GigabitEthernet2/0/0.1

10.2.1.2/24

PE1

GigabitEthernet2/0/0

GigabitEthernet2/0/0.2

-

PE2

GigabitEthernet1/0/0

GigabitEthernet1/0/0.1

10.3.1.2/24

PE2

GigabitEthernet1/0/0

GigabitEthernet1/0/0.2

-

PE2

GigabitEthernet2/0/0

GigabitEthernet2/0/0.1

10.4.1.2/24

PE2

GigabitEthernet2/0/0

GigabitEthernet2/0/0.2

-

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure OSPF entre los dispositivos P y PE para garantizar la conectividad IP en la red de estructura básica.
  2. Habilite las capacidades básicas de MPLS y MPLS LDP en los dispositivos P y PE para configurar túneles de MPLS LSP para la transmisión de datos VPN en la red de estructura básica.
  3. Configure MP-IBGP en PE1 y PE2 para habilitarlas a intercambiar información de enrutamiento VPN.
  4. Configure BGP/MPLS IP VPN. Configure las instancias de L3VPN vpna y vpnb en PE1 y PE2. Establezca el VPN-target de vpna en 111:1 y el VPN-target de vpnb en 222:2. Esta configuración permite a los usuarios comunicarse en la misma VPN entre ellos y aísla a los usuarios en diferentes VPN. Configure las subinterfaces de terminación dot1q para paquetes de etiqueta única enviados desde CE1 y CE3. Configure las subinterfaces de terminación de QinQ para los paquetes de doble etiqueta enviados desde CE2 y CE4.
  5. Configure el servicio VPLS. Cree instancias de VSI de VPLS en PE1 y PE2. En cada instancia de VSI, especifique BGP como el protocolo de señalización y configure el RD, VPN-target y Site. Vincule las subinterfaces a instancias de VSI para que las subinterfaces funcionen como interfaces de AC para proporcionar acceso a los usuarios de VPLS. Configure las subinterfaces de terminación dot1q para paquetes de etiqueta única enviados desde CE1 y CE3. Configure las subinterfaces de terminación de QinQ para los paquetes de doble etiqueta enviados desde CE2 y CE4.
  6. Configure QinQ selectivo en las interfaces del lado CE de los switches y especifique las VLAN permitidas por las interfaces.
  7. Configure las relaciones de pares EBGP entre los dispositivos CE y PE para que puedan intercambiar información de enrutamiento VPN.

Procedimiento

  1. Configure un protocolo IGP en la red de estructura básica MPLS para que los dispositivos PE y P puedan comunicarse entre sí.

    # Configure PE1.

    <Quidway> system-view
    [Quidway] sysname PE1
    [PE1] interface loopback 1
    [PE1-LoopBack1] ip address 1.1.1.9 32
    [PE1-LoopBack1] quit
    [PE1] vlan batch 30
    [PE1] interface gigabitethernet 3/0/0
    [PE1-GigabitEthernet3/0/0] port hybrid pvid vlan 30
    [PE1-GigabitEthernet3/0/0] port hybrid untagged vlan 30
    [PE1-GigabitEthernet3/0/0] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] ip address 172.1.1.1 24
    [PE1-Vlanif30] quit
    [PE1] ospf 1
    [PE1-ospf-1] area 0
    [PE1-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [PE1-ospf-1-area-0.0.0.0] network 1.1.1.9 0.0.0.0
    [PE1-ospf-1-area-0.0.0.0] quit
    [PE1-ospf-1] quit

    # Configure P.

    <Quidway> system-view
    [Quidway] sysname P
    [P] interface loopback 1
    [P-LoopBack1] ip address 2.2.2.9 32
    [P-LoopBack1] quit
    [P] vlan batch 30 60
    [P] interface gigabitethernet 1/0/0
    [P-GigabitEthernet1/0/0] port hybrid pvid vlan 30
    [P-GigabitEthernet1/0/0] port hybrid untagged vlan 30
    [P-GigabitEthernet1/0/0] quit
    [P] interface gigabitethernet 2/0/0
    [P-GigabitEthernet2/0/0] port hybrid pvid vlan 60
    [P-GigabitEthernet2/0/0] port hybrid untagged vlan 60
    [P-GigabitEthernet2/0/0] quit
    [P] interface vlanif 30
    [P-Vlanif30] ip address 172.1.1.2 24
    [P-Vlanif30] quit
    [P] interface vlanif 60
    [P-Vlanif60] ip address 172.2.1.1 24
    [P-Vlanif60] quit
    [P] ospf 1
    [P-ospf-1] area 0
    [P-ospf-1-area-0.0.0.0] network 172.1.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 172.2.1.0 0.0.0.255
    [P-ospf-1-area-0.0.0.0] network 2.2.2.9 0.0.0.0
    [P-ospf-1-area-0.0.0.0] quit
    [P-ospf-1] quit

    # Configure PE2.

    <Quidway> system-view
    [Quidway] sysname PE2
    [PE2] interface loopback 1
    [PE2-LoopBack1] ip address 3.3.3.9 32
    [PE2-LoopBack1] quit
    [PE2] vlan batch 60
    [PE2] interface gigabitethernet 3/0/0
    [PE2-GigabitEthernet3/0/0] port hybrid pvid vlan 60
    [PE2-GigabitEthernet3/0/0] port hybrid untagged vlan 60
    [PE2-GigabitEthernet3/0/0] quit
    [PE2] interface vlanif 60
    [PE2-Vlanif60] ip address 172.2.1.2 24
    [PE2-Vlanif60] quit
    [PE2] ospf 1
    [PE2-ospf-1] area 0
    [PE2-ospf-1-area-0.0.0.0] network 172.2.1.0 0.0.0.255
    [PE2-ospf-1-area-0.0.0.0] network 3.3.3.9 0.0.0.0
    [PE2-ospf-1-area-0.0.0.0] quit
    [PE2-ospf-1] quit

    Después de completar la configuración, las relaciones de vecinos OSPF se pueden configurar entre PE1, P y PE2. Ejecute el comando display ospf peer en PE1, P y PE2, y puede ver que el estado vecino es Full. Ejecute el comando display ip routing-table en PE1 y PE2, y puede ver que PE1 y PE2 aprendieron las rutas a la dirección Loopback1 de cada uno.

    La visualización en PE1 se usa como un ejemplo:

    [PE1] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: Public
             Destinations : 8       Routes : 8
    
      Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
    
             1.1.1.9/32   Direct 0    0           D  127.0.0.1       LoopBack1
             2.2.2.9/32   OSPF   10   1           D  172.1.1.2       Vlanif30
             3.3.3.9/32   OSPF   10   2           D  172.1.1.2       Vlanif30
            127.0.0.0/8   Direct 0    0           D  127.0.0.1       InLoopBack0
           127.0.0.1/32   Direct 0    0           D  127.0.0.1       InLoopBack0
           172.1.1.0/24   Direct 0    0           D  172.1.1.1       Vlanif30
           172.1.1.1/32   Direct 0    0           D  127.0.0.1       Vlanif30
           172.2.1.0/24   OSPF   10   2           D  172.1.1.2       Vlanif30
    
    [PE1] display ospf peer
    
              OSPF Process 1 with Router ID 1.1.1.9
                      Neighbors
    
     Area 0.0.0.0 interface 172.1.1.1(Vlanif30)'s neighbors
     Router ID: 2.2.2.9         Address: 172.1.1.2
       State: Full  Mode:Nbr is  Master  Priority: 1
       DR: 172.1.1.2  BDR: 172.1.1.1  MTU: 0 
       Dead timer due in 37  sec
       Retrans timer interval: 5 
       Neighbor is up for 00:16:21
       Authentication Sequence: [ 0 ]

  2. Habilite las capacidades básicas de MPLS y MPLS LDP en los dispositivos PE para configurar los LDP LSP en la red de estructura básica MPLS.

    # Configure PE1.

    [PE1] mpls lsr-id 1.1.1.9
    [PE1] mpls
    [PE1-mpls] quit
    [PE1] mpls ldp
    [PE1-mpls-ldp] quit
    [PE1] interface vlanif 30
    [PE1-Vlanif30] mpls
    [PE1-Vlanif30] mpls ldp
    [PE1-Vlanif30] quit

    # Configure P.

    [P] mpls lsr-id 2.2.2.9
    [P] mpls
    [P-mpls] quit
    [P] mpls ldp
    [P-mpls-ldp] quit
    [P] interface vlanif 30
    [P-Vlanif30] mpls
    [P-Vlanif30] mpls ldp
    [P-Vlanif30] quit
    [P] interface vlanif 60
    [P-Vlanif60] mpls
    [P-Vlanif60] mpls ldp
    [P-Vlanif60] quit

    # Configure PE2.

    [PE2] mpls lsr-id 3.3.3.9
    [PE2] mpls
    [PE2-mpls] quit
    [PE2] mpls ldp
    [PE2-mpls-ldp] quit
    [PE2] interface vlanif 60
    [PE2-Vlanif60] mpls
    [PE2-Vlanif60] mpls ldp
    [PE2-Vlanif60] quit

    Después de completar la configuración, las sesiones de LDP se establecen entre PE1 y P, entre P y PE2. Ejecute el comando display mpls ldp session en PE1, P y PE2, y puede ver que el estado (Status) de la sesión LDP es Operational. Ejecute el comando display mpls ldp lsp y podrá ver información sobre los LDP LSP establecidos.

    La visualización en PE1 se usa como un ejemplo:

    [PE1] display mpls ldp session
    
     LDP Session(s) in Public Network
     Codes: LAM(Label Advertisement Mode), SsnAge Unit(DDDD:HH:MM)
     A '*' before a session means the session is being deleted. 
     ------------------------------------------------------------------------------
     PeerID            Status      LAM  SsnRole  SsnAge       KASent/Rcv
     ------------------------------------------------------------------------------
     2.2.2.9:0          Operational DU   Active   0000:00:01  6/6
     ------------------------------------------------------------------------------
     TOTAL: 1 session(s) Found.
    [PE1] display mpls ldp lsp
    
    LDP LSP Information
     -------------------------------------------------------------------------------
     Flag after Out IF: (I) - LSP Is Only Iterated by RLFA
     -------------------------------------------------------------------------------
     DestAddress/Mask   In/OutLabel   UpstreamPeer     NextHop     OutInterface   
     -------------------------------------------------------------------------------
     1.1.1.9/32         3/NULL        2.2.2.9          127.0.0.1   Inloop0    
    *1.1.1.9/32         Liberal/1025                   DS/2.2.2.9
     2.2.2.9/32         NULL/3        -                172.1.1.2   Vlanif30       
     2.2.2.9/32         1024/3        2.2.2.9          172.1.1.2   Vlanif30       
     3.3.3.9/32         NULL/1025     -                172.1.1.2   Vlanif30       
     3.3.3.9/32         1025/1025     2.2.2.9          172.1.1.2   Vlanif30      
     -------------------------------------------------------------------------------
     TOTAL: 5 Normal LSP(s) Found.
     TOTAL: 1 Liberal LSP(s) Found.
     TOTAL: 0 Frr LSP(s) Found.
     A '*' before an LSP means the LSP is not established 
     A '*' before a Label means the USCB or DSCB is stale 
     A '*' before a UpstreamPeer means the session is stale 
     A '*' before a DS means the session is stale 
     A '*' before a NextHop means the LSP is FRR LSP
    

  3. Configure las instancias L3VPN en los dispositivos PE. Configure las subinterfaces de terminación dot1q para paquetes de etiqueta única desde vpna. Configure las subinterfaces de terminación QinQ para paquetes de doble etiqueta desde vpnb. (Los usuarios del servicio de Capa 3 son identificados por la VLAN 10 y la VLAN 20, y los dispositivos PE usan la VLAN 10 y la VLAN 100 para identificar los servicios de Capa 3.)

    # Configure PE1.

    [PE1] ip vpn-instance vpna
    [PE1-vpn-instance-vpna] route-distinguisher 100:1
    [PE1-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE1-vpn-instance-vpna-af-ipv4] quit
    [PE1-vpn-instance-vpna] quit
    [PE1] ip vpn-instance vpnb
    [PE1-vpn-instance-vpnb] route-distinguisher 100:2
    [PE1-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE1-vpn-instance-vpnb-af-ipv4] quit
    [PE1-vpn-instance-vpnb] quit
    [PE1] interface gigabitethernet 1/0/0.1
    [PE1-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [PE1-GigabitEthernet1/0/0.1] ip binding vpn-instance vpna
    [PE1-GigabitEthernet1/0/0.1] ip address 10.1.1.2 24
    [PE1-GigabitEthernet1/0/0.1] arp broadcast enable
    [PE1-GigabitEthernet1/0/0.1] quit
    [PE1] interface gigabitethernet 2/0/0.1
    [PE1-GigabitEthernet2/0/0.1] qinq termination pe-vid 100 ce-vid 20
    [PE1-GigabitEthernet2/0/0.1] ip binding vpn-instance vpnb
    [PE1-GigabitEthernet2/0/0.1] ip address 10.2.1.2 24
    [PE1-GigabitEthernet2/0/0.1] arp broadcast enable
    [PE1-GigabitEthernet2/0/0.1] quit

    # Configure PE2.

    [PE2] ip vpn-instance vpna
    [PE2-vpn-instance-vpna] route-distinguisher 200:1
    [PE2-vpn-instance-vpna-af-ipv4] vpn-target 111:1 both
    [PE2-vpn-instance-vpna-af-ipv4] quit
    [PE2-vpn-instance-vpna] quit
    [PE2] ip vpn-instance vpnb
    [PE2-vpn-instance-vpnb] route-distinguisher 200:2
    [PE2-vpn-instance-vpnb-af-ipv4] vpn-target 222:2 both
    [PE2-vpn-instance-vpnb-af-ipv4] quit
    [PE2-vpn-instance-vpnb] quit
    [PE2] interface gigabitethernet 1/0/0.1
    [PE2-GigabitEthernet1/0/0.1] dot1q termination vid 10
    [PE2-GigabitEthernet1/0/0.1] ip binding vpn-instance vpna
    [PE2-GigabitEthernet1/0/0.1] ip address 10.3.1.2 24
    [PE2-GigabitEthernet1/0/0.1] arp broadcast enable
    [PE2-GigabitEthernet1/0/0.1] quit
    [PE2] interface gigabitethernet 2/0/0.1
    [PE2-GigabitEthernet2/0/0.1] qinq termination pe-vid 100 ce-vid 20
    [PE2-GigabitEthernet2/0/0.1] ip binding vpn-instance vpnb
    [PE2-GigabitEthernet2/0/0.1] ip address 10.4.1.2 24
    [PE2-GigabitEthernet2/0/0.1] arp broadcast enable
    [PE2-GigabitEthernet2/0/0.1] quit

    # Configure CE1 conectándose a la sede de la empresa A. Configure las direcciones IP para las interfaces de CE2, CE3 y CE4 de acuerdo con Figura 9-7. Las configuraciones de CE2, CE3 y CE4 son similares a la configuración de CE1 y no se mencionan aquí.

    <Quidway> system-view
    [Quidway] sysname CE1
    [CE1] vlan batch 10 to 11
    [CE1] interface gigabitethernet 1/0/0
    [CE1-GigabitEthernet1/0/0] port hybrid tagged vlan 10 to 11
    [CE1-GigabitEthernet1/0/0] quit
    [CE1] interface vlanif 10
    [CE1-Vlanif10] ip address 10.1.1.1 24
    [CE1-Vlanif10] quit
    

    Después de completar la configuración, ejecute el comando display ip vpn-instance verbose en PE1 y PE2 para ver la configuración de la instancia de VPN. Los dispositivos PE pueden hacer ping a los dispositivos CE conectados a ellos.

    NOTA:

    Si un dispositivo PE tiene múltiples interfaces vinculadas a la misma instancia de VPN, debe especificar una dirección IP de origen cuando haga ping al dispositivo CE conectado al dispositivo PE remoto. Para especificar la dirección IP de origen, configure el parámetro -a source-ip-address en el comando ping -vpn-instance vpn-instance-name -a source-ip-address dest-ip-address. Si no se especifica una dirección IP de origen, la operación de ping falla.

    La prueba de ping de PE1 a CE1 se usa como ejemplo:

    [PE1] display ip vpn-instance verbose
     Total VPN-Instances configured : 2
     Total IPv4 VPN-Instances configured : 2
     Total IPv6 VPN-Instances configured : 0
    
     VPN-Instance Name and ID : vpna, 1
      Interfaces : Vlanif10
     Address family ipv4
      Create date : 2012/07/25 00:58:17 UTC+08:00
      Up time : 0 days, 22 hours, 24 minutes and 53 seconds
      Route Distinguisher : 100:1
      Export VPN Targets :  111:1
      Import VPN Targets :  111:1
      Label Policy : label per instance
      Per-Instance Label : 4096  
      Log Interval : 5
    
     VPN-Instance Name and ID : vpnb, 2
      Interfaces : Vlanif20
     Address family ipv4
      Create date : 2012/07/25 00:58:17 UTC+08:00
      Up time : 0 days, 22 hours, 24 minutes and 53 seconds
      Route Distinguisher : 100:2
      Export VPN Targets :  222:2
      Import VPN Targets :  222:2
      Label Policy : label per instance
      Per-Instance Label : 4096  
      Log Interval : 5
    
    [PE1] ping -vpn-instance vpnb 10.2.1.1
      PING 10.1.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.1: bytes=56 Sequence=1 ttl=255 time=5 ms
        Reply from 10.1.1.1: bytes=56 Sequence=2 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=3 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=4 ttl=255 time=3 ms
        Reply from 10.1.1.1: bytes=56 Sequence=5 ttl=255 time=16 ms
    
      --- 10.1.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 3/6/16 ms

  4. Cree instancias de VSI de VPLS en PE1 y PE2. En cada instancia de VSI, especifique BGP como el protocolo de señalización y configure el RD, VPN-target y Site. Vincule las subinterfaces a instancias de VSI para que las subinterfaces funcionen como interfaces de AC para proporcionar acceso a los usuarios de VPLS. Configure las subinterfaces de terminación dot1q para paquetes de etiqueta única enviados desde CE1 y CE3. Configure las subinterfaces de terminación de QinQ para los paquetes de doble etiqueta enviados desde CE2 y CE4. (Los dispositivos CE usan la VLAN 11 y la VLAN 21 para identificar a los usuarios del servicio de Capa 2, y los dispositivos PE usan la VLAN 11 y la VLAN 200 para identificar los servicios de Capa 2.)

    # Configure PE1.

    [PE1] mpls l2vpn
    [PE1-l2vpn] quit
    [PE1] vsi vsi1 auto
    [PE1-vsi-vsi1] pwsignal bgp
    [PE1-vsi-vsi1-bgp] route-distinguisher 101:1
    [PE1-vsi-vsi1-bgp] vpn-target 100:1 import-extcommunity
    [PE1-vsi-vsi1-bgp] vpn-target 100:1 export-extcommunity
    [PE1-vsi-vsi1-bgp] site 1 range 5 default-offset 0
    [PE1-vsi-vsi1-bgp] quit
    [PE1-vsi-vsi1] quit
    [PE1] vsi vsi2 auto
    [PE1-vsi-vsi2] pwsignal bgp
    [PE1-vsi-vsi2-bgp] route-distinguisher 101:2
    [PE1-vsi-vsi2-bgp] vpn-target 200:1 import-extcommunity
    [PE1-vsi-vsi2-bgp] vpn-target 200:1 export-extcommunity
    [PE1-vsi-vsi2-bgp] site 1 range 5 default-offset 0
    [PE1-vsi-vsi2-bgp] quit
    [PE1-vsi-vsi2] quit
    [PE1] interface gigabitethernet 1/0/0.2
    [PE1-GigabitEthernet1/0/0.2] dot1q termination vid 11
    [PE1-GigabitEthernet1/0/0.2] l2 binding vsi vsi1
    [PE1-GigabitEthernet1/0/0.2] quit
    [PE1] interface gigabitethernet 2/0/0.2
    [PE1-GigabitEthernet2/0/0.2] qinq termination pe-vid 200 ce-vid 21
    [PE1-GigabitEthernet2/0/0.2] l2 binding vsi vsi2
    [PE1-GigabitEthernet2/0/0.2] quit

    # Configure PE2.

    [PE2] mpls l2vpn
    [PE2-l2vpn] quit
    [PE2] vsi vsi1 auto
    [PE2-vsi-vsi1] pwsignal bgp
    [PE2-vsi-vsi1-bgp] route-distinguisher 201:1
    [PE2-vsi-vsi1-bgp] vpn-target 100:1 import-extcommunity
    [PE2-vsi-vsi1-bgp] vpn-target 100:1 export-extcommunity
    [PE2-vsi-vsi1-bgp] site 2 range 5 default-offset 0
    [PE2-vsi-vsi1-bgp] quit
    [PE2-vsi-vsi1] quit
    [PE2] vsi vsi2 auto
    [PE2-vsi-vsi2] pwsignal bgp
    [PE2-vsi-vsi2-bgp] route-distinguisher 201:2
    [PE2-vsi-vsi2-bgp] vpn-target 200:1 import-extcommunity
    [PE2-vsi-vsi2-bgp] vpn-target 200:1 export-extcommunity
    [PE2-vsi-vsi2-bgp] site 2 range 5 default-offset 0
    [PE2-vsi-vsi2-bgp] quit
    [PE2-vsi-vsi2] quit
    [PE2] interface gigabitethernet 1/0/0.2
    [PE2-GigabitEthernet1/0/0.2] dot1q termination vid 11
    [PE2-GigabitEthernet1/0/0.2] l2 binding vsi vsi1
    [PE2-GigabitEthernet1/0/0.2] quit
    [PE2] interface gigabitethernet 2/0/0.2
    [PE2-GigabitEthernet2/0/0.2] qinq termination pe-vid 200 ce-vid 21
    [PE2-GigabitEthernet2/0/0.2] l2 binding vsi vsi2
    [PE2-GigabitEthernet2/0/0.2] quit

  5. Configure las relaciones entre peers EBGP entre los dispositivos PE y CE e importe las rutas L3VPN a BGP.

    # Configure CE1 conectándose a la sede de la empresa A. Las configuraciones de CE2, CE3 y CE4 son similares a las de CE1 y no se mencionan aquí.

    [CE1] bgp 65410
    [CE1-bgp] peer 10.1.1.2 as-number 100
    [CE1-bgp] import-route direct
    [CE1-bgp] quit

    # Configure PE1. La configuración de PE2 es similar a la de PE1, y no se menciona aquí.

    [PE1] bgp 100
    [PE1-bgp] ipv4-family vpn-instance vpna
    [PE1-bgp-vpna] peer 10.1.1.1 as-number 65410
    [PE1-bgp-vpna] import-route direct
    [PE1-bgp-vpna] quit
    [PE1-bgp] ipv4-family vpn-instance vpnb
    [PE1-bgp-vpnb] peer 10.2.1.1 as-number 65420
    [PE1-bgp-vpnb] import-route direct
    [PE1-bgp-vpnb] quit
    [PE1-bgp]quit

    Después de completar la configuración, ejecute el comando display bgp vpnv4 vpn-instance peer en los dispositivos PE. Puede ver que las relaciones de peers de BGP entre los dispositivos PE y CE se han establecido y se encuentran en el estado Established.

    La relación de peers BGP entre PE1 y CE1 se usa como un ejemplo:

    [PE1] display bgp vpnv4 vpn-instance vpna peer
    
     BGP local router ID : 1.1.1.9
     Local AS number : 100
     VPN-Instance vpna, Router ID 1.1.1.9:
     Total number of peers : 1                 Peers in established state : 1
    
      Peer            V    AS  MsgRcvd  MsgSent  OutQ  Up/Down       State      PrefRcv
    
      10.1.1.1        4 65410       11        9     0 00:07:25      Established       1
    

  6. Establezca una relación de peers MP-IBGP entre PE1 y PE2.

    # Configure PE1.

    [PE1] bgp 100
    [PE1-bgp] peer 3.3.3.9 as-number 100
    [PE1-bgp] peer 3.3.3.9 connect-interface loopback 1
    [PE1-bgp] ipv4-family vpnv4
    [PE1-bgp-af-vpnv4] peer 3.3.3.9 enable
    [PE1-bgp-af-vpnv4] quit
    [PE1-bgp] vpls-family
    [PE1-bgp-af-vpls] peer 3.3.3.9 enable
    [PE1-bgp-af-vpls] quit
    [PE1-bgp] quit

    # Configure PE2.

    [PE2] bgp 100
    [PE2-bgp] peer 1.1.1.9 as-number 100
    [PE2-bgp] peer 1.1.1.9 connect-interface loopback 1
    [PE2-bgp] ipv4-family vpnv4
    [PE2-bgp-af-vpnv4] peer 1.1.1.9 enable
    [PE2-bgp-af-vpnv4] quit
    [PE2-bgp] vpls-family
    [PE2-bgp-af-vpls] peer 1.1.1.9 enable
    [PE2-bgp-af-vpls] quit
    [PE2-bgp] quit

  7. Configure QinQ selectivo en las interfaces del lado CE de los switches y especifique las VLAN permitidas por las interfaces.

    # Configure Switch1.

    <Quidway> system-view
    [Quidway] sysname Switch1
    [Switch1] vlan batch 100 200
    [Switch1] interface gigabitethernet 2/0/0
    [Switch1-GigabitEthernet2/0/0] port hybrid tagged vlan 100 200
    [Switch1-GigabitEthernet2/0/0] quit
    [Switch1] interface gigabitethernet 1/0/0
    [Switch1-GigabitEthernet1/0/0] port hybrid untagged vlan 100 200
    [Switch1-GigabitEthernet1/0/0] port vlan-stacking vlan 20 stack-vlan 100
    [Switch1-GigabitEthernet1/0/0] port vlan-stacking vlan 21 stack-vlan 200
    [Switch1-GigabitEthernet1/0/0] quit

    # Configure Switch2.

    <Quidway> system-view
    [Quidway] sysname Switch2
    [Switch2] vlan batch 100 200
    [Switch2] interface gigabitethernet 2/0/0
    [Switch2-GigabitEthernet2/0/0] port hybrid tagged vlan 100 200
    [Switch2-GigabitEthernet2/0/0] quit
    [Switch2] interface gigabitethernet 1/0/0
    [Switch2-GigabitEthernet1/0/0] port hybrid untagged vlan 100 200
    [Switch2-GigabitEthernet1/0/0] port vlan-stacking vlan 20 stack-vlan 100
    [Switch2-GigabitEthernet1/0/0] port vlan-stacking vlan 21 stack-vlan 200
    [Switch2-GigabitEthernet1/0/0] quit

  8. Verifique la configuración

    Ejecute el comando display ip routing-table vpn-instance en PE1 y PE2 para ver las rutas L3VPN a los dispositivos CE remotos.

    La visualización en PE1 se usa como un ejemplo:

    [PE1] display ip routing-table vpn-instance vpna
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpna
             Destinations : 3        Routes : 3
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
         10.1.1.0/24    Direct 0    0        D     10.1.1.2        Vlanif10
         10.1.1.2/32    Direct 0    0        D     127.0.0.1       Vlanif10
         10.3.1.0/24    IBGP   255  0        RD    3.3.3.9         Vlanif30
    
    [PE1] display ip routing-table vpn-instance vpnb
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------
    Routing Tables: vpnb
             Destinations : 3        Routes : 3
    
    Destination/Mask    Proto  Pre  Cost     Flags NextHop         Interface
         10.2.1.0/24    Direct 0    0        D     10.2.1.2        Vlanif20
         10.2.1.2/32    Direct 0    0        D     127.0.0.1       Vlanif20
         10.4.1.0/24    IBGP   255  0        RD    3.3.3.9         Vlanif30
    

    Los dispositivos CE en la misma instancia VPN pueden hacer ping entre sí con éxito, mientras que los dispositivos CE en diferentes instancias VPN no pueden hacerlo.

    Por ejemplo, CE1 conectada a la sede de la empresa A puede hacer ping a CE3 conectada a una sucursal en 10.3.1.1 pero no puede hacer ping a CE4 conectada a la sede de la empresa B en 10.4.1.1.

    [CE1] ping 10.3.1.1
      PING 10.3.1.1: 56  data bytes, press CTRL_C to break
        Reply from 10.3.1.1: bytes=56 Sequence=1 ttl=253 time=72 ms
        Reply from 10.3.1.1: bytes=56 Sequence=2 ttl=253 time=34 ms
        Reply from 10.3.1.1: bytes=56 Sequence=3 ttl=253 time=50 ms
        Reply from 10.3.1.1: bytes=56 Sequence=4 ttl=253 time=50 ms
        Reply from 10.3.1.1: bytes=56 Sequence=5 ttl=253 time=34 ms
      --- 10.3.1.1 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 34/48/72 ms  
    
    [CE1] ping 10.4.1.1
      PING 10.4.1.1: 56  data bytes, press CTRL_C to break
        Request time out
        Request time out
        Request time out
        Request time out
        Request time out
      --- 10.4.1.1 ping statistics ---
        5 packet(s) transmitted
        0 packet(s) received
        100.00% packet loss

    Ejecute el comando display vsi name vsi2 verbose en PE1, y puede ver que vsi2 tiene un PW a PE2 y está en estado Up.

    [PE1] display vsi name vsi2 verbose
    
     ***VSI Name               : vsi2
        Administrator VSI      : no
        Isolate Spoken         : disable
        VSI Index              : 1
        PW Signaling           : bgp
        Member Discovery Style : auto
        PW MAC Learn Style     : unqualify
        Encapsulation Type     : vlan
        MTU                    : 1500
        Diffserv Mode          : uniform
        Mpls Exp               : --
        DomainId               : 255
        Domain Name            :
        Ignore AcState         : disable
        P2P VSI                : disable
        Create Time            : 0 days, 0 hours, 22 minutes, 6 seconds
        VSI State              : up
    
        BGP RD                 : 101:2
        SiteID/Range/Offset    : 1/5/0
        Import vpn target      : 200:1
        Export vpn target      : 200:1
        Remote Label Block     : 35845/5/0
        Local Label Block      : 0/35845/5/0
    
        Interface Name         : GigabitEthernet2/0/0.2
        State                  : up
        Access Port            : false
        Last Up Time           : 2012/12/24 21:19:48
        Total Up Time          : 0 days, 0 hours, 20 minutes, 42 seconds
    
      **PW Information:
    
       *Peer Ip Address        : 3.3.3.9
        PW State               : up
        Local VC Label         : 35847
        Remote VC Label        : 35846
        PW Type                : label
        Local  VCCV            : alert lsp-ping bfd
        Remote VCCV            : alert lsp-ping bfd
        Tunnel ID              : 0x5
        Broadcast Tunnel ID    : 0x5
        Broad BackupTunnel ID  : 0x0
        Ckey                   : 0xc
        Nkey                   : 0xb
        Main PW Token          : 0x5
        Slave PW Token         : 0x0
        Tnl Type               : LSP
        OutInterface           : Vlanif30
        Backup OutInterface    :
        Stp Enable             : 0
        PW Last Up Time        : 2012/12/24 21:38:43
        PW Total Up Time       : 0 days, 0 hours, 1 minutes, 47 seconds  

Archivos de configuración

  • Archivo de configuración de PE1

    #
    sysname PE1
    #
    vlan batch 30
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 100:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 100:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 1.1.1.9
    mpls
    #
    mpls l2vpn
    #
    vsi vsi1 auto
     pwsignal bgp
      route-distinguisher 101:1
      vpn-target 100:1 import-extcommunity
      vpn-target 100:1 export-extcommunity
      site 1 range 5 default-offset 0
    #
    vsi vsi2 auto
     pwsignal bgp
      route-distinguisher 101:2
      vpn-target 200:1 import-extcommunity
      vpn-target 200:1 export-extcommunity
      site 1 range 5 default-offset 0
    #
    mpls ldp
    #
    interface Vlanif30
     ip address 172.1.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
    # 
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     ip binding vpn-instance vpna
     ip address 10.1.1.2 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet1/0/0.2
     dot1q termination vid 11
     l2 binding vsi vsi1
    #
    interface GigabitEthernet2/0/0
    #
    interface GigabitEthernet2/0/0.1
     qinq termination pe-vid 100 ce-vid 20
     ip binding vpn-instance vpnb
     ip address 10.2.1.2 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet2/0/0.2
     dot1q termination vid 21
     l2 binding vsi vsi2
    #
    interface GigabitEthernet3/0/0
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    #
    interface LoopBack1
     ip address 1.1.1.9 255.255.255.255
    #
    bgp 100
     peer 3.3.3.9 as-number 100
     peer 3.3.3.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 3.3.3.9 enable
     #                                 
     vpls-family                       
      policy vpn-target                   
      peer 3.3.3.9 enable  
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 3.3.3.9 enable
     #
     ipv4-family vpn-instance vpna
      peer 10.1.1.1 as-number 65410
      import-route direct
     #
     ipv4-family vpn-instance vpnb
      peer 10.2.1.1 as-number 65420
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 1.1.1.9 0.0.0.0
    #
    return
  • Archivo de configuración del dispositivo P

    #
    sysname P
    #
    vlan batch 30 60
    #
     mpls lsr-id 2.2.2.9
     mpls
    #
    mpls ldp
    # 
    interface Vlanif30
     ip address 172.1.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface Vlanif60
     ip address 172.2.1.1 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
     port hybrid pvid vlan 30
     port hybrid untagged vlan 30
    # 
    interface GigabitEthernet2/0/0
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    # 
    interface LoopBack1
     ip address 2.2.2.9 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 172.1.1.0 0.0.0.255
      network 172.2.1.0 0.0.0.255
      network 2.2.2.9 0.0.0.0
    #
    return
  • Archivo de configuración de PE2

    #
    sysname PE2
    #
    vlan batch 60
    #
    ip vpn-instance vpna
     ipv4-family
      route-distinguisher 200:1
      vpn-target 111:1 export-extcommunity
      vpn-target 111:1 import-extcommunity
    #
    ip vpn-instance vpnb
     ipv4-family
      route-distinguisher 200:2
      vpn-target 222:2 export-extcommunity
      vpn-target 222:2 import-extcommunity
    #
    mpls lsr-id 3.3.3.9
    mpls
    #                                                                  
    mpls l2vpn                                                           
    #                                                                  
    vsi vsi1 auto                                                      
     pwsignal bgp                                                     
      route-distinguisher 201:1                                       
      vpn-target 100:1 import-extcommunity                            
      vpn-target 100:1 export-extcommunity                            
      site 2 range 5 default-offset 0                                 
    #                                                                 
    vsi vsi2 auto                                                     
     pwsignal bgp                                                      
      route-distinguisher 201:2                                        
      vpn-target 200:1 import-extcommunity                             
      vpn-target 200:1 export-extcommunity                             
      site 2 range 5 default-offset 0
    #
    mpls ldp
    #
    interface Vlanif60
     ip address 172.2.1.2 255.255.255.0
     mpls
     mpls ldp
    #
    interface GigabitEthernet1/0/0
    # 
    interface GigabitEthernet1/0/0.1
     dot1q termination vid 10
     ip binding vpn-instance vpna
     ip address 10.3.1.2 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet1/0/0.2
     dot1q termination vid 11
     l2 binding vsi vsi1
    #
    interface GigabitEthernet2/0/0
    #
    interface GigabitEthernet2/0/0.1
     qinq termination pe-vid 100 ce-vid 20
     ip binding vpn-instance vpnb
     ip address 10.4.1.2 255.255.255.0
     arp broadcast enable
    #
    interface GigabitEthernet2/0/0.2
     dot1q termination vid 21
     l2 binding vsi vsi2
    #
    interface GigabitEthernet3/0/0
     port hybrid pvid vlan 60
     port hybrid untagged vlan 60
    #
    interface LoopBack1
     ip address 3.3.3.9 255.255.255.255
    #
    bgp 100
     peer 1.1.1.9 as-number 100
     peer 1.1.1.9 connect-interface LoopBack1
     #
     ipv4-family unicast
      undo synchronization
      peer 1.1.1.9 enable
     #                            
     vpls-family                  
      policy vpn-target           
      peer 1.1.1.9 enable 
     #
     ipv4-family vpnv4
      policy vpn-target
      peer 1.1.1.9 enable
     #
     ipv4-family vpn-instance vpna
      peer 10.3.1.1 as-number 65430
      import-route direct
     #
     ipv4-family vpn-instance vpnb
      peer 10.4.1.1 as-number 65440
      import-route direct
    #
    ospf 1
     area 0.0.0.0
      network 172.2.1.0 0.0.0.255
      network 3.3.3.9 0.0.0.0
    # 
    return
  • Archivo de configuración de CE1 que se conecta a la sede de la empresa A

    #
    sysname CE1
    #
    vlan batch 10 to 11
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port hybrid tagged vlan 10 to 11
    #
    bgp 65410
     peer 10.1.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.1.1.2 enable
    #
    return
  • Archivo de configuración de CE2 que se conecta a la sede de la empresa B

    #
    sysname CE2
    #
    vlan batch 20 to 21
    #
    interface Vlanif20
     ip address 10.2.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port hybrid tagged vlan 20 to 21
    #
    bgp 65420
     peer 10.2.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.2.1.2 enable
    #
    return
  • Archivo de configuración de CE3 que se conecta a una sucursal de la empresa A

    #
    sysname CE3
    #
    vlan batch 10 to 11
    #
    interface Vlanif10
     ip address 10.3.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port hybrid tagged vlan 10 to 11
    #
    bgp 65430
     peer 10.3.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.3.1.2 enable
    #
    return
  • Archivo de configuración de CE4 que se conecta a una sucursal de la empresa B

    #
    sysname CE4
    #
    vlan batch 20 to 21
    #
    interface Vlanif20
     ip address 10.4.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/0
     port hybrid tagged vlan 20 to 21
    #
    bgp 65440
     peer 10.4.1.2 as-number 100
     #
     ipv4-family unicast
      undo synchronization
      import-route direct
      peer 10.4.1.2 enable
    #
    return
  • Archivo de configuración de Switch1

    #
    sysname Switch1
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/0
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 20 stack-vlan 100
     port vlan-stacking vlan 21 stack-vlan 200
    #
    interface GigabitEthernet2/0/0
     port hybrid tagged vlan 100 200
    #
    return
  • Archivo de configuración de Switch2

    #
    sysname Switch2
    #
    vlan batch 100 200
    #
    interface GigabitEthernet1/0/0
     port hybrid untagged vlan 100 200
     port vlan-stacking vlan 20 stack-vlan 100
     port vlan-stacking vlan 21 stack-vlan 200
    #
    interface GigabitEthernet2/0/0
     port hybrid tagged vlan 100 200
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15654

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente