No se encuentran recursos de mapeo en el idioma seleccionado.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para asociar el estado de la sesión BFD con el estado de la interfaz

Ejemplo para asociar el estado de la sesión BFD con el estado de la interfaz

Descripción general de BFD

Un dispositivo de red debe detectar rápidamente fallos de comunicación entre dispositivos adyacentes, de forma que se puedan tomar medidas inmediatamente y se puedan evitar las interrupciones del servicio. En la práctica, la detección de hardware se usa para detectar fallas de enlace. Por ejemplo, las alarmas de Jerarquía digital síncrona (SDH) se utilizan para informar fallas de enlace. Sin embargo, no todos los medios pueden proporcionar el mecanismo de detección de hardware. Las aplicaciones usan el mecanismo Hello del protocolo de enrutamiento de capa superior para detectar fallas. La detección con este mecanismo lleva más de 1 segundo, que es demasiado larga para algunas aplicaciones. En una red Layer 3, el mecanismo de detección de paquetes Hello no puede detectar fallas para todas las rutas, como las rutas estáticas. Esto significa que una falla entre sistemas interconectados es difícil de localizar.

BFD proporciona una detección rápida de fallas independiente de los medios y los protocolos de enrutamiento. Con la detección y conmutación de fallas a nivel de milisegundos, BFD es apropiado para escenarios que son sensibles a la pérdida y la demora de paquetes.

Notas de configuración

  • El discriminador local del sistema local y el discriminador remoto del sistema remoto deben ser el mismo. Si el discriminador local del sistema local y el discriminador remoto del sistema remoto son diferentes, no se puede configurar una sesión BFD estática. Después de configurar el discriminador local y el discriminador remoto, no se puede modificarlos.

  • Si una sesión BFD está vinculada a la dirección de multidifusión predeterminada, el discriminador local y el discriminador remoto deben ser diferentes.

  • Si se configura el tiempo de WTR, configure el mismo tiempo de WTR en ambos dispositivos. De lo contrario, cuando el estado de la sesión BFD se cambia en un dispositivo, las aplicaciones en ambos dispositivos detectan diferentes estados de sesión BFD.

  • A lo siguiente se describen los Modelos de productos y versiones aplicables.

Tabla 10-1  Modelos de productos y versiones aplicables

Producto

Modelo del Producto

Versión del software

S3300

S3300EI

V100R006C05

S3300HI

V200R001C00

S5300

S5320SI

V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5300EI

V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5300HI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S5310EI

V200R002C00, V200R003C00, V200R005(C00&C02)

S5320EI

V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5320HI

V200R009C00, V200R010C00, V200R011C10, V200R012C00

S5330SI

V200R011C10, V200R012C00

S6300

S6300EI

V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

S6320EI

V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

S6320SI

V200R011C10, V200R012C00

S6320HI

V200R012C00

S9300

S9303, S9306 y S9312

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

S9300

S9310

V200R010C00, V200R011C10, V200R012C00

S9300X

S9310X

V200R010C00, V200R011C10, V200R012C00

S9300E

S9303E, S9306E y S9312E

V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

NOTA:
Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En Figura 10-1, SwitchA se conecta directamente a SwitchB en la capa de red y los dispositivos de transmisión de Capa 2, SwitchC y SwitchD, se despliegan entre ellos. Se requiere que SwitchA y SwitchB detecten rápidamente las fallas de enlace de los dispositivos de transmisión de Capa 2 para activar la convergencia de ruta rápida.

Figura 10-1  Asociar el estado de la sesión BFD con el estado de la interfaz

Hoja de ruta de configuración

La hoja de ruta de la configuración es la siguiente:

  1. Configure una sesión BFD en SwitchA y SwitchB para detectar fallas en el enlace entre SwitchA y SwitchB.

  2. Configure la asociación entre el estado de la sesión BFD y el estado de la interfaz en SwitchA y SwitchB después de que la sesión BFD se convierta en Up.

Procedimiento

  1. Establezca las direcciones IP de las interfaces directamente conectadas en SwitchA y SwitchB.

    # Asigne una dirección IP a la interfaz de SwitchA.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan 10
    [SwitchA-vlan10] quit
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface vlanif 10
    [SwitchA-Vlanif10] ip address 10.1.1.1 24
    [SwitchA-Vlanif10] quit

    # Asigne una dirección IP a la interfaz de SwitchB.

    <Quidway> system-view
    [Quidway] sysname SwitchB
    [SwitchB] vlan 10
    [SwitchB-vlan10] quit
    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] port hybrid pvid vlan 10
    [SwitchB-GigabitEthernet1/0/1] port hybrid untagged vlan 10
    [SwitchB-GigabitEthernet1/0/1] quit
    [SwitchB] interface vlanif 10
    [SwitchB-Vlanif10] ip address 10.1.1.2 24
    [SwitchB-Vlanif10] quit

  2. Configure BFD de un solo salto.

    # Habilite BFD en SwitchA y establezca una sesión de BFD llamada atob entre SwitchA y SwitchB.

    [SwitchA] bfd   //Habilite BFD globalmente.
    [SwitchA-bfd] quit
    [SwitchA] bfd atob bind peer-ip default-ip interface gigabitethernet 1/0/1   //Configure una sesión BFD nombrada atob.
    [SwitchA-bfd-session-atob] discriminator local 10   //Configure el discriminador local de la sesión BFD. El discriminador local en SwitchA debe ser el mismo que el discriminador remoto en SwitchB.
    [SwitchA-bfd-session-atob] discriminator remote 20   //Configure el discriminador remoto de la sesión BFD. El discriminador remoto en SwitchA debe ser el mismo que el discriminador local en SwitchB.
    [SwitchA-bfd-session-atob] commit   //Confirme la sesión de BFD para que la configuración se ponga en vigor.
    [SwitchA-bfd-session-atob] quit

    # Habilite BFD en SwitchB y establezca una sesión de BFD llamada btoa entre SwitchB y SwitchA.

    [SwitchB] bfd
    [SwitchB-bfd] quit
    [SwitchB] bfd btoa bind peer-ip default-ip interface gigabitethernet 1/0/1   //Configure una sesión BFD nombrada btoa.
    [SwitchB-bfd-session-btoa] discriminator local 20
    [SwitchB-bfd-session-btoa] discriminator remote 10
    [SwitchB-bfd-session-btoa] commit
    [SwitchB-bfd-session-btoa] quit

    # Una vez completada la configuración, ejecute el comando display bfd session all verbose en SwitchA y SwitchB. Puede ver que una sesión BFD de un solo salto está configurada y su estado es Up. La visualización en SwitchA se usa como un ejemplo.

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16384     (One Hop) State : Up        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(GigabitEthernet1/0/1)
      Bind Session Type      : Static
      Bind Peer Ip Address   : 224.0.0.184
      NextHop Ip Address     : 224.0.0.184
      Bind Interface         : GigabitEthernet1/0/1
      FSM Board Id           : 3                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 1000             Actual Rx Interval (ms): 1000
      Local Detect Multi     : 3                Detect Interval (ms)   : 3000
      Echo Passive           : Disable          Acl Number             : - 
      Destination Port       : 3784             TTL                    : 255
      Proc interface status  : Disable          Process PST            : Disable
      WTR Interval (ms)      : -                  
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : No Application Bind
      Session TX TmrID       : -                Session Detect TmrID   : - 
      Session Init TmrID     : -                Session WTR TmrID      : - 
      Session Echo Tx TmrID  : - 
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0 
      Session Description    : - 
    --------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 1/0

  3. Configure el enlace entre el estado de la sesión BFD y el estado de la interfaz.

    # Configure el enlace entre el estado de la sesión BFD y el estado de la interfaz en SwitchA.

    [SwitchA] bfd atob 
    [SwitchA-bfd-session-atob] process-interface-status
    [SwitchA-bfd-session-atob] quit

    # Configure el enlace entre el estado de la sesión BFD y el estado de la interfaz en SwitchB.

    [SwitchB] bfd btoa
    [SwitchB-bfd-session-btoa] process-interface-status
    [SwitchB-bfd-session-btoa] quit

  4. Verifique la configuración.

    Una vez completada la configuración, ejecute el comando display bfd session all verbose en SwitchA y SwitchB. Pueden ver que el campo Proc interface status es Enable.

    La visualización en SwitchA se usa como un ejemplo.

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16384     (One Hop) State : Up        Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(GigabitEthernet1/0/1)
      Bind Session Type      : Static
      Bind Peer Ip Address   : 224.0.0.184
      NextHop Ip Address     : 224.0.0.184
      Bind Interface         : GigabitEthernet1/0/1
      FSM Board Id           : 3                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 1000
      Actual Tx Interval (ms): 13000            Actual Rx Interval (ms): 13000
      Local Detect Multi     : 3                Detect Interval (ms)   : 30
      Echo Passive           : Disable          Acl Number             : - 
      Destination Port       : 3784             TTL                    : 255
      Proc interface status  : Enable           Process PST            : Disable
      WTR Interval (ms)      : -                 
      Active Multi           : 3
      Last Local Diagnostic  : No Diagnostic
      Bind Application       : IFNET
      Session TX TmrID       : -                Session Detect TmrID   : - 
      Session Init TmrID     : -                Session WTR TmrID      : - 
      Session Echo Tx TmrID  : -  
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
      Session Description    : - 
    --------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 1/0

    Ejecute el comando shutdown en GE1/0/1 de SwitchB para hacer que la sesión de BFD es Down.

    [SwitchB] interface gigabitethernet 1/0/1
    [SwitchB-GigabitEthernet1/0/1] shutdown
    [SwitchB-GigabitEthernet1/0/1] quit

    Ejecute los comandos display bfd session all verbose y display interface gigabitethernet1/0/1 en SwitchA. Pueden ver que el estado de la sesión BFD es Down, y el estado de GE1/0/1 es UP (BFD status down).

    [SwitchA] display bfd session all verbose
    --------------------------------------------------------------------------------
    Session MIndex : 16384     (One Hop) State : Down      Name : atob
    --------------------------------------------------------------------------------
      Local Discriminator    : 10               Remote Discriminator   : 20
      Session Detect Mode    : Asynchronous Mode Without Echo Function
      BFD Bind Type          : Interface(GigabitEthernet1/0/1)
      Bind Session Type      : Static
      Bind Peer Ip Address   : 224.0.0.184
      NextHop Ip Address     : 224.0.0.184
      Bind Interface         : GigabitEthernet1/0/1
      FSM Board Id           : 3                TOS-EXP                : 7
      Min Tx Interval (ms)   : 1000             Min Rx Interval (ms)   : 10
      Actual Tx Interval (ms): 13000            Actual Rx Interval (ms): 13000
      Local Detect Multi     : 3                Detect Interval (ms)   : 30
      Echo Passive           : Disable          Acl Number             : - 
      Destination Port       : 3784             TTL                    : 255
      Proc interface status  : Enable          Process PST            : Disable
      WTR Interval (ms)      : -                  
      Active Multi           : 3
      Last Local Diagnostic  : Control Detection Time Expired
      Bind Application       : IFNET
      Session TX TmrID       : -                Session Detect TmrID   : - 
      Session Init TmrID     : -                Session WTR TmrID      : - 
      Session Echo Tx TmrID  : - 
      PDT Index              : FSM-0 | RCV-0 | IF-0 | TOKEN-0
      Session Description    : - 
    --------------------------------------------------------------------------------
    
         Total UP/DOWN Session Number : 0/1
    
    [SwitchA] display interface gigabitethernet 1/0/1
    GigabitEthernet1/0/1 current state : UP                                         
    Line protocol current state : UP(BFD status down)
    ...
    
    NOTA:

    Solo la información importante aparece en la lista debajo del comando display interface gigabitethernet1/0/1 y "..." indica que esa información se omite.

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 10
    #
     bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 10
     port hybrid untagged vlan 10
    #
    bfd atob bind peer-ip default-ip interface GigabitEthernet1/0/1
     discriminator local 10
     discriminator remote 20
     process-interface-status
     commit
    #
    return
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 10
    #
     bfd
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 10
     port hybrid untagged vlan10
    #
    bfd btoa bind peer-ip default-ip interface GigabitEthernet1/0/1
     discriminator local 20
     discriminator remote 10
     process-interface-status
     commit
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15365

Descargas: 127

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente