No se encuentran recursos de mapeo en el idioma seleccionado.

Ejemplos típicos de configuración de la serie Sx300

Rate and give feedback:
Acerca de la traducción
Huawei ha traducido este documento a diferentes idiomas combinando la traducción automática con la revisión humana a fin de permitirle entender mejor su contenido. Nota: Sin importar lo avanzada que sea, la traducción automática no puede igualar la calidad que proporcionan los traductores profesionales. Huawei no asume ninguna responsabilidad por la precisión de las traducciones y recomienda consultar el documento escrito en inglés (al cual puede acceder mediante el enlace proporcionado).
Ejemplo para configurar un grupo de VRRP en modo activo/standby

Ejemplo para configurar un grupo de VRRP en modo activo/standby

Descripción general de VRRP activo/standby

Generalmente, todos los hosts en el mismo segmento de red tienen la dirección del gateway como la dirección del siguiente salto para el enrutamiento predeterminado . Los hosts utilizan el enrutamiento predeterminado para enviar paquetes al gateway y el gateway reenvía los paquetes a otros segmentos de red. Cuando el gateway falla, los hosts con el mismo enrutamiento predeterminado no pueden comunicarse con redes externas. La configuración de gateways de salida múltiples es un método común para mejorar la confiabilidad del sistema. Sin embargo, la selección de ruta entre los gateways se convierte en un problema.

VRRP resuelve este problema. VRRP virtualiza múltiples dispositivos de enrutamiento en un router virtual sin cambiar la red y utiliza la dirección IP del router virtual como la dirección de gateway predeterminado para implementar el gateway de reserva. Cuando el gateway se vuelve defectuoso, VRRP selecciona un nuevo gateway para transmitir tráfico de servicio para garantizar una comunicación confiable.

Se recomienda que establezca el retardo de preferencia de Backup en un grupo VRRP en 0, configure Master en el modo de preferencia y establezca el retardo de preferencia en más de 15 segundos. Estas configuraciones permiten un período para la sincronización de estado entre el enlace ascendente y el enlace descendente en una red inestable. Si no se utilizan las configuraciones anteriores, los dos Masters pueden coexistir y los dispositivos del usuario pueden aprender una dirección incorrecta de Master. Como resultado, el tráfico se interrumpe.
  • Modo de preferencia: Backup va a ser Master cuando su prioridad es mayor que Master.

  • Modo de no preferencia: Siempre que Master esté funcionando correctamente, Backup con una prioridad más alta no puede convertirse en Master.

Notas de configuración

  • En V200R003 y versiones anteriores, VRRP se puede configurar solo en la interfaz VLANIF.

    En V200R005 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF y en la interfaz Ethernet de capa 3.

    Para un switch modular en V200R006 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3, subinterfaz de terminación Dot1q y subinterfaz de terminación QinQ.

    Para un switch fijo en V200R009 y versiones posteriores, VRRP se puede configurar en la interfaz VLANIF, interfaz Ethernet de capa 3 y subinterfaz.

  • Asegúrese de que cada dispositivo del mismo grupo VRRP esté configurado con el mismo VRID.
  • Los grupos VRRP deben usar diferentes direcciones IP virtuales. La dirección IP virtual de un grupo VRRP debe estar en el mismo segmento de red que la dirección IP de la interfaz donde está configurado el grupo VRRP.

  • A lo siguiente se describen los Modelos de productos y versiones aplicables.
    Tabla 10-2  Modelos de productos y versiones aplicables

    Producto

    Modelo del Producto

    Versión del software

    S2300

    S2320EI

    V200R011C10, V200R012C00

    S3300

    S3300EI

    V100R006C05

    S3300HI

    V200R001C00

    S5300

    S5320LI

    V200R010C00, V200R011C10, V200R012C00

    S5320SI

    V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5300EI

    V200R001C00, V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5300HI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S5310EI

    V200R002C00, V200R003C00, V200R005(C00&C02)

    S5320EI

    V200R007C00, V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5320HI

    V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S5330SI

    V200R011C10, V200R012C00

    S6300

    S6300EI

    V200R001(C00&C01), V200R002C00, V200R003C00, V200R005(C00&C01&C02)

    S6320EI

    V200R008C00, V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S6320SI

    V200R011C10, V200R012C00

    S6320HI

    V200R012C00

    S9300

    S9303, S9306 y S9312

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    S9300

    S9310

    V200R010C00, V200R011C10, V200R012C00

    S9300X

    S9310X

    V200R010C00, V200R011C10, V200R012C00

    S9300E

    S9303E, S9306E y S9312E

    V200R001C00, V200R002C00, V200R003C00, V200R005C00SPC300, V200R006C00, V200R007C00, V200R008(C00&C10), V200R009C00, V200R010C00, V200R011C10, V200R012C00

    NOTA:
    Para conocer los detalles sobre las asignaciones de software, consulte Hardware Query Tool.

Requisitos de redes

En Figura 10-2, HostA es dual-homed a SwitchA y SwitchB a través del switch. Para garantizar la transmisión ininterrumpida del servicio, un grupo VRRP en modo activo/standby debe configurarse en SwitchA y SwitchB.
  • El host utiliza SwitchA como el gateway predeterminado para conectarse a Internet. Cuando SwitchA está defectuoso, SwitchB funciona como el gateway. Esto implementa el gateway de reserva.

  • Después de que SwitchA se recupera, va a ser Master para transmitir datos después de un retraso de prioridad de 20 segundos.

NOTA:

En este escenario, para evitar bucles, asegúrese de que todas las interfaces conectadas tengan STP deshabilitado y las interfaces conectadas se eliminen de la VLAN 1. Si STP está habilitado y las interfaces VLANIF de switches se usan para construir una red de anillo de Capa 3, una interfaz en la red va a ser bloqueado. Como resultado, los servicios de Capa 3 en la red no pueden ejecutarse normalmente.

Figura 10-2  Redes para configurar un grupo VRRP en modo activo/standby

Hoja de ruta de configuración

Un grupo VRRP en modo activo/standby se usa para implementar el gateway de reserva. La hoja de ruta de la configuración es la siguiente:

  1. Asigne una dirección IP a cada interfaz y configure un protocolo de enrutamiento para garantizar la conectividad de la red.
  2. Configure un grupo VRRP en SwitchA ySwitchB. Establezca una prioridad más alta para SwitchA para que SwitchA funcione como Master de reenviar el tráfico y establezca el retraso de preferencia en 20s en SwitchA. Establezca una prioridad más baja para SwitchB para que SwitchB funcione como la copia de seguridad.

Procedimiento

  1. Configure los dispositivos para garantizar la conectividad de la red.

    # Asigne una dirección IP a cada interfaz. SwitchA se usa como un ejemplo. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    <Quidway> system-view
    [Quidway] sysname SwitchA
    [SwitchA] vlan batch 100 300
    [SwitchA] interface gigabitethernet 1/0/1
    [SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 300
    [SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 300
    [SwitchA-GigabitEthernet1/0/1] quit
    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [SwitchA-GigabitEthernet1/0/2] quit
    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] ip address 10.1.1.1 24
    [SwitchA-Vlanif100] quit
    [SwitchA] interface vlanif 300
    [SwitchA-Vlanif300] ip address 192.168.1.1 24
    [SwitchA-Vlanif300] quit

    # Configure el reenvío de Capa 2 en el switch.

    <Quidway> system-view
    [Quidway] sysname Switch
    [Switch] vlan 100
    [Switch-vlan100] quit
    [Switch] interface gigabitethernet 1/0/1
    [Switch-GigabitEthernet1/0/1] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/1] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/1] quit
    [Switch] interface gigabitethernet 1/0/2
    [Switch-GigabitEthernet1/0/2] port hybrid pvid vlan 100
    [Switch-GigabitEthernet1/0/2] port hybrid untagged vlan 100
    [Switch-GigabitEthernet1/0/2] quit
    

    # Configure OSPF en SwitchA, SwitchB, y SwitchC. SwitchA se usa como un ejemplo. Las configuraciones de SwitchB y SwitchC son similares a la configuración de SwitchA, y no se mencionan aquí. Para más detalles, vea los archivos de configuración.

    [SwitchA] ospf 1
    [SwitchA-ospf-1] area 0
    [SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [SwitchA-ospf-1-area-0.0.0.0] quit
    [SwitchA-ospf-1] quit

  2. Configure un grupo VRRP.

    # Configure el grupo 1 de VRRP en SwitchA, y establezca la prioridad de SwitchA a 120 y el retardo de preferencia en 20 segundos.

    [SwitchA] interface vlanif 100
    [SwitchA-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [SwitchA-Vlanif100] vrrp vrid 1 priority 120                  //La prioridad predeterminada de un dispositivo en un grupo VRRP es 100. Cambie la prioridad de Master para que sea más alta que Backup.
    [SwitchA-Vlanif100] vrrp vrid 1 preempt-mode timer delay 20   //Un dispositivo en un grupo VRRP usa prioridad inmediata por defecto. Cambie la demora de preferencia de Master para evitar interrupciones de servicio en una red inestable donde los dispositivos en el grupo VRRP se adelantan como Master.
    [SwitchA-Vlanif100] quit

    # Configure el grupo 1 de VRRP en SwitchB. SwitchB usa el valor predeterminado 100.

    [SwitchB] interface vlanif 100
    [SwitchB-Vlanif100] vrrp vrid 1 virtual-ip 10.1.1.111
    [SwitchB-Vlanif100] quit

  3. Verifique la configuración

    # Una vez completada la configuración, ejecute el comando display vrrp en SwitchA y SwitchB. Pueden ver que SwitchA está en estado Master y SwitchB está en estado Backup.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46
    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:15:46

    # Ejecute el comando display ip routing-table en SwitchA y SwitchB. El resultado del comando muestra que existe una ruta directa a la dirección IP virtual en la tabla de enrutamiento de SwitchA y existe una ruta OSPF a la dirección IP virtual en el tabla de enrutamiento de SwitchB. El resultado del comando en SwitchA y SwitchB es el siguiente:

    [SwitchA] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 9       Routes : 10                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
         10.1.1.0/24    Direct   0     0         D      10.1.1.1        Vlanif100
         10.1.1.1/32    Direct   0     0         D      127.0.0.1       Vlanif100
     10.1.1.111/32    Direct  0     0         D      127.0.0.1      Vlanif100
         127.0.0.0/8    Direct   0    0          D      127.0.0.1       InLoopBack0
        127.0.0.1/32    Direct   0    0          D      127.0.0.1       InLoopBack0
       172.16.1.0/24    OSPF     10   2          D      192.168.1.2     Vlanif300
      192.168.1.0/24    Direct   0    0          D      192.168.1.1     Vlanif300
      192.168.1.1/32    Direct   0    0          D      127.0.0.1       Vlanif300
      192.168.2.0/24    OSPF     10   2          D      10.1.1.2        Vlanif100
                        OSPF     10   2          D      192.168.1.2     Vlanif300
    [SwitchB] display ip routing-table
    Route Flags: R - relay, D - download to fib
    ------------------------------------------------------------------------------  
    Routing Tables: Public                                                          
             Destinations : 9       Routes : 10                                    
                                                                                    
    Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface      
                                                                                    
         10.1.1.0/24    Direct   0     0         D     10.1.1.2        Vlanif100
         10.1.1.2/32    Direct   0     0         D     127.0.0.1       Vlanif100
     10.1.1.111/32    OSPF    10    2         D     10.1.1.1       Vlanif100
         127.0.0.0/8    Direct   0     0         D     127.0.0.1       InLoopBack0
        127.0.0.1/32    Direct   0     0         D     127.0.0.1       InLoopBack0
       172.16.1.0/24    OSPF     10    2         D     192.168.2.2     Vlanif200
      192.168.1.0/24    OSPF     10    2         D     10.1.1.1        Vlanif100
                        OSPF     10    2         D     192.168.2.2     Vlanif200
      192.168.2.0/24    Direct   0     0         D     192.168.2.1     Vlanif200
      192.168.2.1/32    Direct   0     0         D     127.0.0.1       Vlanif200

    # Ejecute el comando de shutdown en GE1/0/2 de SwitchA para simular un error de enlace.

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] shutdown
    [SwitchA-GigabitEthernet1/0/2] quit

    # Ejecute el comando display vrrp en SwitchB para ver el estado de VRRP. El resultado del comando muestra que SwitchB está en estado Master.

    [SwitchB] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.2
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 100                                                        
        Preempt : YES   Delay Time : 0 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:18:40

    # Ejecute el comando undo shutdownen GE1/0/2 de SwitchA.

    [SwitchA] interface gigabitethernet 1/0/2
    [SwitchA-GigabitEthernet1/0/2] undo shutdown
    [SwitchA-GigabitEthernet1/0/2] quit

    # Después de 20 s, ejecute el comando display vrrp en SwitchA para ver el estado de VRRP. El resultado del comando muestra que SwitchA está en estado Master.

    [SwitchA] display vrrp
      Vlanif100 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.1.111
        Master IP : 10.1.1.1
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s
        TimerRun : 1 s
        TimerConfig : 1 s
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config type : normal-vrrp                                                   
        Backup-forward : disabled
        Create time : 2012-01-12 20:15:46
        Last change time : 2012-01-12 20:20:56
    

Archivos de configuración

  • El archivo de configuración de SwitchA

    #
    sysname SwitchA
    #
    vlan batch 100 300
    #
    interface Vlanif100
     ip address 10.1.1.1 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    interface Vlanif300
     ip address 192.168.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchB

    #
    sysname SwitchB
    #
    vlan batch 100 200
    #
    interface Vlanif100
     ip address 10.1.1.2 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.1.111
    #
    interface Vlanif200
     ip address 192.168.2.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
  • El archivo de configuración de SwitchC

    #
    sysname SwitchC
    #
    vlan batch 200 300 400
    #
    interface Vlanif200
     ip address 192.168.2.2 255.255.255.0
    #
    interface Vlanif300
     ip address 192.168.1.2 255.255.255.0
    #
    interface Vlanif400
     ip address 172.16.1.1 255.255.255.0
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 300
     port hybrid untagged vlan 300
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 200
     port hybrid untagged vlan 200
    #
    interface GigabitEthernet1/0/3
     port hybrid pvid vlan 400
     port hybrid untagged vlan 400
    #
    ospf 1
     area 0.0.0.0
      network 172.16.1.0 0.0.0.255
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return
    
  • Archivo de configuración del switch

    #
    sysname Switch
    #
    vlan batch 100
    #
    interface GigabitEthernet1/0/1
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    interface GigabitEthernet1/0/2
     port hybrid pvid vlan 100
     port hybrid untagged vlan 100
    #
    return
Descargar
Updated: 2018-08-15

N.° del documento: EDOC1100027119

Vistas:15823

Descargas: 131

Average rating:
This Document Applies to these Products
Documentos relacionados
Related Version
Share
Anterior Siguiente